Loading ...
Sorry, an error occurred while loading the content.

RPi with DStar DVAP

Expand Messages
  • Beischel
    Hello everyone, I have a couple of RPis that I use with DStar. One has a hotspot connected to it and it runs flawlessly for weeks and weeks with no issues. The
    Message 1 of 6 , Mar 4, 2013
    • 0 Attachment
      Hello everyone,

      I have a couple of RPis that I use with DStar. One has a hotspot connected to it and it runs flawlessly for weeks and weeks with no issues.

      The other RPi has a DVAP connected to it. The RPi runs fine, but the DVAP, for lack of a better word, goes off-line within hours. The status light just flashes green on the DVAP. The only way I have found to bring it back is to reboot the RPi.

      Another ham suggested updating the firmware on the RPi and I did that, but came down this morning and DVAP is off-line again. Reboot RPi, and back again.

      Anyone else have this issue and possibly a solution to the problem?

      Thanks,

      Duffy
      www.wb8nut.com
    • vk4tux
      Mike does it again, We knew each other years ago building rpms and yum repositories for D-Rats and Mike took it all to a another level. For the Rpi redhat fans
      Message 2 of 6 , Mar 4, 2013
      • 0 Attachment


        Mike does it again, We knew each other years ago building rpms and yum repositories for D-Rats
        and Mike took it all to a another level.

        For the Rpi redhat fans wanting some dvap action, here it is for fedora 18 remix;

        http://vk4tux.no-ip.org/DVAPTool_Rpi_rpm.jpg

        New!!!! fc18remix rpms thanks to Mike Heitman N0SO

        All these are in a yum repository > get Rpi.repo

        http://vk4tux.no-ip.org/IMG/rpm/Rpi.repo

        In fedora remix do

        wget http://vk4tux.no-ip.org/IMG/rpm/Rpi.repo

        cp Rpi.repo /etc/yum.repos.d/Rpi.repo

        as root (add sudo first if need)

        yum update

        Options:

        yum install d-rats

        yum install DVAPTool

        yum install ircDDBGateway

        yum install Repeater

        menu's are also auto created etc.

        Tested on my Rpi;



        Adrian ... vk4tux


      • Kerry McKenzie
        Greetings from Oz back in the old days of dos we used simple timers to bring back locked gear in remote locations with a power reboot every 24 hours. This will
        Message 3 of 6 , Mar 4, 2013
        • 0 Attachment
          Greetings from Oz
          back in the old days of dos we used simple timers to bring back locked
          gear in remote locations with a power reboot every 24 hours.
          This will give you a temporary fix until you can find a solution or if
          it works reliably keep it working.I have a sneaking feeling that your SD
          card has a little bit to do with your problem?
          Kerry VK4TUB
        • Beischel
          I thought of the same thing, except for the fat that the DVAP is going off-line about every 4 to 6 hours. So I have to ssh into it and tell it to reboot. Duffy
          Message 4 of 6 , Mar 5, 2013
          • 0 Attachment
            I thought of the same thing, except for the fat that the DVAP is going off-line about every 4 to 6 hours. So I have to ssh into it and tell it to reboot.

            Duffy
            www.wb8nut.com

            --- In Raspberry_Pi_4-Ham_RADIO@yahoogroups.com, Kerry McKenzie <kermck@...> wrote:
            >
            > Greetings from Oz
            > back in the old days of dos we used simple timers to bring back locked
            > gear in remote locations with a power reboot every 24 hours.
            > This will give you a temporary fix until you can find a solution or if
            > it works reliably keep it working.I have a sneaking feeling that your SD
            > card has a little bit to do with your problem?
            > Kerry VK4TUB
            >
          • Beischel
            OK, I got the Linux version with the DVAP software compiled from WA6JKF, installed that for the DVAP instead and have that working now. It seems to be OK,
            Message 5 of 6 , Mar 6, 2013
            • 0 Attachment
              OK, I got the Linux version with the DVAP software compiled from WA6JKF, installed that for the DVAP instead and have that working now.

              It seems to be OK, except when it disconnects from the repeater or a reflector, it does not reconnect even though I have the box checked to automatically try to reconnect.

              I can do a reconnect to that same repeater or reflector manually from the radio so it is not an issue of the repeater/reflector being off-line and unable to reconnect.

              Anyone else have that issue?

              Thanks,

              Duffy
              www.wb8nut.com

              --- In Raspberry_Pi_4-Ham_RADIO@yahoogroups.com, "Beischel" <beischel@...> wrote:
              >
              > I thought of the same thing, except for the fat that the DVAP is going off-line about every 4 to 6 hours. So I have to ssh into it and tell it to reboot.
              >
              > Duffy
              > www.wb8nut.com
              >
              > --- In Raspberry_Pi_4-Ham_RADIO@yahoogroups.com, Kerry McKenzie <kermck@> wrote:
              > >
              > > Greetings from Oz
              > > back in the old days of dos we used simple timers to bring back locked
              > > gear in remote locations with a power reboot every 24 hours.
              > > This will give you a temporary fix until you can find a solution or if
              > > it works reliably keep it working.I have a sneaking feeling that your SD
              > > card has a little bit to do with your problem?
              > > Kerry VK4TUB
              > >
              >
            • Beischel
              OK, I got the Linux version with the DVAP software compiled from WA6JKF, installed that for the DVAP instead and have that working now. It seems to be OK,
              Message 6 of 6 , Mar 6, 2013
              • 0 Attachment
                OK, I got the Linux version with the DVAP software compiled from WA6JKF, installed that for the DVAP instead and have that working now.

                It seems to be OK, except when it disconnects from the repeater or a reflector, it does not reconnect even though I have the box checked to automatically try to reconnect.

                I can do a reconnect to that same repeater or reflector manually from the radio so it is not an issue of the repeater/reflector being off-line and unable to reconnect.

                Anyone else have that issue?

                Thanks,

                Duffy
                www.wb8nut.com

                --- In Raspberry_Pi_4-Ham_RADIO@yahoogroups.com, "Beischel" <beischel@...> wrote:
                >
                > I thought of the same thing, except for the fat that the DVAP is going off-line about every 4 to 6 hours. So I have to ssh into it and tell it to reboot.
                >
                > Duffy
                > www.wb8nut.com
                >
                > --- In Raspberry_Pi_4-Ham_RADIO@yahoogroups.com, Kerry McKenzie <kermck@> wrote:
                > >
                > > Greetings from Oz
                > > back in the old days of dos we used simple timers to bring back locked
                > > gear in remote locations with a power reboot every 24 hours.
                > > This will give you a temporary fix until you can find a solution or if
                > > it works reliably keep it working.I have a sneaking feeling that your SD
                > > card has a little bit to do with your problem?
                > > Kerry VK4TUB
                > >
                >
              Your message has been successfully submitted and would be delivered to recipients shortly.