Loading ...
Sorry, an error occurred while loading the content.

Re: [Raspberry_Pi_4-Ham_RADIO] JNOS 2.0j.2 on RPi: tun device problem

Expand Messages
  • jerome schatten
    What do you see when you: cat /proc/modules   with jnos running?   Mine says: tun 141719  2  - Live  0xbf071000 .  If jnos  isn t running the number
    Message 1 of 4 , Dec 30, 2012
    • 0 Attachment
      What do you see when you: 'cat /proc/modules'  with jnos running?   Mine says: 'tun 141719  2  - Live  0xbf071000'.  If jnos  isn't running the number after 141719 (or whatever yours is) will be a zero.
      j.

      --- On Sun, 12/30/12, KD6OAT <kd6oat@...> wrote:

      From: KD6OAT <kd6oat@...>
      Subject: Re: [Raspberry_Pi_4-Ham_RADIO] JNOS 2.0j.2 on RPi: tun device problem
      To: "Raspberry_Pi_4-Ham_RADIO@yahoogroups.com" <Raspberry_Pi_4-Ham_RADIO@yahoogroups.com>
      Date: Sunday, December 30, 2012, 5:22 PM

       

      Thanks Jerome. I tried modprobe early in my investigation but without success. IPV4 forwarding appears okay and jnos runs okay except for tun. I run it as root.



      On Dec 30, 2012, at 5:41 PM, jerome schatten <va7vv@...> wrote:

       

      Try 'modprobe tun' before you bring up jnos and see if that works.

      BTW... I've just managed to get everything compiled and running with no errors under jnos2j. 

      Also... are you running as root?  Were you able to turn on ipv4 forwarding with
      'sudo echo 1 > /proc/sys/net/ipv4/ip_forward'  I could not do it with sudo, but I could in a root terminal. Very strange!

      jerome - ve7ass

      --- On Sun, 12/30/12, kd6oat <kd6oat@...> wrote:

      From: kd6oat <kd6oat@...>
      Subject: [Raspberry_Pi_4-Ham_RADIO] JNOS 2.0j.2 on RPi: tun device problem
      To: Raspberry_Pi_4-Ham_RADIO@yahoogroups.com
      Date: Sunday, December 30, 2012, 3:31 PM

       

      Hello all. I just complied JNOS on my raspberry Pi which is running debian wheezy. For some reason, when I run jnos, I get the following error message:


      tun1: ERROR while getting interface flags: No such device

      I checked /dev/net/tun to make sure tun was present - which it is - but evidently the lines of instructions in the autoexec.nos file are not creating tun1 (the exact same lines work just fine under Ubuntu on a different machine).

      I've been running through numerous threads after googleing but am coming up empty so far. Any suggestions are appreciated.

      73~Ken

    Your message has been successfully submitted and would be delivered to recipients shortly.