Loading ...
Sorry, an error occurred while loading the content.
 

Setting up WiFi

Expand Messages
  • dereck white
    Hi Guys Have built a Raspberry pi IRLP node and it works great when tethered to my router with an Ethernet cable. I have now purchased an Alcatel Y800 mobile
    Message 1 of 24 , Mar 24, 2014

      Hi Guys

       

      Have built a Raspberry pi IRLP node and it works great when tethered to my router with an Ethernet cable.

       

      I have now purchased an Alcatel Y800 mobile wireless router and have been trying for days to get it set up!!!!

       

      I have been in the sudo nano /etc/network/interfaces and added the following:-

       

      auto lo< /p>

      iface lo inet loopback

      iface eth0 inet dhcp

       

      allow-hotplug wlan0

      auto wlan0

       

      iface wlan0 inet dhcp

                  wpa2-ssid “My network ssid”

                  wpa2-psk “My password”

       

      Ctrl o return to write lines Ctrl x to exit.

       

      Sudo service networking reload and I get reload “Failed”

       

      When I check ifconfig    Nothing!!

      When I run the IRLP trouble shoot I get DNS error and No port forwarding done.

       

      Any help would be appreciated please

       

      Regards to all

       

      Dereck M0YDW

       

    • John Wiseman
      Dereck, There shouldn t be a
      Message 2 of 24 , Mar 24, 2014

        Dereck,

        There shouldn’t be a </p) on the auto lo line – I suspect that has come from copying the example from a web page.

        Also check that your wifi dongle has been recognised. I think ifconfig wlan0 will show it before it is configure but just ifconfig won’t

        73,

        John

         


        From: Raspberry_Pi_4-Ham_RADIO@yahoogroups.com [mailto:Raspberry_Pi_4-Ham_RADIO@yahoogroups.com] On Behalf Of dereck white
        Sent: 24 March 2014 21:11
        To: Raspberry_Pi_4-Ham_RADIO@yahoogroups.com
        Subject: [Raspberry_Pi_4-Ham_RADIO] Setting up WiFi

         

         

        Hi Guys

        Have built a Raspberry pi IRLP node and it works great when tethered to my router with an Ethernet cable.

        I have now purchased an Alcatel Y800 mobile wireless router and have been trying for days to get it set up!!!!

        I have been in the sudo nano /etc/network/interfaces and added the following:-

        auto lo</ span>< /p>

        iface lo inet loopback

        iface eth0 inet dhcp

        allow-hotplug wlan0

        auto wlan0

        iface wlan0 inet dhcp

                    wpa2-ssid “My network ssid”

                    wpa2-psk “My password”

        Ctrl o return to write lines Ctrl x to exit.

        Sudo service networking reload and I get reload “Failed”

        When I check ifconfig    Nothing!!

        When I run the IRLP trouble shoot I get DNS error and No port forwarding done.

         

        Any help would be appreciated please

         

        Regards to all

         

        Dereck M0YDW

         

      • g4sra
        Check you can connect something e.g a laptop tablet phone to your Alcatel router to prove it is correctly set up, then..... Google rasberry pi wifi how to
        Message 3 of 24 , Mar 25, 2014
          Check you can connect something e.g a laptop\tablet\phone to your
          Alcatel router to prove it is correctly set up, then.....

          Google 'rasberry pi wifi how to' for a guide,
          you have many mistakes in your /etc/network/interfaces example.


          On 24/03/14 21:11, dereck white wrote:
          > Hi Guys
          >
          > Have built a Raspberry pi IRLP node and it works great when tethered to my
          > router with an Ethernet cable.
          >
          > I have now purchased an Alcatel Y800 mobile wireless router and have been
          > trying for days to get it set up!!!!
          >
          > I have been in the sudo nano /etc/network/interfaces and added the
          > following:-
          >
          > auto lo< /p>
          >
          > iface lo inet loopback
          >
          > iface eth0 inet dhcp
          >
          >
          >
          > allow-hotplug wlan0
          >
          > auto wlan0
          >
          >
          >
          > iface wlan0 inet dhcp
          >
          > wpa2-ssid "My network ssid"
          >
          > wpa2-psk "My password"
          >
          >
          >
          > Ctrl o return to write lines Ctrl x to exit.
          >
          >
          >
          > Sudo service networking reload and I get reload "Failed"
          >
          >
          >
          > When I check ifconfig Nothing!!
          >
          > When I run the IRLP trouble shoot I get DNS error and No port forwarding
          > done.
          >
          >
          >
          > Any help would be appreciated please
          >
          >
          >
          > Regards to all
          >
          >
          >
          > Dereck M0YDW
          >
          >
          >
          >
        • disco5live@btinternet.com
          Hi John and members Thanks for the reply John, on the first line the /Span was not used (as you stated this must have come when I cut and pasted the
          Message 4 of 24 , Mar 25, 2014
            Hi John and members

            Thanks for the reply John, on the first line the /Span ></p> was not used (as you stated this must have come when I cut and pasted the email)

            Still not got it working, someone out there must have used the Raspberry pi/IRLP Board and the Alcatel mobile wifi router

            Help please

            Regards

            Dereck M0YDW






            Sent from Samsung tablet



            -------- Original message --------
            From: John Wiseman <john.wiseman@...>
            Date: 24/03/2014 22:23 (GMT+00:00)
            To: Raspberry_Pi_4-Ham_RADIO@yahoogroups.com
            Subject: RE: [Raspberry_Pi_4-Ham_RADIO] Setting up WiFi


             

            Dereck,

            There shouldn’t be a </p) on the auto lo line – I suspect that has come from copying the example from a web page.

            Also check that your wifi dongle has been recognised. I think ifconfig wlan0 will show it before it is configure but just ifconfig won’t

            73,

            John

             


            From: Raspberry_Pi_4-Ham_RADIO@yahoogroups.com [mailto:Raspberry_Pi_4-Ham_RADIO@yahoogroups.com] On Behalf Of dereck white
            Sent: 24 March 2014 21:11
            To: Raspberry_Pi_4-Ham_RADIO@yahoogroups.com
            Subject: [Raspberry_Pi_4-Ham_RADIO] Setting up WiFi

             

             

            Hi Guys

            Have built a Raspberry pi IRLP node and it works great when tethered to my router with an Ethernet cable.

            I have now purchased an Alcatel Y800 mobile wireless router and have been trying for days to get it set up!!!!

            I have been in the sudo nano /etc/network/interfaces and added the following:-

            auto lo/ span>< /p>

            iface lo inet loopback

            iface eth0 inet dhcp

            allow-hotplug wlan0

            auto wlan0

            iface wlan0 inet dhcp

                        wpa2-ssid “My network ssid”

                        wpa2-psk “My password”

            Ctrl o return to write lines Ctrl x to exit.

            Sudo service networking reload and I get reload “Failed”

            When I check ifconfig    Nothing!!

            When I run the IRLP trouble shoot I get DNS error and No port forwarding done.

             

            Any help would be appreciated please

             

            Regards to all

             

            Dereck M0YDW

             

          • John Wiseman
            Dereck, My /etc/network/interfaces is auto lo iface lo inet loopback iface eth0 inet dhcp allow-hotplug wlan0 auto wlan0 iface wlan0 inet static address
            Message 5 of 24 , Mar 25, 2014
              Dereck,

              My /etc/network/interfaces is

              auto lo
              iface lo inet loopback

              iface eth0 inet dhcp

              allow-hotplug wlan0

              auto wlan0

              iface wlan0 inet static
              address 192.168.1.31
              netmask 255.255.255.0
              gateway 192.168.1.254

              wpa-ssid "Hilton"
              wpa-psk "xxxxxxxxxxx"

              I assigned a fixed address to my pi to make it easier to find, but it works
              with

              iface wlan0 inet dhcp

              wpa-ssid "Hilton"
              wpa-psk "xxxxxxxxxxx"


              I don't have an Alcatel moblle router, so can't say if that needs any
              special config.

              What wifi adapter are you using?

              73,
              John

              ________________________________________
              From: Raspberry_Pi_4-Ham_RADIO@yahoogroups.com
              [mailto:Raspberry_Pi_4-Ham_RADIO@yahoogroups.com] On Behalf Of
              disco5live@...
              Sent: 25 March 2014 12:09
              To: Raspberry_Pi_4-Ham_RADIO@yahoogroups.com
              Subject: RE: [Raspberry_Pi_4-Ham_RADIO] Setting up WiFi

               
              Hi John and members

              Thanks for the reply John, on the first line the /Span ></p> was not used
              (as you stated this must have come when I cut and pasted the email)

              Still not got it working, someone out there must have used the Raspberry
              pi/IRLP Board and the Alcatel mobile wifi router

              Help please

              Regards

              Dereck M0YDW
            • dereck white
              Hi John Thanks for the reply, I have tried your suggestion below and still no success. The wifi adaptor I am using is the one suggested by David Camaron the
              Message 6 of 24 , Mar 25, 2014

                Hi John

                 

                Thanks for the reply, I have tried your suggestion below and still no success.

                The wifi adaptor I am using is the one suggested by David Camaron the 802.11n

                 

                Regards

                 

                Dereck

                 

                 

                 

                 

                From: Raspberry_Pi_4-Ham_RADIO@yahoogroups.com [mailto:Raspberry_Pi_4-Ham_RADIO@yahoogroups.com] On Behalf Of John Wiseman
                Sent: 25 March 2014 18:06
                To: Raspberry_Pi_4-Ham_RADIO@yahoogroups.com
                Subject: RE: [Raspberry_Pi_4-Ham_RADIO] Setting up WiFi

                 

                 

                Dereck,

                My /etc/network/interfaces is

                auto lo
                iface lo inet loopback

                iface eth0 inet dhcp

                allow-hotplug wlan0

                auto wlan0

                iface wlan0 inet static
                address 192.168.1.31
                netmask 255.255.255.0
                gateway 192.168.1.254

                wpa-ssid "Hilton"
                wpa-psk "xxxxxxxxxxx"

                I assigned a fixed address to my pi to make it easier to find, but it works
                with

                iface wlan0 inet dhcp

                wpa-ssid "Hilton"
                wpa-psk "xxxxxxxxxxx"

                I don't have an Alcatel moblle router, so can't say if that needs any
                special config.

                What wifi adapter are you using?

                73,
                John

                ________________________________________
                From: Raspberry_Pi_4-Ham_RADIO@yahoogroups.com
                [mailto:Raspberry_Pi_4-Ham_RADIO@yahoogroups.com] On Behalf Of
                disco5live@...
                Sent: 25 March 2014 12:09
                To: Raspberry_Pi_4-Ham_RADIO@yahoogroups.com
                Subject: RE: [Raspberry_Pi_4-Ham_RADIO] Setting up WiFi

                 
                Hi John and members

                Thanks for the reply John, on the first line the /Span ></p> was not used
                (as you stated this must have come when I cut and pasted the email)

                Still not got it working, someone out there must have used the Raspberry
                pi/IRLP Board and the Alcatel mobile wifi router

                Help please

                Regards

                Dereck M0YDW

              • Tommy Kane
                There needs to be a link to wifi conf, through wpa_supplicant/ wpa_supplicant.conf Loads of info on Google and Rasp sites, had to set mine up today. Tommy
                Message 7 of 24 , Mar 27, 2014

                  There needs to be a link to wifi conf, through wpa_supplicant/ wpa_supplicant.conf

                   

                  Loads of info on Google and Rasp sites, had to set mine up today.

                   

                  Tommy

                   

                  From: Raspberry_Pi_4-Ham_RADIO@yahoogroups.com [mailto:Raspberry_Pi_4-Ham_RADIO@yahoogroups.com] On Behalf Of dereck white
                  Sent: 25 March 2014 21:46
                  To: Raspberry_Pi_4-Ham_RADIO@yahoogroups.com
                  Subject: RE: [Raspberry_Pi_4-Ham_RADIO] Setting up WiFi

                   

                   

                  Hi John

                   

                  Thanks for the reply, I have tried your suggestion below and still no success.

                  The wifi adaptor I am using is the one suggested by David Camaron the 802.11n

                   

                  Regards

                   

                  Dereck

                   

                   

                   

                   

                  From: Raspberry_Pi_4-Ham_RADIO@yahoogroups.com [mailto:Raspberry_Pi_4-Ham_RADIO@yahoogroups.com] On Behalf Of John Wiseman
                  Sent: 25 March 2014 18:06
                  To: Raspberry_Pi_4-Ham_RADIO@yahoogroups.com
                  Subject: RE: [Raspberry_Pi_4-Ham_RADIO] Setting up WiFi

                   

                   

                  Dereck,

                  My /etc/network/interfaces is

                  auto lo
                  iface lo inet loopback

                  iface eth0 inet dhcp

                  allow-hotplug wlan0

                  auto wlan0

                  iface wlan0 inet static
                  address 192.168.1.31
                  netmask 255.255.255.0
                  gateway 192.168.1.254

                  wpa-ssid "Hilton"
                  wpa-psk "xxxxxxxxxxx"

                  I assigned a fixed address to my pi to make it easier to find, but it works
                  with

                  iface wlan0 inet dhcp

                  wpa-ssid "Hilton"
                  wpa-psk "xxxxxxxxxxx"

                  I don't have an Alcatel moblle router, so can't say if that needs any
                  special config.

                  What wifi adapter are you using?

                  73,
                  John

                  ________________________________________
                  From: Raspberry_Pi_4-Ham_RADIO@yahoogroups.com
                  [mailto:Raspberry_Pi_4-Ham_RADIO@yahoogroups.com] On Behalf Of
                  disco5live@...
                  Sent: 25 March 2014 12:09
                  To: Raspberry_Pi_4-Ham_RADIO@yahoogroups.com
                  Subject: RE: [Raspberry_Pi_4-Ham_RADIO] Setting up WiFi

                   
                  Hi John and members

                  Thanks for the reply John, on the first line the /Span ></p> was not used
                  (as you stated this must have come when I cut and pasted the email)

                  Still not got it working, someone out there must have used the Raspberry
                  pi/IRLP Board and the Alcatel mobile wifi router

                  Help please

                  Regards

                  Dereck M0YDW

                • John Guillory
                  Stupid thing on my part is, the wifi came bundled with my Pi, case, and power supply, so as I see it, if any part of the problem isn t supported, or doesn t
                  Message 8 of 24 , Mar 27, 2014
                    Stupid thing on my part is, the wifi came bundled with my Pi, case, and power supply, so as I see it, if any part of the problem isn't supported, or doesn't have enough power, it is the Vendor's fault.  But in my case, it works straight out of the box on pidora, just I hate pidora and can't find the compilers I want in the pidora repository.  

                    --
                    KF5QEO
                    John Guillory
                    Cell: 601-754-9233
                    Pinger: 337-240-7890
                    Google Voice: 601-265-1307


                    On Mar 27, 2014, at 2:08 PM, "Tommy Kane" <coolcamper55@...> wrote:

                     

                    There needs to be a link to wifi conf, through wpa_supplicant/ wpa_supplicant.conf

                     

                    Loads of info on Google and Rasp sites, had to set mine up today.

                     

                    Tommy

                     

                    From: Raspberry_Pi_4-Ham_RADIO@yahoogroups.com [mailto:Raspberry_Pi_4-Ham_RADIO@yahoogroups.com] On Behalf Of dereck white
                    Sent: 25 March 2014 21:46
                    To: Raspberry_Pi_4-Ham_RADIO@yahoogroups.com
                    Subject: RE: [Raspberry_Pi_4-Ham_RADIO] Setting up WiFi

                     

                     

                    Hi John

                     

                    Thanks for the reply, I have tried your suggestion below and still no success.

                    The wifi adaptor I am using is the one suggested by David Camaron the 802.11n

                     

                    Regards

                     

                    Dereck

                     

                     

                     

                     

                    From: Raspberry_Pi_4-Ham_RADIO@yahoogroups.com [mailto:Raspberry_Pi_4-Ham_RADIO@yahoogroups.com] On Behalf Of John Wiseman
                    Sent: 25 March 2014 18:06
                    To: Raspberry_Pi_4-Ham_RADIO@yahoogroups.com
                    Subject: RE: [Raspberry_Pi_4-Ham_RADIO] Setting up WiFi

                     

                     

                    Dereck,

                    My /etc/network/interfaces is

                    auto lo
                    iface lo inet loopback

                    iface eth0 inet dhcp

                    allow-hotplug wlan0

                    auto wlan0

                    iface wlan0 inet static
                    address 192.168.1.31
                    netmask 255.255.255.0
                    gateway 192.168.1.254

                    wpa-ssid "Hilton"
                    wpa-psk "xxxxxxxxxxx"

                    I assigned a fixed address to my pi to make it easier to find, but it works
                    with

                    iface wlan0 inet dhcp

                    wpa-ssid "Hilton"
                    wpa-psk "xxxxxxxxxxx"

                    I don't have an Alcatel moblle router, so can't say if that needs any
                    special config.

                    What wifi adapter are you using?

                    73,
                    John

                    ________________________________________
                    From: Raspberry_Pi_4-Ham_RADIO@yahoogroups.com
                    [mailto:Raspberry_Pi_4-Ham_RADIO@yahoogroups.com] On Behalf Of
                    disco5live@...
                    Sent: 25 March 2014 12:09
                    To: Raspberry_Pi_4-Ham_RADIO@yahoogroups.com
                    Subject: RE: [Raspberry_Pi_4-Ham_RADIO] Setting up WiFi

                     
                    Hi John and members

                    Thanks for the reply John, on the first line the /Span ></p> was not used
                    (as you stated this must have come when I cut and pasted the email)

                    Still not got it working, someone out there must have used the Raspberry
                    pi/IRLP Board and the Alcatel mobile wifi router

                    Help please

                    Regards

                    Dereck M0YDW

                  • Brock Winfrey
                    I bought a wireless usb plug in for my rpi and it also doesn t work. I ve seen one sold by I th ink element 14 that is made just for the rpi for $11.00. I m
                    Message 9 of 24 , Mar 27, 2014

                      I bought a wireless usb plug in for my rpi and it also doesn't work.  I've seen one sold by I th ink element 14 that is made just for the rpi for $11.00.  I'm just using cable now. Brock

                      On Mar 24, 2014 5:52 PM, "dereck white" <disco5live@...> wrote:
                       

                      Hi Guys

                       

                      Have built a Raspberry pi IRLP node and it works great when tethered to my router with an Ethernet cable.

                       

                      I have now purchased an Alcatel Y800 mobile wireless router and have been trying for days to get it set up!!!!

                       

                      I have been in the sudo nano /etc/network/interfaces and added the following:-

                       

                      auto lo< /p>

                      iface lo inet loopback

                      iface eth0 inet dhcp

                       

                      allow-hotplug wlan0

                      auto wlan0

                       

                      iface wlan0 inet dhcp

                                  wpa2-ssid “My network ssid”

                                  wpa2-psk “My password”

                       

                      Ctrl o return to write lines Ctrl x to exit.

                       

                      Sudo service networking reload and I get reload “Failed”

                       

                      When I check ifconfig    Nothing!!

                      When I run the IRLP trouble shoot I get DNS error and No port forwarding done.

                       

                      Any help would be appreciated please

                       

                      Regards to all

                       

                      Dereck M0YDW

                       

                    • pmooney22
                      Might be a stupid question, but are drivers for the wifi device been installed? Paul 5B8BA
                      Message 10 of 24 , Mar 27, 2014
                        Might be a stupid question, but are drivers for the wifi device been installed?

                        Paul 5B8BA
                      • Ray Wells
                        When I first started using the RPi with wifi I also had difficulty, which I blamed on network-manager (which can clash with manual configuration). I
                        Message 11 of 24 , Mar 27, 2014
                          When I first started using the RPi with wifi I also had difficulty, which I blamed on network-manager (which can clash with manual configuration). I uninstalled network-manager and installed wicd, which allowed me to configure the wifi dongle. wicd can also configure ethernet and it has fallover options. The curses interface is also handy for managing connections on headless installations.

                          Ray vk2tv


                          On 28/03/14 06:51, John Guillory wrote:
                          ��
                          Stupid thing on my part is, the wifi came bundled with my Pi, case, and power supply, so as I see it, if any part of the problem isn't supported, or doesn't have enough power, it is the Vendor's fault. ��But in my case, it works straight out of the box on pidora, just I hate pidora and can't find the compilers I want in the pidora repository. ��

                          --
                          KF5QEO
                          John Guillory
                          Cell: 601-754-9233
                          Pinger: 337-240-7890
                          Google Voice:��601-265-1307


                          On Mar 27, 2014, at 2:08 PM, "Tommy Kane" <coolcamper55@...> wrote:

                          ��

                          There needs to be a link to wifi conf, through wpa_supplicant/ wpa_supplicant.conf

                          ��

                          Loads of info on Google and Rasp sites, had to set mine up today.

                          ��

                          Tommy

                          ��

                          From: Raspberry_Pi_4-Ham_RADIO@yahoogroups.com [mailto:Raspberry_Pi_4-Ham_RADIO@yahoogroups.com] On Behalf Of dereck white
                          Sent: 25 March 2014 21:46
                          To: Raspberry_Pi_4-Ham_RADIO@yahoogroups.com
                          Subject: RE: [Raspberry_Pi_4-Ham_RADIO] Setting up WiFi

                          ��

                          ��

                          Hi John

                          ��

                          Thanks for the reply, I have tried your suggestion below and still no success.

                          The wifi adaptor I am using is the one suggested by David Camaron the 802.11n

                          ��

                          Regards

                          ��

                          Dereck

                          ��

                          ��

                          ��

                          ��

                          From: Raspberry_Pi_4-Ham_RADIO@yahoogroups.com [mailto:Raspberry_Pi_4-Ham_RADIO@yahoogroups.com] On Behalf Of John Wiseman
                          Sent: 25 March 2014 18:06
                          To: Raspberry_Pi_4-Ham_RADIO@yahoogroups.com
                          Subject: RE: [Raspberry_Pi_4-Ham_RADIO] Setting up WiFi

                          ��

                          ��

                          Dereck,

                          My /etc/network/interfaces is

                          auto lo
                          iface lo inet loopback

                          iface eth0 inet dhcp

                          allow-hotplug wlan0

                          auto wlan0

                          iface wlan0 inet static
                          address 192.168.1.31
                          netmask 255.255.255.0
                          gateway 192.168.1.254

                          wpa-ssid "Hilton"
                          wpa-psk "xxxxxxxxxxx"

                          I assigned a fixed address to my pi to make it easier to find, but it works
                          with

                          iface wlan0 inet dhcp

                          wpa-ssid "Hilton"
                          wpa-psk "xxxxxxxxxxx"

                          I don't have an Alcatel moblle router, so can't say if that needs any
                          special config.

                          What wifi adapter are you using?

                          73,
                          John

                          ________________________________________
                          From: Raspberry_Pi_4-Ham_RADIO@yahoogroups.com
                          [mailto:Raspberry_Pi_4-Ham_RADIO@yahoogroups.com] On Behalf Of
                          disco5live@...
                          Sent: 25 March 2014 12:09
                          To: Raspberry_Pi_4-Ham_RADIO@yahoogroups.com
                          Subject: RE: [Raspberry_Pi_4-Ham_RADIO] Setting up WiFi

                          ��
                          Hi John and members

                          Thanks for the reply John, on the first line the /Span ></p> was not used
                          (as you stated this must have come when I cut and pasted the email)

                          Still not got it working, someone out there must have used the Raspberry
                          pi/IRLP Board and the Alcatel mobile wifi router

                          Help please

                          Regards

                          Dereck M0YDW


                        • Tommy Kane
                          good point check to see if it shows up ps -a I think. It will show all the ports connected and look for your adapter in there. If it does not show there is a
                          Message 12 of 24 , Mar 27, 2014

                            good point check to see if it shows up "ps -a" I think. It will show all the ports connected and look for your adapter in there.

                            If it does not show there is a method for getting additional drivers.

                            http://pingbin.com/2012/12/setup-wifi-raspberry-pi/    was very helpful to me

                            Tommy

                            From: Raspberry_Pi_4-Ham_RADIO@yahoogroups.com [mailto:Raspberry_Pi_4-Ham_RADIO@yahoogroups.com] On Behalf Of pmooney22@...
                            Sent: 27 March 2014 21:33
                            To: Raspberry_Pi_4-Ham_RADIO@yahoogroups.com
                            Subject: [Raspberry_Pi_4-Ham_RADIO] Re: Setting up WiFi

                             

                             

                            Might be a stupid question, but are drivers for the wifi device been installed?

                             

                            Paul 5B8BA

                          • g4sra
                            I just I hate pidora and can t find the compilers I want in the pidora repository. I want to install the package that has that executable in it but I cant
                            Message 13 of 24 , Mar 28, 2014
                              "I just I hate pidora and can't find the compilers I want in the pidora
                              repository."

                              I want to install the package that has that executable in it but I cant
                              remember it's name. It starts with 'ifconf' but I don't know which
                              directory it goes in, either /bin, /sbin, /usr/bin, or /usr/sbin.

                              yum provides "*bin/ifconf*"


                              I am looking for a compiler but I don't know which one...

                              yum search compiler

                              Then it is up to you to make a decision (the Pi cant do everything for
                              you, if it could, you would be redundant).
                            • g4sra
                              To check for USB Devices e.g Wifi Adapter (Adapter - not dongle, a Dongle is a security device, not *anything* that plugs into a USB port, please don t
                              Message 14 of 24 , Mar 28, 2014
                                To check for USB Devices e.g Wifi Adapter (Adapter - not dongle, a
                                Dongle is a security device, not *anything* that plugs into a USB port,
                                please don't propagate bad\incorrect technology reporting by the Media,
                                Amateur Transceivers are not CB's):

                                lsusb

                                To check which kernel modules (Windows users call them drivers, if you
                                are using Linux, call them modules) are loaded:

                                lsmod


                                To check which kernel modules are installed

                                find /usr/lib/modules/$(uname -r)


                                To check for \ information about a specific module

                                modinfo fuse

                                (the module name, e.g. 'fuse.ko' without the '.ko' extension)


                                All of these commands have switches that change the information\detail
                                they provide, refer to the 'man' pages.

                                man lsusb
                              • Mike Brogan
                                I bought a cheap (about $5) wireless adapter that was plugged into the Pi from the word go while while installation from noobs was taking place. All worked
                                Message 15 of 24 , Mar 28, 2014
                                  I bought a cheap (about $5) wireless adapter that was plugged into the Pi from the word go while while installation from noobs was taking place. All worked absolutely fine and connected to the wireless system here (which is protected by password and mac number) immediately.

                                  Maybe I was just lucky - I did not have to do any editing of the config at all.......

                                  On 27/03/2014 21:13, Brock Winfrey wrote:
                                   

                                  I bought a wireless usb plug in for my rpi and it also doesn't work.  I've seen one sold by I th ink element 14 that is made just for the rpi for $11.00.  I'm just using cable now. Brock

                                  On Mar 24, 2014 5:52 PM, "dereck white" <disco5live@...> wrote:
                                   

                                  Hi Guys

                                   

                                  Have built a Raspberry pi IRLP node and it works great when tethered to my router with an Ethernet cable.

                                   

                                  I have now purchased an Alcatel Y800 mobile wireless router and have been trying for days to get it set up!!!!

                                   



                                  -- 
                                  Mike Brogan
                                  
                                  g8jhe@...
                                • westlakegeek
                                  Just a FYI, when I read your letter, I used SSH to connect to my Pi in the other room. I first checked for ‘network-manager’ and it wasn’t installed. I
                                  Message 16 of 24 , Mar 28, 2014
                                    Just a FYI, when I read your letter, I used SSH to connect to my Pi in the other room.  I first checked for ‘network-manager’ and it wasn’t installed.  I then installed wicd.  Once it was installed, I installed the ncurses, GTK, and another interface for wicd.  I ran wicd-ncurses and it gave me a list of my wireless routers and my wired eithernet.  I attempted to connect to my main router (which now that I think of it, normally the pi has issues with…) and instantly I was disconnected from my connection to the Pi (somewhat to be expected, but figured I’d get to enter the password before it disconnected…) So I didn’t get to try any more, will go into the room with the Pi later, when the wife wakes up and connect it to wifi.  Honestly, normally I’d prefer a wired connection because it’s faster.  But, in this case, I’ve gotta stretch a 100’ eithernet cable all over the place to get wired access, so I’d just prefer go wireless.  Not to mention, with it wireless, if I decide to move the Pi, I can and not be worried about an internet connection.  I really appreciate it.  I’m not sure why I didn’t think to install Wicd, because it’s what I use on all other Linux variants to connect to the wifi, and I think it’s what I used on Pidora, etc.  Just assumed the distribution would have whatever it needed to connect to a wifi….


                                    Sent from Windows Mail

                                    From: Ray Wells
                                    Sent: ‎Thursday‎, ‎March‎ ‎27‎, ‎2014 ‎6‎:‎07‎ ‎PM
                                    To: Raspberry_Pi_4-Ham_RADIO@yahoogroups.com

                                     

                                    When I first started using the RPi with wifi I also had difficulty, which I blamed on network-manager (which can clash with manual configuration). I uninstalled network-manager and installed wicd, which allowed me to configure the wifi dongle. wicd can also configure ethernet and it has fallover options. The curses interface is also handy for managing connections on headless installations.

                                    Ray vk2tv


                                    On 28/03/14 06:51, John Guillory wrote:
                                    ��
                                    Stupid thing on my part is, the wifi came bundled with my Pi, case, and power supply, so as I see it, if any part of the problem isn't supported, or doesn't have enough power, it is the Vendor's fault. ��But in my case, it works straight out of the box on pidora, just I hate pidora and can't find the compilers I want in the pidora repository. ��

                                    --
                                    KF5QEO
                                    John Guillory
                                    Cell: 601-754-9233
                                    Pinger: 337-240-7890
                                    Google Voice:��601-265-1307


                                    On Mar 27, 2014, at 2:08 PM, "Tommy Kane" <coolcamper55@...> wrote:

                                    ��

                                    There needs to be a link to wifi conf, through wpa_supplicant/ wpa_supplicant.conf

                                    ��

                                    Loads of info on Google and Rasp sites, had to set mine up today.

                                    ��

                                    Tommy

                                    ��

                                    From: Raspberry_Pi_4-Ham_RADIO@yahoogroups.com [mailto:Raspberry_Pi_4-Ham_RADIO@yahoogroups.com] On Behalf Of dereck white
                                    Sent: 25 March 2014 21:46
                                    To: Raspberry_Pi_4-Ham_RADIO@yahoogroups.com
                                    Subject: RE: [Raspberry_Pi_4-Ham_RADIO] Setting up WiFi

                                    ��

                                    ��

                                    Hi John

                                    ��

                                    Thanks for the reply, I have tried your suggestion below and still no success.

                                    The wifi adaptor I am using is the one suggested by David Camaron the 802.11n

                                    ��

                                    Regards

                                    ��

                                    Dereck

                                    ��

                                    ��

                                    ��

                                    ��

                                    From: Raspberry_Pi_4-Ham_RADIO@yahoogroups.com [mailto:Raspberry_Pi_4-Ham_RADIO@yahoogroups.com] On Behalf Of John Wiseman
                                    Sent: 25 March 2014 18:06
                                    To: Raspberry_Pi_4-Ham_RADIO@yahoogroups.com
                                    Subject: RE: [Raspberry_Pi_4-Ham_RADIO] Setting up WiFi

                                    ��

                                    ��

                                    Dereck,

                                    My /etc/network/interfaces is

                                    auto lo
                                    iface lo inet loopback

                                    iface eth0 inet dhcp

                                    allow-hotplug wlan0

                                    auto wlan0

                                    iface wlan0 inet static
                                    address 192.168.1.31
                                    netmask 255.255.255.0
                                    gateway 192.168.1.254

                                    wpa-ssid "Hilton"
                                    wpa-psk "xxxxxxxxxxx"

                                    I assigned a fixed address to my pi to make it easier to find, but it works
                                    with

                                    iface wlan0 inet dhcp

                                    wpa-ssid "Hilton"
                                    wpa-psk "xxxxxxxxxxx"

                                    I don't have an Alcatel moblle router, so can't say if that needs any
                                    special config.

                                    What wifi adapter are you using?

                                    73,
                                    John

                                    ________________________________________
                                    From: Raspberry_Pi_4-Ham_RADIO@yahoogroups.com
                                    [mailto:Raspberry_Pi_4-Ham_RADIO@yahoogroups.com] On Behalf Of
                                    disco5live@...
                                    Sent: 25 March 2014 12:09
                                    To: Raspberry_Pi_4-Ham_RADIO@yahoogroups.com
                                    Subject: RE: [Raspberry_Pi_4-Ham_RADIO] Setting up WiFi

                                    ��
                                    Hi John and members

                                    Thanks for the reply John, on the first line the /Span ></p> was not used
                                    (as you stated this must have come when I cut and pasted the email)

                                    Still not got it working, someone out there must have used the Raspberry
                                    pi/IRLP Board and the Alcatel mobile wifi router

                                    Help please

                                    Regards

                                    Dereck M0YDW



                                  • k6acj
                                    If the WiFi dongle is on the approved list all that must be done is plug it in and power up then go to the WiFi setup on the RPi Desktop, scan the routers and
                                    Message 17 of 24 , Mar 28, 2014
                                      If the WiFi dongle is on the approved list all that must be done is plug it in and power up then go to the WiFi setup on the RPi Desktop, scan the routers and save the setting.

                                      A couple of times my WiFi and SSH stopped after an apt-get update/upgrade and I had to check the WiFi setup. One time nothing would restore WiFi so I moved the WiFi dongle fromt eh RPi USB port to the external USB hub and it loaded fine. Something unknown was corrupted (I always use sudo shutdown -h now) so by using another USB port the USB configuration and Dongle looked like a new installation and recovering WiFi was routine.  I have 3 RPi's on WiFi and they work fine when using approved parts.   Bill acj
                                    • John Guillory
                                      In my case, I searched for compiler. The only option was download the source, compile it, and instal it. -- KF5QEO John Guillory westlakegeek@yahoo.com Cell:
                                      Message 18 of 24 , Mar 28, 2014
                                        In my case, I searched for compiler.  The only option was download the source, compile it, and instal it.

                                        --
                                        KF5QEO
                                        John Guillory
                                        Cell: 601-754-9233
                                        Pinger: 337-240-7890
                                        Google Voice: 601-265-1307


                                        On Mar 28, 2014, at 4:54 AM, g4sra <g4sra@...> wrote:

                                         

                                        "I just I hate pidora and can't find the compilers I want in the pidora
                                        repository."

                                        I want to install the package that has that executable in it but I cant
                                        remember it's name. It starts with 'ifconf' but I don't know which
                                        directory it goes in, either /bin, /sbin, /usr/bin, or /usr/sbin.

                                        yum provides "*bin/ifconf*"

                                        I am looking for a compiler but I don't know which one...

                                        yum search compiler

                                        Then it is up to you to make a decision (the Pi cant do everything for
                                        you, if it could, you would be redundant).

                                      • Ray Wells
                                        What I didn t say in my previous was that even though I got wifi working, it wasn t reliable and the connection would crash often - from a couple of hours to a
                                        Message 19 of 24 , Mar 28, 2014
                                          What I didn't say in my previous was that even though I got wifi working, it wasn't reliable and the connection would crash often - from a couple of hours to a max of ten days - and not restore without a reboot. It was useless for a 24/7 server. My solution was to use a DLink DAP1155 wireless bridge to provide two ethernet ports at the remote end and that works flawlessly.

                                          In fairness to the Pi, which I abandoned for some months because of the reliability issue, I later found that the supply voltage to the Pi was reasonably critical and anything less than about 5.1V caused unreliable USB. I ended up running the Pi from a 5.15V 3A linear supply and shorted out ALL polyfuses to ensure the highest voltage possible at the USB ports. My ADSB server now has an uptime of 78 days and the aprs gateway shows 74 days.

                                          Ray vk2tv


                                          On 29/03/14 01:47, westlakegeek@... wrote:
                                           

                                          Just a FYI, when I read your letter, I used SSH to connect to my Pi in the other room.  I first checked for ‘network-manager’ and it wasn’t installed.  I then installed wicd.  Once it was installed, I installed the ncurses, GTK, and another interface for wicd.  I ran wicd-ncurses and it gave me a list of my wireless routers and my wired eithernet.  I attempted to connect to my main router (which now that I think of it, normally the pi has issues with…) and instantly I was disconnected from my connection to the Pi (somewhat to be expected, but figured I’d get to enter the password before it disconnected…) So I didn’t get to try any more, will go into the room with the Pi later, when the wife wakes up and connect it to wifi.  Honestly, normally I’d prefer a wired connection because it’s faster.  But, in this case, I’ve gotta stretch a 100’ eithernet cable all over the place to get wired access, so I’d just prefer go wireless.  Not to mention, with it wireless, if I decide to move the Pi, I can and not be worried about an internet connection.  I really appreciate it.  I’m not sure why I didn’t think to install Wicd, because it’s what I use on all other Linux variants to connect to the wifi, and I think it’s what I used on Pidora, etc.  Just assumed the distribution would have whatever it needed to connect to a wifi….




                                        • g4sra
                                          PC USB ports provide 100mA, if more is required, the connecting device must negotiate for more current, up to 500mA, the PC USB hardware will regulate this.
                                          Message 20 of 24 , Mar 29, 2014
                                            PC USB ports provide 100mA, if more is required, the connecting device
                                            must negotiate for more current, up to 500mA, the PC USB hardware will
                                            regulate this.

                                            Early Pi's have USB polyfuses restricting the maximum usable current to
                                            100mA per port.

                                            Later Pi's have these removed, changing the issue....
                                            The main Pi input has a polyfuse restricting current to the whole board,
                                            putting load on the USB ports will cause a brownout and crash the Pi.

                                            USB Hubs do not negotiate or manage power in any way.

                                            Many USB devices will exceed the 500mA current specification given the
                                            opportunity, such HDD, Wifi, and UMTS\HSDPA Modems.

                                            The Pi has an 3 port USB Hub & ethernet built-in, only two ports are
                                            brought out. It does not negotiate or manage power. The built-in
                                            ethernet port works over what would have been the fourth USB port.

                                            A powered external USB hub is advised by the Foundation.


                                            Cheap '5v phone battery chargers' are exactly that, often having poor 5v
                                            regulation. Load them and you can expect a brownout.

                                            Beware when buying powered USB Hubs, many are sold with inadequate power
                                            supplies (often only 1A). A fully loaded four port USB hub would require
                                            at minimum 4 x 500mA + 100mA for the Hub itself. To get good voltage
                                            stability use a 5v power supply with a rating of 3A.

                                            Some powered Hubs backfeed, this may conflict with the Pi input voltage
                                            power supply. Running the Pi and the Hub from the same power supply
                                            overcomes this issue.
                                          • James French
                                            I haven t had any issues with my 15 dollar hub I found at Best buy locally. I ll have to take a look at the supply for it to make sure what the total amps are
                                            Message 21 of 24 , Apr 14, 2014
                                              I haven't had any issues with my 15 dollar hub I found at Best buy locally. I'll have to take a look at the supply for it to make sure what the total amps are but I think it is around 2.5 amps.

                                              I have powered my pi through the hub thus negating the need for another supply dedicated for power. Have had my wifi, and a few other things connected along with my pi.

                                              I just remembered, I did have an issue with using the keyboard and mouse thru the hub. It just would not work. Plugged them back in to the other available port on the pi and they work again. That was before I even tried to power the pi thru the hub though.

                                              James W8ISS


                                              On Sat, Mar 29, 2014 at 10:20 AM, g4sra <g4sra@...> wrote:
                                               

                                              PC USB ports provide 100mA, if more is required, the connecting device
                                              must negotiate for more current, up to 500mA, the PC USB hardware will
                                              regulate this.

                                              Early Pi's have USB polyfuses restricting the maximum usable current to
                                              100mA per port.

                                              Later Pi's have these removed, changing the issue....
                                              The main Pi input has a polyfuse restricting current to the whole board,
                                              putting load on the USB ports will cause a brownout and crash the Pi.

                                              USB Hubs do not negotiate or manage power in any way.

                                              Many USB devices will exceed the 500mA current specification given the
                                              opportunity, such HDD, Wifi, and UMTS\HSDPA Modems.

                                              The Pi has an 3 port USB Hub & ethernet built-in, only two ports are
                                              brought out. It does not negotiate or manage power. The built-in
                                              ethernet port works over what would have been the fourth USB port.

                                              A powered external USB hub is advised by the Foundation.

                                              Cheap '5v phone battery chargers' are exactly that, often having poor 5v
                                              regulation. Load them and you can expect a brownout.

                                              Beware when buying powered USB Hubs, many are sold with inadequate power
                                              supplies (often only 1A). A fully loaded four port USB hub would require
                                              at minimum 4 x 500mA + 100mA for the Hub itself. To get good voltage
                                              stability use a 5v power supply with a rating of 3A.

                                              Some powered Hubs backfeed, this may conflict with the Pi input voltage
                                              power supply. Running the Pi and the Hub from the same power supply
                                              overcomes this issue.


                                            • adshar64
                                              Pidora 20 is the best possible raspberry pi software in use now. It has not been publicly released, but a few have developed from the Koji repositories on
                                              Message 22 of 24 , Apr 16, 2014
                                                Pidora 20 is the best possible raspberry pi software in use now. It has not been publicly released, but a few have developed from the Koji repositories on lengthy yum release updates to get the final pidora 20 package.

                                                One of the very few images available is here;


                                                 The post  from KF5QEO indicated a bit of linux learning required, I think you are looking for;

                                                [root@raspi ~]# yum provides ifconfig

                                                net-tools

                                                Don't hate the software because you havn't bothered to learn how to use it.

                                                ZS6ANC



                                              • Michael O'Bannon
                                                Could you explain what makes it better than other distributions for hams? I m not disagreeing with you, just looking for information from someone who has
                                                Message 23 of 24 , Apr 16, 2014
                                                  Could you explain what makes it better than other distributions for hams?  I'm not disagreeing with you, just looking for information from someone who has actually used it.

                                                  What ham applications are you running with Pidora 20?
                                                  Does it handle processor-intensive applications such as fldigi and the k1jt programs reliably on the Pi?
                                                  The online information seems to be out of date.  Are you able to get current information and support when you need it?

                                                  Thanks,
                                                  Michael  KD4SGN

                                                  Pidora 20 is the best possible raspberry pi software in use now. It has not been publicly released, but a few have developed from the Koji repositories on lengthy yum release updates to get the final pidora 20 package.



                                                • adshar64
                                                  It is the only Rpi software which will run the cpu intensive DVDongle correctly. Try it out download the image , yum remove dstarrepeater_1 ircddbgateway and
                                                  Message 24 of 24 , Apr 16, 2014
                                                    It is the only Rpi software which will run the cpu intensive DVDongle correctly.

                                                    Try it out download the image , 

                                                    yum remove dstarrepeater_1 ircddbgateway and then do what you like with it. It is more like using the BBB than the Rpi.

                                                    The Pidora 20 repositories are massive , yes the online info is stuck at 18. I think they were planning a big surprise with 20. A few like vk4tux got in early on this fantastic development for the Rpi.
                                                    just grab a 4GB + card and try it. > yum repositories. have at it.

                                                    ZS6ANC

                                                    see


                                                  Your message has been successfully submitted and would be delivered to recipients shortly.