Loading ...
Sorry, an error occurred while loading the content.

RE: [Raspberry_Pi_4-Ham_RADIO] TNC-X-PI and i2c bus...

Expand Messages
  • John Wiseman
    Eric, Check that Xastir has the right path to com1, and the rights of the symlink and the underlying pty. 73, John _____ From:
    Message 1 of 6 , May 23, 2013
    • 0 Attachment
      Eric,
       
      Check that Xastir has the right path to com1, and the rights of the symlink and the underlying pty.
       
      73, John


      From: Raspberry_Pi_4-Ham_RADIO@yahoogroups.com [mailto:Raspberry_Pi_4-Ham_RADIO@yahoogroups.com] On Behalf Of Eric Scott
      Sent: 23 May 2013 16:30
      To: Raspberry_Pi_4-Ham_RADIO@yahoogroups.com
      Subject: Re: [Raspberry_Pi_4-Ham_RADIO] TNC-X-PI and i2c bus...

       

      John,

      I did do that. I got the AX.25 part to work. I then killed the process and set up with a symbolic link to com1.  Xastir did not recognize my settings. I guess I must have gotten something wrong.  

      On 2013-05-23, at 7:48 AM, "John Wiseman" <john.wiseman@...> wrote:

       

      Eric
       
      The TNC-PI manual at http://www.tnc-x.com/TNCPi.pdf  has a section entitled Running Applications other than LinBPQ with TNC-Pi in I2C mode.
       
      Set i2ckiss up to create a  pty pair, and define the com port to your application,
       
      Or LinBPQ includes an APRS Digi/Igate, and can use the TNC in i2c mode.
       
      73, John
       


      From: Raspberry_Pi_4-Ham_RADIO@yahoogroups.com [mailto:Raspberry_Pi_4-Ham_RADIO@yahoogroups.com] On Behalf Of Eric Scott
      Sent: 23 May 2013 15:25
      To: Raspberry_Pi_4-Ham_RADIO@yahoogroups.com
      Subject: [Raspberry_Pi_4-Ham_RADIO] TNC-X-PI and i2c bus...

       

      Hi,

      I recently built a TNC-X-PI and got it working.  I changed it from the serial bus to the i2c bus, and it worked out well once I found the tutorial on this listserver.  How do yo get it to work with Xaistr?  If that doesn't work, is there another way of getting APRS to work?  Maybe a command line version?  I have the Adafruit GPS unit that I need to operate off of the serial port, so I moved the TNC-X-PI to the i2C bus.

      Any help would be appreciated.

      '73

      Eric Scott
      VE7KLZ / KC7KLZ  

    • Eric Scott
      That could be my issue. I will check that out. 73 Eric VE7KLZ / KC7KLZ
      Message 2 of 6 , May 23, 2013
      • 0 Attachment
        That could be my issue. I will check that out. 

        '73

        Eric
        VE7KLZ / KC7KLZ

        On 2013-05-23, at 9:03 AM, "John Wiseman" <john.wiseman@...> wrote:

         

        Eric,
         
        Check that Xastir has the right path to com1, and the rights of the symlink and the underlying pty.
         
        73, John


        From: Raspberry_Pi_4-Ham_RADIO@yahoogroups.com [mailto:Raspberry_Pi_4-Ham_RADIO@yahoogroups.com] On Behalf Of Eric Scott
        Sent: 23 May 2013 16:30
        To: Raspberry_Pi_4-Ham_RADIO@yahoogroups.com
        Subject: Re: [Raspberry_Pi_4-Ham_RADIO] TNC-X-PI and i2c bus...

         

        John,

        I did do that. I got the AX.25 part to work. I then killed the process and set up with a symbolic link to com1.  Xastir did not recognize my settings. I guess I must have gotten something wrong.  

        On 2013-05-23, at 7:48 AM, "John Wiseman" <john.wiseman@...> wrote:

         

        Eric
         
        The TNC-PI manual at http://www.tnc-x.com/TNCPi.pdf  has a section entitled Running Applications other than LinBPQ with TNC-Pi in I2C mode.
         
        Set i2ckiss up to create a  pty pair, and define the com port to your application,
         
        Or LinBPQ includes an APRS Digi/Igate, and can use the TNC in i2c mode.
         
        73, John
         


        From: Raspberry_Pi_4-Ham_RADIO@yahoogroups.com [mailto:Raspberry_Pi_4-Ham_RADIO@yahoogroups.com] On Behalf Of Eric Scott
        Sent: 23 May 2013 15:25
        To: Raspberry_Pi_4-Ham_RADIO@yahoogroups.com
        Subject: [Raspberry_Pi_4-Ham_RADIO] TNC-X-PI and i2c bus...

         

        Hi,

        I recently built a TNC-X-PI and got it working.  I changed it from the serial bus to the i2c bus, and it worked out well once I found the tutorial on this listserver.  How do yo get it to work with Xaistr?  If that doesn't work, is there another way of getting APRS to work?  Maybe a command line version?  I have the Adafruit GPS unit that I need to operate off of the serial port, so I moved the TNC-X-PI to the i2C bus.

        Any help would be appreciated.

        '73

        Eric Scott
        VE7KLZ / KC7KLZ  

      • Eric Scott
        Hi, I got the link set up, and Xastir worked.  Then I closed it, and it wouldn t work again.  I killed the i2ckiss process and set it up again, still no joy.
        Message 3 of 6 , May 23, 2013
        • 0 Attachment
          Hi,

          I got the link set up, and Xastir worked.  Then I closed it, and it wouldn't work again.  I killed the i2ckiss process and set it up again, still no joy.  I'll have to check it out later when I have more time. 

          '73

          Eric Scott
          VE7KLZ / KC7KLZ 


          From: Eric Scott <kc7klz@...>
          To: "Raspberry_Pi_4-Ham_RADIO@yahoogroups.com" <Raspberry_Pi_4-Ham_RADIO@yahoogroups.com>
          Sent: Thursday, May 23, 2013 9:40 AM
          Subject: Re: [Raspberry_Pi_4-Ham_RADIO] TNC-X-PI and i2c bus...

           
          That could be my issue. I will check that out. 

          '73

          Eric
          VE7KLZ / KC7KLZ

          On 2013-05-23, at 9:03 AM, "John Wiseman" <john.wiseman@...> wrote:

           
          Eric,
           
          Check that Xastir has the right path to com1, and the rights of the symlink and the underlying pty.
           
          73, John


          From: Raspberry_Pi_4-Ham_RADIO@yahoogroups.com [mailto:Raspberry_Pi_4-Ham_RADIO@yahoogroups.com] On Behalf Of Eric Scott
          Sent: 23 May 2013 16:30
          To: Raspberry_Pi_4-Ham_RADIO@yahoogroups.com
          Subject: Re: [Raspberry_Pi_4-Ham_RADIO] TNC-X-PI and i2c bus...

           
          John,

          I did do that. I got the AX.25 part to work. I then killed the process and set up with a symbolic link to com1.  Xastir did not recognize my settings. I guess I must have gotten something wrong.  

          On 2013-05-23, at 7:48 AM, "John Wiseman" <john.wiseman@...> wrote:

           
          Eric
           
          The TNC-PI manual at http://www.tnc-x.com/TNCPi.pdf  has a section entitled Running Applications other than LinBPQ with TNC-Pi in I2C mode.
           
          Set i2ckiss up to create a  pty pair, and define the com port to your application,
           
          Or LinBPQ includes an APRS Digi/Igate, and can use the TNC in i2c mode.
           
          73, John
           


          From: Raspberry_Pi_4-Ham_RADIO@yahoogroups.com [mailto:Raspberry_Pi_4-Ham_RADIO@yahoogroups.com] On Behalf Of Eric Scott
          Sent: 23 May 2013 15:25
          To: Raspberry_Pi_4-Ham_RADIO@yahoogroups.com
          Subject: [Raspberry_Pi_4-Ham_RADIO] TNC-X-PI and i2c bus...

           
          Hi,

          I recently built a TNC-X-PI and got it working.  I changed it from the serial bus to the i2c bus, and it worked out well once I found the tutorial on this listserver.  How do yo get it to work with Xaistr?  If that doesn't work, is there another way of getting APRS to work?  Maybe a command line version?  I have the Adafruit GPS unit that I need to operate off of the serial port, so I moved the TNC-X-PI to the i2C bus.

          Any help would be appreciated.

          '73

          Eric Scott
          VE7KLZ / KC7KLZ  


        Your message has been successfully submitted and would be delivered to recipients shortly.