Loading ...
Sorry, an error occurred while loading the content.

Raspberry Pi and dttsp

Expand Messages
  • roland etienne
    Hi all, I think this could be of some interest for this list, this info comes from dttsp-linux group. 73, Roland F8CHK De : dttsp-linux@yahoogroups.com
    Message 1 of 1 , Apr 22 12:28 AM
    • 0 Attachment

      Hi all,

       

      I think this could be of some interest for this list, this info comes from dttsp-linux group.

       

       

      73,

      Roland F8CHK

       

       

      De : dttsp-linux@yahoogroups.com [mailto:dttsp-linux@yahoogroups.com] De la part de Glen Overby
      Envoyé : dimanche 21 avril 2013 18:38
      À : dttsp-linux@yahoogroups.com
      Objet : [dttsp-linux] sdr-core on Raspberry Pi

       

       

      I bought a Raspberry Pi, and tried it out as an SDR.  I'm now listening to WWV using my Softrock 6.3, E-Mu 0204 USB audio adapter, and R-Pi.  I must mention that the 0204 is the largest of the components, and its about the size of the other two (but those are bare boards).

      It was a an adventure getting here.  The jackd that comes with the raspian distribution has problems (it coredumps).  I found this page that has an explanation and fixes:
      http://wiki.linuxaudio.org/wiki/raspberrypi


      I've found it to be very fragile.  Plugging in a USB hub, or the 0204 caused it to crash (I didn't have a monitor connected at the time so I don't know the cause).  If jackd fails to start once, it won't start properly again (removing /run/shm/* might be a fix to this).  Jackd has to be started using the hardware index from /proc/asound/cards, not the name.

      I ran jackd at 48khz.  I overclocked my R-Pi to 900mhz, and observed sdr-core with top:

          28% cpu in ssb mode
          40% after setNR 1
          40% after setANF 1
          32% after setNB 1
          55% with all 3 turned on

      When I turn on filter and meter (-s and -m), the cpu utilization goes up about 2% (but that's without anything retrieving spectrum or meter).  jackd runs at about 5.5% cpu.

      I installed these additional packages in order to build:

      - dttsp -
      libjack-jackd2-dev
      libfftw3-dev
      libgsl0-dev
      liblo-dev

      - usbsoftrock -
      libusb-dev
      (I hacked out the interactive mode; it needs ncurses)

      without a GUI, I had to configure dttsp manually.  For those who haven't done this before, here's what I did:

      nc -u localhost 19001
      setOsc -12000.0
      setMode 1
      setFilter 50 2500

      then I tuned with usbsoftrock 12000 hz lower than the desired frequency, e.g. for WWV at 10mhz:
      usbsoftrock set freq 9.988

      I haven't tried to transmit yet.

      Glen, kc0iyt

       

    Your message has been successfully submitted and would be delivered to recipients shortly.