Loading ...
Sorry, an error occurred while loading the content.

Re: [Raspberry_Pi_4-Ham_RADIO] Re: kissattach error with TNC-PI

Expand Messages
  • John Wiseman
    The console=tty1 must be left in. 73, John Sent from Samsung tablet
    Message 1 of 10 , Mar 31, 2013
    • 0 Attachment
      The console=tty1 must be left in.

      73, John




      Sent from Samsung tablet

      Charles <k4gbb1@...> wrote:

      >In case anyone has followed the suggestion that the two statements in
      >cmdline.txt may be remarked out. This does NOT work. You MUST delete the
      >two elements. Cmdline.txt is a single line with elements separated by a
      >space.
      >
      >Here is the contents of cmdline.txt.
      >
      >dwc_otg.lpm_enable=0 console=ttyAMA0,115200 kgdboc=ttyAMA0,115200
      >console=tty1 root=/dev/mmcblk0p2 rootfstype=ext4 elevator=deadline
      >rootwait
      >
      >The underlined part is to be deleted,leaving.....
      >
      >dwc_otg.lpm_enable=0 root=/dev/mmcblk0p2 rootfstype=ext4
      >elevator=deadline rootwait
      >
      >73
      ><<Charley>>
      > k4gbb
      >
      >--- In Raspberry_Pi_4-Ham_RADIO@yahoogroups.com, "John Wiseman"
      ><john.wiseman@...> wrote:
      >>
      >> Hopefully not!
      >>
      >> cmdline.txt is in the boot partition, and can be edited from windows.
      >Just
      >> plug the card into you windows machine.
      >>
      >> You may be able to see what you've done wrong. If not, I'm sure
      >someone on
      >> here will send you one. I'm away from home, so I cant send you mine
      >>
      >> 73, John
      >>
      >> _____
      >>
      >> From: Raspberry_Pi_4-Ham_RADIO@yahoogroups.com
      >> [mailto:Raspberry_Pi_4-Ham_RADIO@yahoogroups.com] On Behalf Of
      >> hawksbillpines
      >> Sent: 29 March 2013 21:40
      >> To: Raspberry_Pi_4-Ham_RADIO@yahoogroups.com
      >> Subject: [Raspberry_Pi_4-Ham_RADIO] Re: kissattach error with TNC-PI
      >>
      >>
      >>
      >>
      >> Thanks so much for the very quick response. I went ahead and made the
      >> suggested changes to both the cmdline.txt and inittab file. BUT...upon
      >> rebooting I have no connection with my Pi:-( It's not showing up on my
      >DHCP
      >> Client Table and of course indicating "...No route to host" when I try
      >ssh.
      >> I've tried both WIFI and wired connections.
      >>
      >> Unable to connect with my Pi, I'm assuming my next step is to start
      >all over
      >> and install an new OS img. (mumble, mumble)
      >>
      >> Any suggestions before I jump back to square one????
      >>
      >> Thanks,
      >> Dave K4DPF
      >>
      >> --- In Raspberry_Pi_4-Ham_RADIO@yahoogroups.com
      >> <mailto:Raspberry_Pi_4-Ham_RADIO%40yahoogroups.com> , "John Wiseman"
      >> john.wiseman@ wrote:
      >> >
      >> > You cant have blank lines in /etc/ax25/axports. You will probably
      >find a
      >> > blank line at line 7
      >> >
      >> > It would be wise to do the changes to cmdline.txt - you are using
      >the
      >> serial
      >> > port.
      >> >
      >> > 73, John G8BPQ
      >> >
      >> >
      >> >
      >> >
      >> > _____
      >> >
      >> > From: Raspberry_Pi_4-Ham_RADIO@yahoogroups.com
      >> <mailto:Raspberry_Pi_4-Ham_RADIO%40yahoogroups.com>
      >> > [mailto:Raspberry_Pi_4-Ham_RADIO@yahoogroups.com
      >> <mailto:Raspberry_Pi_4-Ham_RADIO%40yahoogroups.com> ] On Behalf Of
      >> > hawksbillpines
      >> > Sent: 29 March 2013 20:58
      >> > To: Raspberry_Pi_4-Ham_RADIO@yahoogroups.com
      >> <mailto:Raspberry_Pi_4-Ham_RADIO%40yahoogroups.com>
      >> > Subject: [Raspberry_Pi_4-Ham_RADIO] kissattach error with TNC-PI
      >> >
      >> >
      >> >
      >> >
      >> > Good day, All...
      >> >
      >> > In the past few days I have received and assembled my TNC-PI.
      >Everything
      >> > went well until I started configuring the Pi per the instructions. I
      >did
      >> the
      >> > update and upgrades as indicated. Now here is where my newbie level
      >> > knowledge may be causing me problems. The directions talk about
      >editing
      >> the
      >> > cmdline.txt file if you are going to use the serial port to connect
      >the
      >> > TNC-PI to the Raspberry Pi. Since I was connecting the two devices
      >> together
      >> > my assumption was that I didn't need to make these edits.
      >> >
      >> > Anyway, I continued on and edited the /etc/ax25/axports file with
      >> >
      >> > 1 K4DPF 19200 236 2 TNC 1
      >> > That's the only active line in the file. All others are commented
      >out.
      >> >
      >> > Unlike others who successfully rand
      >> > sudo kissattach /dev/ttyAMA0 1 10.1.1.1
      >> >
      >> > I got the message
      >> > "kissattach: unable to parse line 7 of the axports file."
      >> >
      >> > I know that not much insight, but if anyone has seen that response
      >would
      >> you
      >> > please share suggestions to correct the situation.
      >> >
      >> > Many thanks,
      >> > Dave K4DPF
      >> >
      >>
      >
    • Tom Hoflich
      I get the following error: kissattach: cannot find port 1 in axports My axports file looks exactly the same as the documentation except for KM5H in place of
      Message 2 of 10 , Apr 1, 2013
      • 0 Attachment
        I get the following error:
        kissattach: cannot find port 1 in axports

        My axports file looks exactly the same as the documentation except for KM5H in place of W2FS
        what am I missing?
        73, Tom KM5H




         


        From: John Wiseman <john.wiseman@...>
        To: raspberry_pi_4-ham_radio@yahoogroups.com
        Sent: Sunday, March 31, 2013 2:08 PM
        Subject: Re: [Raspberry_Pi_4-Ham_RADIO] Re: kissattach error with TNC-PI

         
        The console=tty1 must be left in.

        73, John

        Sent from Samsung tablet

        Charles <k4gbb1@...> wrote:

        >In case anyone has followed the suggestion that the two statements in
        >cmdline.txt may be remarked out. This does NOT work. You MUST delete the
        >two elements. Cmdline.txt is a single line with elements separated by a
        >space.
        >
        >Here is the contents of cmdline.txt.
        >
        >dwc_otg.lpm_enable=0 console=ttyAMA0,115200 kgdboc=ttyAMA0,115200
        >console=tty1 root=/dev/mmcblk0p2 rootfstype=ext4 elevator=deadline
        >rootwait
        >
        >The underlined part is to be deleted,leaving.....
        >
        >dwc_otg.lpm_enable=0 root=/dev/mmcblk0p2 rootfstype=ext4
        >elevator=deadline rootwait
        >
        >73
        ><<Charley>>
        > k4gbb
        >
        >--- In Raspberry_Pi_4-Ham_RADIO@yahoogroups.com, "John Wiseman"
        ><john.wiseman@...> wrote:
        >>
        >> Hopefully not!
        >>
        >> cmdline.txt is in the boot partition, and can be edited from windows.
        >Just
        >> plug the card into you windows machine.
        >>
        >> You may be able to see what you've done wrong. If not, I'm sure
        >someone on
        >> here will send you one. I'm away from home, so I cant send you mine
        >>
        >> 73, John
        >>
        >> _____
        >>
        >> From: Raspberry_Pi_4-Ham_RADIO@yahoogroups.com
        >> [mailto:Raspberry_Pi_4-Ham_RADIO@yahoogroups.com] On Behalf Of
        >> hawksbillpines
        >> Sent: 29 March 2013 21:40
        >> To: Raspberry_Pi_4-Ham_RADIO@yahoogroups.com
        >> Subject: [Raspberry_Pi_4-Ham_RADIO] Re: kissattach error with TNC-PI
        >>
        >>
        >>
        >>
        >> Thanks so much for the very quick response. I went ahead and made the
        >> suggested changes to both the cmdline.txt and inittab file. BUT...upon
        >> rebooting I have no connection with my Pi:-( It's not showing up on my
        >DHCP
        >> Client Table and of course indicating "...No route to host" when I try
        >ssh.
        >> I've tried both WIFI and wired connections.
        >>
        >> Unable to connect with my Pi, I'm assuming my next step is to start
        >all over
        >> and install an new OS img. (mumble, mumble)
        >>
        >> Any suggestions before I jump back to square one????
        >>
        >> Thanks,
        >> Dave K4DPF
        >>
        >> --- In Raspberry_Pi_4-Ham_RADIO@yahoogroups.com
        >> <mailto:Raspberry_Pi_4-Ham_RADIO%40yahoogroups.com> , "John Wiseman"
        >> john.wiseman@ wrote:
        >> >
        >> > You cant have blank lines in /etc/ax25/axports. You will probably
        >find a
        >> > blank line at line 7
        >> >
        >> > It would be wise to do the changes to cmdline.txt - you are using
        >the
        >> serial
        >> > port.
        >> >
        >> > 73, John G8BPQ
        >> >
        >> >
        >> >
        >> >
        >> > _____
        >> >
        >> > From: Raspberry_Pi_4-Ham_RADIO@yahoogroups.com
        >> <mailto:Raspberry_Pi_4-Ham_RADIO%40yahoogroups.com>
        >> > [mailto:Raspberry_Pi_4-Ham_RADIO@yahoogroups.com
        >> <mailto:Raspberry_Pi_4-Ham_RADIO%40yahoogroups.com> ] On Behalf Of
        >> > hawksbillpines
        >> > Sent: 29 March 2013 20:58
        >> > To: Raspberry_Pi_4-Ham_RADIO@yahoogroups.com
        >> <mailto:Raspberry_Pi_4-Ham_RADIO%40yahoogroups.com>
        >> > Subject: [Raspberry_Pi_4-Ham_RADIO] kissattach error with TNC-PI
        >> >
        >> >
        >> >
        >> >
        >> > Good day, All...
        >> >
        >> > In the past few days I have received and assembled my TNC-PI.
        >Everything
        >> > went well until I started configuring the Pi per the instructions. I
        >did
        >> the
        >> > update and upgrades as indicated. Now here is where my newbie level
        >> > knowledge may be causing me problems. The directions talk about
        >editing
        >> the
        >> > cmdline.txt file if you are going to use the serial port to connect
        >the
        >> > TNC-PI to the Raspberry Pi. Since I was connecting the two devices
        >> together
        >> > my assumption was that I didn't need to make these edits.
        >> >
        >> > Anyway, I continued on and edited the /etc/ax25/axports file with
        >> >
        >> > 1 K4DPF 19200 236 2 TNC 1
        >> > That's the only active line in the file. All others are commented
        >out.
        >> >
        >> > Unlike others who successfully rand
        >> > sudo kissattach /dev/ttyAMA0 1 10.1.1.1
        >> >
        >> > I got the message
        >> > "kissattach: unable to parse line 7 of the axports file."
        >> >
        >> > I know that not much insight, but if anyone has seen that response
        >would
        >> you
        >> > please share suggestions to correct the situation.
        >> >
        >> > Many thanks,
        >> > Dave K4DPF
        >> >
        >>
        >


      • Bob Scanferla
        post your axports fileĀ  so we can see.....a picture is worth a thousand words. B ________________________________ From: Tom Hoflich To:
        Message 3 of 10 , Apr 1, 2013
        • 0 Attachment
          post your axports file  so we can see.....a picture is worth a thousand words.

          B


          From: Tom Hoflich <km5h@...>
          To: "Raspberry_Pi_4-Ham_RADIO@yahoogroups.com" <Raspberry_Pi_4-Ham_RADIO@yahoogroups.com>
          Sent: Monday, April 1, 2013 2:57:21 PM
          Subject: Re: [Raspberry_Pi_4-Ham_RADIO] Re: kissattach error with TNC-PI

           
          I get the following error:
          kissattach: cannot find port 1 in axports

          My axports file looks exactly the same as the documentation except for KM5H in place of W2FS
          what am I missing?
          73, Tom KM5H




           


          From: John Wiseman <john.wiseman@...>
          To: raspberry_pi_4-ham_radio@yahoogroups.com
          Sent: Sunday, March 31, 2013 2:08 PM
          Subject: Re: [Raspberry_Pi_4-Ham_RADIO] Re: kissattach error with TNC-PI

           
          The console=tty1 must be left in.

          73, John

          Sent from Samsung tablet

          Charles <k4gbb1@...> wrote:

          >In case anyone has followed the suggestion that the two statements in
          >cmdline.txt may be remarked out. This does NOT work. You MUST delete the
          >two elements. Cmdline.txt is a single line with elements separated by a
          >space.
          >
          >Here is the contents of cmdline.txt.
          >
          >dwc_otg.lpm_enable=0 console=ttyAMA0,115200 kgdboc=ttyAMA0,115200
          >console=tty1 root=/dev/mmcblk0p2 rootfstype=ext4 elevator=deadline
          >rootwait
          >
          >The underlined part is to be deleted,leaving.....
          >
          >dwc_otg.lpm_enable=0 root=/dev/mmcblk0p2 rootfstype=ext4
          >elevator=deadline rootwait
          >
          >73
          ><<Charley>>
          > k4gbb
          >
          >--- In Raspberry_Pi_4-Ham_RADIO@yahoogroups.com, "John Wiseman"
          ><john.wiseman@...> wrote:
          >>
          >> Hopefully not!
          >>
          >> cmdline.txt is in the boot partition, and can be edited from windows.
          >Just
          >> plug the card into you windows machine.
          >>
          >> You may be able to see what you've done wrong. If not, I'm sure
          >someone on
          >> here will send you one. I'm away from home, so I cant send you mine
          >>
          >> 73, John
          >>
          >> _____
          >>
          >> From: Raspberry_Pi_4-Ham_RADIO@yahoogroups.com
          >> [mailto:Raspberry_Pi_4-Ham_RADIO@yahoogroups.com] On Behalf Of
          >> hawksbillpines
          >> Sent: 29 March 2013 21:40
          >> To: Raspberry_Pi_4-Ham_RADIO@yahoogroups.com
          >> Subject: [Raspberry_Pi_4-Ham_RADIO] Re: kissattach error with TNC-PI
          >>
          >>
          >>
          >>
          >> Thanks so much for the very quick response. I went ahead and made the
          >> suggested changes to both the cmdline.txt and inittab file. BUT...upon
          >> rebooting I have no connection with my Pi:-( It's not showing up on my
          >DHCP
          >> Client Table and of course indicating "...No route to host" when I try
          >ssh.
          >> I've tried both WIFI and wired connections.
          >>
          >> Unable to connect with my Pi, I'm assuming my next step is to start
          >all over
          >> and install an new OS img. (mumble, mumble)
          >>
          >> Any suggestions before I jump back to square one????
          >>
          >> Thanks,
          >> Dave K4DPF
          >>
          >> --- In Raspberry_Pi_4-Ham_RADIO@yahoogroups.com
          >> <mailto:Raspberry_Pi_4-Ham_RADIO%40yahoogroups.com> , "John Wiseman"
          >> john.wiseman@ wrote:
          >> >
          >> > You cant have blank lines in /etc/ax25/axports. You will probably
          >find a
          >> > blank line at line 7
          >> >
          >> > It would be wise to do the changes to cmdline.txt - you are using
          >the
          >> serial
          >> > port.
          >> >
          >> > 73, John G8BPQ
          >> >
          >> >
          >> >
          >> >
          >> > _____
          >> >
          >> > From: Raspberry_Pi_4-Ham_RADIO@yahoogroups.com
          >> <mailto:Raspberry_Pi_4-Ham_RADIO%40yahoogroups.com>
          >> > [mailto:Raspberry_Pi_4-Ham_RADIO@yahoogroups.com
          >> <mailto:Raspberry_Pi_4-Ham_RADIO%40yahoogroups.com> ] On Behalf Of
          >> > hawksbillpines
          >> > Sent: 29 March 2013 20:58
          >> > To: Raspberry_Pi_4-Ham_RADIO@yahoogroups.com
          >> <mailto:Raspberry_Pi_4-Ham_RADIO%40yahoogroups.com>
          >> > Subject: [Raspberry_Pi_4-Ham_RADIO] kissattach error with TNC-PI
          >> >
          >> >
          >> >
          >> >
          >> > Good day, All...
          >> >
          >> > In the past few days I have received and assembled my TNC-PI.
          >Everything
          >> > went well until I started configuring the Pi per the instructions. I
          >did
          >> the
          >> > update and upgrades as indicated. Now here is where my newbie level
          >> > knowledge may be causing me problems. The directions talk about
          >editing
          >> the
          >> > cmdline.txt file if you are going to use the serial port to connect
          >the
          >> > TNC-PI to the Raspberry Pi. Since I was connecting the two devices
          >> together
          >> > my assumption was that I didn't need to make these edits.
          >> >
          >> > Anyway, I continued on and edited the /etc/ax25/axports file with
          >> >
          >> > 1 K4DPF 19200 236 2 TNC 1
          >> > That's the only active line in the file. All others are commented
          >out.
          >> >
          >> > Unlike others who successfully rand
          >> > sudo kissattach /dev/ttyAMA0 1 10.1.1.1
          >> >
          >> > I got the message
          >> > "kissattach: unable to parse line 7 of the axports file."
          >> >
          >> > I know that not much insight, but if anyone has seen that response
          >would
          >> you
          >> > please share suggestions to correct the situation.
          >> >
          >> > Many thanks,
          >> > Dave K4DPF
          >> >
          >>
          >




        • Tom Hoflich
          As I was looking at the axposts and trying to figure out how post it, I noticed that the two lines that I wanted contained a # in the first position making it
          Message 4 of 10 , Apr 1, 2013
          • 0 Attachment
            As I was looking at the axposts and trying to figure out how post it, I noticed that the two lines that I wanted
            contained a # in the first position making it a comment.
            I removed that and now I get "AX.25 port 1 bound to device ax0" which I assume is correct.
            Thanks for making me look ANOTHER time.

            73, Tom
             





            From: Bob Scanferla <va3rjs@...>
            To: "Raspberry_Pi_4-Ham_RADIO@yahoogroups.com" <Raspberry_Pi_4-Ham_RADIO@yahoogroups.com>
            Sent: Monday, April 1, 2013 2:31 PM
            Subject: Re: [Raspberry_Pi_4-Ham_RADIO] Re: kissattach error with TNC-PI

             
            post your axports file  so we can see.....a picture is worth a thousand words.

            B


            From: Tom Hoflich <km5h@...>
            To: "Raspberry_Pi_4-Ham_RADIO@yahoogroups.com" <Raspberry_Pi_4-Ham_RADIO@yahoogroups.com>
            Sent: Monday, April 1, 2013 2:57:21 PM
            Subject: Re: [Raspberry_Pi_4-Ham_RADIO] Re: kissattach error with TNC-PI

             
            I get the following error:
            kissattach: cannot find port 1 in axports

            My axports file looks exactly the same as the documentation except for KM5H in place of W2FS
            what am I missing?
            73, Tom KM5H




             
            http://km5h.softrockradio.org/


            From: John Wiseman <john.wiseman@...>
            To: raspberry_pi_4-ham_radio@yahoogroups.com
            Sent: Sunday, March 31, 2013 2:08 PM
            Subject: Re: [Raspberry_Pi_4-Ham_RADIO] Re: kissattach error with TNC-PI

             
            The console=tty1 must be left in.

            73, John

            Sent from Samsung tablet

            Charles <k4gbb1@...> wrote:

            >In case anyone has followed the suggestion that the two statements in
            >cmdline.txt may be remarked out. This does NOT work. You MUST delete the
            >two elements. Cmdline.txt is a single line with elements separated by a
            >space.
            >
            >Here is the contents of cmdline.txt.
            >
            >dwc_otg.lpm_enable=0 console=ttyAMA0,115200 kgdboc=ttyAMA0,115200
            >console=tty1 root=/dev/mmcblk0p2 rootfstype=ext4 elevator=deadline
            >rootwait
            >
            >The underlined part is to be deleted,leaving.....
            >
            >dwc_otg.lpm_enable=0 root=/dev/mmcblk0p2 rootfstype=ext4
            >elevator=deadline rootwait
            >
            >73
            ><<Charley>>
            > k4gbb
            >
            >--- In Raspberry_Pi_4-Ham_RADIO@yahoogroups.com, "John Wiseman"
            ><john.wiseman@...> wrote:
            >>
            >> Hopefully not!
            >>
            >> cmdline.txt is in the boot partition, and can be edited from windows.
            >Just
            >> plug the card into you windows machine.
            >>
            >> You may be able to see what you've done wrong. If not, I'm sure
            >someone on
            >> here will send you one. I'm away from home, so I cant send you mine
            >>
            >> 73, John
            >>
            >> _____
            >>
            >> From: Raspberry_Pi_4-Ham_RADIO@yahoogroups.com
            >> [mailto:Raspberry_Pi_4-Ham_RADIO@yahoogroups.com] On Behalf Of
            >> hawksbillpines
            >> Sent: 29 March 2013 21:40
            >> To: Raspberry_Pi_4-Ham_RADIO@yahoogroups.com
            >> Subject: [Raspberry_Pi_4-Ham_RADIO] Re: kissattach error with TNC-PI
            >>
            >>
            >>
            >>
            >> Thanks so much for the very quick response. I went ahead and made the
            >> suggested changes to both the cmdline.txt and inittab file. BUT...upon
            >> rebooting I have no connection with my Pi:-( It's not showing up on my
            >DHCP
            >> Client Table and of course indicating "...No route to host" when I try
            >ssh.
            >> I've tried both WIFI and wired connections.
            >>
            >> Unable to connect with my Pi, I'm assuming my next step is to start
            >all over
            >> and install an new OS img. (mumble, mumble)
            >>
            >> Any suggestions before I jump back to square one????
            >>
            >> Thanks,
            >> Dave K4DPF
            >>
            >> --- In Raspberry_Pi_4-Ham_RADIO@yahoogroups.com
            >> <mailto:Raspberry_Pi_4-Ham_RADIO%40yahoogroups.com> , "John Wiseman"
            >> john.wiseman@ wrote:
            >> >
            >> > You cant have blank lines in /etc/ax25/axports. You will probably
            >find a
            >> > blank line at line 7
            >> >
            >> > It would be wise to do the changes to cmdline.txt - you are using
            >the
            >> serial
            >> > port.
            >> >
            >> > 73, John G8BPQ
            >> >
            >> >
            >> >
            >> >
            >> > _____
            >> >
            >> > From: Raspberry_Pi_4-Ham_RADIO@yahoogroups.com
            >> <mailto:Raspberry_Pi_4-Ham_RADIO%40yahoogroups.com>
            >> > [mailto:Raspberry_Pi_4-Ham_RADIO@yahoogroups.com
            >> <mailto:Raspberry_Pi_4-Ham_RADIO%40yahoogroups.com> ] On Behalf Of
            >> > hawksbillpines
            >> > Sent: 29 March 2013 20:58
            >> > To: Raspberry_Pi_4-Ham_RADIO@yahoogroups.com
            >> <mailto:Raspberry_Pi_4-Ham_RADIO%40yahoogroups.com>
            >> > Subject: [Raspberry_Pi_4-Ham_RADIO] kissattach error with TNC-PI
            >> >
            >> >
            >> >
            >> >
            >> > Good day, All...
            >> >
            >> > In the past few days I have received and assembled my TNC-PI.
            >Everything
            >> > went well until I started configuring the Pi per the instructions. I
            >did
            >> the
            >> > update and upgrades as indicated. Now here is where my newbie level
            >> > knowledge may be causing me problems. The directions talk about
            >editing
            >> the
            >> > cmdline.txt file if you are going to use the serial port to connect
            >the
            >> > TNC-PI to the Raspberry Pi. Since I was connecting the two devices
            >> together
            >> > my assumption was that I didn't need to make these edits.
            >> >
            >> > Anyway, I continued on and edited the /etc/ax25/axports file with
            >> >
            >> > 1 K4DPF 19200 236 2 TNC 1
            >> > That's the only active line in the file. All others are commented
            >out.
            >> >
            >> > Unlike others who successfully rand
            >> > sudo kissattach /dev/ttyAMA0 1 10.1.1.1
            >> >
            >> > I got the message
            >> > "kissattach: unable to parse line 7 of the axports file."
            >> >
            >> > I know that not much insight, but if anyone has seen that response
            >would
            >> you
            >> > please share suggestions to correct the situation.
            >> >
            >> > Many thanks,
            >> > Dave K4DPF
            >> >
            >>
            >






          • andelscott
            ... OK - I m sure I had the same problem, but maybe a different cause. You have loaded the mkiss module? (I add this to the rc.modules file to ensure it s
            Message 5 of 10 , Apr 1, 2013
            • 0 Attachment
              --- In Raspberry_Pi_4-Ham_RADIO@yahoogroups.com, Tom Hoflich <km5h@...> wrote:
              >
              > I get the following error:
              > kissattach: cannot find port 1 in axports
              >
              >
              > My axports file looks exactly the same as the documentation except for KM5H in place of W2FS
              > what am I missing?


              OK - I'm sure I had the same problem, but maybe a different cause. You have loaded the mkiss module? (I add this to the rc.modules file to ensure it's loaded on each boot - otherwise use lsmod to see if it's installed. modprobe mkiss will load it for you if it isn't there.)

              I say Raspbian as it is configured with the hamradio drivers (modules), whereas the debian image I used at first didn't seem to play nicely and had me scratching my head for a while.
            Your message has been successfully submitted and would be delivered to recipients shortly.