Loading ...
Sorry, an error occurred while loading the content.

RE: Help!. RCX 10 Main Control Board Problem

Expand Messages
  • astrojim1
    I own an RCX400 and replaced the main board years ago. I am now convinced that was unnecessary. Would you care to share more details on the problems you are
    Message 1 of 3 , Oct 3, 2013
    • 0 Attachment

       I own an RCX400 and replaced the main board years ago.  I am now convinced that was unnecessary. Would you care to share more details on the problems you are experiencing with your telescope?




      ---In rcx400@yahoogroups.com, <wkrolak57@...> wrote:

      My scope has stopped working and the problem has been traced by a very experienced electronics friend to be a hardware problem on the main control board (with main processor chip). . I am not ready to give up on this scope and the board is easy to replace if I can get a replacement. Meade has no boards I am told since the scope is out of production for some time now. If anyone knows of availability of the main board part somewhere, I would be interested. Dr Clay has been a big help for these scopes and perhaps can advise.

      Waldemar Krolak
      RCX10
    • greystonerental
      I was using the scope for 3 nights in a row. It was on a scope buggy and I rolled it out and powered it up as normal. The scope seemed to power up with the
      Message 2 of 3 , Oct 4, 2013
      • 0 Attachment

         I was using the scope for 3 nights in a row. It was on a scope buggy and I rolled it out and powered it up as normal. The scope seemed to power up with the normal messages on the hand controller...then no response from the Smartdrive routine and no response when I tried to initiate calibration.


        The next day, I tried the sequence again and began to troubleshoot. I suspected corrupt software so I reloaded the software (2.2i) and got a successful reload. Still no joy on the scope response. There was no response from the motors to commands, no response or input from GPS, no response from the dew heater or fan. All of these are controlled thru the main board. Troubleshooting of the board suggesed that there is a broken connection. Some solder cracks were found and fixed under a microscope but without circuit diagrams it is slow detective work. The commands are just not being generated from the main board! 


        I hope there is a main board somewhere, or, does anyone have suggestions as to what else might be contributing to the issue.


        W. Krolak

        RCX 10



        ---In RCX400@yahoogroups.com, <rcx400@yahoogroups.com> wrote:

         I own an RCX400 and replaced the main board years ago.  I am now convinced that was unnecessary. Would you care to share more details on the problems you are experiencing with your telescope?




        ---In rcx400@yahoogroups.com, <wkrolak57@...> wrote:

        My scope has stopped working and the problem has been traced by a very experienced electronics friend to be a hardware problem on the main control board (with main processor chip). . I am not ready to give up on this scope and the board is easy to replace if I can get a replacement. Meade has no boards I am told since the scope is out of production for some time now. If anyone knows of availability of the main board part somewhere, I would be interested. Dr Clay has been a big help for these scopes and perhaps can advise.

        Waldemar Krolak
        RCX10
      Your message has been successfully submitted and would be delivered to recipients shortly.