Loading ...
Sorry, an error occurred while loading the content.
 

RE: RE: Losing USB & CW2 simultaneously problem

Expand Messages
  • richie_asg1
    Finally solved. Checking the bases of Q16 and Q17 gave good 4.7v when selected. I used the scope to sniff for the crystals working during the fault condition,
    Message 1 of 9 , Sep 11, 2013

      Finally solved.

      Checking the bases of Q16 and Q17 gave good 4.7v when selected. I used the scope to sniff for the crystals working during the fault condition, and I was getting no resonance when selecting USB and CW2, but resonance in both when on LSB and CW1. As they are so close together is difficult to say which was duff straight off.

       

      Flipping the radio over I saw that these two crystals had trimmers fitted - that are not on the schematic. Touching one side with a scope probe was enough to stop the good crystal resonating, so now I knew the other trimmer was at fault. used a trim tool to move it and USB came back. Just touching it caused crackly response - so we are dealing with a bad joint.

       Resoldered the base with passive flux and all is good now !

       

      Will put a photo of the trimmers in the photos file under M6AGL. Seem to be from the active side of the crystal onto near components - possibly ground not sure. Are these standard or a factory mod or otherwise? Trimmer at fault was the one on the left responsible for USB and CW2.

       

      Richie

      M6AGL 



       

       
      Richie
      M6AGL.


       
       
    • Tom H
      Congrats on fixing the problem, Richie. These trimmer caps, TC4 & TC5, were a tacked on factory mod for revision A. Probably a tricky bit of soldering that was
      Message 2 of 9 , Sep 12, 2013
        Congrats on fixing the problem, Richie. These trimmer caps, TC4 & TC5, were a tacked on factory mod for revision A. Probably a tricky bit of soldering that was done poorly in your case. On the B revision, the trimmers are properly mounted and labelled on the same side of the pcb as the ceramic resonators. You can see them in the schematic for the B model found in the Addendum to the Service Manual, the PDF of which is in the Files > Documentation area of the website.

        Tom ve3meo
      Your message has been successfully submitted and would be delivered to recipients shortly.