Loading ...
Sorry, an error occurred while loading the content.
 

Re: [PkOug] Unable to View Data in Reports

Expand Messages
  • Muhmmad Ahmad
    dear nawaz MUHAMMAD, first of all tell us your problem exactly what type of problem u r facing. from the message u have sent. i come to know that your
    Message 1 of 5 , Aug 1, 2007
      dear nawaz MUHAMMAD,
      first of all tell us your problem exactly what type of problem u r facing.
      from the message u have sent.
      i come to know that your ex-developer have created some constrainst on user level.
      so that the clieant could not run reports after some speicifed date.
      the constraints might be on form level or might be on database level also.
      you u have to check the whole scnario in details.
       
      Muhammad Ahmad


      nawaz muhammad <nawaz79@...> wrote:
      i have am facing a problem need your help
       
      i have an application developed on Oracle Dev 6i, with Oracle 9i
      this was developed in 3 year back, by one of my friend
      this application is working fine on client side, now i want to extend this application
      on my side it all insert/Update/ Delete are working fine
      but it  doesn't most of the data in the Report Section
      some body told me that it could be a DATE format problem,
      can any body suggust me the exact solution / Helpfull tip

       
       
      Muhammad Nawaz Khan
      0321-2006828


      Luggage? GPS? Comic books?
      Check out fitting gifts for grads at Yahoo! Search.


      Got a little couch potato?
      Check out fun summer activities for kids.

    • mirza_nosha
      Dear Nawaz, Please make sure if it was developed using 6i version of Oracle Developer. What I understood from your message is that you have copied the
      Message 2 of 5 , Aug 1, 2007
        Dear Nawaz,

        Please make sure if it was developed using "6i" version of Oracle
        Developer.

        What I understood from your message is that you have copied the
        application (I assume, compiled/RUNTIME files) from client's machine.
        Now when you are running that application on your own PC, the forms
        (insert/update/delete operations) are working but the reports are not
        running.

        If this is the case, you need to see the message in "background report
        engine" window, which is automatically opened when you run a report.
        See if it says something like "unable to retrieve string...". If it
        does, it simply means that you will need to recompile the reports from
        the source files using your local database.

        Hope it helps.

        Regards,

        Aamir Abbas

        --- In PkOug@yahoogroups.com, nawaz muhammad <nawaz79@...> wrote:
        >
        > i have am facing a problem need your help
        >
        > i have an application developed on Oracle Dev 6i, with Oracle 9i
        > this was developed in 3 year back, by one of my friend
        > this application is working fine on client side, now i want to
        extend this application
        > on my side it all insert/Update/Delete are working fine
        > but it doesn't most of the data in the Report Section
        > some body told me that it could be a DATE format problem,
        > can any body suggust me the exact solution / Helpfull tip
        >
        >
        >
        > Muhammad Nawaz Khan
        > 0321-2006828
        >
        >
        >
        >
        ____________________________________________________________________________________
        > Be a better Heartthrob. Get better relationship answers from someone
        who knows. Yahoo! Answers - Check it out.
        > http://answers.yahoo.com/dir/?link=list&sid=396545433
        >
      • mit@beaconhouse.edu.pk
        ________________________________ Sent: Tuesday, July 31, 2007 6:46 PM Subject: Question on reports (6i or 10g) I have an application which must print two
        Message 3 of 5 , Aug 1, 2007

          Sent: Tuesday, July 31, 2007 6:46 PM
          Subject: Question on reports (6i or 10g)

           


          I have an application which must print two copies of a report. Currently, the way I do it is to print it to PDF, then use another program which prints the two copies collated so they come out page 1, 1, 2, 2, 3, 3, etc.  These copies are then directed to specific printers (based on the user) which are preloaded with paper that alternates between white and yellow. The purpose of this is to indicate the original and the copy. I was wondering if there is a way to make 10g report actually collate correctly (never did in 6i), and to have reports automatically put watermarks on the reports, perhaps copy 1 have ORIGINAL on it and copy 2 have COPY on it? Has anyone done anything like this before??

           

        • Muhammad Shuja
          You might want to try manually checking/unchecking collate option in the Print dialog box. Or you can programmatically also achieve this with some logic.
          Message 4 of 5 , Aug 5, 2007
            You might want to try manually checking/unchecking 'collate' option in the Print dialog box. Or you can programmatically also achieve this with some logic. Similary, you can have boiler plate text and print it conditionally (programatically). To give you an idea, you can call new instance of same report with 'duplicate' as the parameter, from within a After report trigger.

            With Reports 9i patch 3 or 10g, you have Collate parameter which you can set to No to get printing like 1,1 2,2 3,3



            On 8/2/07, mit@... <mit@...> wrote:


            Sent: Tuesday, July 31, 2007 6:46 PM
            Subject: Question on reports (6i or 10g)

             


            I have an application which must print two copies of a report. Currently, the way I do it is to print it to PDF, then use another program which prints the two copies collated so they come out page 1, 1, 2, 2, 3, 3, etc.  These copies are then directed to specific printers (based on the user) which are preloaded with paper that alternates between white and yellow. The purpose of this is to indicate the original and the copy. I was wondering if there is a way to make 10g report actually collate correctly (never did in 6i), and to have reports automatically put watermarks on the reports, perhaps copy 1 have ORIGINAL on it and copy 2 have COPY on it? Has anyone done anything like this before??

             


          Your message has been successfully submitted and would be delivered to recipients shortly.