Loading ...
Sorry, an error occurred while loading the content.

Re: This is now critical: Palm to Pimlical to Android

Expand Messages
  • Barbara Needham
    NOTE: This came to me as I was brushing my teeth... so late addition.. if you find that your google calendar came un-stuck [via File/Google Calendar]
    Message 1 of 15 , Dec 4, 2010
    View Source
    • 0 Attachment
      NOTE: This came to me as I was brushing my teeth... so late addition.. if you find that your google calendar came un-stuck [via File/Google Calendar] reconnecting it MAY be all you need to do...


      --- In Pimlical@yahoogroups.com, Barbara Needham <nosugref2000@...> wrote:
      >
      > Something may have happened with turning auto-sync categories on and off.
      >
      > For now, turn it OFF in preferences. [Options/Preferences/Google
      > Calendar] For current purposes set Google Refresh Interval to 0,
      > SyncGoogleCalendarOnStarup to false, AssignPimlicalCategoryToGC to false.
      >
      > Now since you have no Google category to select in your list, check this
      > first:
      >
      > Go to File/Google Calendars and enter your user name and passwrod. Make
      > sure it is for the Google User Name that you WANT to use. Then check the
      > Google calendars you want to use, and OK. It should precipitate a sync
      > with google Calendar. If it does not, something else is going on [so let
      > us know that] but if it does proceed to next step.
      >
      > Now; Advanced Find/Clear/Check "Teaching" and FIND. Write down the
      > number of events in that category. Now, do that again: Advanced
      > Find/Clear/Check "teaching" AND NOT G_Teaching. Then use the add dialog
      > to add that category. [As follows: Find/Change/enter G_Teaching but
      > don't check "Add" on that screen, OK, THEN Add] and ok out of all that.
      > Now use Advanced Find again [remember to "clear" first] and find on
      > G_Teaching and make sure that number is the same as the Teaching number
      > you wrote down before. Refresh manually and you should now see your
      > appointments go to Google Calendar. [Note:Try to Keep the total number
      > of appointments [in each category] below 500 [easier] although 999 seems
      > to work OK. It's when the number gets to over 1000 that there seems to
      > be a problem.]
      >
      > Now you can change your preferences back to what they should usually be,
      > which is Refresh Interval 900 [15 minutes], leave sync on startup to
      > false, and change AssignPimlicalCategoryToGC to true. Check it out by
      > adding an appointment in Google and a different appointment in Pimlical
      > and see if they propogate.
      >
      > If all the above works you can proceed with your other categories.
      >
      > If something breaks at the File/Google Calendar step then CESD may have
      > to step in.
      >
      > Every time you successfully propagate a new category, backup everything
      > just to hang on the that!
      >
      > The reason for changing the preferences while working on this is just so
      > that nothing unexpected happens while you are working on it. When you
      > are used to it they can just be left as usual.
      >
      > Hope that isn't too confusing.
      >
      >
      > On 12/4/2010 4:53 PM, annbal wrote:
      > > Ok, obviously this *is* the problem (I did use Advanced Find), but I really don't know how to do the fancy finds and replaces that you've described. I see no way to find a category but not the G_category, because there is no G_Category to select in the category list ??
      > >
      > > The category is Teaching, and everything that went into Pimlical that was dated prior to October has the G_Pimlical Teaching in front of them (I did not put that there), then the rest don't.
      > >
      > > Why would that change? I uploaded them all at once, then just started to enter stuff and hotsync it as usual, haven't changed any categories at all. Nothing I've entered since that point has shown up in Google.
      > >
      > > Ok, so how do I proceed from here (I need to understand how to do this replacing of categories first, I guess).
      > >
      > > Thank you for your help, Barbara :)
      > >
      > > --- In Pimlical@yahoogroups.com, Barbara Needham<nosugref2000@> wrote:
      > >> First of all, check one thing:
      > >> Do an advanced find on one category that is correct in Pimlical and see
      > >> if every item in it has a G_category corresponding to it. If it does
      > >> not, your fix is simple. Just do advanced find again for Category and
      > >> NOT G_category and use change to add the G_category to each item.
      > >> Sync with Google and see if that fixes that category, and then you'll
      > >> know how to proceed.
      > >>
      > >>
      > >> If that is NOT the problem, report back...
      > >>
      > >
      > >
      > >
      > > ------------------------------------
      > >
      > > For information about trying and purchasing Pimlical: http://www.pimlicosoftware.com/pimlicalpreview.htm
      > >
      > > To download latest version of Pimlical: http://www.pimlicosoftware.com/pimlical.msi
      > >
      > > Neither Pimlico, the developer, nor the list owner is responsible for content.
      > >
      > > Yahoo! Groups Links
      > >
      > >
      > >
      > >
      >
    • annbal
      First off I have to mention the error I mentioned in my original post, upon my first start of the current Pimlical installation, I got an error of Invalid
      Message 2 of 15 , Dec 5, 2010
      View Source
      • 0 Attachment
        First off I have to mention the error I mentioned in my original post,
        upon my first start of the current Pimlical installation, I got an error
        of "Invalid Preference Found: pi, with an ok button. Pressed it and
        things continued as normal. that error message hasn't turned up again.

        However, tonight, when I clicked on Options/Preferences, I was
        immediately confronted with three errors in a row:

        Missing/Deprecated Preference Item in Template
        The key 'pi' in PimlicalPreferences.def is not a known preference item,
        An OK button.

        Pressed it, and then got the following:
        Missing/Deprecated Preference Item in Template
        The key 'pim' in PimlicalPreferences.def is not a known preference item,
        Another OK button.

        Pressed it, then got the first message again, with an OK button.
        Pressed it, and it went away. No idea what's going on there. I did
        look through the Google Calendar section of the preferences, and there
        is a line that reads 'pim', but it isn't set to true or false, there's
        nothing there. Here is the text to the right of it:

        If true, Pimlical will use Google's extended properties to preserve
        special items. If false, tags are created in the note field (Google's
        'description' field). If other programs are accessing and updating
        Google Calendar, it's possible they may trash or not properly preserve
        the extended proprties field, in which case it's safer to set this to
        false and have the properties saved in the note field.

        There's nothing there - could this be causing a problem?

        When I closed preferences I received an error message regarding an
        invalid preference, 'pim'. Clicked the ok button, got it again, clicked
        it again, it went away.

        --- In Pimlical@yahoogroups.com, Barbara Needham <nosugref2000@...>
        wrote:
        >
        > Something may have happened with turning auto-sync categories on and
        off.

        Actually, when I went into the preferences to make the changes below it
        was set to false. I have no idea how that happened. Perhaps it's as
        simple as turning it back on? However, I did make the changes you
        outline below.
        >
        > For now, turn it OFF in preferences. [Options/Preferences/Google
        > Calendar] For current purposes set Google Refresh Interval to 0,
        > SyncGoogleCalendarOnStarup to false, AssignPimlicalCategoryToGC to
        false.
        >
        It was off, as were the two other options set to false already (how??),
        I did set the refresh interval to 0, it was 900.

        > Now since you have no Google category to select in your list, check
        this
        > first:
        >
        > Go to File/Google Calendars and enter your user name and passwrod.
        Make
        > sure it is for the Google User Name that you WANT to use. Then check
        the
        > Google calendars you want to use, and OK. It should precipitate a sync
        > with google Calendar. If it does not, something else is going on [so
        let
        > us know that] but if it does proceed to next step.

        That was already done, and it does seem to be querying back and forth,
        as I'm getting constant messages about items being deleted or changed in
        Google, do I want to delete in Pimlical - and no, I don't, because I
        have no idea what those items are.
        >
        > Now; Advanced Find/Clear/Check "Teaching" and FIND. Write down the
        > number of events in that category. Now, do that again: Advanced
        > Find/Clear/Check "teaching" AND NOT G_Teaching. Then use the add
        dialog
        > to add that category. [As follows: Find/Change/enter G_Teaching but
        > don't check "Add" on that screen, OK, THEN Add] and ok out of all
        that.
        > Now use Advanced Find again [remember to "clear" first] and find on
        > G_Teaching and make sure that number is the same as the Teaching
        number
        > you wrote down before. Refresh manually and you should now see your
        > appointments go to Google Calendar. [Note:Try to Keep the total number
        > of appointments [in each category] below 500 [easier] although 999
        seems
        > to work OK. It's when the number gets to over 1000 that there seems to
        > be a problem.]
        >
        Here's where I lose you - how do I tell it 'not G_Pimlical,Teaching'? I
        don't know how to do that, because there is no category called
        G_Pimlical,Teaching in the category list. Really, it shows up in the
        results but not in the listing.

        For the record, there are 872 total in Teaching, 827 have the
        G_Pimlical,Teaching category, and 45 have just Teaching. Of course
        those 45 are the ones that aren't showing up in Google, they're the
        newest appointments I've entered.

        If we can get past this, I hope I can follow the rest of your directions
        and get this all straightened out. Once we do, then I'll just need to
        set up all of the separate calenders in Google and split everything up -
        hopefully we'll cross that bridge soon :)

        When you can, let me know how to proceed. Thank you so much!

        Take care,

        Ann



        [Non-text portions of this message have been removed]
      • Barbara Needham
        I have to test this out... Maybe you ll have to set AutoAssign Category to ON to get all your G_Categories. But with the error messages you are getting, I d
        Message 3 of 15 , Dec 5, 2010
        View Source
        • 0 Attachment
          I have to test this out...

          Maybe you'll have to set AutoAssign Category to ON to get all your G_Categories.

          But with the error messages you are getting, I'd delete Pimlical completely [even using something like Revo Uninstaller] and reinstall it checking all the boxes, well not the user icon.dat box; that stays pretty solid throughout and see if you still get the error.

          OR OR OR

          You might want at this point to send your whole database to CESD. I know he's busy but he does do good customer service!! Backup Everything, Zip that folder, and send to the support address.
        • CESDewar
          of Invalid Preference Found: pi, with an ok button. Pressed it and things continued as normal. that error message hasn t turned up again. Missing/Deprecated
          Message 4 of 15 , Dec 6, 2010
          View Source
          • 0 Attachment
            of "Invalid Preference Found: pi, with an ok button. Pressed it and
            things continued as normal. that error message hasn't turned up again.
            Missing/Deprecated Preference Item in Template
            The key 'pi' in PimlicalPreferences.def is not a known preference item,

            I have already fixed that. It's a text file that is marked as read-only (precisely to avoid it inadvertently getting modified/corrupted), but that seemd to happen anyway.

            You can fix it quickly by editing the PimlicalPreferences.def file (and possibly the default.txt file if you had done a clean install or reset it) using a standard text editor

            Look in the [Google Calendar] section right underneath the preference: MaximumItemsToSafelyDelete

            and change the line:

            pim = .....

            to

            UseGoogleExtendedProperties =

            Cheers!
            CESD, Pimlico Software, Inc.
            . . .


            [Non-text portions of this message have been removed]
          • annbal
            Barbara, I don t think you realized I posted much more info in that e-mail (because of the way it was formatted/quoted). Rather than repeat it all, could you
            Message 5 of 15 , Dec 7, 2010
            View Source
            • 0 Attachment
              Barbara, I don't think you realized I posted much more info in that e-mail (because of the way it was formatted/quoted). Rather than repeat it all, could you go back and scroll down and tell me what you think? (I am having problems with advanced find/replace) I will send my database to CESD, but I'd rather exhaust everything I can first before I bother him :)

              Take care,

              Ann


              --- In Pimlical@yahoogroups.com, "Barbara Needham" <nosugref2000@...> wrote:
              >
              > I have to test this out...
              >
              > Maybe you'll have to set AutoAssign Category to ON to get all your G_Categories.
              >
              > But with the error messages you are getting, I'd delete Pimlical completely [even using something like Revo Uninstaller] and reinstall it checking all the boxes, well not the user icon.dat box; that stays pretty solid throughout and see if you still get the error.
              >
              > OR OR OR
              >
              > You might want at this point to send your whole database to CESD. I know he's busy but he does do good customer service!! Backup Everything, Zip that folder, and send to the support address.
              >
            • Barbara Needham
              Yeah, I realized it... I guess was just lazy. I will go over it again but you won t see the G_Categories until you have successfully connected to your Google
              Message 6 of 15 , Dec 7, 2010
              View Source
              • 0 Attachment
                Yeah, I realized it... I guess was just lazy.
                I will go over it again but you won't see the G_Categories until you
                have successfully connected to your Google calendars... can you try that
                and see if it makes a difference? I'll work on your other questions
                while you do that. And at least CESD explained about the error so now we
                know that wasn't serious.

                On 12/7/2010 8:05 AM, annbal wrote:
                > Barbara, I don't think you realized I posted much more info in that e-mail (because of the way it was formatted/quoted). Rather than repeat it all, could you go back and scroll down and tell me what you think? (I am having problems with advanced find/replace) I will send my database to CESD, but I'd rather exhaust everything I can first before I bother him :)
                >
                > Take care,
                >
                > Ann
                >
                >
                > --- In Pimlical@yahoogroups.com, "Barbara Needham"<nosugref2000@...> wrote:
                >> I have to test this out...
                >>
                >> Maybe you'll have to set AutoAssign Category to ON to get all your G_Categories.
                >>
                >> But with the error messages you are getting, I'd delete Pimlical completely [even using something like Revo Uninstaller] and reinstall it checking all the boxes, well not the user icon.dat box; that stays pretty solid throughout and see if you still get the error.
                >>
                >> OR OR OR
                >>
                >> You might want at this point to send your whole database to CESD. I know he's busy but he does do good customer service!! Backup Everything, Zip that folder, and send to the support address.
                >>
                >
              • Barbara Needham
                ... Is there a reason you have Pimlical as part of the category name? It should just be G_Teaching. [Or whatever your Google calendar name is]. And if there is
                Message 7 of 15 , Dec 7, 2010
                View Source
                • 0 Attachment
                  >
                  > For the record, there are 872 total in Teaching, 827 have the
                  > G_Pimlical,Teaching category, and 45 have just Teaching. Of course
                  > those 45 are the ones that aren't showing up in Google, they're the
                  > newest appointments I've entered.
                  >


                  Is there a reason you have Pimlical as part of the category name? It should just be G_Teaching. [Or whatever your Google calendar name is].

                  And if there is a comma in the name, that doesn't work at present.

                  Your Google calendar should be Teaching and your Pimlical Category should be G_Teaching.

                  I understand that at present you are not seeing G_Teaching in your category list???

                  As you see I'm picking apart your e-mail but this caught my eye as something I may have missed before...

                  With sync interval set to 0 so that Google will only sync when we tell it to, go to File/Google calendar and let's work on ONE calendar at a time. Check the one you want to work with... teaching? and uncheck the others and OK.

                  Then see if in Advanced Find you can see the category G_Teaching.
                  If not, set Auto Assign Category to TRUE and then try the same thing.
                • annbal
                  Barbara, I didn t put Pimlical in there, either Google did, or Pimlical did. I ve never monkeyed around with the categories at all given the earlier
                  Message 8 of 15 , Dec 7, 2010
                  View Source
                  • 0 Attachment
                    Barbara, I didn't put 'Pimlical' in there, either Google did, or Pimlical did. I've never monkeyed around with the categories at all given the earlier problems I had with them (CESD had to get my database and figure it out, back seven versions or so ago).

                    No commas in my names, and no G_Teaching.

                    All of my appointments are in *one* Calendar, called Pimlical. I've never cut up anything, I haven't been able to manage anything properly enough to get that far.....

                    Ann

                    --- In Pimlical@yahoogroups.com, "Barbara Needham" <nosugref2000@...> wrote:
                    >
                    >
                    >
                    > >
                    > > For the record, there are 872 total in Teaching, 827 have the
                    > > G_Pimlical,Teaching category, and 45 have just Teaching. Of course
                    > > those 45 are the ones that aren't showing up in Google, they're the
                    > > newest appointments I've entered.
                    > >
                    >
                    >
                    > Is there a reason you have Pimlical as part of the category name? It should just be G_Teaching. [Or whatever your Google calendar name is].
                    >
                    > And if there is a comma in the name, that doesn't work at present.
                    >
                    > Your Google calendar should be Teaching and your Pimlical Category should be G_Teaching.
                    >
                    > I understand that at present you are not seeing G_Teaching in your category list???
                    >
                    > As you see I'm picking apart your e-mail but this caught my eye as something I may have missed before...
                    >
                    > With sync interval set to 0 so that Google will only sync when we tell it to, go to File/Google calendar and let's work on ONE calendar at a time. Check the one you want to work with... teaching? and uncheck the others and OK.
                    >
                    > Then see if in Advanced Find you can see the category G_Teaching.
                    > If not, set Auto Assign Category to TRUE and then try the same thing.
                    >
                  • Barbara Needham
                    OK.. that is the problem then. You won t get separate categories if you have everything in one Google calendar. Do you mean in Piimlical you do or don t have
                    Message 9 of 15 , Dec 7, 2010
                    View Source
                    • 0 Attachment
                      OK.. that is the problem then. You won't get separate categories if you
                      have everything in one Google calendar. Do you mean in Piimlical you do
                      or don't have categories?? Or just that you have categories in Pimlical
                      but only one Google calendar.

                      On 12/7/2010 2:59 PM, annbal wrote:
                      > Barbara, I didn't put 'Pimlical' in there, either Google did, or Pimlical did. I've never monkeyed around with the categories at all given the earlier problems I had with them (CESD had to get my database and figure it out, back seven versions or so ago).
                      >
                      > No commas in my names, and no G_Teaching.
                      >
                      > All of my appointments are in *one* Calendar, called Pimlical. I've never cut up anything, I haven't been able to manage anything properly enough to get that far.....
                      >
                      > Ann
                      >
                      > --- In Pimlical@yahoogroups.com, "Barbara Needham"<nosugref2000@...> wrote:
                      >>
                      >>
                      >>> For the record, there are 872 total in Teaching, 827 have the
                      >>> G_Pimlical,Teaching category, and 45 have just Teaching. Of course
                      >>> those 45 are the ones that aren't showing up in Google, they're the
                      >>> newest appointments I've entered.
                      >>>
                      >>
                      >> Is there a reason you have Pimlical as part of the category name? It should just be G_Teaching. [Or whatever your Google calendar name is].
                      >>
                      >> And if there is a comma in the name, that doesn't work at present.
                      >>
                      >> Your Google calendar should be Teaching and your Pimlical Category should be G_Teaching.
                      >>
                      >> I understand that at present you are not seeing G_Teaching in your category list???
                      >>
                      >> As you see I'm picking apart your e-mail but this caught my eye as something I may have missed before...
                      >>
                      >> With sync interval set to 0 so that Google will only sync when we tell it to, go to File/Google calendar and let's work on ONE calendar at a time. Check the one you want to work with... teaching? and uncheck the others and OK.
                      >>
                      >> Then see if in Advanced Find you can see the category G_Teaching.
                      >> If not, set Auto Assign Category to TRUE and then try the same thing.
                      >>
                      >
                      >
                      >
                      > ------------------------------------
                      >
                      > For information about trying and purchasing Pimlical: http://www.pimlicosoftware.com/pimlicalpreview.htm
                      >
                      > To download latest version of Pimlical: http://www.pimlicosoftware.com/pimlical.msi
                      >
                      > Neither Pimlico, the developer, nor the list owner is responsible for content.
                      >
                      > Yahoo! Groups Links
                      >
                      >
                      >
                      >
                    • Barbara Needham
                      I just thought I would post this, outside of the ongoing discussion we are having on how to get your stuff in to Google so that you can get it to Android. If
                      Message 10 of 15 , Dec 8, 2010
                      View Source
                      • 0 Attachment
                        I just thought I would post this, outside of the ongoing discussion we are having on how to get your stuff in to Google so that you can get it to Android.

                        If you cannot get your information to Google [at present, you WILL be able to] it will still be SAFE in Pimlical. And for assurance, take a backup everything and put it somewhere else on and off your computer; then your data will be safe as of the date you do that. Now we can get back to our regular discussion!!!
                      • Barbara Needham
                        Still waiting for an answer.. so I can help you better. What do you have in GOOGLE?? I am so confused maybe we should start over from step minus one.
                        Message 11 of 15 , Dec 9, 2010
                        View Source
                        • 0 Attachment
                          Still waiting for an answer.. so I can help you better. What do you have in GOOGLE?? I am so confused maybe we should start over from step minus one.


                          --- In Pimlical@yahoogroups.com, Barbara Needham <nosugref2000@...> wrote:
                          >
                          > OK.. that is the problem then. You won't get separate categories if you
                          > have everything in one Google calendar. Do you mean in Piimlical you do
                          > or don't have categories?? Or just that you have categories in Pimlical
                          > but only one Google calendar.
                          >
                          > On 12/7/2010 2:59 PM, annbal wrote:
                          > > Barbara, I didn't put 'Pimlical' in there, either Google did, or Pimlical did. I've never monkeyed around with the categories at all given the earlier problems I had with them (CESD had to get my database and figure it out, back seven versions or so ago).
                          > >
                          > > No commas in my names, and no G_Teaching.
                          > >
                          > > All of my appointments are in *one* Calendar, called Pimlical. I've never cut up anything, I haven't been able to manage anything properly enough to get that far.....
                          > >
                          > > Ann
                          > >
                          > > --- In Pimlical@yahoogroups.com, "Barbara Needham"<nosugref2000@> wrote:
                          > >>
                          > >>
                          > >>> For the record, there are 872 total in Teaching, 827 have the
                          > >>> G_Pimlical,Teaching category, and 45 have just Teaching. Of course
                          > >>> those 45 are the ones that aren't showing up in Google, they're the
                          > >>> newest appointments I've entered.
                          > >>>
                          > >>
                          > >> Is there a reason you have Pimlical as part of the category name? It should just be G_Teaching. [Or whatever your Google calendar name is].
                          > >>
                          > >> And if there is a comma in the name, that doesn't work at present.
                          > >>
                          > >> Your Google calendar should be Teaching and your Pimlical Category should be G_Teaching.
                          > >>
                          > >> I understand that at present you are not seeing G_Teaching in your category list???
                          > >>
                          > >> As you see I'm picking apart your e-mail but this caught my eye as something I may have missed before...
                          > >>
                          > >> With sync interval set to 0 so that Google will only sync when we tell it to, go to File/Google calendar and let's work on ONE calendar at a time. Check the one you want to work with... teaching? and uncheck the others and OK.
                          > >>
                          > >> Then see if in Advanced Find you can see the category G_Teaching.
                          > >> If not, set Auto Assign Category to TRUE and then try the same thing.
                          > >>
                          > >
                          > >
                          > >
                          > > ------------------------------------
                          > >
                          > > For information about trying and purchasing Pimlical: http://www.pimlicosoftware.com/pimlicalpreview.htm
                          > >
                          > > To download latest version of Pimlical: http://www.pimlicosoftware.com/pimlical.msi
                          > >
                          > > Neither Pimlico, the developer, nor the list owner is responsible for content.
                          > >
                          > > Yahoo! Groups Links
                          > >
                          > >
                          > >
                          > >
                          >
                        Your message has been successfully submitted and would be delivered to recipients shortly.