Loading ...
Sorry, an error occurred while loading the content.

Re: [PanoToolsNG] OT HTML problems

Expand Messages
  • Sacha Griffin
    Use a JavaScript redirect instead. Simpler and should work everywhere. Sacha Griffin Southern Digital Solutions LLC - Atlanta, Georgia http://www.seeit360.com
    Message 1 of 9 , Apr 4, 2012
    • 0 Attachment
      Use a JavaScript redirect instead. Simpler and should work everywhere.

      Sacha Griffin
      Southern Digital Solutions LLC  - Atlanta, Georgia
      Office: 404-551-4275

      On Apr 4, 2012, at 1:08 PM, Willy Kaemena <panokaemena@...> wrote:

       

      I want to redirect    visitors  which still  coming to my soon ending old homepage, to my new page. One  easy way is to  use   Meta Refresh Tag, which normally works fine.  BUT  now  I have  the following problem:




      if I click  this link  on iPhone / iPad  or I.E. on Windows, everything is fine  and the visitor  is redirected to the new URL

      When  using Safari / Firefox/ Chrome  on WIN or Mac  what happens  is that the index file is being downloaded.


      Any  idea  what is going wrong?







    • Roger Howard
      ... The problem isn t the meta refresh, it s the content-type that page is being served up as. A JavaScript redirect will have the same problem - the parent
      Message 2 of 9 , Apr 4, 2012
      • 0 Attachment

        On Apr 4, 2012, at 10:47 AM, Sacha Griffin wrote:

        Use a JavaScript redirect instead. Simpler and should work everywhere.

        The problem isn't the meta refresh, it's the content-type that page is being served up as. A JavaScript redirect will have the same problem - the parent HTML page will still be delivered as application/octet-stream, so the refresh won't ever even get a chance.

        Unless, for some reason, Apple is serving up pages with meta refresh'es with the wrong content-type on purpose, but Willie's root page disproves that notion.

        -R
      • ptgroup
        Yours: Mine: ..
        Message 3 of 9 , Apr 4, 2012
        • 0 Attachment
          Yours:
          <HTML><HEAD><meta http-equiv="refresh" content="4;url=http://www.kaemena360.com/360/GuenzburgTour"></HEAD><BODY></BODY></HTML>
           
          Mine:
          ..
          <META HTTP-EQUIV="Refresh" CONTENT='0; URL=http://www.netzserver1.de/pg8'>
          ...
           
          never hat a problem with this.
           
          ciao
          mike
           

          Mit freundlichen Grüssen
          Virtugraf M. Hundrieser

          http://www.virtugraf.de
          ----------------------------
          360° VR Fotografie:
          http://www.360de.de

          NEU: Abstrakte Fotografie unter:
          http://www.abstraktfoto.de
          -----------------------------
          Aktuelles vom Virtugrafen:
          http://virtugraf.wordpress.com

           


          Von: PanoToolsNG@yahoogroups.com [mailto:PanoToolsNG@yahoogroups.com] Im Auftrag von Willy Kaemena
          Gesendet: Mittwoch, 4. April 2012 19:08
          An: PanoToolsNG@yahoogroups.com
          Betreff: [PanoToolsNG] OT HTML problems

           

          I want to redirect    visitors  which still  coming to my soon ending old homepage, to my new page. One  easy way is to  use   Meta Refresh Tag, which normally works fine.  BUT  now  I have  the following problem:




          if I click  this link  on iPhone / iPad  or I.E. on Windows, everything is fine  and the visitor  is redirected to the new URL

          When  using Safari / Firefox/ Chrome  on WIN or Mac  what happens  is that the index file is being downloaded.


          Any  idea  what is going wrong?









          I am using the Free version of SPAMfighter.
          SPAMfighter has removed 3404 of my spam emails to date.

          Do you have a slow PC? Try free scan!
        • Sacha Griffin
          Looks like a server problem then.. I uploaded the file to my server and it was normal. Steps to troubleshoot.. Take each action singularly from the original
          Message 4 of 9 , Apr 4, 2012
          • 0 Attachment

            Looks like a server problem then..

            I uploaded the file to my server and it was normal.

             

            Steps to troubleshoot.. Take each action singularly from the original file.

            1.       Rename file to something normal like index2.html

            2.       Remove meta refresh tag.

            3.       Add this meta tag <meta http-equiv="Content-Type" content="text/html; charset=utf-8" />

             

            Best Regards,

             

            Sacha Griffin

            Southern Digital Solutions LLC  - Atlanta, Georgia

            http://www.seeit360.com

            http://twitter.com/SeeIt360

            http://www.facebook.com/SeeIt360

            IM: sachagriffin007@...

            Office: 404-551-4275

             

             

            From: PanoToolsNG@yahoogroups.com [mailto:PanoToolsNG@yahoogroups.com] On Behalf Of Roger Howard
            Sent: Wednesday, April 04, 2012 1:57 PM
            To: PanoToolsNG@yahoogroups.com
            Subject: Re: [PanoToolsNG] OT HTML problems

             

             

             

            On Apr 4, 2012, at 10:47 AM, Sacha Griffin wrote:



            Use a JavaScript redirect instead. Simpler and should work everywhere.

             

            The problem isn't the meta refresh, it's the content-type that page is being served up as. A JavaScript redirect will have the same problem - the parent HTML page will still be delivered as application/octet-stream, so the refresh won't ever even get a chance.

             

            Unless, for some reason, Apple is serving up pages with meta refresh'es with the wrong content-type on purpose, but Willie's root page disproves that notion.

             

            -R

          • Willy Kaemena
            Thank you Roger for your insights nothing worked so far. I have a few other redirects on my .Mac which works flawless. like this here:
            Message 5 of 9 , Apr 5, 2012
            • 0 Attachment
              Thank you Roger for your insights

              nothing worked so far. I have a few other redirects  on my .Mac  which works  flawless.


              Willy


              On Apr 4, 2012, at 19:45, Roger Howard wrote:

               


              On Apr 4, 2012, at 10:08 AM, Willy Kaemena wrote:

               

              I want to redirect    visitors  which still  coming to my soon ending old homepage, to my new page. One  easy way is to  use   Meta Refresh Tag, which normally works fine.  BUT  now  I have  the following problem:




              if I click  this link  on iPhone / iPad  or I.E. on Windows, everything is fine  and the visitor  is redirected to the new URL

              When  using Safari / Firefox/ Chrome  on WIN or Mac  what happens  is that the index file is being downloaded.


              Any  idea  what is going wrong?

              Hmmmmm...

              That page is returning it's content type as "application/octet-stream", which is why it's downloading on most browsers.

              iOS browsers and WIndows/IE are instead ignoring the content type (which is set wrong) and sniffing the file for its actual type - this has long been considered a *problem* with IE, but in this case is giving you desirable results (Microsoft has a habit of bending the rules - and, in many cases, for good reasons... many web servers are still misconfigured and report bad content-types, so IE tries to outsmart the server... usually it's OK, like in this case, although sometimes it's a real problem).

              It's not clear to me *why* this is happening, though - your root page (http://homepage.mac.com/wkaemena/index.html) is returning an appropriate content-type (text/html).

              Try opening that page in a text editor and resaving it - I can't imagine why that'd help, but I can't think of anything else (since .Mac doesn't give you access to the server configuration).

              HTH,

              Roger

              __
            • Roger Howard
              ... Yep - all the pages on your site where redirects work are being served using the correct content-type header so it s consistent. Here s something to try -
              Message 6 of 9 , Apr 6, 2012
              • 0 Attachment
                On Thu, Apr 5, 2012 at 4:29 AM, Willy Kaemena <panokaemena@...> wrote:
                 

                Thank you Roger for your insights


                nothing worked so far. I have a few other redirects  on my .Mac  which works  flawless.


                Yep - all the pages on your site where redirects work are being served using the correct content-type header so it's consistent.

                Here's something to try - I noticed the link that's *not* working ends with _swf.html...

                Try creating a new page using the same redirect code, but including _swf.html in the filename, instead of just .html - I wonder if something on Apple's .Mac servers is so stupidly configured that they see "swf" in your URL and just decide to serve it with a content-type that would be appropriate for .swf files, but not .html.

                -R
              Your message has been successfully submitted and would be delivered to recipients shortly.