Loading ...
Sorry, an error occurred while loading the content.

Re: [PanoToolsNG] Re: QTVR Authoring Studio - outputs garbage images

Expand Messages
  • Carl von Einem
    memory allocation is important, a good hint from Willy. Make sure you disable unneccessary extensions (and fonts in ATM...) How much RAM do you have, how much
    Message 1 of 19 , Dec 3, 2006
    • 0 Attachment
      memory allocation is important, a good hint from Willy. Make sure you disable
      unneccessary extensions (and fonts in ATM...) How much RAM do you have, how
      much does the system want?

      http://wiki.panotools.org/QTVRAS provides a link to the 1.0.1 update. Do you
      have that?

      Can you put an example for this problem somewhere on your web site so that
      we can have a look at it?

      Your source is a .tif or .pct in cylindrical projection... did you feed it
      into QTVRAS in landscape mode or 90 deg. rotated and does that make a
      difference?

      Ken Turkowski once suggested to turn off "intermediate progress display" in
      the preferences of QTVRAS.

      6000 x 2300 looks like a relatively large fov... Maybe you need Ken's
      "QuickTime VR Authoring Studio 160 patch", available at
      http://www.worldserver.com/turk/quicktimevr/QTVRlinks.html

      Is there a special reason for a cylindrical QTVR .mov?
      If everything fails to work: why not convert the cylindrical into
      equirectangular projection, add canvas to achieve a 2:1 aspect ratio and
      center your image's "horizon". Then feed into e.g. one of the freeware apps
      that can output Cubic QTVR and restrict pitch. Even easier: use
      CubicConverter.

      hope that helps,
      Carl

      William Donelson wrote:
      > Looks like I cannot do any source pix larger than about 4000 x 1700...
      > Smaller source pix seem to work okay.
      > >
      > > I am trying to convert a 6000 x 2300 cylindrical pano pic into QTVR
      > using
      > > QTVR Authoring Studio (which used to work under Classic / OSX) but now
      > > the output is scrambled garbage images/VR panos.
      > > ( I am running OSX 10.4.8 )


      --
      View this message in context: http://www.nabble.com/QTVR-Authoring-Studio---outputs-garbage-images-tf2746101.html#a7663344
      Sent from the PanoToolsNG mailing list archive at Nabble.com.
    • William Donelson
      Hmmm... How do you increase an app s memory when running Classic under OSX ?
      Message 2 of 19 , Dec 3, 2006
      • 0 Attachment
        Hmmm...

        How do you increase an app's memory when running Classic under OSX ?


        --- In PanoToolsNG@yahoogroups.com, panokaemena@... wrote:
        >
        > I think you have to increase the memory for QTVRAS under classic.....
        >
        > Willy
        >
        >
        > On Dec 3, 2006, at 13:10, William Donelson wrote:
        >
        > > Looks like I cannot do any source pix larger than about 4000 x 1700...
        > >
        > > Smaller source pix seem to work okay.
        > >
        > > Is there any way around this?
        > >
        > > Thanks
        > >
        > > --- In PanoToolsNG@yahoogroups.com, "William Donelson" <wd@> wrote:
        > > >
        > > > I am trying to convert a 6000 x 2300 cylindrical pano pic into
        > > QTVR using QTVR
        > > Authoring
        > > > Studio (which used to work under Classic / OSX) but now the
        > > output is scrambled
        > > garbage
        > > > images/VR panos.
        > > >
        > > > Any solutions?
        > > >
        > > > ( I am running OSX 10.4.8 )
        > > >
        > >
        > >
        > >
        >
        >
        >
        > [Non-text portions of this message have been removed]
        >
      • Carl von Einem
        In Finder choose Macintosh Help from Menu: Help Search for memory classic application (or similar keywords, I m on German 10.3.9 system here) You will find -
        Message 3 of 19 , Dec 3, 2006
        • 0 Attachment
          In Finder choose 'Macintosh Help' from Menu: Help

          Search for
          memory classic application
          (or similar keywords, I'm on German 10.3.9 system here)

          You will find
          - Adjusting the memory allocation for the Classic environment
          (very interesting, that is about increasing temporary memory for the
          classic environment)
          - How to set memory use for Classic Applications

          I used http://search.info.apple.com/ to find the correct English article
          titles.

          Basically just click on the program icon, open the program's information
          window, and in the 'memory' section increase the 'preferred' memory size.

          Carl


          William Donelson wrote:
          >
          > How do you increase an app's memory when running Classic under OSX ?
          >

          --
          View this message in context: http://www.nabble.com/QTVR-Authoring-Studio---outputs-garbage-images-tf2746101.html#a7668291
          Sent from the PanoToolsNG mailing list archive at Nabble.com.
        • William Donelson
          QTVRAS already has 244 MB of RAM allocated in Classic 9... I would be amazed if that s not enough already... W ...
          Message 4 of 19 , Dec 3, 2006
          • 0 Attachment
            QTVRAS already has 244 MB of RAM allocated in Classic 9...

            I would be amazed if that's not enough already...


            W

            --- In PanoToolsNG@yahoogroups.com, Carl von Einem <einem@...> wrote:
            >
            >
            > In Finder choose 'Macintosh Help' from Menu: Help
            >
            > Search for
            > memory classic application
            > (or similar keywords, I'm on German 10.3.9 system here)
            >
            > You will find
            > - Adjusting the memory allocation for the Classic environment
            > (very interesting, that is about increasing temporary memory for the
            > classic environment)
            > - How to set memory use for Classic Applications
            >
            > I used http://search.info.apple.com/ to find the correct English article
            > titles.
            >
            > Basically just click on the program icon, open the program's information
            > window, and in the 'memory' section increase the 'preferred' memory size.
            >
            > Carl
            >
            >
            > William Donelson wrote:
            > >
            > > How do you increase an app's memory when running Classic under OSX ?
            > >
            >
            > --
            > View this message in context: http://www.nabble.com/QTVR-Authoring-Studio---
            outputs-garbage-images-tf2746101.html#a7668291
            > Sent from the PanoToolsNG mailing list archive at Nabble.com.
            >
          • disiszarl
            ... how about what I wrote in http://tech.groups.yahoo.com/group/PanoToolsNG/message/4448 Carl
            Message 5 of 19 , Dec 3, 2006
            • 0 Attachment
              --- In PanoToolsNG@yahoogroups.com, "William Donelson" <wd@...> wrote:
              >
              > QTVRAS already has 244 MB of RAM allocated in Classic 9...
              > I would be amazed if that's not enough already...

              how about what I wrote in
              http://tech.groups.yahoo.com/group/PanoToolsNG/message/4448

              Carl
            • William Donelson
              Carl Thanks. The Turkowski patch is not relevant - only for 160° FOVs. I m not ready yet to get into using many different apps just to get my QTVRs, I d
              Message 6 of 19 , Dec 4, 2006
              • 0 Attachment
                Carl

                Thanks. The Turkowski patch is not relevant - only for 160° FOVs.

                I'm not ready yet to get into using many different apps just to get my QTVRs, I'd rather
                look into fixing/memorating QTVRAS right now.

                I don't see how to increase the RAM allocated to QTVRAS when running OSX with Classic 9
                yet...

                W

                --- In PanoToolsNG@yahoogroups.com, "disiszarl" <einem@...> wrote:
                >
                > --- In PanoToolsNG@yahoogroups.com, "William Donelson" <wd@> wrote:
                > >
                > > QTVRAS already has 244 MB of RAM allocated in Classic 9...
                > > I would be amazed if that's not enough already...
                >
                > how about what I wrote in
                > http://tech.groups.yahoo.com/group/PanoToolsNG/message/4448
                >
                > Carl
                >
              • Hans Nyberg
                ... 9 It is not different than it was in OS9. INFO- Memory - set minimum/preferred size You can read all about it here.
                Message 7 of 19 , Dec 4, 2006
                • 0 Attachment
                  --- In PanoToolsNG@yahoogroups.com, "William Donelson" <wd@...> wrote:
                  >
                  > Carl
                  >
                  > Thanks. The Turkowski patch is not relevant - only for 160° FOVs.
                  >
                  > I'm not ready yet to get into using many different apps just to get my QTVRs, I'd rather
                  > look into fixing/memorating QTVRAS right now.
                  >
                  > I don't see how to increase the RAM allocated to QTVRAS when running OSX with Classic
                  9

                  It is not different than it was in OS9.
                  INFO- Memory - set minimum/preferred size

                  You can read all about it here.
                  http://www.apple.com/support/tiger/classic/

                  Applications:
                  http://docs.info.apple.com/article.html?path=Mac/10.4/en/mh867.html

                  Setting memory for Classic environment.
                  http://docs.info.apple.com/article.html?path=Mac/10.4/en/mh1834.html

                  Hans
                • panokaemena@mac.com
                  Good question..... as you see the Classic App only under OSX environment there you can see the RAM dedicated to QTVRAS but you cannot change it....
                  Message 8 of 19 , Dec 4, 2006
                  • 0 Attachment
                    Good question..... as you see the Classic App only under OSX
                    environment there you can see the RAM dedicated to QTVRAS but you
                    cannot change it....

                    From my point of view the time has come to make a quantum leap to
                    OSX apps like PTgui etc.

                    Willy


                    On Dec 4, 2006, at 15:04, William Donelson wrote:

                    > Carl
                    >
                    > Thanks. The Turkowski patch is not relevant - only for 160° FOVs.
                    >
                    > I'm not ready yet to get into using many different apps just to get
                    > my QTVRs, I'd rather
                    > look into fixing/memorating QTVRAS right now.
                    >
                    > I don't see how to increase the RAM allocated to QTVRAS when
                    > running OSX with Classic 9
                    > yet...
                    >
                    > W
                    >
                    > --- In PanoToolsNG@yahoogroups.com, "disiszarl" <einem@...> wrote:
                    > >
                    > > --- In PanoToolsNG@yahoogroups.com, "William Donelson" <wd@> wrote:
                    > > >
                    > > > QTVRAS already has 244 MB of RAM allocated in Classic 9...
                    > > > I would be amazed if that's not enough already...
                    > >
                    > > how about what I wrote in
                    > > http://tech.groups.yahoo.com/group/PanoToolsNG/message/4448
                    > >
                    > > Carl
                    > >
                    >
                    >
                    >



                    [Non-text portions of this message have been removed]
                  • Carl von Einem
                    Hi William, can you send me your source file directly? I have a working QTVRAS (on my older 867 MHz G4 with a little bit over 1 GB RAM) and can try if it works
                    Message 9 of 19 , Dec 4, 2006
                    • 0 Attachment
                      Hi William,

                      can you send me your source file directly? I have a working QTVRAS (on
                      my older 867 MHz G4 with a little bit over 1 GB RAM) and can try if it
                      works here. Without seeing the broken .mov or having more information
                      about your lens / setup / workflow it's not easy to tell where the
                      problem can be.

                      Carl

                      Posted by: "William Donelson"
                      >
                      > Thanks. The Turkowski patch is not relevant - only for 160° FOVs.
                      >
                      > I'm not ready yet to get into using many different apps just to get my
                      > QTVRs, I'd rather look into fixing/memorating QTVRAS right now.
                      >
                      > I don't see how to increase the RAM allocated to QTVRAS when running OSX
                      > with Classic 9 yet...
                    • William Donelson
                      Hans Got it, thanks. However, increasing app memory size to 750k did not fix the problem of scrambled output. Input source pic size: 6000 x 2332 W ... rather
                      Message 10 of 19 , Dec 4, 2006
                      • 0 Attachment
                        Hans

                        Got it, thanks.

                        However, increasing app memory size to 750k did not fix the problem of scrambled
                        output. Input source pic size: 6000 x 2332


                        W

                        --- In PanoToolsNG@yahoogroups.com, "Hans Nyberg" <hans@...> wrote:
                        >
                        > --- In PanoToolsNG@yahoogroups.com, "William Donelson" <wd@> wrote:
                        > >
                        > > Carl
                        > >
                        > > Thanks. The Turkowski patch is not relevant - only for 160° FOVs.
                        > >
                        > > I'm not ready yet to get into using many different apps just to get my QTVRs, I'd
                        rather
                        > > look into fixing/memorating QTVRAS right now.
                        > >
                        > > I don't see how to increase the RAM allocated to QTVRAS when running OSX with
                        Classic
                        > 9
                        >
                        > It is not different than it was in OS9.
                        > INFO- Memory - set minimum/preferred size
                        >
                        > You can read all about it here.
                        > http://www.apple.com/support/tiger/classic/
                        >
                        > Applications:
                        > http://docs.info.apple.com/article.html?path=Mac/10.4/en/mh867.html
                        >
                        > Setting memory for Classic environment.
                        > http://docs.info.apple.com/article.html?path=Mac/10.4/en/mh1834.html
                        >
                        > Hans
                        >
                      • Hans Nyberg
                        ... 750k ? My QTVRAS is set to 10000 kb min and 16384 kb preferred I have never used it but I just tried it on my G5 in Tiger 10.4.8 filesize 4000x10240 pixels
                        Message 11 of 19 , Dec 4, 2006
                        • 0 Attachment
                          --- In PanoToolsNG@yahoogroups.com, "William Donelson" <wd@...> wrote:
                          >
                          > Hans
                          >
                          > Got it, thanks.
                          >
                          > However, increasing app memory size to 750k did not fix the problem of scrambled
                          > output. Input source pic size: 6000 x 2332

                          750k
                          ?
                          My QTVRAS is set to 10000 kb min and 16384 kb preferred
                          I have never used it but I just tried it on my G5 in Tiger 10.4.8

                          filesize 4000x10240 pixels pict.
                          Everything works fine.

                          Hans
                        • Kathy Wheeler
                          ... It s the over 4000px that causes the problem from memory (no pun intended). There s a patch for that but I presume William already has it? Otherwise 750k
                          Message 12 of 19 , Dec 4, 2006
                          • 0 Attachment
                            On 05/12/2006, at 11:52 AM, Hans Nyberg wrote:
                            > --- In PanoToolsNG@yahoogroups.com, "William Donelson" <wd@...> wrote:
                            >> However, increasing app memory size to 750k did not fix the
                            >> problem of scrambled
                            >> output. Input source pic size: 6000 x 2332
                            >
                            > 750k
                            > ?
                            > My QTVRAS is set to 10000 kb min and 16384 kb preferred
                            > I have never used it but I just tried it on my G5 in Tiger 10.4.8
                            >
                            > filesize 4000x10240 pixels pict.
                            > Everything works fine.

                            It's the over 4000px that causes the problem from memory (no pun
                            intended). There's a patch for that but I presume William already has
                            it? Otherwise "750k" sounds way too small for even a 4000px wide
                            image to stitch ... must be a typo?

                            Cheers,
                            KathyW.
                          • Carl von Einem
                            With 750k he should be referring to 750,000 as the memory size is displayed in KB in that dialog. Maybe it s a corrupted QTVR Authoring Studio Prefs file?
                            Message 13 of 19 , Dec 5, 2006
                            • 0 Attachment
                              With '750k' he should be referring to 750,000 as the memory size is
                              displayed in KB in that dialog.

                              Maybe it's a corrupted 'QTVR Authoring Studio Prefs' file? It's no
                              problem to delete that and than try with fresh standard settings. I
                              could make screenshots from my settings so that he can use the same and
                              try again with a fresh preferences file.

                              There was indeed a limitation for the file size dimension (in pixels).
                              But I think that was a problem of the .pct file format that could be
                              easily dealt with in rotating the source file 90 degrees. The limit was
                              on the x-axis only...

                              It works on my system with a standard JPG in landscape orientation
                              (provided by William) without problems. QTVRAS is not fast but was
                              always a reliable working horse for me.

                              I'd still like to see an example of that scrambled output. Maybe he can
                              post it and some of us could have a look at it with deliVRator.

                              QTVRAS is still used by several wwp participants on a regular basis:
                              http://www.google.co.uk/search?q=qtvras+site:geoimages.berkeley.edu

                              Carl


                              Posted by: "Kathy Wheeler"
                              >
                              > It's the over 4000px that causes the problem from memory (no pun
                              > intended). There's a patch for that but I presume William already has
                              > it? Otherwise "750k" sounds way too small for even a 4000px wide
                              > image to stitch ... must be a typo?
                            • William Donelson
                              I;ve tried everything except deleting the Prefs file. If I delete that, it asks me for the Reg Code, which I have lost somewhere back in the fog of the
                              Message 14 of 19 , Dec 5, 2006
                              • 0 Attachment
                                I;ve tried everything except deleting the Prefs file.

                                If I delete that, it asks me for the Reg Code, which I have lost somewhere back in the fog
                                of the 1990s...


                                W


                                --- In PanoToolsNG@yahoogroups.com, Carl von Einem <einem@...> wrote:
                                >
                                > With '750k' he should be referring to 750,000 as the memory size is
                                > displayed in KB in that dialog.
                                >
                                > Maybe it's a corrupted 'QTVR Authoring Studio Prefs' file? It's no
                                > problem to delete that and than try with fresh standard settings. I
                                > could make screenshots from my settings so that he can use the same and
                                > try again with a fresh preferences file.
                                >
                                > There was indeed a limitation for the file size dimension (in pixels).
                                > But I think that was a problem of the .pct file format that could be
                                > easily dealt with in rotating the source file 90 degrees. The limit was
                                > on the x-axis only...
                                >
                                > It works on my system with a standard JPG in landscape orientation
                                > (provided by William) without problems. QTVRAS is not fast but was
                                > always a reliable working horse for me.
                                >
                                > I'd still like to see an example of that scrambled output. Maybe he can
                                > post it and some of us could have a look at it with deliVRator.
                                >
                                > QTVRAS is still used by several wwp participants on a regular basis:
                                > http://www.google.co.uk/search?q=qtvras+site:geoimages.berkeley.edu
                                >
                                > Carl
                                >
                                >
                                > Posted by: "Kathy Wheeler"
                                > >
                                > > It's the over 4000px that causes the problem from memory (no pun
                                > > intended). There's a patch for that but I presume William already has
                                > > it? Otherwise "750k" sounds way too small for even a 4000px wide
                                > > image to stitch ... must be a typo?
                                >
                              • William Donelson
                                I got it to work. I was using 1 vertical tile for the 6000 x 2332 source pic. If I go to TWO tiles, then it works fine. Must be some sort of
                                Message 15 of 19 , Dec 5, 2006
                                • 0 Attachment
                                  I got it to work.

                                  I was using "1 vertical tile" for the 6000 x 2332 source pic. If I go to TWO tiles, then it works
                                  fine.

                                  Must be some sort of compression/read/write limit...

                                  Thanks to all.
                                • Kathy Wheeler
                                  Congratulations William. You get the prize for dogged perseverance :-) Well done and tks for posting your solution. Cheers, KathyW.
                                  Message 16 of 19 , Dec 6, 2006
                                  • 0 Attachment
                                    Congratulations William. You get the prize for dogged
                                    perseverance :-) Well done and tks for posting your solution.

                                    Cheers,
                                    KathyW.


                                    On 06/12/2006, at 6:30 PM, William Donelson wrote:

                                    >
                                    > I got it to work.
                                    >
                                    > I was using "1 vertical tile" for the 6000 x 2332 source pic. If I
                                    > go to TWO tiles, then it works
                                    > fine.
                                    >
                                    > Must be some sort of compression/read/write limit...
                                    >
                                    > Thanks to all.
                                  Your message has been successfully submitted and would be delivered to recipients shortly.