Loading ...
Sorry, an error occurred while loading the content.

Consistent stitching errors

Expand Messages
  • Blake Michaelson
    Hello, I ve been searching for a resolution to some consistent stitching errors without success - I m hoping I can gain some insight from some of the sage
    Message 1 of 8 , Nov 30, 2006
    View Source
    • 0 Attachment
      Hello,

      I've been searching for a resolution to some consistent stitching errors
      without success - I'm hoping I can gain some insight from some of the
      sage here... Forgive me if this is a bit lengthy, but I wanted to
      ensure I accurately represented the issue.

      I am using a Canon 350D with the Peleng 8mm EOS, a Panosaurus head,
      Bogen 3012B Legs and 486RC2 (with RC2 removable plate) - my first
      instinct is to immediately jump on the panosaurus as the culprit, but I
      don't want to be too quick to judge.

      The consistent problem I am having with the stitching errors is that,
      regardless of the number of images I take (4/6/8/12) I have a
      significant amount of deviation on my control point table. Were I to
      take 4 shots plus Z & N, import them into PTGui (basic mode) and align
      them - my results would be: Average control point distance 8.3524,
      minimum 0.6301, maximum 30.7133 - this is a typical spread for any given
      series of images. Although this isn't too detrimental when taking
      outdoor panos, it is a significant issue when taking indoor panos.

      I have found that I can decrease the spread, i.e. improve the tightness
      of the table, by removing and nadir - marginally, but some - say an
      average of 5.0 for the control points, and a little bit more by removing
      the zenith. The biggest gain is accomplished by simply removing the nadir.

      I have attempted to clean up my control point table by deleting high
      value points, and re-optimizing the table, eventually ending up with
      very few control points, but a "very good" optimization with a max
      distance control point of less than 5.0. Regardless, the same stitching
      issues remain.

      The actual stitching issue is typically a highly visible vertical
      "smudge" or alignment issue on a horizontal surface (i.e. a ceiling
      seam, a structural beam) or simply a skewed vertical stitch placed in
      the middle of a cabinet or wall. As an aside - I had nearly no such
      issues with the same legs, head, camera setup using the 18-55 kit lens
      set to 18mm using 3 rows of 12 shots - 36 pictures with the kit lens
      stitched better than 6 using the peleng! (sample at
      http://www.nwpropertyphotos.com/)

      I've attempted to attach a copy of a nadir from a 6 shot pano - in the
      event it doesn't attach, the picture depicts the base of the panosaurus
      (a circle) displayed as though there are parallax problems. Imagine a
      nautilus shell put on its side, and shifted 60° about it's "nodal point"
      - there's a bit of a lip from each pano image that contributes to making
      the circle look a bit like a pinwheel... if you can imagine what I'm
      attempting to describe.

      The few thoughts that came to mind:
      - I've incorrectly calibrated the lens/head - I followed the
      instructions precisely, and have come up with the same result on many
      attempts over the last few weeks (17.2 on the far left DSLR scale)
      - Somehow the panosaurus is not rotating precisely and I'm getting
      paralax regardless of calibration
      - There is a flaw in my workflow
      - I'm expecting too much from PTGui
      - I'm expecting too much from my gear

      Any thoughts would be greatly appreciated - I've seen so many fantastic
      panos here and I wish I could share similar great work myself!!!

      I'd be happy to post any files you feel may be salient to this topic.

      I'm also thinking its time to step up to a more substantial pano head -
      any sub-$500US suggestions without locking into a body/lens combo like
      the 360P?

      Thanks in advance,
      Blake


      [Non-text portions of this message have been removed]
    • Juergen Schrader
      1. PTGUI is a great tool and you can get perfect results with it. 2. No need to swap the panosaurus right now. I had similar problems when I went from my
      Message 2 of 8 , Nov 30, 2006
      View Source
      • 0 Attachment
        1. PTGUI is a great tool and you can get perfect results with it.
        2. No need to swap the panosaurus right now.

        I had similar problems when I went from my rectilinear lenses to
        fisheyes (also had a Panosaurus in use at that time).

        Three things were mandatory to solve it:

        - check the physical setup
        - in ptgui optimize for (d) and (e) parameters
        - optimize z&n separately

        I use panorama tools optimizer and usually get an average control
        point distance below 1.


        Good luck
        Jürgen


        --- In PanoToolsNG@yahoogroups.com, Blake Michaelson
        <blake.michaelson@...> wrote:
        >
        > Hello,
        >
        > I've been searching for a resolution to some consistent stitching
        errors
        > without success - I'm hoping I can gain some insight from some of
        the
        > sage here... Forgive me if this is a bit lengthy, but I wanted to
        > ensure I accurately represented the issue.
        >
        > I am using a Canon 350D with the Peleng 8mm EOS, a Panosaurus head,
        > Bogen 3012B Legs and 486RC2 (with RC2 removable plate) - my first
        > instinct is to immediately jump on the panosaurus as the culprit,
        but I
        > don't want to be too quick to judge.
        >
        > The consistent problem I am having with the stitching errors is
        that,
        > regardless of the number of images I take (4/6/8/12) I have a
        > significant amount of deviation on my control point table. Were I
        to
        > take 4 shots plus Z & N, import them into PTGui (basic mode) and
        align
        > them - my results would be: Average control point distance 8.3524,
        > minimum 0.6301, maximum 30.7133 - this is a typical spread for any
        given
        > series of images. Although this isn't too detrimental when taking
        > outdoor panos, it is a significant issue when taking indoor panos.
        >
        > I have found that I can decrease the spread, i.e. improve the
        tightness
        > of the table, by removing and nadir - marginally, but some - say an
        > average of 5.0 for the control points, and a little bit more by
        removing
        > the zenith. The biggest gain is accomplished by simply removing
        the nadir.
        >
        > I have attempted to clean up my control point table by deleting
        high
        > value points, and re-optimizing the table, eventually ending up
        with
        > very few control points, but a "very good" optimization with a max
        > distance control point of less than 5.0. Regardless, the same
        stitching
        > issues remain.
        >
        > The actual stitching issue is typically a highly visible vertical
        > "smudge" or alignment issue on a horizontal surface (i.e. a ceiling
        > seam, a structural beam) or simply a skewed vertical stitch placed
        in
        > the middle of a cabinet or wall. As an aside - I had nearly no
        such
        > issues with the same legs, head, camera setup using the 18-55 kit
        lens
        > set to 18mm using 3 rows of 12 shots - 36 pictures with the kit
        lens
        > stitched better than 6 using the peleng! (sample at
        > http://www.nwpropertyphotos.com/)
        >
        > I've attempted to attach a copy of a nadir from a 6 shot pano - in
        the
        > event it doesn't attach, the picture depicts the base of the
        panosaurus
        > (a circle) displayed as though there are parallax problems.
        Imagine a
        > nautilus shell put on its side, and shifted 60° about it's "nodal
        point"
        > - there's a bit of a lip from each pano image that contributes to
        making
        > the circle look a bit like a pinwheel... if you can imagine what
        I'm
        > attempting to describe.
        >
        > The few thoughts that came to mind:
        > - I've incorrectly calibrated the lens/head - I followed the
        > instructions precisely, and have come up with the same result on
        many
        > attempts over the last few weeks (17.2 on the far left DSLR scale)
        > - Somehow the panosaurus is not rotating precisely and I'm getting
        > paralax regardless of calibration
        > - There is a flaw in my workflow
        > - I'm expecting too much from PTGui
        > - I'm expecting too much from my gear
        >
        > Any thoughts would be greatly appreciated - I've seen so many
        fantastic
        > panos here and I wish I could share similar great work myself!!!
        >
        > I'd be happy to post any files you feel may be salient to this
        topic.
        >
        > I'm also thinking its time to step up to a more substantial pano
        head -
        > any sub-$500US suggestions without locking into a body/lens combo
        like
        > the 360P?
        >
        > Thanks in advance,
        > Blake
        >
        >
        > [Non-text portions of this message have been removed]
        >
      • Rodrigo Alarcon-Cielock
        Hi Blake, I have the same equipment combination as yours except for the panohead and tripod. I use the NodalNinja3 panohead
        Message 3 of 8 , Nov 30, 2006
        View Source
        • 0 Attachment
          Hi Blake,

          I have the same equipment combination as yours except for the
          panohead and tripod.
          I use the NodalNinja3 panohead
          http://www.nodalninja.com/order_nodal_ninja.html , installed
          directly onto the centre screw of the tripod. After a number of test
          through out the years I found that the less equipment there is
          between the tripod and the panohead the better results I got, as
          there is less parts to include in the aligment. The NN3 has a buil-
          in level and that is the one which I guide myself with for aligment
          of tripod and panohead. Once I have attach the camera to the NN3 I
          put a small level in the hotshoe of the camera to ensure that the
          camera is horizontally level. Then I proceed to take 6 photos + 1
          Zenith if it is an interior pano, with an exterior pano and no
          sorounding buildings the hole in the zenith is so small that it can
          be touched in Photoshop once I have stitched them using Ptgui. The
          Nadir footprint is also really small and can be touched using CS2.
          You can see a sample of one of my panos using the above technique
          here
          http://geoimages.berkeley.edu/wwp906/html/RodrigoAlarconCielock.html

          If there is anything I can help you please don't hesitate to contact
          me.
          kind regards,

          Rodrigo
        • Alessandro Ugazio
          Blake, I ve seen your pano and I have some workflow suggestions: - be sure all your shots (including zenith and nadir) are _really_ vertical, or portrait mode;
          Message 4 of 8 , Nov 30, 2006
          View Source
          • 0 Attachment
            Blake, I've seen your pano and I have some workflow suggestions:

            - be sure all your shots (including zenith and nadir) are _really_ vertical, or portrait mode;
            if you zenith or nadir are horizontal, rotate them in Photoshop and resave them.
            - set vertical cps not only in anchor image but also in other images every about 90
            degrees in the scene;
            - optimizing, check yaw, pitch and roll for every image and uncheck only yaw for
            anchor image (I use PTMac, don't know how PTGui appears but it should be the same)

            I usually optimize first only for image position, deleting just very high values (90 or more,
            but not 30-40, for example)
            Then I optimize for position + fov (at this point the distance should be strongly reduced),
            then pos+fov+b, then pos+fov+a,b,d,e.
            During these steps I try to keep the more cps I can, and I usually end up with about 3 or 4
            maximum cp distance.

            I have an old Panosaurus not perfectly set up, and a cheap quick-release plate (brand
            Kaiser!...) that produces a remarkable camera inclination in every image; nevertheless, I
            usually obtain satisfying results after described optimization.

            The main issues I have are enblend misalignments that I mask out in Photoshop (I always
            generate an enblend tiff, keeping single layers to play with in PS).

            Another thing I usually do: I shot two nadirs with panohead visible, and then a "free" nadir
            to close the gap; then I merge them in PS and generate a nadir that stitches well with other
            images. I save a lot of time since I begun doing like this.

            I have different camera and lens (Nikon D50+Nikkor 10.5), but even though Panosaurus
            isn't a perfect tool I hope you can obtain aligned panos with your actual gear.

            These are mine:
            <http://www.ziouga.it/Panorami/Panorami.html>

            ciao
            Alessandro Ugazio
          • John Houghton
            ... This suggests that the lateral positioning of the camera is not correct. The entrance pupil may be located correctly front to back, but not side to side.
            Message 5 of 8 , Nov 30, 2006
            View Source
            • 0 Attachment
              --- In PanoToolsNG@yahoogroups.com, Blake Michaelson
              <blake.michaelson@...> wrote:
              >
              > Imagine a nautilus shell put on its side, and shifted 60° about
              > it's "nodal point" - there's a bit of a lip from each pano image
              > that contributes to making the circle look a bit like a pinwheel...
              > if you can imagine what I'm attempting to describe.

              This suggests that the lateral positioning of the camera is not
              correct. The entrance pupil may be located correctly front to back,
              but not side to side. Whatever instructions you are following, they
              don't seem to have worked. Try checking the entrance pupil position
              visually using this simple arrangement:
              http://homepage.ntlworld.com/j.houghton/eppos.jpg
              Point the eyepiece at a bright light source to illuminate the
              entrance pupil. Make sure you have the pano head level and use the
              plumb line to check that the entrance pupil is centered on the axis
              point.

              Generally, there is no requirement to accurately level the panorama
              head and/or the camera to ensure good stitching. Rotating the camera
              about the no-parallax point is the important thing to get right.

              John
            • Sacha Griffin
              There s no way to know really without the original images and your project file where the flaw is in your system. I ve used an identical setup as yours, and
              Message 6 of 8 , Nov 30, 2006
              View Source
              • 0 Attachment
                There's no way to know really without the original images and your project
                file where the flaw is in your system.

                I've used an identical setup as yours, and consistently get under 1 pixel of
                error average with a max error of no more than 1.5 or 2.

                There are literally a dozen or more points of failure and this could turn
                into a dangerous thread of conjecture.

                You can browse past messages here for many many useful hints but I advise to
                post everything somewhere so we can take a look.

                Sacha Griffin
                Southern Digital Solutions LLC
                www.southern-digital.com
                www.seeit360.net
                www.ezphotosafe.com
                404-551-4275
                404-731-7798


                -----Original Message-----
                From: Blake Michaelson [mailto:blake.michaelson@...]
                Sent: Thursday, November 30, 2006 3:57 AM
                To: PanoToolsNG@yahoogroups.com
                Subject: [PanoToolsNG] Consistent stitching errors

                Hello,

                I've been searching for a resolution to some consistent stitching errors
                without success - I'm hoping I can gain some insight from some of the
                sage here... Forgive me if this is a bit lengthy, but I wanted to
                ensure I accurately represented the issue.

                I am using a Canon 350D with the Peleng 8mm EOS, a Panosaurus head,
                Bogen 3012B Legs and 486RC2 (with RC2 removable plate) - my first
                instinct is to immediately jump on the panosaurus as the culprit, but I
                don't want to be too quick to judge.

                The consistent problem I am having with the stitching errors is that,
                regardless of the number of images I take (4/6/8/12) I have a
                significant amount of deviation on my control point table. Were I to
                take 4 shots plus Z & N, import them into PTGui (basic mode) and align
                them - my results would be: Average control point distance 8.3524,
                minimum 0.6301, maximum 30.7133 - this is a typical spread for any given
                series of images. Although this isn't too detrimental when taking
                outdoor panos, it is a significant issue when taking indoor panos.

                I have found that I can decrease the spread, i.e. improve the tightness
                of the table, by removing and nadir - marginally, but some - say an
                average of 5.0 for the control points, and a little bit more by removing
                the zenith. The biggest gain is accomplished by simply removing the nadir.

                I have attempted to clean up my control point table by deleting high
                value points, and re-optimizing the table, eventually ending up with
                very few control points, but a "very good" optimization with a max
                distance control point of less than 5.0. Regardless, the same stitching
                issues remain.

                The actual stitching issue is typically a highly visible vertical
                "smudge" or alignment issue on a horizontal surface (i.e. a ceiling
                seam, a structural beam) or simply a skewed vertical stitch placed in
                the middle of a cabinet or wall. As an aside - I had nearly no such
                issues with the same legs, head, camera setup using the 18-55 kit lens
                set to 18mm using 3 rows of 12 shots - 36 pictures with the kit lens
                stitched better than 6 using the peleng! (sample at
                http://www.nwpropertyphotos.com/)

                I've attempted to attach a copy of a nadir from a 6 shot pano - in the
                event it doesn't attach, the picture depicts the base of the panosaurus
                (a circle) displayed as though there are parallax problems. Imagine a
                nautilus shell put on its side, and shifted 60° about it's "nodal point"
                - there's a bit of a lip from each pano image that contributes to making
                the circle look a bit like a pinwheel... if you can imagine what I'm
                attempting to describe.

                The few thoughts that came to mind:
                - I've incorrectly calibrated the lens/head - I followed the
                instructions precisely, and have come up with the same result on many
                attempts over the last few weeks (17.2 on the far left DSLR scale)
                - Somehow the panosaurus is not rotating precisely and I'm getting
                paralax regardless of calibration
                - There is a flaw in my workflow
                - I'm expecting too much from PTGui
                - I'm expecting too much from my gear

                Any thoughts would be greatly appreciated - I've seen so many fantastic
                panos here and I wish I could share similar great work myself!!!

                I'd be happy to post any files you feel may be salient to this topic.

                I'm also thinking its time to step up to a more substantial pano head -
                any sub-$500US suggestions without locking into a body/lens combo like
                the 360P?

                Thanks in advance,
                Blake


                [Non-text portions of this message have been removed]



                --

                Yahoo! Groups Links
              • Blake Michaelson
                Thank you all for the excellent information! I tore down my system (Canon 350D / Peleng 8mm / Panosaurus - for the next guy who searches for this issue) and
                Message 7 of 8 , Dec 1, 2006
                View Source
                • 0 Attachment
                  Thank you all for the excellent information! I tore down my system
                  (Canon 350D / Peleng 8mm / Panosaurus - for the next guy who searches
                  for this issue) and set it all up once again (I have to admit that the
                  link below to eppos.jpg was a nice simplistic approach to checking the
                  alignment). I took another 4+1+2 (2 nadir opposed 180°), things
                  stitched a little better, but not much different than before.

                  However, I did have GREAT success with going into advanced mode of
                  PTGui, selecting the Optimizer tab, keeping the Optimizer in simple
                  mode, selecting optimize lens Field of View, and selecting Minimize lens
                  distortion to "Heavy + lens shift", then ran the optimizer. I ended up
                  with an average of 1.03, max of 2.47 and min 0.04 - significantly better
                  points, and subsequently significantly better stitched panos! This
                  almost completely eliminated the "nautilus" effect with regard to the
                  unpatched nadir. I went back and restitched some panos I took prior to
                  realigning my setup and they stitched just as precisely as well...

                  Thanks for the all the continued assistance - I appreciate it tremendously!

                  Blake

                  John Houghton wrote:
                  >
                  > --- In PanoToolsNG@yahoogroups.com
                  > <mailto:PanoToolsNG%40yahoogroups.com>, Blake Michaelson
                  > <blake.michaelson@...> wrote:
                  > >
                  > > Imagine a nautilus shell put on its side, and shifted 60° about
                  > > it's "nodal point" - there's a bit of a lip from each pano image
                  > > that contributes to making the circle look a bit like a pinwheel...
                  > > if you can imagine what I'm attempting to describe.
                  >
                  > This suggests that the lateral positioning of the camera is not
                  > correct. The entrance pupil may be located correctly front to back,
                  > but not side to side. Whatever instructions you are following, they
                  > don't seem to have worked. Try checking the entrance pupil position
                  > visually using this simple arrangement:
                  > http://homepage.ntlworld.com/j.houghton/eppos.jpg
                  > <http://homepage.ntlworld.com/j.houghton/eppos.jpg>
                  > Point the eyepiece at a bright light source to illuminate the
                  > entrance pupil. Make sure you have the pano head level and use the
                  > plumb line to check that the entrance pupil is centered on the axis
                  > point.
                  >
                  > Generally, there is no requirement to accurately level the panorama
                  > head and/or the camera to ensure good stitching. Rotating the camera
                  > about the no-parallax point is the important thing to get right.
                  >
                  > John
                  >
                  >
                • Roger D. Williams
                  Blake, I am so glad you got what you needed. As a moderator of the list I must say it gives the very greatest satisfaction to think that we have such
                  Message 8 of 8 , Dec 1, 2006
                  View Source
                  • 0 Attachment
                    Blake, I am so glad you got what you needed. As a moderator of the
                    list I must say it gives the very greatest satisfaction to think
                    that we have such knowledgeable and helpful people in the group.
                    I am only a few years ahead of you, and still groping around near
                    the bottom of the learning curve but I would still be trying to
                    warp images in PaintShop pro if it weren't for this list!

                    Roger W.

                    On Fri, 01 Dec 2006 17:07:07 +0900, Blake Michaelson
                    <blake.michaelson@...> wrote:

                    > Thank you all for the excellent information! I tore down my system
                    > (Canon 350D / Peleng 8mm / Panosaurus - for the next guy who searches
                    > for this issue) and set it all up once again (I have to admit that the
                    > link below to eppos.jpg was a nice simplistic approach to checking the
                    > alignment). I took another 4+1+2 (2 nadir opposed 180°), things
                    > stitched a little better, but not much different than before.
                    >
                    > However, I did have GREAT success with going into advanced mode of
                    > PTGui, selecting the Optimizer tab, keeping the Optimizer in simple
                    > mode, selecting optimize lens Field of View, and selecting Minimize lens
                    > distortion to "Heavy + lens shift", then ran the optimizer. I ended up
                    > with an average of 1.03, max of 2.47 and min 0.04 - significantly better
                    > points, and subsequently significantly better stitched panos! This
                    > almost completely eliminated the "nautilus" effect with regard to the
                    > unpatched nadir. I went back and restitched some panos I took prior to
                    > realigning my setup and they stitched just as precisely as well...
                    >
                    > Thanks for the all the continued assistance - I appreciate it
                    > tremendously!

                    --
                    Work: www.adex-japan.com
                    Play: www.usefilm.com/member/roger
                  Your message has been successfully submitted and would be delivered to recipients shortly.