Loading ...
Sorry, an error occurred while loading the content.

Re: [PanoToolsNG] Why don't manual control points change my Hugin pano?

Expand Messages
  • nathan@twcny.rr.com
    ... Bruno, Thanks for the reply. I don t think I was Aligning all the time. However, my problem still exists. Is it possible that my hand-held shots have
    Message 1 of 17 , Apr 4, 2009
    • 0 Attachment
      ---- Bruno Postle <bruno@...> wrote:
      > On Fri 03-Apr-2009 at 02:09 -0000, mrendo13039 wrote:
      > >
      > >Am I doing something wrong? If I add a bunch of new control
      > >points, shouldn't the panorama algorithms bend my pictures so that
      > >all those control points match up? It seems like my manual control
      > >points aren't doing anything at all.
      >
      > The process of fitting the images takes a few seconds, so it isn't
      > run automatically every time you change control points. You need to
      > go back to the Assistant tab and click Align...
      >

      Bruno,

      Thanks for the reply. I don't think I was "Aligning" all the time.

      However, my problem still exists. Is it possible that my hand-held shots have run into a limitation of the Pano Tools? I added three or four control point pairs to the problem spot (The skyline right in the middle of the pano), and still, the align stretches the left picture (or compresses the right picture) so the skyline does not match up. This is actually a 7 picture pano, and only this pair of pictures has the problem. I think I'm going to have to throw in the towel.

      http://www.flickr.com/photos/12220413@N06/3411192951/
    • Sacha Griffin
      Upload your photos somewhere. 7 photos shouldn’t take one of us more than 10 minutes to stitch/output and upload somewhere. The only problem you may have is
      Message 2 of 17 , Apr 4, 2009
      • 0 Attachment
        Upload your photos somewhere. 7 photos shouldn’t take one of us more than 10 minutes to stitch/output and upload somewhere.

        The only problem you may have is that your hand holding may not have been good enough. If you try to align the foreground objects that have parallax, that will cause the problems you are having.

        The technique here is to align the background objects, stitch, and then do some creative masking for your foreground parallax errors.





        Sacha Griffin

        Southern Digital Solutions LLC

        http://www.southern-digital.com

        http://www.seeit360.net

        GMAIL IM: sachagriffin007@...

        404-551-4275







        From: PanoToolsNG@yahoogroups.com [mailto:PanoToolsNG@yahoogroups.com] On Behalf Of nathan@...
        Sent: Saturday, April 04, 2009 10:59 AM
        To: PanoToolsNG@yahoogroups.com
        Cc: Bruno Postle
        Subject: Re: [PanoToolsNG] Why don't manual control points change my Hugin pano?



        .

        <http://geo.yahoo.com/serv?s=97359714/grpId=18227848/grpspId=1705006496/msgId=28066/stime=1238857203/nc1=5349275/nc2=5191952/nc3=5658267>





        [Non-text portions of this message have been removed]
      • Bruno Postle
        ... I suspect that you have one or more bad control points, you can find these in the Control Points table (F3 button) and delete them:
        Message 3 of 17 , Apr 4, 2009
        • 0 Attachment
          On Sat 04-Apr-2009 at 10:59 -0400, nathan@... wrote:
          >
          >However, my problem still exists. Is it possible that my hand-held
          >shots have run into a limitation of the Pano Tools? I added three
          >or four control point pairs to the problem spot (The skyline right
          >in the middle of the pano), and still, the align stretches the left
          >picture (or compresses the right picture) so the skyline does not
          >match up.

          I suspect that you have one or more 'bad' control points, you can
          find these in the Control Points table (F3 button) and delete them:

          http://wiki.panotools.org/Hugin_Control_Points_table

          --
          Bruno
        • nathan@twcny.rr.com
          ... Bruno, Thanks for the advice. It s really nice to get help from the author of such a great program! I took a look at my control points, besides the rogue
          Message 4 of 17 , Apr 4, 2009
          • 0 Attachment
            ---- Bruno Postle <bruno@...> wrote:
            > I suspect that you have one or more 'bad' control points, you can
            > find these in the Control Points table (F3 button) and delete them:
            >
            > http://wiki.panotools.org/Hugin_Control_Points_table


            Bruno,

            Thanks for the advice. It's really nice to get help from the author of such a great program!

            I took a look at my control points, besides the rogue pair (2000 pixel difference), all the auto points were well matched.

            However, when I put manual control points on the skyline (where my photos refuse to match up), the Control Points table told me they were way off. I beg to differ, though, as I found very distinctive features in the photos and they were definitely very good pairs.

            So, I decided maybe I needed to start from scratch. I removed all control points and made three manual ones - top, middle, and bottom.

            In the result, the right photo is extremely distorted, but the features between the two photos match up very well.

            So I have two questions:
            - How does the Control Points table decide what's a good match and what's a bad match? (In other words, what is "perfect alignment" versus "actual alignment achieved by the optimiser?"
            - What went wrong when I took these pictures?

            http://www.flickr.com/photos/12220413@N06/3413193982/

            thanks,
            nathan
          • John Houghton
            It will help if you read this short description of the optimization process: http://wiki.panotools.org/Optimization Your two images seem to be warped
            Message 5 of 17 , Apr 4, 2009
            • 0 Attachment
              It will help if you read this short description of the optimization process: http://wiki.panotools.org/Optimization

              Your two images seem to be warped differently, so they presumably are not sharing the same lens parameters despite being taken with the same lens. The images need to be exactly the same size and in the same orientation. If you add them to the project at the same time, they should then have the same lens parameters assigned and the images will be warped the same.

              John

              --- In PanoToolsNG@yahoogroups.com, <nathan@...> wrote:
              > So I have two questions:
              > - How does the Control Points table decide what's a good match and what's a bad match? (In other words, what is "perfect alignment" versus "actual alignment achieved by the optimiser?"
              > - What went wrong when I took these pictures?
              >
              > http://www.flickr.com/photos/12220413@N06/3413193982/
              >
              > thanks,
              > nathan
              >
            • Nate
              Sasha, Thanks for the information. I am pretty sure it is a parallax problem, but I ve never quite experienced something like this before and I ve stitched
              Message 6 of 17 , Apr 7, 2009
              • 0 Attachment
                Sasha,

                Thanks for the information. I am pretty sure it
                is a parallax problem, but I've never quite
                experienced something like this before and I've
                stitched together a bunch of panos that have objects in the foreground.

                I have uploaded all 8 photos to my Flickr
                site. It may be a pain in the butt to download
                them, but the problem pictures are Shenandoah 5, 6, and 7.

                http://www.flickr.com/photos/12220413@N06/sets/72157616341435740/


                I guess the "creating masking" in the foreground
                is the part that I have to work on. The only
                photo tools I use are Apple Aperture and Hugin - no Photoshop in my budget.

                Thanks for offering to help!

                nathan

                At 11:26 AM 4/4/2009, you wrote:

                >Upload your photos somewhere. 7 photos
                >shouldn’t take one of us more than 10 minutes
                >to stitch/output and upload somewhere.
                >
                >The only problem you may have is that your hand
                >holding may not have been good enough. If you
                >try to align the foreground objects that have
                >parallax, that will cause the problems you are having.
                >
                >The technique here is to align the background
                >objects, stitch, and then do some creative
                >masking for your foreground parallax errors.
                >
                >Sacha Griffin
                >
                >Southern Digital Solutions LLC
                >
                ><http://www.southern-digital.com>http://www.southern-digital.com
                >
                >http://www.seeit360.net
                >
                >GMAIL IM: <mailto:sachagriffin007%40gmail.com>sachagriffin007@...
                >
                >404-551-4275
                >
                >From:
                ><mailto:PanoToolsNG%40yahoogroups.com>PanoToolsNG@yahoogroups.com
                >[mailto:PanoToolsNG@yahoogroups.com] On Behalf
                >Of <mailto:nathan%40twcny.rr.com>nathan@...
                >Sent: Saturday, April 04, 2009 10:59 AM
                >To: <mailto:PanoToolsNG%40yahoogroups.com>PanoToolsNG@yahoogroups.com
                >Cc: Bruno Postle
                >Subject: Re: [PanoToolsNG] Why don't manual
                >control points change my Hugin pano?
                >
                >.
                >
                ><<http://geo.yahoo.com/serv?s=97359714/grpId=18227848/grpspId=1705006496/msgId=28066/stime=1238857203/nc1=5349275/nc2=5191952/nc3=5658267>http://geo.yahoo.com/serv?s=97359714/grpId=18227848/grpspId=1705006496/msgId=28066/stime=1238857203/nc1=5349275/nc2=5191952/nc3=5658267>
                >
                >
                >[Non-text portions of this message have been removed]
                >
                >


                [Non-text portions of this message have been removed]
              • Nate
                John, Thanks for pointing me to that page. I do have a question about the lens parameters. I used the same camera for all 8 photos, and I add them in one
                Message 7 of 17 , Apr 7, 2009
                • 0 Attachment
                  John,

                  Thanks for pointing me to that page.

                  I do have a question about the lens parameters.

                  I used the same camera for all 8 photos, and I add them in one
                  operation to my Hugin project.

                  However, according to the "Camera and lens" tab of Hugin, I have four
                  lenses, and each "lens" has a higher horizontal field of view than the other:

                  photo 1: lens 0
                  photo 2: lens 0
                  photo 3: lens 0
                  photo 4: lens 1
                  photo 5: lens 1 (Photo 5 and 6 do not match up)
                  photo 6: lens 2
                  photo 7: lens 2
                  photo 8: lens 3


                  I'm getting the idea that it's because I have a zoom lens and a
                  variable focal length. I just checked my EXIF data, and I have a
                  different focal length that falls in line with my "four" lenses.

                  Do you know what this means, considering your comment that they
                  should have the same lens parameters assigned?

                  thanks,
                  nathan

                  At 02:40 AM 4/5/2009, you wrote:

                  >It will help if you read this short description of the optimization
                  >process:
                  ><http://wiki.panotools.org/Optimization>http://wiki.panotools.org/Optimization
                  >
                  >Your two images seem to be warped differently, so they presumably
                  >are not sharing the same lens parameters despite being taken with
                  >the same lens. The images need to be exactly the same size and in
                  >the same orientation. If you add them to the project at the same
                  >time, they should then have the same lens parameters assigned and
                  >the images will be warped the same.
                  >
                  >John
                  >
                  >--- In
                  ><mailto:PanoToolsNG%40yahoogroups.com>PanoToolsNG@yahoogroups.com,
                  ><nathan@...> wrote:
                  > > So I have two questions:
                  > > - How does the Control Points table decide what's a good match
                  > and what's a bad match? (In other words, what is "perfect
                  > alignment" versus "actual alignment achieved by the optimiser?"
                  > > - What went wrong when I took these pictures?
                  > >
                  > >
                  > <http://www.flickr.com/photos/12220413@N06/3413193982/>http://www.flickr.com/photos/12220413@N06/3413193982/
                  > >
                  > > thanks,
                  > > nathan
                  > >
                  >
                  >


                  [Non-text portions of this message have been removed]
                • paul womack
                  ... Nor mine. http://www.gimp.org/ http://www.gimp.org/macintosh/ BugBear
                  Message 8 of 17 , Apr 8, 2009
                  • 0 Attachment
                    Nate wrote:
                    > The only
                    > photo tools I use are Apple Aperture and Hugin - no Photoshop in my budget.

                    Nor mine.

                    http://www.gimp.org/
                    http://www.gimp.org/macintosh/


                    BugBear
                  • paul womack
                    ... I downloaded all 8 (no EXIF), which was slightly tedious, but not too bad. I used a 30mm figure for lens. I have manually added control points, which was
                    Message 9 of 17 , Apr 8, 2009
                    • 0 Attachment
                      Nate wrote:
                      > Sasha,
                      >
                      > Thanks for the information. I am pretty sure it
                      > is a parallax problem, but I've never quite
                      > experienced something like this before and I've
                      > stitched together a bunch of panos that have objects in the foreground.
                      >
                      > I have uploaded all 8 photos to my Flickr
                      > site. It may be a pain in the butt to download
                      > them, but the problem pictures are Shenandoah 5, 6, and 7.

                      I downloaded all 8 (no EXIF), which was slightly tedious,
                      but not too bad.

                      I used a 30mm figure for lens.

                      I have manually added control points, which was difficult;
                      the images have very few "obvious" reference points,
                      and have insufficient overlap.

                      I did a minimal optimise (only positions, starting from anchor,
                      with the anchor on the fourth image).

                      After removing "bad" control points (I had created one totally
                      wrong pair), the average error was 1.5, with a maximum of 7.3.

                      I then did an exposure optimise.

                      I then previewed, centred, and straightened.

                      I then saved the result, and have uploaded it to photobucket:

                      http://i48.photobucket.com/albums/f234/bugbear33/photo_tech/final-1.jpg

                      I strongly suspect, given the trouble I had MANUALLY creating
                      control points, that the automatic points were very poor indeed.

                      BugBear
                    • Nate
                      Bugbear, ... I had no idea Flickr would strip off the EXIF data. It s interesting that Flickr provides some photo data through their web interface, but
                      Message 10 of 17 , Apr 8, 2009
                      • 0 Attachment
                        Bugbear,

                        >I downloaded all 8 (no EXIF), which was slightly tedious,
                        >but not too bad.

                        I had no idea Flickr would strip off the EXIF data. It's interesting
                        that Flickr provides some photo data through their web interface, but
                        doesn't provide it after downloading.

                        >I used a 30mm figure for lens.
                        >
                        >I have manually added control points, which was difficult;
                        >the images have very few "obvious" reference points,
                        >and have insufficient overlap.

                        Hmmm. Insufficient overlap -- that is definitely a good remark. And
                        yes, there aren't a lot of obvious reference points; zooming in
                        allowed me to find a lot of particular trees or shadow transitions.

                        >I did a minimal optimise (only positions, starting from anchor,
                        >with the anchor on the fourth image).
                        >
                        >After removing "bad" control points (I had created one totally
                        >wrong pair), the average error was 1.5, with a maximum of 7.3.
                        >
                        >I then did an exposure optimise.
                        >
                        >I then previewed, centred, and straightened.
                        >
                        >I then saved the result, and have uploaded it to photobucket:
                        >
                        ><http://i48.photobucket.com/albums/f234/bugbear33/photo_tech/final-1.jpg>http://i48.photobucket.com/albums/f234/bugbear33/photo_tech/final-1.jpg
                        >
                        >I strongly suspect, given the trouble I had MANUALLY creating
                        >control points, that the automatic points were very poor indeed.

                        Thanks for your help. I really appreciate you taking the time to
                        look through my pictures and tell me how to do things a better.

                        I am going to try doing a manual pano on my own by going through the
                        steps that you did. Hopefully I can achieve the same results. (Of
                        course, I'll have to do better at overlapping my photos in the future.)

                        nathan

                        [Non-text portions of this message have been removed]
                      • Hans Nyberg
                        ... It is not Flickr that strips of the EXIF. It is the way you download it. I had no problem reading the EXIF after downloading them with Safari. The most
                        Message 11 of 17 , Apr 9, 2009
                        • 0 Attachment
                          --- In PanoToolsNG@yahoogroups.com, Nate <nathan@...> wrote:
                          >
                          > Bugbear,
                          >
                          > >I downloaded all 8 (no EXIF), which was slightly tedious,
                          > >but not too bad.
                          >
                          > I had no idea Flickr would strip off the EXIF data. It's interesting
                          > that Flickr provides some photo data through their web interface, but
                          > doesn't provide it after downloading.

                          It is not Flickr that strips of the EXIF. It is the way you download it.
                          I had no problem reading the EXIF after downloading them with Safari.

                          The most important for you is to make sure you do not use the zoom ring while shooting the pano. I do not know how Hugin handles this but I assume that if Hugin reads EXIF it will just do it on the first pano.

                          After adding individual lensdata for img 4-7 in PTGUI it had no problem stitching it. PTGui generated hundreds of automatic conntrolpoints.

                          Hans
                        • paul womack
                          ... I think we must have download different images (image sizes); I *had* exif, but not the right kind: ExifTool Version Number : 7.43 File Name
                          Message 12 of 17 , Apr 9, 2009
                          • 0 Attachment
                            Hans Nyberg wrote:
                            > --- In PanoToolsNG@yahoogroups.com, Nate <nathan@...> wrote:
                            >> Bugbear,
                            >>
                            >>> I downloaded all 8 (no EXIF), which was slightly tedious,
                            >>> but not too bad.
                            >> I had no idea Flickr would strip off the EXIF data. It's interesting
                            >> that Flickr provides some photo data through their web interface, but
                            >> doesn't provide it after downloading.
                            >
                            > It is not Flickr that strips of the EXIF. It is the way you download it.
                            > I had no problem reading the EXIF after downloading them with Safari.

                            I think we must have download different images (image sizes);
                            I *had* exif, but not the "right" kind:

                            ExifTool Version Number : 7.43
                            File Name : 1.jpg
                            Directory : .
                            File Size : 413 kB
                            File Modification Date/Time : 2009:04:08 09:56:14+01:00
                            File Type : JPEG
                            MIME Type : image/jpeg
                            JFIF Version : 1.01
                            Resolution Unit : inches
                            X Resolution : 72
                            Y Resolution : 72
                            Profile CMM Type : appl
                            Profile Version : 2.2.0
                            Profile Class : Display Device Profile
                            Color Space Data : RGB
                            Profile Connection Space : XYZ
                            Profile Date Time : 2000:08:13 16:06:07
                            Profile File Signature : acsp
                            Primary Platform : Apple Computer Inc.
                            CMM Flags : Not Embedded, Independent
                            Device Manufacturer : appl
                            Device Model :
                            Device Attributes : Reflective, Glossy, Positive, Color
                            Rendering Intent : Media-Relative Colorimetric
                            Connection Space Illuminant : 0.9642 1 0.82491
                            Profile Creator : appl
                            Profile ID : 0
                            Profile Copyright : Copyright 1998 - 2003 Apple Computer Inc., all rights reserved.
                            Profile Description : sRGB Profile
                            Media White Point : 0.95045 1 1.08905
                            Red Tone Reproduction Curve : (Binary data 14 bytes, use -b option to extract)
                            Green Tone Reproduction Curve : (Binary data 14 bytes, use -b option to extract)
                            Blue Tone Reproduction Curve : (Binary data 14 bytes, use -b option to extract)
                            Red Matrix Column : 0.43607 0.22249 0.01392
                            Green Matrix Column : 0.38515 0.71687 0.09708
                            Blue Matrix Column : 0.14307 0.06061 0.7141
                            Video Card Gamma : (Binary data 48 bytes, use -b option to extract)
                            Chromatic Adaptation : 1.04788 0.02292 -0.0502 0.02959 0.99048 -0.01706 -0.00923 0.01508 0.75168
                            Profile Description ML : sRGB Profile
                            Image Width : 682
                            Image Height : 1024
                            Encoding Process : Baseline DCT, Huffman coding
                            Bits Per Sample : 8
                            Color Components : 3
                            Y Cb Cr Sub Sampling : YCbCr4:4:4 (1 1)
                            Image Size : 682x1024


                            BugBear
                          • paul womack
                            ... This is interesting. In the interests of symmetry, I followed the procedure you did - automatic all the way. After 3 (I think) cycles of optimising,
                            Message 13 of 17 , Apr 9, 2009
                            • 0 Attachment
                              Nate wrote:
                              > Bugbear,
                              > Thanks for your help. I really appreciate you taking the time to
                              > look through my pictures and tell me how to do things a better.
                              >
                              > I am going to try doing a manual pano on my own by going through the
                              > steps that you did. Hopefully I can achieve the same results. (Of
                              > course, I'll have to do better at overlapping my photos in the future.)

                              This is interesting. In the interests of symmetry, I followed
                              the procedure you did - automatic all the way.

                              After 3 (I think) cycles of optimising, removing the "bad" control
                              points, optimise again, the result was still a little poor,
                              especially at the 4-5 join (numbers as per hugin GUI).

                              All the control points look quite credible, so I don't quite understand.

                              Furthermore, going back to the hand done sample I posted,
                              viewing it in difference mode (in the hugin preview) reveals
                              it to be far from perfect.

                              This is most likely because, lacking overlap, I just can't get enough
                              control points to optimise enough parameters for a good result.

                              BugBear
                            • paul womack
                              ... In a bid to see how good a job I could do, I faked in the different lens lengths via the camera+lens dialog, added as many manual control points as my
                              Message 14 of 17 , Apr 9, 2009
                              • 0 Attachment
                                paul womack wrote:
                                > I then saved the result, and have uploaded it to photobucket:
                                >
                                > http://i48.photobucket.com/albums/f234/bugbear33/photo_tech/final-1.jpg

                                In a bid to see how good a job I could do, I faked in the different lens
                                lengths via the camera+lens dialog, added as many manual control points
                                as my patience would allow, and then let the optimiser loose on
                                positions, view and barrel.

                                This carries the risk of "false" optimisation, where the optimiser
                                (mis)configures a lens to force the panorama to fit.

                                In this case, it's probably a good thing, but I certainly wouldn't
                                use the resulting lens "calibration" on another project.

                                The resulting pano, in difference mode is:

                                http://i48.photobucket.com/albums/f234/bugbear33/photo_tech/final2.jpg

                                I suspect a blended stitch would be quite acceptable.

                                BugBear
                              • John Houghton
                                ... You are making things unnecessarily complicated if you don t use the same zoom setting for all the shots. You have effectively used 4 different lenses in
                                Message 15 of 17 , Apr 9, 2009
                                • 0 Attachment
                                  --- In PanoToolsNG@yahoogroups.com, Nate <nathan@...> wrote:
                                  >
                                  > I'm getting the idea that it's because I have a zoom lens and a
                                  > variable focal length. I just checked my EXIF data, and I have a
                                  > different focal length that falls in line with my "four" lenses.

                                  You are making things unnecessarily complicated if you don't use the same zoom setting for all the shots. You have effectively used 4 different lenses in your case, and consequently 4 sets of lens parameters need to be evaluated by the optimizer. You need a lot of well spread control points to do this effectively, which may not be possible with your images.

                                  When you can't assign many control points, it's best to use calibrated lens parameters that have been evaluated in a special project shot in a carefully chosen venue that facilitates the assignment of control points.

                                  John
                                Your message has been successfully submitted and would be delivered to recipients shortly.