Loading ...
Sorry, an error occurred while loading the content.

PREFEAT

Expand Messages
  • Chris McLaughlin
    Can PREFEAT be used to check that a FEAT has not been chosen and then allow that FEAT to be chosen? Example1: PC has FEAT:Foo1 PC is then not able to select
    Message 1 of 8 , Jan 3, 2005
    • 0 Attachment
      Can PREFEAT be used to check that a FEAT has not been chosen and then allow
      that FEAT to be chosen?



      Example1:

      PC has FEAT:Foo1

      PC is then not able to select FEAT:Foo2 as the PC as FEAT:Foo1



      I tried:

      Foo2 PREFEAT:1,[Foo1]

      This didn't work; (it seems to require a FEAT rather than NOT a FEAT.)



      Any ideas/help



      Thanks,

      Chris



      [Non-text portions of this message have been removed]
    • thoron-tir-gwaith@lycos.com
      ... That won t work, at least by my haven t had second cup of coffee logic. Little variance in how the logic is read.. The way (and LST standard way, since it
      Message 2 of 8 , Jan 3, 2005
      • 0 Attachment
        > Foo2 PREFEAT:1,[Foo1]
        >
        > This didn't work; (it seems to require a FEAT rather than NOT a FEAT.)

        That won't work, at least by my haven't had second cup of coffee logic. Little variance in how the logic is read..

        The way (and LST standard way, since it is more correct) to write that is
        Foo2 !PREFEAT:1,Foo1

        Note the ! meaning NOT at the beginning. That reads "Can't meet the following: 1 Feat named Foo1"

        What PCGen is seeing that as: PREFEAT:1,[Foo1] "Any One feat from the following list, but not including Foo1" and then no list....

        Using [ ] for NOT in a PRExxx is best used when you want to do something like

        PREFEAT:1,TYPE=Metamagic,[Empower Spell]
        (which reads) "Any One Metamagic feat, not including Empower Spell"

        If I don't have it right, I hope Frugal or someone else will correct me. It's still early yet, and I'm in the middle of "holiday pricing removal" for thousands of items.

        Tir Gwaith
        LST Chimp
      • tir_gwaith
        SPELLLIST:1|Wizard should get you the list, with no options shown (should work behind the scenes). Check the spell tab on that one and see if you get the
        Message 3 of 8 , Jan 4, 2005
        • 0 Attachment
          SPELLLIST:1|Wizard should get you the list, with no options shown
          (should work behind the scenes). Check the spell tab on that one and
          see if you get the spells in the potential to know spells area
          (left). Also, I'd try it using the latest Beta.

          If it isn't, then that's a bug.

          Tir Gwaith
          LST Chimp

          --- In PCGenListFileHelp@yahoogroups.com, Glen Murie <gmurie@n...>
          wrote:
          > Hello again, I'm working my way through the IK list files. I've run
          into
          > what looks like a bug. I'm using pcgen 5.7.11
          >
          > Here's the line for a class called the Arcane Mechanik for Iron
          > Kingdoms. His casts are different at each level, but he uses
          exactly the
          > same spell list as the Wizard, so I've been trying to use SPELLLIST
          to
          > make that happen, rather than creating a .MOD for all those spells!
          >
          > However, I have it exactly as described in the documentation and I
          get a
          > prompt to select the caster type from PCGEN with 0 options allowed
          to
          > me. This is how I have it now.
          >
          > CLASS:Arcane Mechanik SPELLSTAT:INT SPELLTYPE:Arcane
          > MEMORIZE:YES BONUS:CASTERLEVEL|Arcane Mechanik|CL
          SPELLLIST:Wizard
          >
          > Trying it like the following gives me no spellcasting options at
          all.
          > Please help, thanks!
          >
          > CLASS:Arcane Mechanik SPELLSTAT:INT SPELLTYPE:Arcane
          > MEMORIZE:YES BONUS:CASTERLEVEL|Arcane Mechanik|CL
          > SPELLLIST:1|Wizard
        • Evan Miller
          To for a not condition, the PRExxx statement should be preceeded by a !. So in your case: Foo2 !PREFEAT:1,Foo1 Evan ... From: Chris McLaughlin
          Message 4 of 8 , Jan 4, 2005
          • 0 Attachment
            To for a not condition, the PRExxx statement should be preceeded by a !. So
            in your case:

            Foo2 !PREFEAT:1,Foo1

            Evan

            ----- Original Message -----
            From: "Chris McLaughlin" <kilthar@...>
            To: <PCGenListFileHelp@yahoogroups.com>
            Sent: Tuesday, January 04, 2005 12:43 AM
            Subject: [PCGenListFileHelp] PREFEAT


            >
            > Can PREFEAT be used to check that a FEAT has not been chosen and then
            > allow
            > that FEAT to be chosen?
            >
            >
            >
            > Example1:
            >
            > PC has FEAT:Foo1
            >
            > PC is then not able to select FEAT:Foo2 as the PC as FEAT:Foo1
            >
            >
            >
            > I tried:
            >
            > Foo2 PREFEAT:1,[Foo1]
            >
            > This didn't work; (it seems to require a FEAT rather than NOT a FEAT.)
            >
            >
            >
            > Any ideas/help
            >
            >
            >
            > Thanks,
            >
            > Chris
            >
            >
            >
            > [Non-text portions of this message have been removed]
            >
            >
            >
            >
            > Yahoo! Groups Links
            >
            >
            >
            >
            >
            >
            >
            >
          • Glen Murie
            ... There s a bug, which I d have known if I d bothered to check on sourceforge. Sorry.
            Message 5 of 8 , Jan 4, 2005
            • 0 Attachment
              tir_gwaith wrote:

              >SPELLLIST:1|Wizard should get you the list, with no options shown
              >(should work behind the scenes). Check the spell tab on that one and
              >see if you get the spells in the potential to know spells area
              >(left). Also, I'd try it using the latest Beta.
              >
              >If it isn't, then that's a bug.
              >
              >
              >
              There's a bug, which I'd have known if I'd bothered to check on
              sourceforge. Sorry.

              http://sourceforge.net/tracker/index.php?func=detail&aid=1018777&group_id=25576&atid=384719


              --
              No virus found in this outgoing message.
              Checked by AVG Anti-Virus.
              Version: 7.0.298 / Virus Database: 265.6.7 - Release Date: 12/30/2004
            • Chris McLaughlin
              Thanks, that worked!! Chris ... That won t work, at least by my haven t had second cup of coffee logic. Little variance in how the logic is read.. The way (and
              Message 6 of 8 , Jan 4, 2005
              • 0 Attachment
                Thanks, that worked!!



                Chris



                > Foo2 PREFEAT:1,[Foo1]
                >
                > This didn't work; (it seems to require a FEAT rather than NOT a FEAT.)

                That won't work, at least by my haven't had second cup of coffee logic.
                Little variance in how the logic is read..

                The way (and LST standard way, since it is more correct) to write that is
                Foo2 !PREFEAT:1,Foo1

                Note the ! meaning NOT at the beginning. That reads "Can't meet the
                following: 1 Feat named Foo1"

                What PCGen is seeing that as: PREFEAT:1,[Foo1] "Any One feat from the
                following list, but not including Foo1" and then no list....

                Using [ ] for NOT in a PRExxx is best used when you want to do something
                like

                PREFEAT:1,TYPE=Metamagic,[Empower Spell]
                (which reads) "Any One Metamagic feat, not including Empower Spell"

                If I don't have it right, I hope Frugal or someone else will correct me.
                It's still early yet, and I'm in the middle of "holiday pricing removal" for
                thousands of items.

                Tir Gwaith
                LST Chimp





                [Non-text portions of this message have been removed]
              • Chris McLaughlin
                Thanks, that worked!! Chris To for a not condition, the PRExxx statement should be preceeded by a !. So in your case: Foo2 !PREFEAT:1,Foo1 Evan [Non-text
                Message 7 of 8 , Jan 4, 2005
                • 0 Attachment
                  Thanks, that worked!!



                  Chris



                  To for a not condition, the PRExxx statement should be preceeded by a !. So

                  in your case:

                  Foo2 !PREFEAT:1,Foo1

                  Evan






                  [Non-text portions of this message have been removed]
                Your message has been successfully submitted and would be delivered to recipients shortly.