Loading ...
Sorry, an error occurred while loading the content.

[Green Ronin] [Testament] Apology

Expand Messages
  • Paul W. King
    All, It has been brought to my attention that my questions/comments/trackers relating to this source have been offensive to some. This was not my intent, and
    Message 1 of 6 , Sep 2, 2003
    • 0 Attachment
      All,

      It has been brought to my attention that my questions/comments/trackers
      relating to this source have been offensive to some. This was not my
      intent, and for that, I do apologize.

      Paul W. King
      OGL SB and BoD
    • Brass Tilde
      OK, maybe I haven t been paying attention, and this has come through before, but I get the following errors in the debug window when loading just the PHB
      Message 2 of 6 , Sep 4, 2003
      • 0 Attachment
        OK, maybe I haven't been paying attention, and this has come through before,
        but I get the following errors in the debug window when loading just the PHB
        portion of the SRD (i.e. Wizards of the Coast->Core Rules->Core->WotC - DnD
        Core Rulebook I - PHB):

        Could not parse token TYPE=MELEE from bonusInfo
        TYPE=MELEE,TYPE=THROWN in BonusObj.newBonus.
        Could not parse token TYPE=THROWN from bonusInfo
        TYPE=MELEE,TYPE=THROWN in BonusObj.newBonus.
        Could not parse token WOUNDPOINTS from bonusInfo WOUNDPOINTS in
        BonusObj.newBonus.

        The kicker is, I could not find those strings anywhere in any of the LST
        files in the SRD directory.

        This is with 5.3.7, an brand new fresh installation, with no INI files
        present, and no custom sources anywhere that I can find. I hadn't gotten to
        loading a character yet. I found this in the course of trying to track down
        an error in one of my custom sources, so I started over fresh without them.

        Is this a LST problem, or a code problem?

        Thanks.
      • tir_gwaith
        One word: WEIRD. That is a clean install, on 5.3.7, using only the PHB dataset? My first inclination is disbelief, no offense. Can anyone reproduce it? I m
        Message 3 of 6 , Sep 4, 2003
        • 0 Attachment
          One word: WEIRD.

          That is a clean install, on 5.3.7, using only the PHB dataset? My
          first inclination is disbelief, no offense. Can anyone reproduce
          it? I'm having a hard time figuring out where that kind of error
          statement could come from if it isn't in the data to cause it to
          happen. *baffled monkey bangs on keyboard, messing up a nice 'Alas,
          poor Yorick' monologue.*

          TYPE=RANGED is in some halfling entries, but I don't remember a
          TYPE=MELEE ever mentioned in the PHB dataset, and I don't think it
          is in the the SRD anywhere. I have a mess of a CVS sitting open on
          my puter I'm avoiding to get a fresh look at Monks and Boots of
          Striding later today or tomorrow, so I can't rely on that (or I'd
          double check).

          However, I _KNOW_ (ie, would place money on) there is no reference
          of WOUNDPOINTS in the the current SRD files. WOUNDPOINTS hardcoding
          was removed a long while back, anyway (you can technically call
          those alternate HP systems whatever you want; it is defined in the
          GameMode miscinfo.lst, but the DnD game mode doesn't have an
          alternate hp defined.)

          I'd say we have some code parts not talking to each other totally,
          if this is happening from a fresh install of the SRD.... It would
          take a CM of Jayme/Byngl/Bryan quality to figure out that. Jayme
          recently did some work on Bonus code, so he might be able to find
          out what is going on the fastest.

          Tir Gwaith
          PCGen Data SB and BoD
        • Brass Tilde
          Crossposted from PCGenListFileHelp. Quotes are from Tir. ... I agree. ... None taken. It was mine as well. Note that this doesn t appear to affect PCGen s
          Message 4 of 6 , Sep 4, 2003
          • 0 Attachment
            Crossposted from PCGenListFileHelp. Quotes are from Tir.

            > One word: WEIRD.

            I agree.

            > That is a clean install, on 5.3.7, using only the PHB dataset? My
            > first inclination is disbelief, no offense.

            None taken. It was mine as well. Note that this doesn't appear to affect
            PCGen's operation; I just stumbled upon it when I was tracking down a bug in
            some of my stuff. I thought those messages were coming from one of my
            sources, but those are not even on the drive now.

            After examining my INI file to make sure that I'm not referencing any other
            paths on the drive, and the PCC that I'm loading to make sure that *it*
            isn't referencing any other paths, I deleted all other versions of PCGen on
            that drive.

            With the latest alpha jar (5.3.7-autobuild-200309042314) that I downloaded
            (though still with the 5.3.7 beta data), I even went so far as to delete all
            sources except for the ones in "data\d20ogl\srd", so there's nothing else
            there.

            I got even more "could not parse" errors.

            Could not parse token TYPE=MELEE from bonusInfo TYPE=MELEE in
            BonusObj.newBonus.
            Could not parse token TYPE=MELEE from bonusInfo TYPE=MELEE,TYPE=THROWN in
            BonusObj.newBonus.
            Could not parse token TYPE=THROWN from bonusInfo TYPE=MELEE,TYPE=THROWN in
            BonusObj.newBonus.
            Could not parse token TYPE=GRAPPLE from bonusInfo TYPE=GRAPPLE in
            BonusObj.newBonus.
            Could not parse token TYPE=RANGED from bonusInfo TYPE=RANGED in
            BonusObj.newBonus.
            Could not parse token WOUNDPOINTS from bonusInfo WOUNDPOINTS in
            BonusObj.newBonus.
            Could not parse token TYPE=THROWN from bonusInfo TYPE=THROWN in
            BonusObj.newBonus.

            So I downloaded the data that matches the alpha jar that I'm using and
            extracted only the SRD data.

            Same result as above.


            > However, I _KNOW_ (ie, would place money on) there is no reference
            > of WOUNDPOINTS in the the current SRD files.

            You'd win. The first thing I did was to search for those in the SRD list
            files. I found no occurances of either TYPE=MELEE or WOUNDPOINTS.

            > I'd say we have some code parts not talking to each other totally,
            > if this is happening from a fresh install of the SRD.... It would
            > take a CM of Jayme/Byngl/Bryan quality to figure out that.

            Well then, I'll crosspost it to the main list with BUG in the title.
          • David
            ... Here is the debug console from a clean install, no preferences set, only PHB loaded. Where do I put the Tracker? -- david (aka Papa-DRB)
            Message 5 of 6 , Sep 4, 2003
            • 0 Attachment
              --- In PCGenListFileHelp@yahoogroups.com, "tir_gwaith" <thoron-tir-
              gwaith@l...> wrote:
              > One word: WEIRD.

              Here is the debug console from a clean install, no preferences set,
              only PHB loaded. Where do I put the Tracker?

              -- david (aka Papa-DRB)

              ====================================
              -- listing properties --
              java.runtime.name=Java(TM) 2 Runtime Environment, Stand...
              sun.boot.library.path=C:\PROGRAM FILES\JAVA\J2RE1.4.1_02\bin
              java.vm.version=1.4.1_02-b06
              java.vm.vendor=Sun Microsystems Inc.
              java.vendor.url=http://java.sun.com/
              path.separator=;
              java.vm.name=Java HotSpot(TM) Client VM
              file.encoding.pkg=sun.io
              user.country=US
              sun.os.patch.level= A
              java.vm.specification.name=Java Virtual Machine Specification
              user.dir=C:\My Documents\My Download Files\pcgen
              java.runtime.version=1.4.1_02-b06
              java.awt.graphicsenv=sun.awt.Win32GraphicsEnvironment
              java.endorsed.dirs=C:\PROGRAM FILES\JAVA\J2RE1.4.1_02\li...
              os.arch=x86
              java.io.tmpdir=c:\windows\TEMP\
              line.separator=


              java.vm.specification.vendor=Sun Microsystems Inc.
              user.variant=
              os.name=Windows 98
              sun.java2d.fontpath=
              java.library.path=C:\WINDOWS;.;C:\WINDOWS\SYSTEM;C:\WIN...
              java.specification.name=Java Platform API Specification
              java.class.version=48.0
              java.util.prefs.PreferencesFactory=java.util.prefs.WindowsPreferencesF
              ac...
              os.version=4.10
              user.home=C:\WINDOWS
              user.timezone=
              java.awt.printerjob=sun.awt.windows.WPrinterJob
              file.encoding=Cp1252
              java.specification.version=1.4
              user.name=David
              java.class.path=pcgen.jar
              java.vm.specification.version=1.0
              sun.arch.data.model=32
              java.home=C:\PROGRAM FILES\JAVA\J2RE1.4.1_02
              java.specification.vendor=Sun Microsystems Inc.
              user.language=en
              awt.toolkit=sun.awt.windows.WToolkit
              java.vm.info=mixed mode
              java.version=1.4.1_02
              java.ext.dirs=C:\PROGRAM FILES\JAVA\J2RE1.4.1_02\li...
              sun.boot.class.path=C:\PROGRAM FILES\JAVA\J2RE1.4.1_02\li...
              java.vendor=Sun Microsystems Inc.
              file.separator=\
              java.vendor.url.bug=http://java.sun.com/cgi-bin/bugreport...
              sun.cpu.endian=little
              sun.io.unicode.encoding=UnicodeLittle
              sun.cpu.isalist=pentium i486 i386
              PCGen version:5.3.7-autobuild-200309042314
              Could not parse token TYPE=MELEE from bonusInfo TYPE=MELEE in
              BonusObj.newBonus.
              Could not parse token TYPE=MELEE from bonusInfo
              TYPE=MELEE,TYPE=THROWN in BonusObj.newBonus.
              Could not parse token TYPE=THROWN from bonusInfo
              TYPE=MELEE,TYPE=THROWN in BonusObj.newBonus.
              Could not parse token TYPE=GRAPPLE from bonusInfo TYPE=GRAPPLE in
              BonusObj.newBonus.
              Could not parse token TYPE=RANGED from bonusInfo TYPE=RANGED in
              BonusObj.newBonus.
              Could not parse token WOUNDPOINTS from bonusInfo WOUNDPOINTS in
              BonusObj.newBonus.
              Could not parse token TYPE=THROWN from bonusInfo TYPE=THROWN in
              BonusObj.newBonus.
              Number of objects loaded. The following should all be greater than 0:
              Races=25
              Classes=19
              Skills=102
              Feats=116
              Equipment=398
              WeaponProfs=83
              Number of objects loaded. The following should all be greater than 0:
              Races=25
              Classes=19
              Skills=102
              Feats=116
              Equipment=398
              WeaponProfs=83
            • Martijn Verburg (DSLWN)
              Hi All, This is a known issue in that . are being converted to = and visa-versa where appropriate. I believe Jayme Cox, Tir and Hetter are working on
              Message 6 of 6 , Sep 6, 2003
              • 0 Attachment

                Hi All,

                 

                This is a known issue in that '.' are being converted to '=' and visa-versa where appropriate.  I believe Jayme Cox, Tir and Hetter are working on completing this.

                 

                K

                TM SB

                 

                -----Original Message-----
                From: Brass Tilde [mailto:brasstilde@...]
                Sent:
                Friday, 5 September 2003 12:43 p.m.
                To: PCGenListFileHelp@yahoogroups.com; pcgen@yahoogroups.com
                Subject: [PCGenListFileHelp] RE: [BUG] List load errors

                 

                Crossposted from PCGenListFileHelp.  Quotes are from Tir.

                > One word:  WEIRD.

                I agree.

                > That is a clean install, on 5.3.7, using only the PHB dataset?  My
                > first inclination is disbelief, no offense. 

                None taken.  It was mine as well.  Note that this doesn't appear to affect
                PCGen's operation; I just stumbled upon it when I was tracking down a bug in
                some of my stuff.  I thought those messages were coming from one of my
                sources, but those are not even on the drive now.

                After examining my INI file to make sure that I'm not referencing any other
                paths on the drive, and the PCC that I'm loading to make sure that *it*
                isn't referencing any other paths, I deleted all other versions of PCGen on
                that drive.

                With the latest alpha jar (5.3.7-autobuild-200309042314) that I downloaded
                (though still with the 5.3.7 beta data), I even went so far as to delete all
                sources except for the ones in "data\d20ogl\srd", so there's nothing else
                there.

                I got even more "could not parse" errors.

                Could not parse token TYPE=MELEE from bonusInfo TYPE=MELEE in
                BonusObj.newBonus.
                Could not parse token TYPE=MELEE from bonusInfo TYPE=MELEE,TYPE=THROWN in
                BonusObj.newBonus.
                Could not parse token TYPE=THROWN from bonusInfo TYPE=MELEE,TYPE=THROWN in
                BonusObj.newBonus.
                Could not parse token TYPE=GRAPPLE from bonusInfo TYPE=GRAPPLE in
                BonusObj.newBonus.
                Could not parse token TYPE=RANGED from bonusInfo TYPE=RANGED in
                BonusObj.newBonus.
                Could not parse token WOUNDPOINTS from bonusInfo WOUNDPOINTS in
                BonusObj.newBonus.
                Could not parse token TYPE=THROWN from bonusInfo TYPE=THROWN in
                BonusObj.newBonus.

                So I downloaded the data that matches the alpha jar that I'm using and
                extracted only the SRD data.

                Same result as above.


                > However, I _KNOW_ (ie, would place money on) there is no reference
                > of WOUNDPOINTS in the the current SRD files. 

                You'd win.  The first thing I did was to search for those in the SRD list
                files.  I found no occurances of either TYPE=MELEE or WOUNDPOINTS.

                > I'd say we have some code parts not talking to each other totally,
                > if this is happening from a fresh install of the SRD....  It would
                > take a CM of Jayme/Byngl/Bryan quality to figure out that. 

                Well then, I'll crosspost it to the main list with BUG in the title.



                 

              Your message has been successfully submitted and would be delivered to recipients shortly.