Loading ...
Sorry, an error occurred while loading the content.

Special material

Expand Messages
  • billybrpwned
    I have a homebrew special material that increases the crit range by one, which is handled simply enough by BONUS:EQMWEAPON|CRITRANGEADD|1|TYPE=NonStackingCrit,
    Message 1 of 4 , Sep 23, 2013
    • 0 Attachment
      I have a homebrew special material that increases the crit range by one, which is handled simply enough by BONUS:EQMWEAPON|CRITRANGEADD|1|TYPE=NonStackingCrit, but I didn't want it to stack with either keen or improved critical.  by default it does, so I .MODed keen such that it didn't allow black glass weapons, and wrote a keen that added BONUS:EQMWEAPON|CRITRANGEADD|-1|TYPE=NonStackingCrit, to the end, ugly but it worked.  now I'm stuck on improved critical.  I tried to modify improved critical such that it added a -1 to any black glass item of the specified type by BONUS:AUTO:WEAPONPROF=%LIST.Blackglass|CRITRANGEADD|-1|TYPE=NonStackingCrit


      and that doesnt work at all, I'm not sure how to get improved crit to work the right way
    • Andrew
      ... When testing your stuff please use F10 - which will bring up the error log. It will have an error message for using BONUS AUTO. Invalid Token BONUS
      Message 2 of 4 , Sep 23, 2013
      • 0 Attachment
        On 9/23/2013 6:26 AM, billybusbrown@... wrote:
        >
        >
        > I have a homebrew special material that increases the crit range by one, which is handled simply
        > enough by BONUS:EQMWEAPON|CRITRANGEADD|1|TYPE=NonStackingCrit, but I didn't want it to stack with
        > either keen or improved critical. by default it does, so I .MODed keen such that it didn't allow
        > black glass weapons, and wrote a keen that
        > added BONUS:EQMWEAPON|CRITRANGEADD|-1|TYPE=NonStackingCrit, to the end, ugly but it worked. now I'm
        > stuck on improved critical. I tried to modify improved critical such that it added a -1 to any
        > black glass item of the specified type
        > by BONUS:AUTO:WEAPONPROF=%LIST.Blackglass|CRITRANGEADD|-1|TYPE=NonStackingCrit
        >
        >
        > and that doesnt work at all, I'm not sure how to get improved crit to work the right way

        When testing your stuff please use F10 - which will bring up the error log. It will have an error
        message for using "BONUS" AUTO. Invalid Token 'BONUS' blah.

        That's two tags combined into one and PCGen is not flexible enough to take disparate tags and roll
        with it. Your BONUS:AUTO: tag, might work if you remove the AUTO: portion.
        BONUS:WEAPONPROF=%LIST.Blackglass|CRITRANGEADD|-1

        TYPE is pointless on a Penalty, though I do need to ask, are you using ITYPE:Blackglass in your
        material? Otherwise, I don't see that solution as working.

        There is a hack solution, but the issue is Weapons break the BONUS not stacking rule. To fix it, I
        would add a 'BaseWeapon' EQMOD with BONUS:EQMWEAPON|CRITRANGEADD|CritRangeBonus with a
        DEFINE:CritRangeBonus|0

        However, until we can use PRExxx on a EQMOD, then you'd have to manually add the EQMOD for the
        weapon(s) you want the Bonus to apply to.

        Ultimately, this requires some sort of Code fix in the future.


        Cheers,
        Andrew

        >
        >
        >
      • Billy Brown
        thankyou for your response, Blackglass was in the ITYPE:, it is the material type, and it still didn t seem to work after I removed the AUTO, so I m going to
        Message 3 of 4 , Sep 23, 2013
        • 0 Attachment
          thankyou for your response, Blackglass was in the ITYPE:, it is the material type, and it still didn't seem to work after I removed the AUTO, so I'm going to use the eqMod base item option, 


          On Mon, Sep 23, 2013 at 10:42 AM, Andrew <drew0500@...> wrote:
           



          On 9/23/2013 6:26 AM, billybusbrown@... wrote:
          >
          >
          > I have a homebrew special material that increases the crit range by one, which is handled simply
          > enough by BONUS:EQMWEAPON|CRITRANGEADD|1|TYPE=NonStackingCrit, but I didn't want it to stack with
          > either keen or improved critical. by default it does, so I .MODed keen such that it didn't allow
          > black glass weapons, and wrote a keen that
          > added BONUS:EQMWEAPON|CRITRANGEADD|-1|TYPE=NonStackingCrit, to the end, ugly but it worked. now I'm
          > stuck on improved critical. I tried to modify improved critical such that it added a -1 to any
          > black glass item of the specified type
          > by BONUS:AUTO:WEAPONPROF=%LIST.Blackglass|CRITRANGEADD|-1|TYPE=NonStackingCrit
          >
          >
          > and that doesnt work at all, I'm not sure how to get improved crit to work the right way

          When testing your stuff please use F10 - which will bring up the error log. It will have an error
          message for using "BONUS" AUTO. Invalid Token 'BONUS' blah.

          That's two tags combined into one and PCGen is not flexible enough to take disparate tags and roll
          with it. Your BONUS:AUTO: tag, might work if you remove the AUTO: portion.
          BONUS:WEAPONPROF=%LIST.Blackglass|CRITRANGEADD|-1

          TYPE is pointless on a Penalty, though I do need to ask, are you using ITYPE:Blackglass in your
          material? Otherwise, I don't see that solution as working.

          There is a hack solution, but the issue is Weapons break the BONUS not stacking rule. To fix it, I
          would add a 'BaseWeapon' EQMOD with BONUS:EQMWEAPON|CRITRANGEADD|CritRangeBonus with a
          DEFINE:CritRangeBonus|0

          However, until we can use PRExxx on a EQMOD, then you'd have to manually add the EQMOD for the
          weapon(s) you want the Bonus to apply to.

          Ultimately, this requires some sort of Code fix in the future.

          Cheers,
          Andrew

          >
          >
          >


        • Andrew
          I quoted the wrong BONUS %LIST.Blackglass won t work. BONUS:WEAPONPROF=TYPE.Blackglass *might* work, but I rather doubt it since I think that looks at the
          Message 4 of 4 , Sep 23, 2013
          • 0 Attachment
            I quoted the wrong BONUS %LIST.Blackglass won't work.

            BONUS:WEAPONPROF=TYPE.Blackglass *might* work, but I rather doubt it since I think that looks at
            the Proficiency file, not the equipment.

            Good luck.

            On 9/23/2013 10:03 AM, Billy Brown wrote:
            >
            >
            > thankyou for your response, Blackglass was in the ITYPE:, it is the material type, and it still
            > didn't seem to work after I removed the AUTO, so I'm going to use the eqMod base item option,
            >
            >
            > On Mon, Sep 23, 2013 at 10:42 AM, Andrew <drew0500@... <mailto:drew0500@...>> wrote:
            >
            > __
            >
            >
            >
            >
            > On 9/23/2013 6:26 AM, billybusbrown@... <mailto:billybusbrown@...> wrote:
            > >
            > >
            > > I have a homebrew special material that increases the crit range by one, which is handled simply
            > > enough by BONUS:EQMWEAPON|CRITRANGEADD|1|TYPE=NonStackingCrit, but I didn't want it to stack with
            > > either keen or improved critical. by default it does, so I .MODed keen such that it didn't allow
            > > black glass weapons, and wrote a keen that
            > > added BONUS:EQMWEAPON|CRITRANGEADD|-1|TYPE=NonStackingCrit, to the end, ugly but it worked.
            > now I'm
            > > stuck on improved critical. I tried to modify improved critical such that it added a -1 to any
            > > black glass item of the specified type
            > > by BONUS:AUTO:WEAPONPROF=%LIST.Blackglass|CRITRANGEADD|-1|TYPE=NonStackingCrit
            > >
            > >
            > > and that doesnt work at all, I'm not sure how to get improved crit to work the right way
            >
            > When testing your stuff please use F10 - which will bring up the error log. It will have an error
            > message for using "BONUS" AUTO. Invalid Token 'BONUS' blah.
            >
            > That's two tags combined into one and PCGen is not flexible enough to take disparate tags and roll
            > with it. Your BONUS:AUTO: tag, might work if you remove the AUTO: portion.
            > BONUS:WEAPONPROF=%LIST.Blackglass|CRITRANGEADD|-1
            >
            > TYPE is pointless on a Penalty, though I do need to ask, are you using ITYPE:Blackglass in your
            > material? Otherwise, I don't see that solution as working.
            >
            > There is a hack solution, but the issue is Weapons break the BONUS not stacking rule. To fix it, I
            > would add a 'BaseWeapon' EQMOD with BONUS:EQMWEAPON|CRITRANGEADD|CritRangeBonus with a
            > DEFINE:CritRangeBonus|0
            >
            > However, until we can use PRExxx on a EQMOD, then you'd have to manually add the EQMOD for the
            > weapon(s) you want the Bonus to apply to.
            >
            > Ultimately, this requires some sort of Code fix in the future.
            >
            > Cheers,
            > Andrew
            >
            > >
            > >
            > >
            >
            >
            >
            >
            >
          Your message has been successfully submitted and would be delivered to recipients shortly.