Loading ...
Sorry, an error occurred while loading the content.

Re: [PCGenListFileHelp] Modding Magic Missile breaks wizard

Expand Messages
  • Max Paige
    Sent an email to admin@pcgen.org, please let me know if you need any other files or if you didn t recieve it. ... [Non-text portions of this message have been
    Message 1 of 13 , Apr 21, 2013
    • 0 Attachment
      Sent an email to admin@..., please let me know if you need any other
      files or if you didn't recieve it.


      On Sat, Apr 20, 2013 at 5:18 PM, Andrew <drew0500@...> wrote:

      > **
      >
      >
      > Hi,
      >
      > I don't see anything (You did send it to me - admin@..., or perhaps
      > help@...?)
      >
      > This mailing list won't accept attachments.
      >
      > Cheers,
      >
      >
      > On 4/20/2013 1:48 PM, Max Paige wrote:
      > > Attached are the class.lst and spell.lst files. My custom stuff also
      > > includes races, languages, abilities, and ability categories, but
      > hopefully
      > > the bug will be reproducible with just these. The bug also happens if I
      > use
      > > the default races instead of my custom races.
      > >
      > > Thanks,
      > > max
      > >
      > >
      > > On Sat, Apr 20, 2013 at 3:41 PM, Andrew <drew0500@...> wrote:
      > >
      > >> **
      >
      > >>
      > >>
      > >> Hi,
      > >>
      > >> Send me the file(s) in question.
      > >>
      > >> or pastebin.com it and link here. Either way will work.
      > >>
      > >>
      > >> On 4/20/2013 10:58 AM, Max Paige wrote:
      > >>> I'm using version 6.00.0
      > >>>
      > >>> For sources, I'm only using 'SRD 3.5 for Players' and my homebrew
      > stuff,
      > >>> which includes: abilities.lst, ability_categories.lst, classes.lst,
      > >>> language.lst, races.lst, and spells.lst.
      > >>>
      > >>> Here is the error I am getting from pcgen.txt:
      > >>>
      > >>> SEVERE Thread-7 pcgen.cdom.reference.AbstractReferenceManufacturer
      > >>> validateActive Spell Magical Key Change: Magic Missile to Magic
      > >> Missile.MOD
      > >>> The only line in the spell.lst file is the magic missile modifier one.
      > >> When
      > >>> I comment it out, the program works just fine. The modded spell is
      > being
      > >>> added to a custom class - that might matter in some way.
      > >>>
      > >>>
      > >>> On Sat, Apr 20, 2013 at 3:13 AM, Andrew <drew0500@...> wrote:
      > >>>
      > >>>> **
      > >>>> Okay,
      > >>>>
      > >>>> So, this would be a first I've ever heard of a Spell.MOD breaking a
      > >> class.
      > >>>> Are you loading anything else? Which version are you using?
      > >>>>
      > >>>>
      > >>>> On 4/19/2013 11:08 PM, Max Paige wrote:
      > >>>>> There are tabs - I think gmail butchered it for me.
      > >>>>>
      > >>>>>
      > >>>>> Magic Missile.MOD CLASSES:Spellsword=1
      > >>>>>
      > >>>>> There are one or two tabs between it.
      > >>>>>
      > >>>>>
      > >>>>> On Sat, Apr 20, 2013 at 12:25 AM, Andrew <drew0500@...> wrote:
      > >>>>>
      > >>>>>> **
      > >>>>>> Hi,
      > >>>>>>
      > >>>>>> There isn't a space in that line is there?
      > >>>>>>
      > >>>>>>
      > >>>>>> On 4/19/2013 7:09 PM, Max Paige wrote:
      > >>>>>>> I'm trying to add spells to a couple of custom classes. In my
      > >>>> spells.lst
      > >>>>>>> file, I added the line:
      > >>>>>>>
      > >>>>>>> Magic Missile.MOD CLASSES:ClassName=1
      > >>>>>>>
      > >>>>>>> This doesn't work in two different ways:
      > >>>>>>> 1) I add the spell "Magic Missile.MOD" to my class's spell list,
      > not
      > >>>> just
      > >>>>>>> magic missile (but the spell added has the full description &
      > >>>> everything
      > >>>>>>> for magic missile).
      > >>>>>>> 2) When I try to make a wizard, I can select the favorite schools,
      > >> but
      > >>>>>> then
      > >>>>>>> no other menus come up - such as starting clothes or HP - and it
      > >>>> doesn't
      > >>>>>>> add a level of wizard. Furthermore, I can't add any levels to any
      > >> other
      > >>>>>>> class once this bug has occurred. This happens 100% of the time.
      > >>>>>>>
      > >>>>>>> Thanks for any help!
      > >>>>>>>
      > >>>>>>>
      > >>>>>>> [Non-text portions of this message have been removed]
      > >>>>>>>
      > >>>>>>>
      > >>>>>>>
      > >>>>>>> ------------------------------------
      > >>>>>>>
      > >>>>>>> Yahoo! Groups Links
      > >>>>>>>
      > >>>>>>>
      > >>>>>>>
      > >>>>>>>
      > >>>>>> --
      > >>>>>> Andrew Maitland (LegacyKing)
      > >>>>>> Admin Silverback - PCGen Board of Directors
      > >>>>>> Data 2nd, Docs Tamarin, OS Lemur
      > >>>>>> Unique Title "Quick-Silverback Tracker Monkey"
      > >>>>>> Unique Title "The Torturer of PCGen"
      > >>>>>>
      > >>>>>> [Non-text portions of this message have been removed]
      > >>>>>>
      > >>>>>>
      > >>>>>>
      > >>>>> [Non-text portions of this message have been removed]
      > >>>>>
      > >>>>>
      > >>>>>
      > >>>>> ------------------------------------
      > >>>>>
      > >>>>> Yahoo! Groups Links
      > >>>>>
      > >>>>>
      > >>>>>
      > >>>>>
      > >>>> --
      > >>>> Andrew Maitland (LegacyKing)
      > >>>> Admin Silverback - PCGen Board of Directors
      > >>>> Data 2nd, Docs Tamarin, OS Lemur
      > >>>> Unique Title "Quick-Silverback Tracker Monkey"
      > >>>> Unique Title "The Torturer of PCGen"
      > >>>>
      > >>>> [Non-text portions of this message have been removed]
      > >>>>
      > >>>>
      > >>>>
      > >>> [Non-text portions of this message have been removed]
      > >>>
      > >>>
      > >>>
      > >>> ------------------------------------
      > >>>
      > >>> Yahoo! Groups Links
      > >>>
      > >>>
      > >>>
      > >>>
      > >> --
      > >> Andrew Maitland (LegacyKing)
      > >> Admin Silverback - PCGen Board of Directors
      > >> Data 2nd, Docs Tamarin, OS Lemur
      > >> Unique Title "Quick-Silverback Tracker Monkey"
      > >> Unique Title "The Torturer of PCGen"
      > >>
      > >> [Non-text portions of this message have been removed]
      > >>
      > >>
      > >>
      > > [Non-text portions of this message have been removed]
      > >
      > >
      > >
      > > ------------------------------------
      > >
      > > Yahoo! Groups Links
      > >
      > >
      > >
      > >
      >
      > --
      > Andrew Maitland (LegacyKing)
      > Admin Silverback - PCGen Board of Directors
      > Data 2nd, Docs Tamarin, OS Lemur
      > Unique Title "Quick-Silverback Tracker Monkey"
      > Unique Title "The Torturer of PCGen"
      >
      > [Non-text portions of this message have been removed]
      >
      >
      >


      [Non-text portions of this message have been removed]
    • Andrew
      Hi, I got it, and nothing jumps out at me. Is that everything you re using that s homebrew? Nothing else that might be causing any issues? How bout the Log?
      Message 2 of 13 , Apr 21, 2013
      • 0 Attachment
        Hi,

        I got it, and nothing jumps out at me. Is that everything you're using that's homebrew? Nothing else
        that might be causing any issues?

        How bout the Log? Any errors in your log?

        On 4/21/2013 1:18 PM, Max Paige wrote:
        > Sent an email to admin@..., please let me know if you need any other
        > files or if you didn't recieve it.
        >
        >
        > On Sat, Apr 20, 2013 at 5:18 PM, Andrew <drew0500@...> wrote:
        >
        >> **
        >>
        >>
        >> Hi,
        >>
        >> I don't see anything (You did send it to me - admin@..., or perhaps
        >> help@...?)
        >>
        >> This mailing list won't accept attachments.
        >>
        >> Cheers,
        >>
        >>
        >> On 4/20/2013 1:48 PM, Max Paige wrote:
        >>> Attached are the class.lst and spell.lst files. My custom stuff also
        >>> includes races, languages, abilities, and ability categories, but
        >> hopefully
        >>> the bug will be reproducible with just these. The bug also happens if I
        >> use
        >>> the default races instead of my custom races.
        >>>
        >>> Thanks,
        >>> max
        >>>
        >>>
        >>> On Sat, Apr 20, 2013 at 3:41 PM, Andrew <drew0500@...> wrote:
        >>>
        >>>> **
        >>>> Hi,
        >>>>
        >>>> Send me the file(s) in question.
        >>>>
        >>>> or pastebin.com it and link here. Either way will work.
        >>>>
        >>>>
        >>>> On 4/20/2013 10:58 AM, Max Paige wrote:
        >>>>> I'm using version 6.00.0
        >>>>>
        >>>>> For sources, I'm only using 'SRD 3.5 for Players' and my homebrew
        >> stuff,
        >>>>> which includes: abilities.lst, ability_categories.lst, classes.lst,
        >>>>> language.lst, races.lst, and spells.lst.
        >>>>>
        >>>>> Here is the error I am getting from pcgen.txt:
        >>>>>
        >>>>> SEVERE Thread-7 pcgen.cdom.reference.AbstractReferenceManufacturer
        >>>>> validateActive Spell Magical Key Change: Magic Missile to Magic
        >>>> Missile.MOD
        >>>>> The only line in the spell.lst file is the magic missile modifier one.
        >>>> When
        >>>>> I comment it out, the program works just fine. The modded spell is
        >> being
        >>>>> added to a custom class - that might matter in some way.
        >>>>>
        >>>>>
        >>>>> On Sat, Apr 20, 2013 at 3:13 AM, Andrew <drew0500@...> wrote:
        >>>>>
        >>>>>> **
        >>>>>> Okay,
        >>>>>>
        >>>>>> So, this would be a first I've ever heard of a Spell.MOD breaking a
        >>>> class.
        >>>>>> Are you loading anything else? Which version are you using?
        >>>>>>
        >>>>>>
        >>>>>> On 4/19/2013 11:08 PM, Max Paige wrote:
        >>>>>>> There are tabs - I think gmail butchered it for me.
        >>>>>>>
        >>>>>>>
        >>>>>>> Magic Missile.MOD CLASSES:Spellsword=1
        >>>>>>>
        >>>>>>> There are one or two tabs between it.
        >>>>>>>
        >>>>>>>
        >>>>>>> On Sat, Apr 20, 2013 at 12:25 AM, Andrew <drew0500@...> wrote:
        >>>>>>>
        >>>>>>>> **
        >>>>>>>> Hi,
        >>>>>>>>
        >>>>>>>> There isn't a space in that line is there?
        >>>>>>>>
        >>>>>>>>
        >>>>>>>> On 4/19/2013 7:09 PM, Max Paige wrote:
        >>>>>>>>> I'm trying to add spells to a couple of custom classes. In my
        >>>>>> spells.lst
        >>>>>>>>> file, I added the line:
        >>>>>>>>>
        >>>>>>>>> Magic Missile.MOD CLASSES:ClassName=1
        >>>>>>>>>
        >>>>>>>>> This doesn't work in two different ways:
        >>>>>>>>> 1) I add the spell "Magic Missile.MOD" to my class's spell list,
        >> not
        >>>>>> just
        >>>>>>>>> magic missile (but the spell added has the full description &
        >>>>>> everything
        >>>>>>>>> for magic missile).
        >>>>>>>>> 2) When I try to make a wizard, I can select the favorite schools,
        >>>> but
        >>>>>>>> then
        >>>>>>>>> no other menus come up - such as starting clothes or HP - and it
        >>>>>> doesn't
        >>>>>>>>> add a level of wizard. Furthermore, I can't add any levels to any
        >>>> other
        >>>>>>>>> class once this bug has occurred. This happens 100% of the time.
        >>>>>>>>>
        >>>>>>>>> Thanks for any help!
        >>>>>>>>>
        >>>>>>>>>
        >>>>>>>>> [Non-text portions of this message have been removed]
        >>>>>>>>>
        >>>>>>>>>
        >>>>>>>>>
        >>>>>>>>> ------------------------------------
        >>>>>>>>>
        >>>>>>>>> Yahoo! Groups Links
        >>>>>>>>>
        >>>>>>>>>
        >>>>>>>>>
        >>>>>>>>>
        >>>>>>>> --
        >>>>>>>> Andrew Maitland (LegacyKing)
        >>>>>>>> Admin Silverback - PCGen Board of Directors
        >>>>>>>> Data 2nd, Docs Tamarin, OS Lemur
        >>>>>>>> Unique Title "Quick-Silverback Tracker Monkey"
        >>>>>>>> Unique Title "The Torturer of PCGen"
        >>>>>>>>
        >>>>>>>> [Non-text portions of this message have been removed]
        >>>>>>>>
        >>>>>>>>
        >>>>>>>>
        >>>>>>> [Non-text portions of this message have been removed]
        >>>>>>>
        >>>>>>>
        >>>>>>>
        >>>>>>> ------------------------------------
        >>>>>>>
        >>>>>>> Yahoo! Groups Links
        >>>>>>>
        >>>>>>>
        >>>>>>>
        >>>>>>>
        >>>>>> --
        >>>>>> Andrew Maitland (LegacyKing)
        >>>>>> Admin Silverback - PCGen Board of Directors
        >>>>>> Data 2nd, Docs Tamarin, OS Lemur
        >>>>>> Unique Title "Quick-Silverback Tracker Monkey"
        >>>>>> Unique Title "The Torturer of PCGen"
        >>>>>>
        >>>>>> [Non-text portions of this message have been removed]
        >>>>>>
        >>>>>>
        >>>>>>
        >>>>> [Non-text portions of this message have been removed]
        >>>>>
        >>>>>
        >>>>>
        >>>>> ------------------------------------
        >>>>>
        >>>>> Yahoo! Groups Links
        >>>>>
        >>>>>
        >>>>>
        >>>>>
        >>>> --
        >>>> Andrew Maitland (LegacyKing)
        >>>> Admin Silverback - PCGen Board of Directors
        >>>> Data 2nd, Docs Tamarin, OS Lemur
        >>>> Unique Title "Quick-Silverback Tracker Monkey"
        >>>> Unique Title "The Torturer of PCGen"
        >>>>
        >>>> [Non-text portions of this message have been removed]
        >>>>
        >>>>
        >>>>
        >>> [Non-text portions of this message have been removed]
        >>>
        >>>
        >>>
        >>> ------------------------------------
        >>>
        >>> Yahoo! Groups Links
        >>>
        >>>
        >>>
        >>>
        >> --
        >> Andrew Maitland (LegacyKing)
        >> Admin Silverback - PCGen Board of Directors
        >> Data 2nd, Docs Tamarin, OS Lemur
        >> Unique Title "Quick-Silverback Tracker Monkey"
        >> Unique Title "The Torturer of PCGen"
        >>
        >> [Non-text portions of this message have been removed]
        >>
        >>
        >>
        > [Non-text portions of this message have been removed]
        >
        >
        >
        > ------------------------------------
        >
        > Yahoo! Groups Links
        >
        >
        >
        >


        --
        Andrew Maitland (LegacyKing)
        Admin Silverback - PCGen Board of Directors
        Data 2nd, Docs Tamarin, OS Lemur
        Unique Title "Quick-Silverback Tracker Monkey"
        Unique Title "The Torturer of PCGen"


        [Non-text portions of this message have been removed]
      • Barak
        You sholdn t add Magic Missile.MOD ... You should simply add Magic Missile ... There is no Magic Missile.MOD spell. You ve modified the original, not
        Message 3 of 13 , Apr 21, 2013
        • 0 Attachment
          You sholdn't add "Magic Missile.MOD"... You should simply add "Magic
          Missile"... There is no "Magic Missile.MOD" spell. You've modified the
          original, not created a new spell.

          Barak
          On Apr 20, 2013 3:35 AM, "Max Paige" <paige.m89@...> wrote:

          > **
          >
          >
          > I'm trying to add spells to a couple of custom classes. In my spells.lst
          > file, I added the line:
          >
          > Magic Missile.MOD CLASSES:ClassName=1
          >
          > This doesn't work in two different ways:
          > 1) I add the spell "Magic Missile.MOD" to my class's spell list, not just
          > magic missile (but the spell added has the full description & everything
          > for magic missile).
          > 2) When I try to make a wizard, I can select the favorite schools, but then
          > no other menus come up - such as starting clothes or HP - and it doesn't
          > add a level of wizard. Furthermore, I can't add any levels to any other
          > class once this bug has occurred. This happens 100% of the time.
          >
          > Thanks for any help!
          >
          > [Non-text portions of this message have been removed]
          >
          >
          >


          [Non-text portions of this message have been removed]
        • Max Paige
          But I don t want to create a new spell, I want to modify the original and add it to a new class s spell list. I can t find any way to do that in the
          Message 4 of 13 , Apr 22, 2013
          • 0 Attachment
            But I don't want to create a new spell, I want to modify the original and
            add it to a new class's spell list. I can't find any way to do that in the
            documentation, but <spell name>.MOD seems to be the only way possible.


            On Mon, Apr 22, 2013 at 2:00 AM, Barak <barako@...> wrote:

            > You sholdn't add "Magic Missile.MOD"... You should simply add "Magic
            > Missile"... There is no "Magic Missile.MOD" spell. You've modified the
            > original, not created a new spell.
            >
            > Barak
            > On Apr 20, 2013 3:35 AM, "Max Paige" <paige.m89@...> wrote:
            >
            > > **
            > >
            > >
            > > I'm trying to add spells to a couple of custom classes. In my spells.lst
            > > file, I added the line:
            > >
            > > Magic Missile.MOD CLASSES:ClassName=1
            > >
            > > This doesn't work in two different ways:
            > > 1) I add the spell "Magic Missile.MOD" to my class's spell list, not just
            > > magic missile (but the spell added has the full description & everything
            > > for magic missile).
            > > 2) When I try to make a wizard, I can select the favorite schools, but
            > then
            > > no other menus come up - such as starting clothes or HP - and it doesn't
            > > add a level of wizard. Furthermore, I can't add any levels to any other
            > > class once this bug has occurred. This happens 100% of the time.
            > >
            > > Thanks for any help!
            > >
            > > [Non-text portions of this message have been removed]
            > >
            > >
            > >
            >
            >
            > [Non-text portions of this message have been removed]
            >
            >
            >
            > ------------------------------------
            >
            > Yahoo! Groups Links
            >
            >
            >
            >


            [Non-text portions of this message have been removed]
          • Barak
            ... And that s what you do when you use. MOD. However, you still refer to the spell by its regular name... You said you used Magic Missile.MOD to try and add
            Message 5 of 13 , Apr 22, 2013
            • 0 Attachment
              On Apr 22, 2013 5:55 PM, "Max Paige" <paige.m89@...> wrote:
              >
              > But I don't want to create a new spell, I want to modify the original and
              > add it to a new class's spell list. I can't find any way to do that in the
              > documentation, but <spell name>.MOD seems to be the only way possible.
              >
              And that's what you do when you use. MOD.

              However, you still refer to the spell by its regular name...

              You said you used "Magic Missile.MOD" to try and add it to the spell list
              and that is incorrect. You should still use "Magic Missile" when you want
              to refer to the modified spell.

              Barak


              [Non-text portions of this message have been removed]
            Your message has been successfully submitted and would be delivered to recipients shortly.