Loading ...
Sorry, an error occurred while loading the content.

Auto:Equip gives Quantity zero of an item?

Expand Messages
  • Pythor
    I tried putting together a Kobold race so I can advance a Kobold leader to 4th level. It took me forever to find the right file to edit, then a while longer
    Message 1 of 8 , May 31 7:03 PM
    • 0 Attachment
      I tried putting together a Kobold race so I can advance a Kobold leader to
      4th level. It took me forever to find the right file to edit, then a while
      longer to get all the bugs out, and I still don't have everything working.
      One thing I thought I had working was the Auto:Equip. I have this:

      <TAB>AUTO:EQUIP|Leather|Spear|Sling<TAB>

      as one part of my race line. I then go to equip my gear in the default set,
      and none of those items show available. Looking back at the gear tab, I see
      that while the items are listed, they all show a quantity of zero. Is that
      a problem with PCGen, or a problem with my race?

      Another issue I had was that I couldn't figure out from the documentation
      how to add the Skill Focus(Perception) to a race. I realized that as
      characters, the race doesn't get it anyway, so I gave up for now.

      I'm using version 5.16.2, and the Pathfinder dataset, including the
      bestiary.

      Lee


      [Non-text portions of this message have been removed]
    • Andrew Maitland
      Are you granting the items by any method, or are you just relying on the AUTO:EQUIP tag? I believe you need to use a KIT that grants the equipment and then
      Message 2 of 8 , Jun 1, 2010
      • 0 Attachment
        Are you granting the items by any method, or are you just relying on the AUTO:EQUIP tag?

        I believe you need to use a KIT that grants the equipment and then AUTO:EQUIP would work.




        ________________________________
        From: Pythor <pythor@...>
        To: PCGenListFileHelp@yahoogroups.com
        Sent: Mon, May 31, 2010 7:03:30 PM
        Subject: [PCGenListFileHelp] Auto:Equip gives Quantity zero of an item?

        I tried putting together a Kobold race so I can advance a Kobold leader to
        4th level.  It took me forever to find the right file to edit, then a while
        longer to get all the bugs out, and I still don't have everything working.
        One thing I thought I had working was the Auto:Equip.  I have this:

        <TAB>AUTO:EQUIP|Leather|Spear|Sling<TAB>

        as one part of my race line.  I then go to equip my gear in the default set,
        and none of those items show available.  Looking back at the gear tab, I see
        that while the items are listed, they all show a quantity of zero.  Is that
        a problem with PCGen, or a problem with my race?

        Another issue I had was that I couldn't figure out from the documentation
        how to add the Skill Focus(Perception) to a race.  I realized that as
        characters, the race doesn't get it anyway, so I gave up for now.

        I'm using version 5.16.2, and the Pathfinder dataset, including the
        bestiary.

        Lee


        [Non-text portions of this message have been removed]



        ------------------------------------

        Yahoo! Groups Links



        [Non-text portions of this message have been removed]
      • Eddy Anthony
        ... Em, no. Those two methods are unrelated. Kits grant stuff in the same manor that adding it manually does (which means you can set how many and remove items
        Message 3 of 8 , Jun 1, 2010
        • 0 Attachment
          On 6/1/10 10:36 AM, Andrew Maitland wrote:
          > I believe you need to use a KIT that grants the equipment and then AUTO:EQUIP would work.
          >

          Em, no. Those two methods are unrelated. Kits grant stuff in the same
          manor that adding it manually does (which means you can set how many and
          remove items later). AUTO:EQUIP does not give you control over the
          number of items granted that way and you cannot remove any items granted
          with it from the gear list (although you can unequip them). You do not
          need to use a kit to make AUTO:EQUIP work.

          --
          ~ Eddy Anthony (MoSaT)
          ~ PCGen Data, Docs& Tracker Chimp
          ~ Outputsheet Tamarin& Mac build guru
        • Andrew Maitland
          So we have a Bug then? ________________________________ From: Eddy Anthony To: PCGenListFileHelp@yahoogroups.com Sent: Tue, June 1,
          Message 4 of 8 , Jun 1, 2010
          • 0 Attachment
            So we have a Bug then?




            ________________________________
            From: Eddy Anthony <eddyba@...>
            To: PCGenListFileHelp@yahoogroups.com
            Sent: Tue, June 1, 2010 8:58:23 AM
            Subject: Re: [PCGenListFileHelp] Auto:Equip gives Quantity zero of an item?

            On 6/1/10 10:36 AM, Andrew Maitland wrote:
            > I believe you need to use a KIT that grants the equipment and then AUTO:EQUIP would work.
            >   

            Em, no. Those two methods are unrelated. Kits grant stuff in the same
            manor that adding it manually does (which means you can set how many and
            remove items later). AUTO:EQUIP does not give you control over the
            number of items granted that way and you cannot remove any items granted
            with it from the gear list (although you can unequip them). You do not
            need to use a kit to make AUTO:EQUIP work.

            --
            ~ Eddy Anthony (MoSaT)
            ~ PCGen Data, Docs&  Tracker Chimp
            ~ Outputsheet Tamarin&  Mac build guru



            ------------------------------------

            Yahoo! Groups Links



            [Non-text portions of this message have been removed]
          • Pythor
            Was anyone able to figure out if this is a code bug or a data issue? I ll try to fix it if it s a data issue, but I m not sure how. Lee ... [Non-text portions
            Message 5 of 8 , Jun 5, 2010
            • 0 Attachment
              Was anyone able to figure out if this is a code bug or a data issue? I'll
              try to fix it if it's a data issue, but I'm not sure how.

              Lee

              On Tue, Jun 1, 2010 at 12:09 PM, Andrew Maitland <drew0500@...> wrote:

              > So we have a Bug then?
              >
              >
              >
              >
              > ________________________________
              > From: Eddy Anthony <eddyba@...>
              > To: PCGenListFileHelp@yahoogroups.com
              > Sent: Tue, June 1, 2010 8:58:23 AM
              > Subject: Re: [PCGenListFileHelp] Auto:Equip gives Quantity zero of an item?
              >
              > On 6/1/10 10:36 AM, Andrew Maitland wrote:
              > > I believe you need to use a KIT that grants the equipment and then
              > AUTO:EQUIP would work.
              > >
              >
              > Em, no. Those two methods are unrelated. Kits grant stuff in the same
              > manor that adding it manually does (which means you can set how many and
              > remove items later). AUTO:EQUIP does not give you control over the
              > number of items granted that way and you cannot remove any items granted
              > with it from the gear list (although you can unequip them). You do not
              > need to use a kit to make AUTO:EQUIP work.
              >
              > --
              > ~ Eddy Anthony (MoSaT)
              > ~ PCGen Data, Docs& Tracker Chimp
              > ~ Outputsheet Tamarin& Mac build guru
              >
              >
              >
              > ------------------------------------
              >
              > Yahoo! Groups Links
              >
              >
              >
              > [Non-text portions of this message have been removed]
              >
              >
              >
              > ------------------------------------
              >
              > Yahoo! Groups Links
              >
              >
              >
              >


              [Non-text portions of this message have been removed]
            • karianna03
              *Bump*
              Message 6 of 8 , Jun 7, 2010
              • 0 Attachment
                *Bump*

                --- In PCGenListFileHelp@yahoogroups.com, Pythor <pythor@...> wrote:
                >
                > Was anyone able to figure out if this is a code bug or a data issue? I'll
                > try to fix it if it's a data issue, but I'm not sure how.
                >
                > Lee
                >
                > On Tue, Jun 1, 2010 at 12:09 PM, Andrew Maitland <drew0500@...> wrote:
                >
                > > So we have a Bug then?
                > >
                > >
                > >
                > >
                > > ________________________________
                > > From: Eddy Anthony <eddyba@...>
                > > To: PCGenListFileHelp@yahoogroups.com
                > > Sent: Tue, June 1, 2010 8:58:23 AM
                > > Subject: Re: [PCGenListFileHelp] Auto:Equip gives Quantity zero of an item?
                > >
                > > On 6/1/10 10:36 AM, Andrew Maitland wrote:
                > > > I believe you need to use a KIT that grants the equipment and then
                > > AUTO:EQUIP would work.
                > > >
                > >
                > > Em, no. Those two methods are unrelated. Kits grant stuff in the same
                > > manor that adding it manually does (which means you can set how many and
                > > remove items later). AUTO:EQUIP does not give you control over the
                > > number of items granted that way and you cannot remove any items granted
                > > with it from the gear list (although you can unequip them). You do not
                > > need to use a kit to make AUTO:EQUIP work.
                > >
                > > --
                > > ~ Eddy Anthony (MoSaT)
                > > ~ PCGen Data, Docs& Tracker Chimp
                > > ~ Outputsheet Tamarin& Mac build guru
                > >
                > >
                > >
                > > ------------------------------------
                > >
                > > Yahoo! Groups Links
                > >
                > >
                > >
                > > [Non-text portions of this message have been removed]
                > >
                > >
                > >
                > > ------------------------------------
                > >
                > > Yahoo! Groups Links
                > >
                > >
                > >
                > >
                >
                >
                > [Non-text portions of this message have been removed]
                >
              • Andrew Maitland
                I ll investigate this after work today - which is about 7 more hours... -- Andrew ________________________________ From: karianna03
                Message 7 of 8 , Jun 7, 2010
                • 0 Attachment
                  I'll investigate this after work today - which is about 7 more hours...

                  --
                  Andrew




                  ________________________________
                  From: karianna03 <martijnverburg@...>
                  To: PCGenListFileHelp@yahoogroups.com
                  Sent: Mon, June 7, 2010 3:16:59 AM
                  Subject: [PCGenListFileHelp] Re: Auto:Equip gives Quantity zero of an item?

                  *Bump*

                  --- In PCGenListFileHelp@yahoogroups.com, Pythor <pythor@...> wrote:
                  >
                  > Was anyone able to figure out if this is a code bug or a data issue?  I'll
                  > try to fix it if it's a data issue, but I'm not sure how.
                  >
                  > Lee
                  >
                  > On Tue, Jun 1, 2010 at 12:09 PM, Andrew Maitland <drew0500@...> wrote:
                  >
                  > > So we have a Bug then?
                  > >
                  > >
                  > >
                  > >
                  > > ________________________________
                  > > From: Eddy Anthony <eddyba@...>
                  > > To: PCGenListFileHelp@yahoogroups.com
                  > > Sent: Tue, June 1, 2010 8:58:23 AM
                  > > Subject: Re: [PCGenListFileHelp] Auto:Equip gives Quantity zero of an item?
                  > >
                  > > On 6/1/10 10:36 AM, Andrew Maitland wrote:
                  > > > I believe you need to use a KIT that grants the equipment and then
                  > > AUTO:EQUIP would work.
                  > > >
                  > >
                  > > Em, no. Those two methods are unrelated. Kits grant stuff in the same
                  > > manor that adding it manually does (which means you can set how many and
                  > > remove items later). AUTO:EQUIP does not give you control over the
                  > > number of items granted that way and you cannot remove any items granted
                  > > with it from the gear list (although you can unequip them). You do not
                  > > need to use a kit to make AUTO:EQUIP work.
                  > >
                  > > --
                  > > ~ Eddy Anthony (MoSaT)
                  > > ~ PCGen Data, Docs&  Tracker Chimp
                  > > ~ Outputsheet Tamarin&  Mac build guru
                  > >
                  > >
                  > >
                  > > ------------------------------------
                  > >
                  > > Yahoo! Groups Links
                  > >
                  > >
                  > >
                  > > [Non-text portions of this message have been removed]
                  > >
                  > >
                  > >
                  > > ------------------------------------
                  > >
                  > > Yahoo! Groups Links
                  > >
                  > >
                  > >
                  > >
                  >
                  >
                  > [Non-text portions of this message have been removed]
                  >




                  ------------------------------------

                  Yahoo! Groups Links



                  [Non-text portions of this message have been removed]
                • Andrew Maitland
                  http://jira.pcgen.org/browse/CODE-82 Confirmed in Trunk ________________________________ From: Andrew Maitland To:
                  Message 8 of 8 , Jun 8, 2010
                  • 0 Attachment
                    http://jira.pcgen.org/browse/CODE-82


                    Confirmed in Trunk


                    ________________________________
                    From: Andrew Maitland <drew0500@...>
                    To: PCGenListFileHelp@yahoogroups.com
                    Sent: Mon, June 7, 2010 8:04:12 AM
                    Subject: Re: [PCGenListFileHelp] [Drew_TM] Re: Auto:Equip gives Quantity zero of an item?

                    I'll investigate this after work today - which is about 7 more hours...

                    --
                    Andrew




                    ________________________________
                    From: karianna03 <martijnverburg@...>
                    To: PCGenListFileHelp@yahoogroups.com
                    Sent: Mon, June 7, 2010 3:16:59 AM
                    Subject: [PCGenListFileHelp] Re: Auto:Equip gives Quantity zero of an item?

                    *Bump*

                    --- In PCGenListFileHelp@yahoogroups.com, Pythor <pythor@...> wrote:
                    >
                    > Was anyone able to figure out if this is a code bug or a data issue?  I'll
                    > try to fix it if it's a data issue, but I'm not sure how.
                    >
                    > Lee
                    >
                    > On Tue, Jun 1, 2010 at 12:09 PM, Andrew Maitland <drew0500@...> wrote:
                    >
                    > > So we have a Bug then?
                    > >
                    > >
                    > >
                    > >
                    > > ________________________________
                    > > From: Eddy Anthony <eddyba@...>
                    > > To: PCGenListFileHelp@yahoogroups.com
                    > > Sent: Tue, June 1, 2010 8:58:23 AM
                    > > Subject: Re: [PCGenListFileHelp] Auto:Equip gives Quantity zero of an item?
                    > >
                    > > On 6/1/10 10:36 AM, Andrew Maitland wrote:
                    > > > I believe you need to use a KIT that grants the equipment and then
                    > > AUTO:EQUIP would work.
                    > > >
                    > >
                    > > Em, no. Those two methods are unrelated. Kits grant stuff in the same
                    > > manor that adding it manually does (which means you can set how many and
                    > > remove items later). AUTO:EQUIP does not give you control over the
                    > > number of items granted that way and you cannot remove any items granted
                    > > with it from the gear list (although you can unequip them). You do not
                    > > need to use a kit to make AUTO:EQUIP work.
                    > >
                    > > --
                    > > ~ Eddy Anthony (MoSaT)
                    > > ~ PCGen Data, Docs&  Tracker Chimp
                    > > ~ Outputsheet Tamarin&  Mac build guru
                    > >
                    > >
                    > >
                    > > ------------------------------------
                    > >
                    > > Yahoo! Groups Links
                    > >
                    > >
                    > >
                    > > [Non-text portions of this message have been removed]
                    > >
                    > >
                    > >
                    > > ------------------------------------
                    > >
                    > > Yahoo! Groups Links
                    > >
                    > >
                    > >
                    > >
                    >
                    >
                    > [Non-text portions of this message have been removed]
                    >




                    ------------------------------------

                    Yahoo! Groups Links



                    [Non-text portions of this message have been removed]



                    ------------------------------------

                    Yahoo! Groups Links



                    [Non-text portions of this message have been removed]
                  Your message has been successfully submitted and would be delivered to recipients shortly.