Loading ...
Sorry, an error occurred while loading the content.
 

RTTY setup

Expand Messages
  • John McBee
    Boy I wish I would not mess with my mmtty and n1mm setting. Trying to get N1mm and mmtty and k3 working again. I can get my K3 to work with mmtty just fine,
    Message 1 of 22 , Jan 2, 2014
      Boy I wish I would not mess with my mmtty and n1mm setting. Trying to
      get N1mm and mmtty and k3 working again. I can get my K3 to work with
      mmtty just fine, but when i open up N1MM and open digital window it will
      no longer key my k3. I know you don't have to set a com port in mmtty
      when using N1MM, so I don't remember what all of the settings are. What
      is the K3 setting for N1mm and mmtty again? I have the PTT-Key menu in
      k3 set to rts-off. Any help would be great. Maybe this time I will not
      change the setting and forget what I did. This didn't use to be this
      hard. I had this all working great during the WAE rtty contest.

      Thanks
      John
    • WW3S
      yes, you do need to set a com port in MM...the MMTTY port should carry over, but under Config, make sure you have the corresponding com port check for the digi
      Message 2 of 22 , Jan 2, 2014
        yes, you do need to set a com port in MM...the MMTTY port should carry over, but under Config, make sure you have the corresponding com port check for the digi window....
         
         
         
        On 1/2/2014 10:41:38 PM, John McBee (jrmcbee@...) wrote:
        > Boy I
        wish I would not mess with my mmtty and n1mm setting.  Trying to
        >
        get N1mm and mmtty and k3 working again.  I can get my K3 to work with
        > mmtty just fine, but when i open up N1MM and open digital window it
        will
        > no longer key my k3.  I know you
        > don't have to set a
        com port in mmtty
        > when using N1MM, so I don't
        > remember what all
        of the settings are.  What
        > is the K3 setting for N1mm and mmtty
        again? I have the PTT-Key menu in
        > k3 set to rts-off.  Any help
        would be great.  Maybe this time I will not
        > change the setting and
        forget what I did.  This didn't use to be this
        > hard.  I had
        this all working great during the WAE rtty contest.
        >
        >
        Thanks
        > John
        >
        >
        >
        ------------------------------------
        >
        > To unsubscribe, send an
        email to:
        > N1MMLogger-unsubscribe@yahoogroups.com
        >
        > Yahoo
        Groups Links
        >
        > <*> To visit your group on the web, go
        to:
        > http://groups.yahoo.com/group/N1MMLogger/
        >
        > <*>
        Your email settings:
        > Individual Email | Traditional
        >
        >
        <*> To change settings online go to:
        >
        http://groups.yahoo.com/group/N1MMLogger/join
        > (Yahoo! ID
        required)
        >
        > <*> To change settings via email:
        >
        N1MMLogger-digest@yahoogroups.com
        >
        N1MMLogger-fullfeatured@yahoogroups.com
        >
        >
        <*
      • John McBee
        ... Under MMTTY I have com5 selected, but that is also the port which N1mm uses to control the K3. If I choose com 5 for mmtty it says port already used when
        Message 3 of 22 , Jan 3, 2014
          On 1/2/2014 9:52 PM, WW3S wrote:
           

          yes, you do need to set a com port in MM...the MMTTY port should carry over, but under Config, make sure you have the corresponding com port check for the digi window....
           
           
           
          On 1/2/2014 10:41:38 PM, John McBee (jrmcbee@...) wrote:
          > Boy I wish I would not mess with my mmtty and n1mm setting.  Trying to
          > get N1mm and mmtty and k3 working again.  I can get my K3 to work with
          > mmtty just fine, but when i open up N1MM and open digital window it will
          > no longer key my k3.  I know you
          > don't have to set a com port in mmtty
          > when using N1MM, so I don't
          > remember what all of the settings are.  What
          > is the K3 setting for N1mm and mmtty again? I have the PTT-Key menu in
          > k3 set to rts-off.  Any help would be great.  Maybe this time I will not
          > change the setting and forget what I did.  This didn't use to be this
          > hard.  I had this all working great during the WAE rtty contest.
          >
          > Thanks
          > John
          >
          >
          > ------------------------------------
          >
          > To unsubscribe, send an email to:
          > N1MMLogger-unsubscribe@yahoogroups.com
          >
          > Yahoo Groups Links
          >
          > <*> To visit your group on the web, go to:
          > http://groups.yahoo.com/group/N1MMLogger/
          >
          > <*> Your email settings:
          > Individual Email | Traditional
          >
          > <*> To change settings online go to:
          > http://groups.yahoo.com/group/N1MMLogger/join
          > (Yahoo! ID required)
          >
          > <*> To change settings via email:
          > N1MMLogger-digest@yahoogroups.com
          > N1MMLogger-fullfeatured@yahoogroups.com
          >
          > <*
          Under MMTTY I have com5 selected, but that is also the port which N1mm uses to control the K3.  If I choose com 5 for mmtty it says port already used when starting N1MM.  My digital window is greyed out under config editor in N1MM. 
          Here are my setting for N1MM:  using usb to serial cable for only connection to computer to k3.  When I bring up N1MM it does not carry over the com setting from mmtty, it says None for com port.

          What should the mode control be set at under Cofig menu?
          John

        • rich_ve3ki
          You cannot use COM5 for both radio control from N1MM Logger and PTT/FSK keying in MMTTY. If you are using FSK, you must use a different COM port for FSK
          Message 4 of 22 , Jan 3, 2014
            You cannot use COM5 for both radio control from N1MM Logger and PTT/FSK keying in MMTTY. If you are using FSK, you must use a different COM port for FSK keying. If you are using AFSK, you can do PTT from N1MM Logger via COM5, but in that case MMTTY's PTT&FSK Port must be set to NONE.

            You said you have the K3's CONFIG:PTT-KEY set to RTS-OFF; to use this, in the Configurer click on the Set button for COM5 and set RTS to PTT and DTR to Always Off. Do not check any of the PTT via Radio Command buttons; you don't need radio command PTT when you are using RTS. Note that when you have the K3's PTT-KEY set to RTS-OFF, PTT will be active in all modes (i.e. to use QSK or semi-breakin in CW you will have to turn RTS to Always Off or else change PTT-KEY to OFF-OFF). Also, note that if you restart the computer while the K3 is turned on, the OS may toggle RTS a few times during PC startup, which will activate PTT on the radio.

            I don't know what you mean by "My digital window is greyed out under config editor in N1MM." If you mean that the Digital check box beside COM5 is greyed out, that is correct - it is not possible to use COM5 for both radio control and Digital mode FSK/PTT keying. You don't need to check any of the Digital check boxes. Their main use is for a port that is used for both CW keying and FSK keying, which is not relevant to the setup you have described.

            As for mode control, if you are using AFSK on the K3 then on the right side of the window you should set the RTTY boxes to AFSK, and the PSK boxes to PSK. For FSK RTTY you would set the RTTY boxes to RTTY. On the left side of the window, either of the first two choices will work with the K3. If you run into a situation where the function keys are in SSB mode instead of RTTY, or if the program won't let you edit the function keys because it says the operating mode is not set, type RTTY (or CW, SSB or PSK) into the call sign box in the Entry window and press Enter to set the operating mode in N1MM Logger.

            73,
            Rich VE3KI

          • Tony McClenny
            Having trouble setting function keys and/or contest sent exchange for ARRL RTTY RU - which requires rst, state & serial (I think) error is Missing/Invalid
            Message 5 of 22 , Jan 3, 2014

              Having trouble setting function keys and/or contest sent exchange for ARRL RTTY RU - which requires rst, state & serial (I think)

               

              error is "Missing/Invalid Exch" - your assistance would be appreciated - having an "old man moment" I guess.

               

              F1 CQ,{clrrx}{enter}{tx}cq cq ru de * (delaware) cq {rx}

              F2 Exch,{enter}{tx}! 599- {exch} 599- {exch} de * bk{clearrit}{rx}

              F3 TU,{enter}{tx}! tu de * qrz?{rx}{log}

               

              What should go in the Contest "Sent Exchange"?

               

              Currently using:  DE 001

              and that does not work...

               

              Thanks for your help!!

               

              - Tony, N3ME -


              118 Ashwood Street
              Bethany Beach, DE 19930-9699
              (302) 539-5638

              Grid:  FM28lm

              http://www.n3me.net
              Elecraft K3 # 2462

              PVRC Member

               

              From: N1MMLogger@yahoogroups.com [mailto:N1MMLogger@yahoogroups.com] On Behalf Of ve3ki@...
              Sent: Friday, January 03, 2014 12:19 PM
              To: N1MMLogger@yahoogroups.com
              Subject: Re: [N1MM] RTTY setup

               

               

              You cannot use COM5 for both radio control from N1MM Logger and PTT/FSK keying in MMTTY. If you are using FSK, you must use a different COM port for FSK keying. If you are using AFSK, you can do PTT from N1MM Logger via COM5, but in that case MMTTY's PTT&FSK Port must be set to NONE.

              You said you have the K3's CONFIG:PTT-KEY set to RTS-OFF; to use this, in the Configurer click on the Set button for COM5 and set RTS to PTT and DTR to Always Off. Do not check any of the PTT via Radio Command buttons; you don't need radio command PTT when you are using RTS. Note that when you have the K3's PTT-KEY set to RTS-OFF, PTT will be active in all modes (i.e. to use QSK or semi-breakin in CW you will have to turn RTS to Always Off or else change PTT-KEY to OFF-OFF). Also, note that if you restart the computer while the K3 is turned on, the OS may toggle RTS a few times during PC startup, which will activate PTT on the radio.

              I don't know what you mean by "My digital window is greyed out under config editor in N1MM." If you mean that the Digital check box beside COM5 is greyed out, that is correct - it is not possible to use COM5 for both radio control and Digital mode FSK/PTT keying. You don't need to check any of the Digital check boxes. Their main use is for a port that is used for both CW keying and FSK keying, which is not relevant to the setup you have described.

              As for mode control, if you are using AFSK on the K3 then on the right side of the window you should set the RTTY boxes to AFSK, and the PSK boxes to PSK. For FSK RTTY you would set the RTTY boxes to RTTY. On the left side of the window, either of the first two choices will work with the K3. If you run into a situation where the function keys are in SSB mode instead of RTTY, or if the program won't let you edit the function keys because it says the operating mode is not set, type RTTY (or CW, SSB or PSK) into the call sign box in the Entry window and press Enter to set the operating mode in N1MM Logger.

              73,
              Rich VE3KI

            • rich_ve3ki
              Your sent exchange is your state only - no serial number. Stations outside W/VE send serial numbers, but W/VE stations send only their state/province (plus a
              Message 6 of 22 , Jan 3, 2014
                Your sent exchange is your state only - no serial number. Stations outside W/VE send serial numbers, but W/VE stations send only their state/province (plus a pro forma signal report, but you don't put that in the Sent Exchange box).

                I believe the "Missing/Invalid Exchange" message you are referring to is issued when you try to log a contact with (wait for it) a missing or invalid exchange. My guess is that you probably tried to log both a state and a serial number, which is invalid; it's one or the other, depending on the call sign (W/VE vs. DX).

                Are you aware of the sample function key files on the N1MM Logger web site? Go to www.n1mm.com, select Files > Sample Function Key Files from the menu, then click on Sample Function Key Files - Digital and look for ARRLRTTY.mc .

                73,
                Rich VE3KI
              • Hank Garretson
                On Fri, Jan 3, 2014 at 2:47 PM, Tony McClenny wrote: Having trouble setting function keys and/or contest sent exchange for ARRL ... F1, CQ, CQ
                Message 7 of 22 , Jan 3, 2014



                  On Fri, Jan 3, 2014 at 2:47 PM, Tony McClenny <n3me@...> wrote:

                  Having trouble setting function keys and/or contest sent exchange for ARRL RTTY RU - which requires rst, state & serial (I think)

                   

                  error is "Missing/Invalid Exch" - your assistance would be appreciated - having an "old man moment" I guess.

                   

                  F1 CQ,{clrrx}{enter}{tx}cq cq ru de * (delaware) cq {rx}

                  F2 Exch,{enter}{tx}! 599- {exch} 599- {exch} de * bk{clearrit}{rx}

                  F3 TU,{enter}{tx}! tu de * qrz?{rx}{log}


                  F1, CQ, CQ RU N3ME N3ME CQ

                  Rather than sending CQ twice, better to send your call which is useful information twice. DE is not useful in a CQ.

                  F2 Exch, ! 599 DE DE

                  Never, never send 599 twice--waste of everyone's time. DE is not useful before your call. In fact, you do not need to send your call as part of your exchange. BK is another time waster--just drop your carrier. I find it best to hard program exchange rather than using {exch} because if you send {exch} twice 599 gets sent twice.

                  F3, ! TU N3ME CQ

                  Again DE is a waste of time. CQ is the standard at the end of a QSO, not QRZ.

                  I'll leave it to you to put in the ENTERS and following-last SPACE at end of each transmission.
                   

                  What should go in the Contest "Sent Exchange"?


                  DE

                  N1MM automatically adds 599.
                   

                  Currently using:  DE 001

                  and that does not work...


                  Because RU exchange does not include NR.

                  CU tomorrow.

                  Contest Exuberantly,

                  Hank, W6SX

                • iain macdonnell - N6ML
                  ... The first CQ is mostly redundant too, unless you re trying to drag the message out a bit. I use something like: F1 CQ,{TX}{ENTER}RU * * CQ{CLEARRIT} {RX}
                  Message 8 of 22 , Jan 3, 2014
                    On Fri, Jan 3, 2014 at 3:12 PM, Hank Garretson <w6sx@...> wrote:
                    >
                    >
                    >
                    >
                    >
                    > On Fri, Jan 3, 2014 at 2:47 PM, Tony McClenny <n3me@...> wrote:
                    >
                    >> Having trouble setting function keys and/or contest sent exchange for ARRL
                    >> RTTY RU - which requires rst, state & serial (I think)
                    >>
                    >>
                    >>
                    >> error is "Missing/Invalid Exch" - your assistance would be appreciated -
                    >> having an "old man moment" I guess.
                    >>
                    >>
                    >>
                    >> F1 CQ,{clrrx}{enter}{tx}cq cq ru de * (delaware) cq {rx}
                    >>
                    >> F2 Exch,{enter}{tx}! 599- {exch} 599- {exch} de * bk{clearrit}{rx}
                    >>
                    >> F3 TU,{enter}{tx}! tu de * qrz?{rx}{log}
                    >
                    >
                    > F1, CQ, CQ RU N3ME N3ME CQ
                    >
                    > Rather than sending CQ twice, better to send your call which is useful
                    > information twice. DE is not useful in a CQ.

                    The first 'CQ' is mostly redundant too, unless you're trying to drag
                    the message out a bit. I use something like:

                    F1 CQ,{TX}{ENTER}RU * * CQ{CLEARRIT} {RX}


                    > F2 Exch, ! 599 DE DE
                    >
                    > Never, never send 599 twice--waste of everyone's time. DE is not useful
                    > before your call. In fact, you do not need to send your call as part of your
                    > exchange. BK is another time waster--just drop your carrier. I find it best
                    > to hard program exchange rather than using {exch} because if you send {exch}
                    > twice 599 gets sent twice.

                    Not true - {exch} sends whatever is in the "sent exchange", and, as
                    you point out, that does not include the RST. I might use:

                    F2 Exch,{TX}599 {EXCH} {EXCH} ! {RX}

                    although in this case, I'll probably send only one {exch}, since I'm a
                    N6 and it's reasonable to guess I'm in CA.

                    If you're using ESM, you do NOT want '!' (his call) at the start,
                    because ESM automatically sends F5 followed by F2. Including '!' at
                    the end is good when you're running rate, since sometimes the start of
                    your exchange can get covered by other callers.

                    73,

                    ~iain / N6ML
                  • Hank Garretson
                    ... Not as it works at W6SX. If Sent Exchange is CA, {EXCH} in a macro sends 599 CA. ... Good point. Contest Exuberantly, Hank, W6SX
                    Message 9 of 22 , Jan 3, 2014



                      On Fri, Jan 3, 2014 at 3:57 PM, iain macdonnell - N6ML <ar@...> wrote:

                      Not true - {exch} sends whatever is in the "sent exchange", and, as
                      you point out, that does not include the RST. I might use:

                      F2 Exch,{TX}599 {EXCH} {EXCH} ! {RX}

                      although in this case, I'll probably send only one {exch}, since I'm a
                      N6 and it's reasonable to guess I'm in CA.

                      Not as it works at W6SX. If Sent Exchange is CA, {EXCH} in a macro sends 599 CA.

                      If you're using ESM, you do NOT want '!' (his call) at the start,
                      because ESM automatically sends F5 followed by F2.

                      Good point.

                      Contest Exuberantly,

                      Hank, W6SX
                    • Tony McClenny
                      Hank, Your assistance is appreciated as are your thoughts and suggestions - thank you. - Tony, N3ME - 118 Ashwood Street Bethany Beach, DE 19930-9699 (302)
                      Message 10 of 22 , Jan 3, 2014

                        Hank,

                         

                        Your assistance is appreciated as are your thoughts and suggestions - thank you.

                         

                        - Tony, N3ME -


                        118 Ashwood Street
                        Bethany Beach, DE 19930-9699
                        (302) 539-5638

                        Grid:  FM28lm

                        http://www.n3me.net
                        Elecraft K3 # 2462

                        PVRC Member

                         

                        From: N1MMLogger@yahoogroups.com [mailto:N1MMLogger@yahoogroups.com] On Behalf Of Hank Garretson
                        Sent: Friday, January 03, 2014 18:13 PM
                        To: N1MMLogger@yahoogroups.com
                        Cc: NCCC Reflector
                        Subject: Re: [N1MM] RTTY setup

                         

                         

                         

                         

                        On Fri, Jan 3, 2014 at 2:47 PM, Tony McClenny <n3me@...> wrote:

                        Having trouble setting function keys and/or contest sent exchange for ARRL RTTY RU - which requires rst, state & serial (I think)

                         

                        error is "Missing/Invalid Exch" - your assistance would be appreciated - having an "old man moment" I guess.

                         

                        F1 CQ,{clrrx}{enter}{tx}cq cq ru de * (delaware) cq {rx}

                        F2 Exch,{enter}{tx}! 599- {exch} 599- {exch} de * bk{clearrit}{rx}

                        F3 TU,{enter}{tx}! tu de * qrz?{rx}{log}

                         

                        F1, CQ, CQ RU N3ME N3ME CQ

                        Rather than sending CQ twice, better to send your call which is useful information twice. DE is not useful in a CQ.

                        F2 Exch, ! 599 DE DE

                        Never, never send 599 twice--waste of everyone's time. DE is not useful before your call. In fact, you do not need to send your call as part of your exchange. BK is another time waster--just drop your carrier. I find it best to hard program exchange rather than using {exch} because if you send {exch} twice 599 gets sent twice.

                        F3, ! TU N3ME CQ

                        Again DE is a waste of time. CQ is the standard at the end of a QSO, not QRZ.

                        I'll leave it to you to put in the ENTERS and following-last SPACE at end of each transmission.

                         

                        What should go in the Contest "Sent Exchange"?

                         

                        DE

                        N1MM automatically adds 599.
                         

                        Currently using:  DE 001

                        and that does not work...

                         

                        Because RU exchange does not include NR.

                        CU tomorrow.

                        Contest Exuberantly,

                        Hank, W6SX

                         

                      • Robert Chudek - K0RC
                        / Not as it works at W6SX. If Sent Exchange is CA, {EXCH} in a macro sends 599 CA. / Which macro? The Run macro or the S&P macro? 73 de Bob - KØRC in MN ...
                        Message 11 of 22 , Jan 3, 2014
                          "Not as it works at W6SX. If Sent Exchange is CA, {EXCH} in a macro sends 599 CA."

                          Which macro? The Run macro or the S&P macro?

                          73 de Bob - KØRC in MN



                          On 1/3/2014 6:06 PM, Hank Garretson wrote:



                          On Fri, Jan 3, 2014 at 3:57 PM, iain macdonnell - N6ML <ar@...> wrote:

                          Not true - {exch} sends whatever is in the "sent exchange", and, as
                          you point out, that does not include the RST. I might use:

                          F2 Exch,{TX}599 {EXCH} {EXCH} ! {RX}

                          although in this case, I'll probably send only one {exch}, since I'm a
                          N6 and it's reasonable to guess I'm in CA.

                          Not as it works at W6SX. If Sent Exchange is CA, {EXCH} in a macro sends 599 CA.

                          If you're using ESM, you do NOT want '!' (his call) at the start,
                          because ESM automatically sends F5 followed by F2.

                          Good point.

                          Contest Exuberantly,

                          Hank, W6SX

                        • Tony McClenny
                          Iain, Thank you for taking time to help me with my concern - your suggestions are very much appreciated. - Tony, N3ME - 118 Ashwood Street Bethany Beach, DE
                          Message 12 of 22 , Jan 3, 2014

                            Iain,

                             

                            Thank you for taking time to help me with my concern - your suggestions are very much appreciated.

                             

                            - Tony, N3ME -


                            118 Ashwood Street
                            Bethany Beach, DE 19930-9699
                            (302) 539-5638

                            Grid:  FM28lm

                            http://www.n3me.net
                            Elecraft K3 # 2462

                            PVRC Member

                             

                            From: N1MMLogger@yahoogroups.com [mailto:N1MMLogger@yahoogroups.com] On Behalf Of iain macdonnell - N6ML
                            Sent: Friday, January 03, 2014 18:57 PM
                            To: N1MMLogger@yahoogroups.com
                            Cc: NCCC Reflector
                            Subject: Re: [N1MM] RTTY setup

                             

                             

                            On Fri, Jan 3, 2014 at 3:12 PM, Hank Garretson <w6sx@...> wrote:

                            >
                            >
                            >
                            >
                            >
                            > On Fri, Jan 3, 2014 at 2:47 PM, Tony McClenny <n3me@...> wrote:
                            >
                            >> Having trouble setting function keys and/or contest sent exchange for ARRL
                            >> RTTY RU - which requires rst, state & serial (I think)
                            >>
                            >>
                            >>
                            >> error is "Missing/Invalid Exch" - your assistance would be appreciated -
                            >> having an "old man moment" I guess.
                            >>
                            >>
                            >>
                            >> F1 CQ,{clrrx}{enter}{tx}cq cq ru de * (delaware) cq {rx}
                            >>
                            >> F2 Exch,{enter}{tx}! 599- {exch} 599- {exch} de * bk{clearrit}{rx}
                            >>
                            >> F3 TU,{enter}{tx}! tu de * qrz?{rx}{log}
                            >
                            >
                            > F1, CQ, CQ RU N3ME N3ME CQ
                            >
                            > Rather than sending CQ twice, better to send your call which is useful
                            > information twice. DE is not useful in a CQ.

                            The first 'CQ' is mostly redundant too, unless you're trying to drag
                            the message out a bit. I use something like:

                            F1 CQ,{TX}{ENTER}RU * * CQ{CLEARRIT} {RX}

                            > F2 Exch, ! 599 DE DE
                            >
                            > Never, never send 599 twice--waste of everyone's time. DE is not useful
                            > before your call. In fact, you do not need to send your call as part of your
                            > exchange. BK is another time waster--just drop your carrier. I find it best
                            > to hard program exchange rather than using {exch} because if you send {exch}
                            > twice 599 gets sent twice.

                            Not true - {exch} sends whatever is in the "sent exchange", and, as
                            you point out, that does not include the RST. I might use:

                            F2 Exch,{TX}599 {EXCH} {EXCH} ! {RX}

                            although in this case, I'll probably send only one {exch}, since I'm a
                            N6 and it's reasonable to guess I'm in CA.

                            If you're using ESM, you do NOT want '!' (his call) at the start,
                            because ESM automatically sends F5 followed by F2. Including '!' at
                            the end is good when you're running rate, since sometimes the start of
                            your exchange can get covered by other callers.

                            73,

                            ~iain / N6ML

                          • Tony McClenny
                            Rich, Thank you for such a prompt. polite, thorough explanation - - Tony, N3ME - 118 Ashwood Street Bethany Beach, DE 19930-9699 (302) 539-5638 Grid: FM28lm
                            Message 13 of 22 , Jan 3, 2014

                              Rich,

                               

                              Thank you for such a prompt. polite, thorough explanation -

                               

                              - Tony, N3ME -


                              118 Ashwood Street
                              Bethany Beach, DE 19930-9699
                              (302) 539-5638

                              Grid:  FM28lm

                              http://www.n3me.net
                              Elecraft K3 # 2462

                              PVRC Member

                               

                              From: N1MMLogger@yahoogroups.com [mailto:N1MMLogger@yahoogroups.com] On Behalf Of ve3ki@...
                              Sent: Friday, January 03, 2014 18:11 PM
                              To: N1MMLogger@yahoogroups.com
                              Subject: RE: [N1MM] RTTY setup

                               

                               

                              Your sent exchange is your state only - no serial number. Stations outside W/VE send serial numbers, but W/VE stations send only their state/province (plus a pro forma signal report, but you don't put that in the Sent Exchange box).

                              I believe the "Missing/Invalid Exchange" message you are referring to is issued when you try to log a contact with (wait for it) a missing or invalid exchange. My guess is that you probably tried to log both a state and a serial number, which is invalid; it's one or the other, depending on the call sign (W/VE vs. DX).

                              Are you aware of the sample function key files on the N1MM Logger web site? Go to www.n1mm.com, select Files > Sample Function Key Files from the menu, then click on Sample Function Key Files - Digital and look for ARRLRTTY.mc .

                              73,
                              Rich VE3KI

                            • Hank Garretson
                              ... Anywhere. {EXCH} Sent Exchange, based on the contents of the Sent Exchange box in the Contest Setup dialog. When the sent exchange includes a serial number
                              Message 14 of 22 , Jan 3, 2014



                                On Fri, Jan 3, 2014 at 4:50 PM, Robert Chudek - K0RC <k0rc@...> wrote:
                                 

                                "Not as it works at W6SX. If Sent Exchange is CA, {EXCH} in a macro sends 599 CA."

                                Which macro? The Run macro or the S&P macro?

                                Anywhere.

                                {EXCH} Sent Exchange, based on the contents of the Sent Exchange box in the Contest Setup dialog. When the sent exchange includes a serial number (001 or # in the Sent Exchange box), the number sent will be for the current QSO if there is a call sign in the entry window, or for the previous QSO if there is no call sign in the entry window.

                                73,

                                Hank, W6SX
                              • Adriano
                                I will signing as PR2X. Hpe to give some points to you guys. I also will be using n1mm mmtty here. GL all PY2ADR - Adriano Perazio ... I will signing as PR2X.
                                Message 15 of 22 , Jan 3, 2014
                                  I will signing as PR2X. Hpe to give some points to you guys.
                                  I also will be using n1mm mmtty here.
                                  GL all

                                  PY2ADR - Adriano Perazio


                                  Em 03/01/2014, às 22:52, Tony McClenny <n3me@...> escreveu:

                                   

                                  Rich,

                                   

                                  Thank you for such a prompt. polite, thorough explanation -

                                   

                                  - Tony, N3ME -


                                  118 Ashwood Street
                                  Bethany Beach, DE 19930-9699
                                  (302) 539-5638

                                  Grid:  FM28lm

                                  http://www.n3me.net
                                  Elecraft K3 # 2462

                                  PVRC Member

                                   

                                  From: N1MMLogger@yahoogroups.com [mai lto:N1MMLogger@yahoogroups.com] On Behalf Of ve3ki@...
                                  Sent: Friday, January 03, 2014 18:11 PM
                                  To: N1MMLogger@yahoogroups.com
                                  Subject: RE: [N1MM] RTTY setup

                                   

                                   

                                  Your sent exchange is your state only - no serial number. Stations outside W/VE send serial numbers, but W/VE stations send only their state/province (plus a pro forma signal report, but you don't put that in the Sent Exchange box).

                                  I believe the "Missing/Invalid Exchange" message you are referring to is issued when you try to log a contact with (wait for it) a missing or invalid exchange. My guess is that you probably tried to log both a state and a serial number, which is invalid; it's one or the other, depending on the call sign (W/VE vs. DX).

                                  Are you aware of the sample function key files on the N1MM Logger web site? Go to www.n1mm.com, select Files > Sample Function Key Files from the menu, then click on Sample Function Key Files - Digital and look for ARRLRTTY.mc .

                                  73,
                                  Rich VE3KI

                                • iain macdonnell - N6ML
                                  ... For me, it does, and always has done, exactly that - no 599 . 73, ~iain / N6ML
                                  Message 16 of 22 , Jan 3, 2014
                                    On Fri, Jan 3, 2014 at 4:55 PM, Hank Garretson <w6sx@...> wrote:
                                    >
                                    >
                                    >
                                    >
                                    >
                                    >
                                    > On Fri, Jan 3, 2014 at 4:50 PM, Robert Chudek - K0RC <k0rc@...> wrote:
                                    >>
                                    >>
                                    >>
                                    >> "Not as it works at W6SX. If Sent Exchange is CA, {EXCH} in a macro sends 599 CA."
                                    >>
                                    >> Which macro? The Run macro or the S&P macro?
                                    >
                                    > Anywhere.
                                    >
                                    > {EXCH} Sent Exchange, based on the contents of the Sent Exchange box in the Contest Setup dialog. When the sent exchange includes a serial number (001 or # in the Sent Exchange box), the number sent will be for the current QSO if there is a call sign in the entry window, or for the previous QSO if there is no call sign in the entry window.

                                    For me, it does, and always has done, exactly that - no '599'.

                                    73,

                                    ~iain / N6ML
                                  • Robert Chudek - K0RC
                                    If the Sent Exchange in the contest setup box contains CA, the {EXCH} macro placed in a Function Key will send CA , not 599 CA . Your written response
                                    Message 17 of 22 , Jan 3, 2014
                                      If the Sent Exchange in the contest setup box contains CA, the {EXCH} macro placed in a Function Key will send "CA", not "599 CA".

                                      Your written response suggested the latter.

                                      73 de Bob - KØRC in MN



                                      On 1/3/2014 6:55 PM, Hank Garretson wrote:

                                    • Larry Gauthier (K8UT)
                                      Tony, A complete set of Function Key definitions for RTTY Roundup can be found on the website in the Files Sample Function Keys Digital section. You may
                                      Message 18 of 22 , Jan 3, 2014
                                        Tony,
                                         
                                        A complete set of Function Key definitions for RTTY Roundup can be found on the website in the >Files >Sample Function Keys >Digital section. You may want to tweak them a little to suit your preferences, but they’ll work for most folks without modification.
                                         
                                         
                                        -larry (K8UT)
                                         
                                        Sent: Friday, January 03, 2014 5:47 PM
                                        Subject: RE: [N1MM] RTTY setup
                                         


                                        Having trouble setting function keys and/or contest sent exchange for ARRL RTTY RU - which requires rst, state & serial (I think)

                                         

                                        error is "Missing/Invalid Exch" - your assistance would be appreciated - having an "old man moment" I guess.

                                         

                                        F1 CQ,{clrrx}{enter}{tx}cq cq ru de * (delaware) cq {rx}

                                        F2 Exch,{enter}{tx}! 599- {exch} 599- {exch} de * bk{clearrit}{rx}

                                        F3 TU,{enter}{tx}! tu de * qrz?{rx}{log}

                                         

                                        What should go in the Contest "Sent Exchange"?

                                         

                                        Currently using:  DE 001

                                        and that does not work...

                                         

                                        Thanks for your help!!

                                         

                                        - Tony, N3ME -


                                        118 Ashwood Street
                                        Bethany Beach, DE 19930-9699
                                        (302) 539-5638

                                        Grid:  FM28lm

                                        http://www.n3me.net
                                        Elecraft K3 # 2462

                                        PVRC Member

                                         

                                        From: N1MMLogger@yahoogroups.com [mailto:N1MMLogger@yahoogroups.com] On Behalf Of ve3ki@...
                                        Sent: Friday, January 03, 2014 12:19 PM
                                        To: N1MMLogger@yahoogroups.com
                                        Subject: Re: [N1MM] RTTY setup

                                         

                                         

                                        You cannot use COM5 for both radio control from N1MM Logger and PTT/FSK keying in MMTTY. If you are using FSK, you must use a different COM port for FSK keying. If you are using AFSK, you can do PTT from N1MM Logger via COM5, but in that case MMTTY's PTT&FSK Port must be set to NONE.

                                        You said you have the K3's CONFIG:PTT-KEY set to RTS-OFF; to use this, in the Configurer click on the Set button for COM5 and set RTS to PTT and DTR to Always Off. Do not check any of the PTT via Radio Command buttons; you don't need radio command PTT when you are using RTS. Note that when you have the K3's PTT-KEY set to RTS-OFF, PTT will be active in all modes (i.e. to use QSK or semi-breakin in CW you will have to turn RTS to Always Off or else change PTT-KEY to OFF-OFF). Also, note that if you restart the computer while the K3 is turned on, the OS may toggle RTS a few times during PC startup, which will activate PTT on the radio.

                                        I don't know what you mean by "My digital window is greyed out under config editor in N1MM." If you mean that the Digital check box beside COM5 is greyed out, that is correct - it is not possible to use COM5 for both radio control and Digital mode FSK/PTT keying. You don't need to check any of the Digital check boxes. Their main use is for a port that is used for both CW keying and FSK keying, which is not relevant to the setup you have described.

                                        As for mode control, if you are using AFSK on the K3 then on the right side of the window you should set the RTTY boxes to AFSK, and the PSK boxes to PSK. For FSK RTTY you would set the RTTY boxes to RTTY. On the left side of the window, either of the first two choices will work with the K3. If you run into a situation where the function keys are in SSB mode instead of RTTY, or if the program won't let you edit the function keys because it says the operating mode is not set, type RTTY (or CW, SSB or PSK) into the call sign box in the Entry window and press Enter to set the operating mode in N1MM Logger.

                                        73,
                                        Rich VE3KI

                                      • Tony McClenny
                                        Larry, Thank you. Now setup and ready to run (literally) - as always your assistance is very valuable - thank you. - Tony, N3ME - 118 Ashwood Street Bethany
                                        Message 19 of 22 , Jan 3, 2014

                                          Larry,

                                           

                                          Thank you.  Now setup and ready to run (literally) - as always your assistance is very valuable - thank you.

                                           

                                          - Tony, N3ME -


                                          118 Ashwood Street
                                          Bethany Beach, DE 19930-9699
                                          (302) 539-5638

                                          Grid:  FM28lm

                                          http://www.n3me.net
                                          Elecraft K3 # 2462

                                          PVRC Member

                                           

                                          From: N1MMLogger@yahoogroups.com [mailto:N1MMLogger@yahoogroups.com] On Behalf Of Larry Gauthier (K8UT)
                                          Sent: Friday, January 03, 2014 20:25 PM
                                          To: N1MMLogger@yahoogroups.com
                                          Subject: Re: [N1MM] RTTY setup

                                           

                                           

                                          Tony,

                                           

                                          A complete set of Function Key definitions for RTTY Roundup can be found on the website in the >Files >Sample Function Keys >Digital section. You may want to tweak them a little to suit your preferences, but they’ll work for most folks without modification.

                                           

                                           

                                          -larry (K8UT)

                                           

                                          Sent: Friday, January 03, 2014 5:47 PM

                                          Subject: RE: [N1MM] RTTY setup

                                           




                                          Having trouble setting function keys and/or contest sent exchange for ARRL RTTY RU - which requires rst, state & serial (I think)

                                           

                                          error is "Missing/Invalid Exch" - your assistance would be appreciated - having an "old man moment" I guess.

                                           

                                          F1 CQ,{clrrx}{enter}{tx}cq cq ru de * (delaware) cq {rx}

                                          F2 Exch,{enter}{tx}! 599- {exch} 599- {exch} de * bk{clearrit}{rx}

                                          F3 TU,{enter}{tx}! tu de * qrz?{rx}{log}

                                           

                                          What should go in the Contest "Sent Exchange"?

                                           

                                          Currently using:  DE 001

                                          and that does not work...

                                           

                                          Thanks for your help!!

                                           

                                          - Tony, N3ME -


                                          118 Ashwood Street
                                          Bethany Beach, DE 19930-9699
                                          (302) 539-5638

                                          Grid:  FM28lm

                                          http://www.n3me.net
                                          Elecraft K3 # 2462

                                          PVRC Member

                                           

                                          From: N1MMLogger@yahoogroups.com [mailto:N1MMLogger@yahoogroups.com] On Behalf Of ve3ki@...
                                          Sent: Friday, January 03, 2014 12:19 PM
                                          To: N1MMLogger@yahoogroups.com
                                          Subject: Re: [N1MM] RTTY setup

                                           

                                           

                                          You cannot use COM5 for both radio control from N1MM Logger and PTT/FSK keying in MMTTY. If you are using FSK, you must use a different COM port for FSK keying. If you are using AFSK, you can do PTT from N1MM Logger via COM5, but in that case MMTTY's PTT&FSK Port must be set to NONE.

                                          You said you have the K3's CONFIG:PTT-KEY set to RTS-OFF; to use this, in the Configurer click on the Set button for COM5 and set RTS to PTT and DTR to Always Off. Do not check any of the PTT via Radio Command buttons; you don't need radio command PTT when you are using RTS. Note that when you have the K3's PTT-KEY set to RTS-OFF, PTT will be active in all modes (i.e. to use QSK or semi-breakin in CW you will have to turn RTS to Always Off or else change PTT-KEY to OFF-OFF). Also, note that if you restart the computer while the K3 is turned on, the OS may toggle RTS a few times during PC startup, which will activate PTT on the radio.

                                          I don't know what you mean by "My digital window is greyed out under config editor in N1MM." If you mean that the Digital check box beside COM5 is greyed out, that is correct - it is not possible to use COM5 for both radio control and Digital mode FSK/PTT keying. You don't need to check any of the Digital check boxes. Their main use is for a port that is used for both CW keying and FSK keying, which is not relevant to the setup you have described.

                                          As for mode control, if you are using AFSK on the K3 then on the right side of the window you should set the RTTY boxes to AFSK, and the PSK boxes to PSK. For FSK RTTY you would set the RTTY boxes to RTTY. On the left side of the window, either of the first two choices will work with the K3. If you run into a situation where the function keys are in SSB mode instead of RTTY, or if the program won't let you edit the function keys because it says the operating mode is not set, type RTTY (or CW, SSB or PSK) into the call sign box in the Entry window and press Enter to set the operating mode in N1MM Logger.

                                          73,
                                          Rich VE3KI

                                        • John McBee
                                          ... Rich- Do you run a K3? For some reason I still can t get this to work. I must have something not checked or something. It has never been this hard to get
                                          Message 20 of 22 , Jan 3, 2014
                                            On 1/3/2014 11:18 AM, ve3ki@... wrote:
                                             

                                            You cannot use COM5 for both radio control from N1MM Logger and PTT/FSK keying in MMTTY. If you are using FSK, you must use a different COM port for FSK keying. If you are using AFSK, you can do PTT from N1MM Logger via COM5, but in that case MMTTY's PTT&FSK Port must be set to NONE.

                                            You said you have the K3's CONFIG:PTT-KEY set to RTS-OFF; to use this, in the Configurer click on the Set button for COM5 and set RTS to PTT and DTR to Always Off. Do not check any of the PTT via Radio Command buttons; you don't need radio command PTT when you are using RTS. Note that when you have the K3's PTT-KEY set to RTS-OFF, PTT will be active in all modes (i.e. to use QSK or semi-breakin in CW you will have to turn RTS to Always Off or else change PTT-KEY to OFF-OFF). Also, note that if you restart the computer while the K3 is turned on, the OS may toggle RTS a few times during PC startup, which will activate PTT on the radio.

                                            I don't know what you mean by "My digital window is greyed out under config editor in N1MM." If you mean that the Digital check box beside COM5 is greyed out, that is correct - it is not possible to use COM5 for both radio control and Digital mode FSK/PTT keying. You don't need to check any of the Digital check boxes. Their main use is for a port that is used for both CW keying and FSK keying, which is not relevant to the setup you have described.

                                            As for mode control, if you are using AFSK on the K3 then on the right side of the window you should set the RTTY boxes to AFSK, and the PSK boxes to PSK. For FSK RTTY you would set the RTTY boxes to RTTY. On the left side of the window, either of the first two choices will work with the K3. If you run into a situation where the function keys are in SSB mode instead of RTTY, or if the program won't let you edit the function keys because it says the operating mode is not set, type RTTY (or CW, SSB or PSK) into the call sign box in the Entry window and press Enter to set the operating mode in N1MM Logger.

                                            73,
                                            Rich VE3KI

                                            Rich- Do you run a K3?  For some reason I still can't get this to work.  I must have something not checked or something.  It has never been this hard to get my k3 to work for rtty.  I usually just turn on n1mm and open the digital box and everthing is fine. I must have changed something and not known it.   I am using AFSK.  Like I said everything works in mmtty by itself, but when I start n1mm and hit tx on the mmtty window or a F key  nothing happens.  I have went through email several times and just can't seem to get this working.  What does the k3 menu need to be set at Config:  PTT-KEY?  I am only using 1 serial cable from k3 to computer which is com 5.  Not for sure if you seen my other post this morning on how my settings were.  I snipped two images of my settings and posted them in a email.   I have since turned the PTT-Key to rts-dtr and set the dtr and RTS to always off.   I have also uninstalled and reinstalled N1MM just in case I have messed something up somewhere.  I will keep working threw your email again and see if I come across what I have done. 
                                            Thanks again for your help and patients.
                                            John
                                            KM5PS
                                          • John McBee
                                            ... Rich- I turned off the k3 in config and turned on com port in mmtty to see what happens and all works in N1MM with digital window open. So still must have
                                            Message 21 of 22 , Jan 3, 2014
                                              On 1/3/2014 11:18 AM, ve3ki@... wrote:
                                               

                                              You cannot use COM5 for both radio control from N1MM Logger and PTT/FSK keying in MMTTY. If you are using FSK, you must use a different COM port for FSK keying. If you are using AFSK, you can do PTT from N1MM Logger via COM5, but in that case MMTTY's PTT&FSK Port must be set to NONE.

                                              You said you have the K3's CONFIG:PTT-KEY set to RTS-OFF; to use this, in the Configurer click on the Set button for COM5 and set RTS to PTT and DTR to Always Off. Do not check any of the PTT via Radio Command buttons; you don't need radio command PTT when you are using RTS. Note that when you have the K3's PTT-KEY set to RTS-OFF, PTT will be active in all modes (i.e. to use QSK or semi-breakin in CW you will have to turn RTS to Always Off or else change PTT-KEY to OFF-OFF). Also, note that if you restart the computer while the K3 is turned on, the OS may toggle RTS a few times during PC startup, which will activate PTT on the radio.

                                              I don't know what you mean by "My digital window is greyed out under config editor in N1MM." If you mean that the Digital check box beside COM5 is greyed out, that is correct - it is not possible to use COM5 for both radio control and Digital mode FSK/PTT keying. You don't need to check any of the Digital check boxes. Their main use is for a port that is used for both CW keying and FSK keying, which is not relevant to the setup you have described.

                                              As for mode control, if you are using AFSK on the K3 then on the right side of the window you should set the RTTY boxes to AFSK, and the PSK boxes to PSK. For FSK RTTY you would set the RTTY boxes to RTTY. On the left side of the window, either of the first two choices will work with the K3. If you run into a situation where the function keys are in SSB mode instead of RTTY, or if the program won't let you edit the function keys because it says the operating mode is not set, type RTTY (or CW, SSB or PSK) into the call sign box in the Entry window and press Enter to set the operating mode in N1MM Logger.

                                              73,
                                              Rich VE3KI

                                              Rich- I turned off the k3 in config and turned on com port  in mmtty to see what happens and all works in N1MM with digital window open.  So still must have a setting wrong in N1MM setup, because I know that if you have Com port selected in Config ports that it should
                                              read the K3's freq. and key the rig under mmtty (digital window), but it does not.  May just have to use it this way this weekend or until I figure out what I have done wrong in the settings.

                                              John
                                            • Hank Garretson
                                              I was wrong. {EXCH} does not send 599 CA. {EXCH} sends CA. {SENTRST}{EXCH} sends 599 CA. {SENTRST}{EXCH}{EXCH} sends 599 CA CA. (or whatever state you have
                                              Message 22 of 22 , Jan 3, 2014
                                                I was wrong. {EXCH} does not send 599 CA. {EXCH} sends CA.

                                                {SENTRST}{EXCH} sends 599 CA. {SENTRST}{EXCH}{EXCH} sends 599 CA CA.

                                                (or whatever state you have entered in Sent Exchange.

                                                Sorry for the confusion I created.

                                                Work you all tomorrow on many bands.

                                                Contest Exuberantly,

                                                Hank, W6SX
                                              Your message has been successfully submitted and would be delivered to recipients shortly.