Loading ...
Sorry, an error occurred while loading the content.

RE: N1MM now crashes when launched

Expand Messages
  • rich_ve3ki
    You can likely get the program working again as follows: 1. Make a backup copy of your N1MM Logger.ini file. Save it somewhere safe. There may be something in
    Message 1 of 9 , Sep 8, 2013
    • 0 Attachment

      You can likely get the program working again as follows:


      1. Make a backup copy of your N1MM Logger.ini file. Save it somewhere safe. There may be something in it that causes the problem, or it may contain clues as to what went wrong that might be useful in debugging the problem. Also, it may be useful in restoring your configuration. 

      2. Once your backup is safe, delete the N1MM Logger.ini file from your N1MM Logger program folder.

      3. Try starting up the Logger. It should open, but all of your configuration information will be lost, at least temporarily.


      At this point, you can either restore your configuration from scratch from within the program, or if you are brave, you can try recovering some of your configuration from the saved file as follows (if this fails, you can always go back to step 2 and try again):


      4. Shut down the Logger.

      5. Open the new N1MM Logger.ini file with Notepad (or another text editor).

      6. In a separate window, open your saved backup copy of the N1MM Logger.ini file with Notepad.

      7. Both files will contain many sections, each section starting with a header name between square brackets (e.g. [EntryWindow]) followed by several lines with variable names and their values (e.g. IsOpen=True). Not knowing exactly where the problem is, I can't be sure which sections are safe and which are not, but my guess is that you can safely copy the majority of these sections from the saved file and paste them into the new file in place of whatever is already there for that section, or at the end if there isn't a corresponding section in the new file. The ones not to copy over at first are any with Digital, PSK or MMVARI in the header name, since those appear to be the ones most likely related to the problem. Try copying every section except for these from the saved backup copy into the new ini file, then saving the new ini file.

      8. Start up the Logger. If the copy operation went successfully and there isn't a problem in that part of the file, your configuration except for the digital windows should have been restored. Before going on to the next step, you might want to shut down the Logger and make a separate backup of the new N1MM Logger.ini file (but do not overwrite your previous backup).

      9. You may even be able to restore some of your digital configuration, which might be important to you if you have previously used RTTY successfully. Repeat steps 4, 5, 6 and 7 again, this time copying over the sections with Digital in their header names (but not the ones with PSK or MMVARI in the header name).

      10. Repeat step 8; with luck, now your RTTY configuration will also be restored.

      11. Now before trying PSK, first go into the DI Setup window, select the MMVARI Setup tab, and in the lower right corner set the # of MMVARI Channels to 1. This is necessary to enable the newer multi-channel browser in MMVARI. Click on Save Configuration. Again, you might want to shut the Logger down and make a backup copy of the N1MM Logger.ini file to save what you have so far.


      12. Once you have your setup reconfigured except for PSK, and having saved a backup of the ini file up to this point, you can try setting up the PSK engine again. Knowing that you ran into trouble last time, keep notes on what you do for possible use in debugging. First try getting PSK working without the multi-channel browser, then once that is definitely OK and you have tested shutting down and restarting the program, you can move on to try enabling the multi-channel browser. 


      73,

      Rich VE3KI




      --- In N1MMLogger@yahoogroups.com, <n1mmlogger@yahoogroups.com> wrote:

      Hi
      I've been an N1MM user for a few years and never had this problem. This issue seems only to occur after I was setting up in MMVARI (for the first time) Multi Channel Receive. This was my first attempt at trying PSK mode.
      Now when I launch N1MM and just before it is fully loaded N1MM shuts down with the message;
      N1MM has stopped working.
      A problem caused the program to stop working correctly. Windows will close the program and notify you if a solution is available.

      I'm not sure if the problem stems from a setting in MMVARI but I can't think what else it could be and I'm unable to make change due to crashing. Tried PC off/on to no avail.

      Set up is PC Win7, N1MM ver 13.5.2, Rig K3, Microham MK2 and this set up has worked for months with no issues.

      I'd appreciate any advice.

      Steve GM4OSS
    • stevegm4oss
      Hi Rich Many thanks for sending a comprehensive description on what to do with the ini file. I found this very helpful. I ended up copying & pasting all but
      Message 2 of 9 , Sep 9, 2013
      • 0 Attachment

        Hi Rich

        Many thanks for sending a comprehensive description on what to do with the ini file. I found this very helpful. I ended up copying & pasting all but the PSK part of the ini file and I now have N1MM running as it should.


        I've only recently started using MMTY for RTTY with N1MM and had a few contest qsos. I've now just started PSK31 using MMVARI & N1MM but not managed a qso yet due to a couple of issues.


        With the above set up and with multi receive browser window open where i can see separate qsos, click on a call puts call into entry window and hit enter to call stn the K3 is keyed OK ( tx light on) but there is no RF power going out? Is there something wrong with setup? P.S. K3 is on DATA A mode.


        I've tried to set up the waterfall but not managed to do this so far. Is the multi receive window as good as or better than having the waterfall?


        Rich, thanks again and any info on PSK you can pass on will be very much appreciated.


        Steve GM4OSS



        --- In n1mmlogger@yahoogroups.com, <ve3ki@...> wrote:

        You can likely get the program working again as follows:


        1. Make a backup copy of your N1MM Logger.ini file. Save it somewhere safe. There may be something in it that causes the problem, or it may contain clues as to what went wrong that might be useful in debugging the problem. Also, it may be useful in restoring your configuration. 

        2. Once your backup is safe, delete the N1MM Logger.ini file from your N1MM Logger program folder.

        3. Try starting up the Logger. It should open, but all of your configuration information will be lost, at least temporarily.


        At this point, you can either restore your configuration from scratch from within the program, or if you are brave, you can try recovering some of your configuration from the saved file as follows (if this fails, you can always go back to step 2 and try again):


        4. Shut down the Logger.

        5. Open the new N1MM Logger.ini file with Notepad (or another text editor).

        6. In a separate window, open your saved backup copy of the N1MM Logger.ini file with Notepad.

        7. Both files will contain many sections, each section starting with a header name between square brackets (e.g. [EntryWindow]) followed by several lines with variable names and their values (e.g. IsOpen=True). Not knowing exactly where the problem is, I can't be sure which sections are safe and which are not, but my guess is that you can safely copy the majority of these sections from the saved file and paste them into the new file in place of whatever is already there for that section, or at the end if there isn't a corresponding section in the new file. The ones not to copy over at first are any with Digital, PSK or MMVARI in the header name, since those appear to be the ones most likely related to the problem. Try copying every section except for these from the saved backup copy into the new ini file, then saving the new ini file.

        8. Start up the Logger. If the copy operation went successfully and there isn't a problem in that part of the file, your configuration except for the digital windows should have been restored. Before going on to the next step, you might want to shut down the Logger and make a separate backup of the new N1MM Logger.ini file (but do not overwrite your previous backup).

        9. You may even be able to restore some of your digital configuration, which might be important to you if you have previously used RTTY successfully. Repeat steps 4, 5, 6 and 7 again, this time copying over the sections with Digital in their header names (but not the ones with PSK or MMVARI in the header name).

        10. Repeat step 8; with luck, now your RTTY configuration will also be restored.

        11. Now before trying PSK, first go into the DI Setup window, select the MMVARI Setup tab, and in the lower right corner set the # of MMVARI Channels to 1. This is necessary to enable the newer multi-channel browser in MMVARI. Click on Save Configuration. Again, you might want to shut the Logger down and make a backup copy of the N1MM Logger.ini file to save what you have so far.


        12. Once you have your setup reconfigured except for PSK, and having saved a backup of the ini file up to this point, you can try setting up the PSK engine again. Knowing that you ran into trouble last time, keep notes on what you do for possible use in debugging. First try getting PSK working without the multi-channel browser, then once that is definitely OK and you have tested shutting down and restarting the program, you can move on to try enabling the multi-channel browser. 


        73,

        Rich VE3KI




        --- In N1MMLogger@yahoogroups.com, <n1mmlogger@yahoogroups.com> wrote:

        Hi
        I've been an N1MM user for a few years and never had this problem. This issue seems only to occur after I was setting up in MMVARI (for the first time) Multi Channel Receive. This was my first attempt at trying PSK mode.
        Now when I launch N1MM and just before it is fully loaded N1MM shuts down with the message;
        N1MM has stopped working.
        A problem caused the program to stop working correctly. Windows will close the program and notify you if a solution is available.

        I'm not sure if the problem stems from a setting in MMVARI but I can't think what else it could be and I'm unable to make change due to crashing. Tried PC off/on to no avail.

        Set up is PC Win7, N1MM ver 13.5.2, Rig K3, Microham MK2 and this set up has worked for months with no issues.

        I'd appreciate any advice.

        Steve GM4OSS
      • rich_ve3ki
        Steve, Some thoughts: It sounds as if your PTT is working. When you do RTTY, is it FSK or AFSK? If it s AFSK, you have the necessary audio connections, and
        Message 3 of 9 , Sep 9, 2013
        • 0 Attachment

          Steve,


          Some thoughts:


          It sounds as if your PTT is working.


          When you do RTTY, is it FSK or AFSK? If it's AFSK, you have the necessary audio connections, and it's just a matter of software configuration. If it's FSK, there could be a few more things to check to get PSK working.


          Assuming your physical audio connections are OK, note that the sound card selection and settings are independent for the different digital engines, so it is possible to have the correct sound card selected in MMTTY and the wrong sound card selected in MMVARI. For MMVARI, the sound card selection is in the Digital Setup window under the MMVARI Setup tab; make sure that both the transmit and receive sound cards are set to the correct sound card output and input.


          The sound card level settings may also need adjustment. With the K3, you need to adjust the sound card playback level and the K3's MIC gain control so as to see 4-5 bars on the K3's ALC meter when the software is transmitting. Once you have the audio level set correctly, you adjust the output power using the K3's PWR control. For PSK modes, you should not set the PWR control above approximately 50% of full power (around 50 watts), as you will start to create IMD at higher power levels.


          You will want to have the waterfall working regardless of whether you are using the multi-channel browser or not. If you can't see signals on the waterfall, the multi-channel browser likely isn't going to pick up anything either. It's probably best to start out without the multi-channel browser, just to make sure that basic functions are all working. What the multi-channel receive browser gives you is automatic decoding of several different signals at different places on the waterfall at the same time, whereas the main receive pane in the DI window just decodes the one signal you are actually working. The main receive pane works basically the same way as in RTTY, whereas the multi-channel browser lets you monitor other signals nearby at the same time, something you cannot do so easily in RTTY.


          In order to ensure that you are transmitting on the same frequency you are receiving on, you would want to start out with NET enabled. There are some situations where you might want to turn NET off during a QSO, if either your TX and RX signals or the other station's TX and RX signals are not accurately aligned with each other, in order to prevent creeping up or down the band during a QSO, but for most cases, especially for contest-type QSOs, you will probably want to have NET on. AFC can be helpful, but it can sometimes pull you right off the signal you are trying to work onto a stronger nearby signal, so you may want to turn it off in those situations and do all your fine tuning by clicking in the waterfall. There are various adjustments you can make to AFC to make it work better depending on the conditions (how busy the band is and how strong signals are).


          73,

          Rich VE3KI




          --- In N1MMLogger@yahoogroups.com, <n1mmlogger@yahoogroups.com> wrote:

          Hi Rich

          Many thanks for sending a comprehensive description on what to do with the ini file. I found this very helpful. I ended up copying & pasting all but the PSK part of the ini file and I now have N1MM running as it should.


          I've only recently started using MMTY for RTTY with N1MM and had a few contest qsos. I've now just started PSK31 using MMVARI & N1MM but not managed a qso yet due to a couple of issues.


          With the above set up and with multi receive browser window open where i can see separate qsos, click on a call puts call into entry window and hit enter to call stn the K3 is keyed OK ( tx light on) but there is no RF power going out? Is there something wrong with setup? P.S. K3 is on DATA A mode.


          I've tried to set up the waterfall but not managed to do this so far. Is the multi receive window as good as or better than having the waterfall?


          Rich, thanks again and any info on PSK you can pass on will be very much appreciated.


          Steve GM4OSS



          --- In n1mmlogger@yahoogroups.com, <ve3ki@...> wrote:

          You can likely get the program working again as follows:


          1. Make a backup copy of your N1MM Logger.ini file. Save it somewhere safe. There may be something in it that causes the problem, or it may contain clues as to what went wrong that might be useful in debugging the problem. Also, it may be useful in restoring your configuration. 

          2. Once your backup is safe, delete the N1MM Logger.ini file from your N1MM Logger program folder.

          3. Try starting up the Logger. It should open, but all of your configuration information will be lost, at least temporarily.


          At this point, you can either restore your configuration from scratch from within the program, or if you are brave, you can try recovering some of your configuration from the saved file as follows (if this fails, you can always go back to step 2 and try again):


          4. Shut down the Logger.

          5. Open the new N1MM Logger.ini file with Notepad (or another text editor).

          6. In a separate window, open your saved backup copy of the N1MM Logger.ini file with Notepad.

          7. Both files will contain many sections, each section starting with a header name between square brackets (e.g. [EntryWindow]) followed by several lines with variable names and their values (e.g. IsOpen=True). Not knowing exactly where the problem is, I can't be sure which sections are safe and which are not, but my guess is that you can safely copy the majority of these sections from the saved file and paste them into the new file in place of whatever is already there for that section, or at the end if there isn't a corresponding section in the new file. The ones not to copy over at first are any with Digital, PSK or MMVARI in the header name, since those appear to be the ones most likely related to the problem. Try copying every section except for these from the saved backup copy into the new ini file, then saving the new ini file.

          8. Start up the Logger. If the copy operation went successfully and there isn't a problem in that part of the file, your configuration except for the digital windows should have been restored. Before going on to the next step, you might want to shut down the Logger and make a separate backup of the new N1MM Logger.ini file (but do not overwrite your previous backup).

          9. You may even be able to restore some of your digital configuration, which might be important to you if you have previously used RTTY successfully. Repeat steps 4, 5, 6 and 7 again, this time copying over the sections with Digital in their header names (but not the ones with PSK or MMVARI in the header name).

          10. Repeat step 8; with luck, now your RTTY configuration will also be restored.

          11. Now before trying PSK, first go into the DI Setup window, select the MMVARI Setup tab, and in the lower right corner set the # of MMVARI Channels to 1. This is necessary to enable the newer multi-channel browser in MMVARI. Click on Save Configuration. Again, you might want to shut the Logger down and make a backup copy of the N1MM Logger.ini file to save what you have so far.


          12. Once you have your setup reconfigured except for PSK, and having saved a backup of the ini file up to this point, you can try setting up the PSK engine again. Knowing that you ran into trouble last time, keep notes on what you do for possible use in debugging. First try getting PSK working without the multi-channel browser, then once that is definitely OK and you have tested shutting down and restarting the program, you can move on to try enabling the multi-channel browser. 


          73,

          Rich VE3KI




          --- In N1MMLogger@yahoogroups.com, <n1mmlogger@yahoogroups.com> wrote:

          Hi
          I've been an N1MM user for a few years and never had this problem. This issue seems only to occur after I was setting up in MMVARI (for the first time) Multi Channel Receive. This was my first attempt at trying PSK mode.
          Now when I launch N1MM and just before it is fully loaded N1MM shuts down with the message;
          N1MM has stopped working.
          A problem caused the program to stop working correctly. Windows will close the program and notify you if a solution is available.

          I'm not sure if the problem stems from a setting in MMVARI but I can't think what else it could be and I'm unable to make change due to crashing. Tried PC off/on to no avail.

          Set up is PC Win7, N1MM ver 13.5.2, Rig K3, Microham MK2 and this set up has worked for months with no issues.

          I'd appreciate any advice.

          Steve GM4OSS
        • stevegm4oss
          Hi Rich Thanks again for the reply. I think my mode for RTTYis FSK, K3 is set for FSK D mode and I ve had lots of QSOs this way. I ve also checked soundcard
          Message 4 of 9 , Sep 10, 2013
          • 0 Attachment

             Hi Rich

            Thanks again for the reply.

            I think my mode for RTTYis FSK, K3 is set for FSK D mode and I've had lots of QSOs this way.


            I've also checked soundcard settings for MMVARI and they seem OK. I have found that if I set K3 to PSK D then I appeared to put RF out on TX. Previously using DATA A meant no RF out. Tried calling a few stns using PSK D but not had any replies so not sure whether PSK D is correct mode, whether RF is really getting out or if I'm netted on their freq correctly.


            I was not able to set up soundcard level settings ie K3 mic gain, 4-5 bars on K3 ALC meter. Does this apply to me with my setup, K3, Microham MK2, Win 7 PC, logger32 & N1MM, MMTY & MMVARI engines?


            The waterfall is now sorted. It was my fault, when I selected waterfall I did not give it enough time to display. I now can see plenty of PSK stns on waterfall and multi channel.


            Thanks again for your help.


            Steve



            --- In n1mmlogger@yahoogroups.com, <ve3ki@...> wrote:

            Steve,


            Some thoughts:


            It sounds as if your PTT is working.


            When you do RTTY, is it FSK or AFSK? If it's AFSK, you have the necessary audio connections, and it's just a matter of software configuration. If it's FSK, there could be a few more things to check to get PSK working.


            Assuming your physical audio connections are OK, note that the sound card selection and settings are independent for the different digital engines, so it is possible to have the correct sound card selected in MMTTY and the wrong sound card selected in MMVARI. For MMVARI, the sound card selection is in the Digital Setup window under the MMVARI Setup tab; make sure that both the transmit and receive sound cards are set to the correct sound card output and input.


            The sound card level settings may also need adjustment. With the K3, you need to adjust the sound card playback level and the K3's MIC gain control so as to see 4-5 bars on the K3's ALC meter when the software is transmitting. Once you have the audio level set correctly, you adjust the output power using the K3's PWR control. For PSK modes, you should not set the PWR control above approximately 50% of full power (around 50 watts), as you will start to create IMD at higher power levels.


            You will want to have the waterfall working regardless of whether you are using the multi-channel browser or not. If you can't see signals on the waterfall, the multi-channel browser likely isn't going to pick up anything either. It's probably best to start out without the multi-channel browser, just to make sure that basic functions are all working. What the multi-channel receive browser gives you is automatic decoding of several different signals at different places on the waterfall at the same time, whereas the main receive pane in the DI window just decodes the one signal you are actually working. The main receive pane works basically the same way as in RTTY, whereas the multi-channel browser lets you monitor other signals nearby at the same time, something you cannot do so easily in RTTY.


            In order to ensure that you are transmitting on the same frequency you are receiving on, you would want to start out with NET enabled. There are some situations where you might want to turn NET off during a QSO, if either your TX and RX signals or the other station's TX and RX signals are not accurately aligned with each other, in order to prevent creeping up or down the band during a QSO, but for most cases, especially for contest-type QSOs, you will probably want to have NET on. AFC can be helpful, but it can sometimes pull you right off the signal you are trying to work onto a stronger nearby signal, so you may want to turn it off in those situations and do all your fine tuning by clicking in the waterfall. There are various adjustments you can make to AFC to make it work better depending on the conditions (how busy the band is and how strong signals are).


            73,

            Rich VE3KI




            --- In N1MMLogger@yahoogroups.com, <n1mmlogger@yahoogroups.com> wrote:

            Hi Rich

            Many thanks for sending a comprehensive description on what to do with the ini file. I found this very helpful. I ended up copying & pasting all but the PSK part of the ini file and I now have N1MM running as it should.


            I've only recently started using MMTY for RTTY with N1MM and had a few contest qsos. I've now just started PSK31 using MMVARI & N1MM but not managed a qso yet due to a couple of issues.


            With the above set up and with multi receive browser window open where i can see separate qsos, click on a call puts call into entry window and hit enter to call stn the K3 is keyed OK ( tx light on) but there is no RF power going out? Is there something wrong with setup? P.S. K3 is on DATA A mode.


            I've tried to set up the waterfall but not managed to do this so far. Is the multi receive window as good as or better than having the waterfall?


            Rich, thanks again and any info on PSK you can pass on will be very much appreciated.


            Steve GM4OSS



            --- In n1mmlogger@yahoogroups.com, <ve3ki@...> wrote:

            You can likely get the program working again as follows:


            1. Make a backup copy of your N1MM Logger.ini file. Save it somewhere safe. There may be something in it that causes the problem, or it may contain clues as to what went wrong that might be useful in debugging the problem. Also, it may be useful in restoring your configuration. 

            2. Once your backup is safe, delete the N1MM Logger.ini file from your N1MM Logger program folder.

            3. Try starting up the Logger. It should open, but all of your configuration information will be lost, at least temporarily.


            At this point, you can either restore your configuration from scratch from within the program, or if you are brave, you can try recovering some of your configuration from the saved file as follows (if this fails, you can always go back to step 2 and try again):


            4. Shut down the Logger.

            5. Open the new N1MM Logger.ini file with Notepad (or another text editor).

            6. In a separate window, open your saved backup copy of the N1MM Logger.ini file with Notepad.

            7. Both files will contain many sections, each section starting with a header name between square brackets (e.g. [EntryWindow]) followed by several lines with variable names and their values (e.g. IsOpen=True). Not knowing exactly where the problem is, I can't be sure which sections are safe and which are not, but my guess is that you can safely copy the majority of these sections from the saved file and paste them into the new file in place of whatever is already there for that section, or at the end if there isn't a corresponding section in the new file. The ones not to copy over at first are any with Digital, PSK or MMVARI in the header name, since those appear to be the ones most likely related to the problem. Try copying every section except for these from the saved backup copy into the new ini file, then saving the new ini file.

            8. Start up the Logger. If the copy operation went successfully and there isn't a problem in that part of the file, your configuration except for the digital windows should have been restored. Before going on to the next step, you might want to shut down the Logger and make a separate backup of the new N1MM Logger.ini file (but do not overwrite your previous backup).

            9. You may even be able to restore some of your digital configuration, which might be important to you if you have previously used RTTY successfully. Repeat steps 4, 5, 6 and 7 again, this time copying over the sections with Digital in their header names (but not the ones with PSK or MMVARI in the header name).

            10. Repeat step 8; with luck, now your RTTY configuration will also be restored.

            11. Now before trying PSK, first go into the DI Setup window, select the MMVARI Setup tab, and in the lower right corner set the # of MMVARI Channels to 1. This is necessary to enable the newer multi-channel browser in MMVARI. Click on Save Configuration. Again, you might want to shut the Logger down and make a backup copy of the N1MM Logger.ini file to save what you have so far.


            12. Once you have your setup reconfigured except for PSK, and having saved a backup of the ini file up to this point, you can try setting up the PSK engine again. Knowing that you ran into trouble last time, keep notes on what you do for possible use in debugging. First try getting PSK working without the multi-channel browser, then once that is definitely OK and you have tested shutting down and restarting the program, you can move on to try enabling the multi-channel browser. 


            73,

            Rich VE3KI




            --- In N1MMLogger@yahoogroups.com, <n1mmlogger@yahoogroups.com> wrote:

            Hi
            I've been an N1MM user for a few years and never had this problem. This issue seems only to occur after I was setting up in MMVARI (for the first time) Multi Channel Receive. This was my first attempt at trying PSK mode.
            Now when I launch N1MM and just before it is fully loaded N1MM shuts down with the message;
            N1MM has stopped working.
            A problem caused the program to stop working correctly. Windows will close the program and notify you if a solution is available.

            I'm not sure if the problem stems from a setting in MMVARI but I can't think what else it could be and I'm unable to make change due to crashing. Tried PC off/on to no avail.

            Set up is PC Win7, N1MM ver 13.5.2, Rig K3, Microham MK2 and this set up has worked for months with no issues.

            I'd appreciate any advice.

            Steve GM4OSS
          • rich_ve3ki
            PSK D is not the right mode to use with most soundcard PSK software. Like FSK D, it does not accept audio input from a sound card. The only way to use PSK D is
            Message 5 of 9 , Sep 10, 2013
            • 0 Attachment

              PSK D is not the right mode to use with most soundcard PSK software. Like FSK D, it does not accept audio input from a sound card. The only way to use PSK D is either from a CW paddle connected directly to the radio (not through a keyer), or from software that supports the KY CAT command (N1MM Logger does not; the K3 Utility and one or two other programs are the only ones that do). Unlike FSK D, PSK D does not accept keying input from the ACC connector on the K3 either.


              In both FSK D and PSK D, when PTT is asserted you will transmit a steady unmodulated carrier unless you have some means of supplying digital modulation to the transmitter. You won't make many QSOs transmitting an unmodulated carrier.


              With MMVARI, you should be using DATA A. If you want to try AFSK RTTY from MMTTY, you should use AFSK A. For either DATA A or AFSK A, you need audio input from the sound card to the Line In jack on the back of the radio. If you have a microHAM interface, you should consult the microHAM documentation at <http://www.microham.com/Downloads/MK2_N1MM_Setup.pdf>, and look at the section called "MMVARI setup with AFSK".


              73,

              Rich VE3KI




              --- In N1MMLogger@yahoogroups.com, <n1mmlogger@yahoogroups.com> wrote:

               Hi Rich

              Thanks again for the reply.

              I think my mode for RTTYis FSK, K3 is set for FSK D mode and I've had lots of QSOs this way.


              I've also checked soundcard settings for MMVARI and they seem OK. I have found that if I set K3 to PSK D then I appeared to put RF out on TX. Previously using DATA A meant no RF out. Tried calling a few stns using PSK D but not had any replies so not sure whether PSK D is correct mode, whether RF is really getting out or if I'm netted on their freq correctly.


              I was not able to set up soundcard level settings ie K3 mic gain, 4-5 bars on K3 ALC meter. Does this apply to me with my setup, K3, Microham MK2, Win 7 PC, logger32 & N1MM, MMTY & MMVARI engines?


              The waterfall is now sorted. It was my fault, when I selected waterfall I did not give it enough time to display. I now can see plenty of PSK stns on waterfall and multi channel.


              Thanks again for your help.


              Steve




            • stevegm4oss
              Hi Rich I m still no further forward but feel I ve taken too much of your time with my problem although I very much appreciate your input. When I used N1MM on
              Message 6 of 9 , Sep 12, 2013
              • 0 Attachment

                Hi Rich

                I'm still no further forward but feel I've taken too much of your time with my problem although I very much appreciate your input.


                When I used N1MM on digi modes I can selct MMTY or MMVARI from the DI window no problem and mode will automatically change on K3 from FSK D for RTTY & DATA A for PSK.


                I can rx/tx on RTTY no problem. Had plenty of QSOs.


                I can rx no problem PSK, plenty of stations on the waterfall as well as on the multi channel receive. When I transmit the K3 red tx light is lit but no RF out and no tones or sound of any kind through the headphones. This is the problem.


                The only small thing I've noticed is occasionally when I launch N1MM or if changes are made to the confg ports, mode control, audio,  I get this message "open error" "port 5 is already open"


                In MK2 Com 5 is selected for FSK, PTT ticked, 45 5N1.5

                N1MM is setup for SO1V, in config ports, hardware tab, Com 5 is ticked for digital.

                MMTTY & MMVARI both have PORTS selected for Com 5 ( I assume this is correct?)


                Does this setup feel OK to you?


                Thanks again.


                Steve



                --- In N1MMLogger@yahoogroups.com, <n1mmlogger@yahoogroups.com> wrote:

                PSK D is not the right mode to use with most soundcard PSK software. Like FSK D, it does not accept audio input from a sound card. The only way to use PSK D is either from a CW paddle connected directly to the radio (not through a keyer), or from software that supports the KY CAT command (N1MM Logger does not; the K3 Utility and one or two other programs are the only ones that do). Unlike FSK D, PSK D does not accept keying input from the ACC connector on the K3 either.


                In both FSK D and PSK D, when PTT is asserted you will transmit a steady unmodulated carrier unless you have some means of supplying digital modulation to the transmitter. You won't make many QSOs transmitting an unmodulated carrier.


                With MMVARI, you should be using DATA A. If you want to try AFSK RTTY from MMTTY, you should use AFSK A. For either DATA A or AFSK A, you need audio input from the sound card to the Line In jack on the back of the radio. If you have a microHAM interface, you should consult the microHAM documentation at <http://www.microham.com/Downloads/MK2_N1MM_Setup.pdf>, and look at the section called "MMVARI setup with AFSK".


                73,

                Rich VE3KI




                --- In N1MMLogger@yahoogroups.com, <n1mmlogger@yahoogroups.com> wrote:

                 Hi Rich

                Thanks again for the reply.

                I think my mode for RTTYis FSK, K3 is set for FSK D mode and I've had lots of QSOs this way.


                I've also checked soundcard settings for MMVARI and they seem OK. I have found that if I set K3 to PSK D then I appeared to put RF out on TX. Previously using DATA A meant no RF out. Tried calling a few stns using PSK D but not had any replies so not sure whether PSK D is correct mode, whether RF is really getting out or if I'm netted on their freq correctly.


                I was not able to set up soundcard level settings ie K3 mic gain, 4-5 bars on K3 ALC meter. Does this apply to me with my setup, K3, Microham MK2, Win 7 PC, logger32 & N1MM, MMTY & MMVARI engines?


                The waterfall is now sorted. It was my fault, when I selected waterfall I did not give it enough time to display. I now can see plenty of PSK stns on waterfall and multi channel.


                Thanks again for your help.


                Steve




              • rich_ve3ki
                All that serial port stuff you described is for PTT and FSK keying, which we already know is working. You haven t mentioned the connection that matters for
                Message 7 of 9 , Sep 12, 2013
                • 0 Attachment

                  All that serial port stuff you described is for PTT and FSK keying, which we already know is working.


                  You haven't mentioned the connection that matters for transmitting in DATA A, which is the audio connection from the output of the sound card (in the MKII, presumably) to your K3's Line In jack, and the corresponding configuration setup, i.e. the sound card playback/transmit setup. You need to ensure that the sound card configuration in N1MM Logger's DI Setup window for transmitting from your digital engine (MMVARI) is set to use the correct sound card output; that there is a physical connection from that output to the K3's Line In jack; that in DATA A the K3's MAIN:MIC SEL is set to LINE IN; and that the K3's MIC gain control is advanced sufficiently far so that you see 4-5 bars on the K3's ALC meter. Once you do that you should be getting RF output (in PSK31, set the K3's PWR control no higher than about 50 watts - but if it's set at 50 watts and the ALC meter is reading 4-5 bars, you should be seeing 50 watts on the RF output meter).


                  73,

                  Rich VE3KI




                  --- In N1MMLogger@yahoogroups.com, <n1mmlogger@yahoogroups.com> wrote:

                  Hi Rich

                  I'm still no further forward but feel I've taken too much of your time with my problem although I very much appreciate your input.


                  When I used N1MM on digi modes I can selct MMTY or MMVARI from the DI window no problem and mode will automatically change on K3 from FSK D for RTTY & DATA A for PSK.


                  I can rx/tx on RTTY no problem. Had plenty of QSOs.


                  I can rx no problem PSK, plenty of stations on the waterfall as well as on the multi channel receive. When I transmit the K3 red tx light is lit but no RF out and no tones or sound of any kind through the headphones. This is the problem.


                  The only small thing I've noticed is occasionally when I launch N1MM or if changes are made to the confg ports, mode control, audio,  I get this message "open error" "port 5 is already open"


                  In MK2 Com 5 is selected for FSK, PTT ticked, 45 5N1.5

                  N1MM is setup for SO1V, in config ports, hardware tab, Com 5 is ticked for digital.

                  MMTTY & MMVARI both have PORTS selected for Com 5 ( I assume this is correct?)


                  Does this setup feel OK to you?


                  Thanks again.


                  Steve



                  --- In N1MMLogger@yahoogroups.com, <n1mmlogger@yahoogroups.com> wrote:

                  PSK D is not the right mode to use with most soundcard PSK software. Like FSK D, it does not accept audio input from a sound card. The only way to use PSK D is either from a CW paddle connected directly to the radio (not through a keyer), or from software that supports the KY CAT command (N1MM Logger does not; the K3 Utility and one or two other programs are the only ones that do). Unlike FSK D, PSK D does not accept keying input from the ACC connector on the K3 either.


                  In both FSK D and PSK D, when PTT is asserted you will transmit a steady unmodulated carrier unless you have some means of supplying digital modulation to the transmitter. You won't make many QSOs transmitting an unmodulated carrier.


                  With MMVARI, you should be using DATA A. If you want to try AFSK RTTY from MMTTY, you should use AFSK A. For either DATA A or AFSK A, you need audio input from the sound card to the Line In jack on the back of the radio. If you have a microHAM interface, you should consult the microHAM documentation at <http://www.microham.com/Downloads/MK2_N1MM_Setup.pdf>, and look at the section called "MMVARI setup with AFSK".


                  73,

                  Rich VE3KI




                  --- In N1MMLogger@yahoogroups.com, <n1mmlogger@yahoogroups.com> wrote:

                   Hi Rich

                  Thanks again for the reply.

                  I think my mode for RTTYis FSK, K3 is set for FSK D mode and I've had lots of QSOs this way.


                  I've also checked soundcard settings for MMVARI and they seem OK. I have found that if I set K3 to PSK D then I appeared to put RF out on TX. Previously using DATA A meant no RF out. Tried calling a few stns using PSK D but not had any replies so not sure whether PSK D is correct mode, whether RF is really getting out or if I'm netted on their freq correctly.


                  I was not able to set up soundcard level settings ie K3 mic gain, 4-5 bars on K3 ALC meter. Does this apply to me with my setup, K3, Microham MK2, Win 7 PC, logger32 & N1MM, MMTY & MMVARI engines?


                  The waterfall is now sorted. It was my fault, when I selected waterfall I did not give it enough time to display. I now can see plenty of PSK stns on waterfall and multi channel.


                  Thanks again for your help.


                  Steve




                • GM4OSS
                  HI Rich Sorted!!! Changing MAIN:MIC SEL to LINE IN and turning up the TX pot on MK2 along with MIC gain on K3 gave me 4-5 bars on ALC meter. Even had a contact
                  Message 8 of 9 , Sep 13, 2013
                  • 0 Attachment
                    HI Rich
                    Sorted!!!
                    Changing MAIN:MIC SEL to LINE IN and turning up the TX pot on MK2 along with MIC gain on K3 gave me 4-5 bars on ALC meter. Even had a contact with PSK31.

                    Sorry it took me so long.

                    Thanks for your patience with me it is very much appreciated.

                    Cheers Steve


                    On Fri, Sep 13, 2013 at 3:18 AM, <ve3ki@...> wrote:
                     

                    All that serial port stuff you described is for PTT and FSK keying, which we already know is working.


                    You haven't mentioned the connection that matters for transmitting in DATA A, which is the audio connection from the output of the sound card (in the MKII, presumably) to your K3's Line In jack, and the corresponding configuration setup, i.e. the sound card playback/transmit setup. You need to ensure that the sound card configuration in N1MM Logger's DI Setup window for transmitting from your digital engine (MMVARI) is set to use the correct sound card output; that there is a physical connection from that output to the K3's Line In jack; that in DATA A the K3's MAIN:MIC SEL is set to LINE IN; and that the K3's MIC gain control is advanced sufficiently far so that you see 4-5 bars on the K3's ALC meter. Once you do that you should be getting RF output (in PSK31, set the K3's PWR control no higher than about 50 watts - but if it's set at 50 watts and the ALC meter is reading 4-5 bars, you should be seeing 50 watts on the RF output meter).


                    73,

                    Rich VE3KI




                    --- In N1MMLogger@yahoogroups.com, <n1mmlogger@yahoogroups.com> wrote:

                    Hi Rich

                    I'm still no further forward but feel I've taken too much of your time with my problem although I very much appreciate your input.


                    When I used N1MM on digi modes I can selct MMTY or MMVARI from the DI window no problem and mode will automatically change on K3 from FSK D for RTTY & DATA A for PSK.


                    I can rx/tx on RTTY no problem. Had plenty of QSOs.


                    I can rx no problem PSK, plenty of stations on the waterfall as well as on the multi channel receive. When I transmit the K3 red tx light is lit but no RF out and no tones or sound of any kind through the headphones. This is the problem.


                    The only small thing I've noticed is occasionally when I launch N1MM or if changes are made to the confg ports, mode control, audio,  I get this message "open error" "port 5 is already open"


                    In MK2 Com 5 is selected for FSK, PTT ticked, 45 5N1.5

                    N1MM is setup for SO1V, in config ports, hardware tab, Com 5 is ticked for digital.

                    MMTTY & MMVARI both have PORTS selected for Com 5 ( I assume this is correct?)


                    Does this setup feel OK to you?


                    Thanks again.


                    Steve



                    --- In N1MMLogger@yahoogroups.com, <n1mmlogger@yahoogroups.com> wrote:

                    PSK D is not the right mode to use with most soundcard PSK software. Like FSK D, it does not accept audio input from a sound card. The only way to use PSK D is either from a CW paddle connected directly to the radio (not through a keyer), or from software that supports the KY CAT command (N1MM Logger does not; the K3 Utility and one or two other programs are the only ones that do). Unlike FSK D, PSK D does not accept keying input from the ACC connector on the K3 either.


                    In both FSK D and PSK D, when PTT is asserted you will transmit a steady unmodulated carrier unless you have some means of supplying digital modulation to the transmitter. You won't make many QSOs transmitting an unmodulated carrier.


                    With MMVARI, you should be using DATA A. If you want to try AFSK RTTY from MMTTY, you should use AFSK A. For either DATA A or AFSK A, you need audio input from the sound card to the Line In jack on the back of the radio. If you have a microHAM interface, you should consult the microHAM documentation at <http://www.microham.com/Downloads/MK2_N1MM_Setup.pdf>, and look at the section called "MMVARI setup with AFSK".


                    73,

                    Rich VE3KI




                    --- In N1MMLogger@yahoogroups.com, <n1mmlogger@yahoogroups.com> wrote:

                     Hi Rich

                    Thanks again for the reply.

                    I think my mode for RTTYis FSK, K3 is set for FSK D mode and I've had lots of QSOs this way.


                    I've also checked soundcard settings for MMVARI and they seem OK. I have found that if I set K3 to PSK D then I appeared to put RF out on TX. Previously using DATA A meant no RF out. Tried calling a few stns using PSK D but not had any replies so not sure whether PSK D is correct mode, whether RF is really getting out or if I'm netted on their freq correctly.


                    I was not able to set up soundcard level settings ie K3 mic gain, 4-5 bars on K3 ALC meter. Does this apply to me with my setup, K3, Microham MK2, Win 7 PC, logger32 & N1MM, MMTY & MMVARI engines?


                    The waterfall is now sorted. It was my fault, when I selected waterfall I did not give it enough time to display. I now can see plenty of PSK stns on waterfall and multi channel.


                    Thanks again for your help.


                    Steve







                    --
                    73s de Steve GM4OSS
                  Your message has been successfully submitted and would be delivered to recipients shortly.