Loading ...
Sorry, an error occurred while loading the content.

Re: K-3/N1MM/K1EL

Expand Messages
  • rich_ve3ki
    This is long and detailed; hopefully it will address several different issues that your message raised. 1. If by the K1EL dialog box you mean one of the
    Message 1 of 5 , May 2, 2013
    • 0 Attachment
      This is long and detailed; hopefully it will address several different issues that your message raised.

      1. If by the "K1EL dialog box" you mean one of the programs supplied with the Winkeyer (WKTEST or WK2MGR), you can't have one of these programs running at the same time as N1MM Logger; if one of them is running, the Logger won't be able to connect to the Winkeyer.

      2. If version 12 referred to a version 12.xx.yy of N1MM Logger, then yes, you should update to the latest version, if only because the programming team only supports the current version.

      3. There are two COM ports involved. One is the port connected to the K3 for radio control, and the other is the port connected to the Winkeyer. They are probably both USB connections, but to the operating system they look like two separate serial ports, and in N1MM Logger they are configured as two separate ports. Whoever told you to use the same port for both apparently didn't want you to use your Winkeyer.

      4. The port number for the Winkeyer will be the same serial port number that was used in the K1EL software. Only one program can connect to this port at a time. I don't know what port number this is, but let's suppose for purposes of illustration that it is COM7. In the N1MM Logger Configurer, beside COM7 (the port number that the Winkeyer is connected to), the Radio box should read None (this serial port is not connected to a radio, it's connected to a Winkeyer). The CW/Other box beside this port should be checked. Click on the Set button for this port, set the Radio Nr to 1 and check the check box called "WinKey". The DTR, RTS and CW/PTT Port Addr will be set automatically, the "Allow ext interrupts" should not be checked, and the Two Radio Protocol and Footswitch should both be set to "None". PTT Delay of 20 or 30 ms is fine.

      5. After you have closed the port dialog, you can select the Winkey tab in the Configurer to adjust the Winkeyer's parameters. The defaults should work fine, or you can look at the illustration at www.n1mm.com, N1MM Logger Documentation > Digging Deeper > Contest Setup and Configuration > Configurer > 7. Configurer >Winkeyer Tab .

      6. Assuming you have already taken care of the CW keying cable between the Winkeyer and the K3's KEY IN jack, this should get the CW keying going, but there are some other things to consider.

      First, PTT. Do you want the program to switch the K3 to transmit for the entire duration of function key messages, or would you prefer to use semi-breakin or full QSK? If it's the former, there are several ways to do this, but the simplest way is to connect an RCA cable between the Winkeyer's PTT output and the K3's PTT IN jack. If you prefer semi-breakin or QSK, just don't connect this cable.

      7. The next thing is radio control. It looks as if you are using COM8 for radio control, i.e. COM8 is connected to the K3's RS232 port, perhaps using a KUSB or similar USB-to-serial adapter. Assuming this is correct, I would suggest some changes to the configuration for COM8.

      The Radio box for COM8 should read "Elecraft K3" (incidentally, it's not K-3, it's K3). If you are not using PTT or if you are using the Winkeyer for PTT, the CW/Other check box should not be checked for COM8. If you don't want to use the Winkeyer's PTT, you can check the CW/Other check box for COM8 to do PTT using the radio control port instead.

      Now, under the Set button, I am going to suggest some more changes to your settings:

      DTR: Set this to Always Off. You are using the Winkeyer for CW keying, not the radio control port. It is indeed possible to do CW via DTR with the K3, but you've paid for the Winkeyer, it does a better job, and you don't need or want to use both methods simultaneously.

      RTS: If you are using the Winkeyer for PTT, set this to Always Off. If you are not using the Winkeyer for PTT and you want hard-wired PTT control, you can set this to PTT, and set the K3's CONFIG:PTT-KEY menu setting to RTS-OFF.

      Radio Nr: set this to 1.

      Allow ext interrupts: UNcheck this box.

      Enable both hardware and software PTT: UNcheck this box.

      The three PTT via Radio Command boxes should be unchecked if you have connected the Winkeyer's PTT output to the radio's PTT IN jack, or if you have RTS set to control PTT. The only reason I can think of for checking any of these boxes with a K3 would be if you wanted to use PTT control in SSB and/or Digital modes, but not in CW, in which case you could check the box for the mode(s) you want PTT control in and leave it unchecked for CW. However, if you do decide to do this, make sure that RTS is set to Always Off and that there is nothing connected to the K3's PTT IN jack.

      73,
      Rich VE3KI


      --- In N1MMLogger@yahoogroups.com, "kh7xs" <cqtestk4xs@...> wrote:
      >
      > I accidentally hit send before I finsihed my message.
      >
      > Let me start all over.
      >
      > I can get my K-3 to key just fine when I key from the K1EL dialog box. All CW is good and there is a sidetone in the WinKey box.
      >
      > There is a problem getting the K-3 to key from N1MM. I was using version 12 and switched to the latest hoping it owuld help, but no luck. I can get the rig to respond to the N1MM when I press and F1 or F2 key, but the K-3 just goes into xmt mode and sends no CW. Once the message ends it goes back into rx mode. There is no sidetone from either the K-3 or the Winkey box. However, when CW is sent from just the K1EL dialog box to the K-3 there is a sidetone in both. To me it seems as though the K1EL is working fine, but not communicating with the N1MM.
      >
      > I am using Com 8 for the xcvr and all works as it should except the CW. Someone told me to use the same port for the K3. The settings are:
      > Com 8 Cw is toggled
      >
      > In the Com 8 box:
      > Speed: 38400
      > Parity: N
      > Data bits: 8
      > Stop: 1
      > DTR: CW
      > RTS: PTT
      > PTT Delay: 30
      > Allow int: Is toggled on
      > PTT: is toggled on CW
      > Two radio: None
      > Foot switch: None
      > CW port adr: 260
      >
      > Winkey Window:
      >
      > Keying mode: Iambic
      > Pin 5: PTT
      >
      > Output is going to the back of the K-3 into the "key port".
      >
      > Antennas and towers I know, computers are a mystery. Any help?
      >
      > 73 Bill KH7XS/K4XS
      >
    Your message has been successfully submitted and would be delivered to recipients shortly.