Loading ...
Sorry, an error occurred while loading the content.

79834Re: Not Communicating With Rig

Expand Messages
  • ve3iay
    Dec 1, 2011
    • 0 Attachment
      Riki,

      If you are using RTS for PTT on the K3, you should not check "PTT via Radio Command CW Mode". One PTT control method is sufficient, and on the K3, the hardware method is preferred.

      The "Allow ext interrupts" check box is for footswitches - it will have no effect on your radio control port, since nothing is connected to DSR on that port.

      As John said, you should upgrade to version 11.11.03 or newer. The fix that he introduced in that version affects not only LPT keying (which was where the problem was originally reported), but also other CW keying methods. Since the exact nature of the firmware glitch in the K3 that causes these hangups is unknown, we can't be 100% sure that the problem has been fully resolved, but it is less likely to happen with the newer version. If your K3 hangs in transmit again even with the newer version, please report the problem. Also, if hitting the K3's XMIT button doesn't clear it, please report that as well, as that would be an indication of a different kind of problem.

      73,
      Rich VE3KI


      --- In N1MMLogger@yahoogroups.com, "rikikline" <k7nj@...> wrote:
      >
      > Thank you Rich,
      >
      > I was keying the K3 with a cable connected to the K3 RS232 port going to the computer through a serial to USB adapter cable (that was purchased with the K3 from Elecraft). The K3 configuration was per the recommendation in the K3 manual, i.e. "PTT-KEY" was set to "rts-dtr".
      >
      > N1MM Logger configuration was tried with both checking and unchecking the configuration boxes saying "Allow ext interrupts" and "PTT via Radio Command CW Mode". DTR (pin 4) was set to CW, and RTS (pin 7) was set to PTT.
      >
      > I didn't try tapping the xmt button as you mentioned. Any more ideas?
      >
      > 73, Riki, K7NJ
      >
      >
      > --- In N1MMLogger@yahoogroups.com, "ve3iay" <ve3ki@> wrote:
      > >
      > > Re the hangups in transmit, there are known problems with the K3's software PTT control. Were you using PTT? In particular, were you using PTT via radio command? If so, turning off software PTT and switching to a hardware-only PTT method, or not using PTT at all, might solve that problem. Also, when it happened did you try just tapping the XMIT button on the radio? This has always worked for me.
      > >
      > > 73,
      > > Rich VE3KI
      > >
      > >
      > > --- In N1MMLogger@yahoogroups.com, "rikikline" <k7nj@> wrote:
      > > >
      > > > I installed N1MM Logger and checked it out thoroughly before the recent CQWW CW contest. Everything appeared OK. During the contest, the software would occassionally hang up or simply stop communicating with Telnet. I could usually resume the Telnet by clicking "Reset Radios" available by right-clicking the box with the Telnet spots. The radio getting hung-up was much more problematical. This would happen in S&P mode after sending an exchange. The radio (K3) would stay locked in transmit mode so that I couldn't copy the expected "TU",etc. I had to exit and re-enter N1MM Logger in order to continue. This would happen several times an hour. It appeared to be worse when there were more spot listings appearing. Any comments towards solving these problems would be greatly appreciated. 73, Riki, K7NJ
      > > >
      > >
      >
    • Show all 9 messages in this topic