Loading ...
Sorry, an error occurred while loading the content.

Re: H3Viewer Build 6

Expand Messages
  • bfhdbb0
    Hi Rob, Starting the Help 3 Viewer produces the message VS2010 Help not installed . On the machine in question, VS2010 help was installed from a remote
    Message 1 of 11 , Jan 4, 2010
    View Source
    • 0 Attachment
      Hi Rob,

      Starting the Help 3 Viewer produces the message "VS2010 Help not installed". On the machine in question, VS2010 help was installed from a remote location (did not install successfully from the VS2010 install), but it is local and accessible and displays as installed from the Help Library Manager. It would be nice to use the Help 3 viewer, as we got used to pushing the envelope with the Help2 Viewer. Any ideas?

      Thanks

      Dave Bignotti
    • Robert Chandler
      Hi Dave Anything interesting in the log (Options Show Debug). Here is what the code does... In the registry Look in
      Message 2 of 11 , Jan 4, 2010
      View Source
      • 0 Attachment
        Hi Dave
        Anything interesting in the log (Options > Show Debug).

        Here is what the code does...

        In the registry

        Look in
        HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Help3

        For limited RC preview the key is
        HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Help\v1.0


        --

        Under that key there are 2 string paths
        AppRoot=<path to EXE folder>
        LocalStore=<path to data>

        --

        So the EXEs are

        HelpLibManagerExe = AppRoot + '\HelpLibManager.exe';
        HelpLibAgentexe = AppRoot + '\MSHelpListener.exe';

        for the limited RC...

        HelpLibManagerExe = AppRoot + '\HelpLibManager.exe';
        HelpLibAgentexe = AppRoot + '\HelpLibAgent.exe';


        If paths are not found then we say "VS Help not installed".

        Back to you

        Thanks for your help
        Rob





        --- In MSHelp3@yahoogroups.com, "bfhdbb0" <dave.bignotti@...> wrote:
        >
        > Hi Rob,
        >
        > Starting the Help 3 Viewer produces the message "VS2010 Help not installed". On the machine in question, VS2010 help was installed from a remote location (did not install successfully from the VS2010 install), but it is local and accessible and displays as installed from the Help Library Manager. It would be nice to use the Help 3 viewer, as we got used to pushing the envelope with the Help2 Viewer. Any ideas?
        >
        > Thanks
        >
        > Dave Bignotti
        >
      • bfhdbb0
        Hi Rob, Sorry, I should have mentioned in original post that the log is empty and registry entries appear intact. AppRoot = C: Program Files Microsoft Help
        Message 3 of 11 , Jan 5, 2010
        View Source
        • 0 Attachment
          Hi Rob,

          Sorry, I should have mentioned in original post that the log is empty and registry entries appear intact.

          AppRoot = C:\Program Files\Microsoft Help Viewer\v1.0\
          LocalStore = C:\Documents and Settings\All Users\Application Data\Microsoft\HelpLibrary\

          EXEs are where they should be as well, so now I'm wondering if ther is something in the Agent or Manager config files that may be awry...

          Thanks

          Dave Bignotti

          --- In MSHelp3@yahoogroups.com, "Robert Chandler" <robertc@...> wrote:
          >
          > Hi Dave
          > Anything interesting in the log (Options > Show Debug).
          >
          > Here is what the code does...
          >
          > In the registry
          >
          > Look in
          > HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Help3
          >
          > For limited RC preview the key is
          > HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Help\v1.0
          >
          >
          > --
          >
          > Under that key there are 2 string paths
          > AppRoot=<path to EXE folder>
          > LocalStore=<path to data>
          >
          > --
          >
          > So the EXEs are
          >
          > HelpLibManagerExe = AppRoot + '\HelpLibManager.exe';
          > HelpLibAgentexe = AppRoot + '\MSHelpListener.exe';
          >
          > for the limited RC...
          >
          > HelpLibManagerExe = AppRoot + '\HelpLibManager.exe';
          > HelpLibAgentexe = AppRoot + '\HelpLibAgent.exe';
          >
          >
          > If paths are not found then we say "VS Help not installed".
          >
          > Back to you
          >
          > Thanks for your help
          > Rob
          >
          >
          >
          >
          >
          > --- In MSHelp3@yahoogroups.com, "bfhdbb0" <dave.bignotti@> wrote:
          > >
          > > Hi Rob,
          > >
          > > Starting the Help 3 Viewer produces the message "VS2010 Help not installed". On the machine in question, VS2010 help was installed from a remote location (did not install successfully from the VS2010 install), but it is local and accessible and displays as installed from the Help Library Manager. It would be nice to use the Help 3 viewer, as we got used to pushing the envelope with the Help2 Viewer. Any ideas?
          > >
          > > Thanks
          > >
          > > Dave Bignotti
          > >
          >
        • Rob Chandler
          I ll email you directly Dave so we can sort this out. Thanks Rob At 02:49 AM 6/01/2010, bfhdbb0 wrote: Hi Rob, Sorry, I should have mentioned in original post
          Message 4 of 11 , Jan 5, 2010
          View Source
          • 0 Attachment
            I'll email you directly Dave so we can sort this out.
            Thanks
            Rob

            At 02:49 AM 6/01/2010, bfhdbb0 wrote:
             

            Hi Rob,

            Sorry, I should have mentioned in original post that the log is empty and registry entries appear intact.

            AppRoot = C:\Program Files\Microsoft Help Viewer\v1.0\
            LocalStore = C:\Documents and Settings\All Users\Application Data\Microsoft\HelpLibrary\

            EXEs are where they should be as well, so now I'm wondering if ther is something in the Agent or Manager config files that may be awry...

            Thanks

            Dave Bignotti

            --- In MSHelp3@yahoogroups.com, "Robert Chandler" <robertc@...> wrote:
            >
            > Hi Dave
            > Anything interesting in the log (Options > Show Debug).
            >
            > Here is what the code does...
            >
            > In the registry
            >
            > Look in
            > HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Help3
            >
            > For limited RC preview the key is
            > HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Help\v1.0
            >
            >
            > --
            >
            > Under that key there are 2 string paths
            > AppRoot=<path to EXE folder>
            > LocalStore=<path to data>
            >
            > --
            >
            > So the EXEs are
            >
            > HelpLibManagerExe = AppRoot + '\HelpLibManager.exe';
            > HelpLibAgentexe = AppRoot + '\MSHelpListener.exe';
            >
            > for the limited RC...
            >
            > HelpLibManagerExe = AppRoot + '\HelpLibManager.exe';
            > HelpLibAgentexe = AppRoot + '\HelpLibAgent.exe';
            >
            >
            > If paths are not found then we say "VS Help not installed".
            >
            > Back to you
            >
            > Thanks for your help
            > Rob
            >
            >
            >
            >
            >
            > --- In MSHelp3@yahoogroups.com, "bfhdbb0" <dave.bignotti@> wrote:
            > >
            > > Hi Rob,
            > >
            > > Starting the Help 3 Viewer produces the message "VS2010 Help not installed". On the machine in question, VS2010 help was installed from a remote location (did not install successfully from the VS2010 install), but it is local and accessible and displays as installed from the Help Library Manager. It would be nice to use the Help 3 viewer, as we got used to pushing the envelope with the Help2 Viewer. Any ideas?
            > >
            > > Thanks
            > >
            > > Dave Bignotti
            > >
            >

          • Rob Chandler
            Hi Dave I just read the the subject. You are only on Build 6. Not compatible with the latest Help. Please download the latest build (16).
            Message 5 of 11 , Jan 5, 2010
            View Source
            • 0 Attachment
              Hi Dave
              I just read the the subject. You are only on Build 6. Not compatible with the latest Help. Please download the latest build (16).
              http://mshcmigrate.helpmvp.com/viewer

              Thanks
              Rob


              At 02:49 AM 6/01/2010, bfhdbb0 wrote:
               

              Hi Rob,

              Sorry, I should have mentioned in original post that the log is empty and registry entries appear intact.

              AppRoot = C:\Program Files\Microsoft Help Viewer\v1.0\
              LocalStore = C:\Documents and Settings\All Users\Application Data\Microsoft\HelpLibrary\

              EXEs are where they should be as well, so now I'm wondering if ther is something in the Agent or Manager config files that may be awry...

              Thanks

              Dave Bignotti

              --- In MSHelp3@yahoogroups.com, "Robert Chandler" <robertc@...> wrote:
              >
              > Hi Dave
              > Anything interesting in the log (Options > Show Debug).
              >
              > Here is what the code does...
              >
              > In the registry
              >
              > Look in
              > HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Help3
              >
              > For limited RC preview the key is
              > HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Help\v1.0
              >
              >
              > --
              >
              > Under that key there are 2 string paths
              > AppRoot=<path to EXE folder>
              > LocalStore=<path to data>
              >
              > --
              >
              > So the EXEs are
              >
              > HelpLibManagerExe = AppRoot + '\HelpLibManager.exe';
              > HelpLibAgentexe = AppRoot + '\MSHelpListener.exe';
              >
              > for the limited RC...
              >
              > HelpLibManagerExe = AppRoot + '\HelpLibManager.exe';
              > HelpLibAgentexe = AppRoot + '\HelpLibAgent.exe';
              >
              >
              > If paths are not found then we say "VS Help not installed".
              >
              > Back to you
              >
              > Thanks for your help
              > Rob
              >
              >
              >
              >
              >
              > --- In MSHelp3@yahoogroups.com, "bfhdbb0" <dave.bignotti@> wrote:
              > >
              > > Hi Rob,
              > >
              > > Starting the Help 3 Viewer produces the message "VS2010 Help not installed". On the machine in question, VS2010 help was installed from a remote location (did not install successfully from the VS2010 install), but it is local and accessible and displays as installed from the Help Library Manager. It would be nice to use the Help 3 viewer, as we got used to pushing the envelope with the Help2 Viewer. Any ideas?
              > >
              > > Thanks
              > >
              > > Dave Bignotti
              > >
              >

            • bfhdbb0
              Hi Rob, Very Strange. My last H3Viewer download was on Jan 4 and for some reason build 6 downloaded. Not sure how that happened. I m up and running with build
              Message 6 of 11 , Jan 6, 2010
              View Source
              • 0 Attachment
                Hi Rob,

                Very Strange. My last H3Viewer download was on Jan 4 and for some reason build 6 downloaded. Not sure how that happened. I'm up and running with build 16 now.

                Thanks!

                Dave Bignotti
              Your message has been successfully submitted and would be delivered to recipients shortly.