Loading ...
Sorry, an error occurred while loading the content.

33868Couldn't launch LR Agent on 2 terminal sessions

Expand Messages
  • taweesak.opasvorarat
    Sep 28, 2013
    • 0 Attachment

      Dear Expert:

       

      I have ...

       

          Load Controller V. 11.52 installed on Windows 7 Enterprise 64-bit

          Load Generator V.11.52 installed on Windows 2008 R2 SP1

       

      I am doing SAP testing and I want to maximize #Vusers running on my Load Generator box -- DL380 G5 box with 24 GB RAM.

       

      I found this post: http://h30499.www3.hp.com/t5/LoadRunner-Support-Forum/LoadRunner-11-and-SAP-can-t-run-more-than-100-VU-s-on-1/td-p/2392473#.UkZVhYn-LDd

       

      .. and wanted to do something similar: setting up 2 terminal sessions with 70 Vusers in each session doing SAPGUI.

       

      On the Load Generator machine, I created 2 users (with admin rights) -- lets say it is admin1 and admin2. I logged on as admin1 and ticked that "Enable Terminal Services" checkbox. Restarted the Agent as a process. I left the admin1 session on.

       

      Next I did the same for admin2.

       

      And I opened Taskmgr and saw 2 LoadRunner Agent Process running fine.

       

      In admin1 sessions, I saw: LR_Bridge, LR_Balancer, LR_Agent process running.

       

      In admin2 sessions, I saw only LR Agent running. 

       

      (At this point, there were only 2 sessions running -- no more.)

       

      Agent Log in admin2 session showed the following....

       

      DriverLogger: Log started at 28/09/2013 15:31:08 .

      28/09/2013 15:31:08 Error: Communication error: Failed to bind socket while calling bind function. [MsgId: MERR-10344]
      28/09/2013 15:31:08 Error: Two Way Communication Error: Function two_way_comm_create_acceptor failed. [MsgId: MERR-60999]
      28/09/2013 15:31:08 Error: Communication error: Failed to bind socket while calling bind function. [MsgId: MERR-10344]
      28/09/2013 15:31:08 Error: Two Way Communication Error: Function two_way_comm_create_acceptor failed. [MsgId: MERR-60999]
      28/09/2013 15:31:08 Error: Non Mdrv Message - Failed to create acceptor. [MsgId: MERR-29016]

       

      But in admin1 session, Agent Log showed nothing wrong.

       

      When I ran my test from the Controller, it seemed that Controller could talk to only admin1 session.

       

      (I already configured the Generator: Terminal Services Tab correctly..

       

      I ticked that Enable Terminal Services Manager checkbox, I set Number of terminals to 2 and Max Vusers per terminal to 70.

       

      I just put 20 Vusers only. I thought it were gonna split between the 2 sessions equally. But all were poured into session 1.

       

      I restarted LR agent process many times + restarted the box itself... but to no avail.

       

      Seemed like I can successfully launch only one agent. If I start Agent on admin2 session first, the Agent on admin2 works fine -- who comes first would win.

       

      I am totally confused on how to fix this...

      Need to get to about 2400 Vusers with 14 more DL380 boxes to configure. Now stuck on the first box and couldn't move forward.

       

      Appreciate your kind advice,

       

      --taweesak