Loading ...
Sorry, an error occurred while loading the content.

Re: Pactor setup help

Expand Messages
  • SV1UY
    ... [snip] ... Hi Hans, If you are still in Greece, are you near Athens? I ll buy you a cold beer if we meet! 73 de Demetre SV1UY
    Message 1 of 15 , Jun 22, 2013
    • 0 Attachment
      --- In LinuxRMS@yahoogroups.com, "Hans" <dl5di@...> wrote:
      [snip]
      > 73 from Greece
      >
      > de Hans DL5DI

      Hi Hans,

      If you are still in Greece, are you near Athens? I'll buy you a cold beer if we meet!

      73 de Demetre SV1UY
    • tharenberg
      Hi Hans, thanks for digging into that. I had some busy weeks without the time to take care about the system. I think I still have another problem with TNT,
      Message 2 of 15 , Jun 23, 2013
      • 0 Attachment
        Hi Hans,

        thanks for digging into that. I had some busy weeks without the time to take care about the system.

        I think I still have another problem with TNT, this is what happens at the console after starting when trying to run "runt main":

        TNT V1.9.1(BC,Sound) Packet Radio Terminal
        LINUX-Version, Created: 2000/06/06
        Copyright (C) 1993-99 by Mark Wahl, DL4YBG
        Further development by Matthias Hensler, WSPse 1998-2000
        Changes from version 1.2 to 1.3 by Johann Hanne, DH3MB
        GnuPG/PGP extensions by Walter Koch, DG9EP

        Maintainers: Berndt Josef Wulf (VK5ABN), Hans Mayer (OE1SMC), Matthias Hensler
        Thanks to many people for testing, suggestions and ideas
        Find new versions at http://www.wspse.de
        Send bugreports to mailto:tnt-bugs@...-aachen.de

        For license details see documentation.
        To get help: <ALT> H or <Esc> H
        Compiled on Apr 30 2013

        runt main
        Only while connected
        Try to connect to interface
        Can't connect to program, will try later again


        these "Try to connect to interface, Can't connect to program" messages continue appearing about once per minute (also without executing "runt main").

        changed tnt_bin_dir to /usr/lib/tnt, but that didn't help (and you have it left to "bin/", so that shouldn't be the issue). Unfortunately, I haven't found a way to do more logging in TNT to find out what exactly he's looking for.

        Enjoy your holiday time !!!

        73s

        Torsten DL1THM
      • Hans
        Hi Torsten! Some minor findings that may help to get that old tnt stuff work on actual Linux systems: - change the shell entry in the main script (1st line)
        Message 3 of 15 , Jun 27, 2013
        • 0 Attachment
          Hi Torsten!
          Some minor findings that may help to get that old tnt stuff work on actual Linux systems:

          - change the shell entry in the "main" script (1st line) from #/bin/sh to #/bin/bash
          I found that the default shell on some distributions is set to /bin/dash by default, which is very limited.
          In my case the shell did not support the shell command "read" with timeout option, which may cause the endless loop that you saw.

          - there is a call to a script "sfi.pl" in the main script.
          Remove that lines. This feature shows the actual solar flux message on connect. It only works if you have a dx-spider running on the same system which provides that information.

          However, I hope you can get the software run. It is many years old and outdated and was never maintained as there was never any interest.
          Most important would be to change tnt to support actual pty's, or to add that old pty-feature to the current kernel.

          DA5UDI is now back on air with that tnt setup. I could get it run after my return from vacation.

          73 de Hans DL5DI

          --- In LinuxRMS@yahoogroups.com, "tharenberg" <tharenberg@...> wrote:
          >
          > Hi Hans,
          >
          > thanks for digging into that. I had some busy weeks without the time to take care about the system.
          >
          > I think I still have another problem with TNT, this is what happens at the console after starting when trying to run "runt main":
          >
          > TNT V1.9.1(BC,Sound) Packet Radio Terminal
          > LINUX-Version, Created: 2000/06/06
          > Copyright (C) 1993-99 by Mark Wahl, DL4YBG
          > Further development by Matthias Hensler, WSPse 1998-2000
          > Changes from version 1.2 to 1.3 by Johann Hanne, DH3MB
          > GnuPG/PGP extensions by Walter Koch, DG9EP
          >
          > Maintainers: Berndt Josef Wulf (VK5ABN), Hans Mayer (OE1SMC), Matthias Hensler
          > Thanks to many people for testing, suggestions and ideas
          > Find new versions at http://www.wspse.de
          > Send bugreports to mailto:tnt-bugs@...
          >
          > For license details see documentation.
          > To get help: <ALT> H or <Esc> H
          > Compiled on Apr 30 2013
          >
          > runt main
          > Only while connected
          > Try to connect to interface
          > Can't connect to program, will try later again
          >
          >
          > these "Try to connect to interface, Can't connect to program" messages continue appearing about once per minute (also without executing "runt main").
          >
          > changed tnt_bin_dir to /usr/lib/tnt, but that didn't help (and you have it left to "bin/", so that shouldn't be the issue). Unfortunately, I haven't found a way to do more logging in TNT to find out what exactly he's looking for.
          >
          > Enjoy your holiday time !!!
          >
          > 73s
          >
          > Torsten DL1THM
          >
        • tharenberg
          Hi Hans, thanks again. I really hope we can get it running, the flexibility of the setup is really worth it :). ... Good point - changed that. ... I already
          Message 4 of 15 , Jun 29, 2013
          • 0 Attachment
            Hi Hans,

            thanks again.

            I really hope we can get it running, the flexibility of the setup is really worth it :).

            Let me follow up inline:

            --- In LinuxRMS@yahoogroups.com, "Hans" <dl5di@...> wrote:
            > - change the shell entry in the "main" script (1st line) from #/bin/sh to #/bin/bash
            > I found that the default shell on some distributions is set to /bin/dash by default, which is very limited.
            > In my case the shell did not support the shell command "read" with timeout option, which may cause the endless loop that you saw.

            Good point - changed that.

            >
            > - there is a call to a script "sfi.pl" in the main script.
            > Remove that lines. This feature shows the actual solar flux message on connect. It only works if you have a dx-spider running on the same system which provides that information.

            I already removed that from the beginning.

            > However, I hope you can get the software run. It is many years old and outdated and was never maintained as there was never any interest.
            > Most important would be to change tnt to support actual pty's, or to add that old pty-feature to the current kernel.

            Fortunately, Ubuntu Server kernels have

            CONFIG_LEGACY_PTYS=y

            so I think re-compiling the kernel is not needed (I don't see any related error).

            > DA5UDI is now back on air with that tnt setup. I could get it run after my return from vacation.

            congratulations!! Glad to hear that.


            Status here is now:

            I could get rid of the

            """
            Try to connect to interface
            Can't connect to program, will try later again
            """

            messages.

            There were "ACTBOX" commands for every SSID in the tnt-pt.up file, while cannot succeed as I don't run dpbox.

            While that has been solved, "runt main" will still complain "Only while connected" (and if I understand the source code correctly, this is the intended behavior, but maybe you could cross-check on your setup?).

            Unfortunately, the ham on PJ2 which gave me remote access to his Pactor (client) station (Airmail 2000) is on vacations now. Will try to reach the station from here but I only have a Windom antenna here so don't know if that will work. Do you know if there is any chance to run the program out of TNT even if the channel is not connected?

            73s and have a good weekend!

            Torsten
          Your message has been successfully submitted and would be delivered to recipients shortly.