Loading ...
Sorry, an error occurred while loading the content.
 

Re: rPI

Expand Messages
  • n8gfo
    Wrote too soon. After handling a few messages, the system is back to the nearly-endless looping when trying to deliver a message.
    Message 1 of 23 , Jan 14, 2013
      Wrote too soon. After handling a few messages, the system is back to the nearly-endless looping when trying to deliver a message.

      --- In LinuxRMS@yahoogroups.com, "n8gfo" wrote:
      >
      >
      > I think I've found the issue. The TNC in TERMINAL interface mode (KPC3+) had XFLOW turned on. I came out of KISS mode and turned XFLOW off, and I've been able to pass messages ok since.
      >
      > It would appear that the KPC3+ firmware doesn't ignore the parameters that would interfere with binary data when put in a binary data mode. I'm guessing that the string "FS Y" encodes into something that looks like an XOFF or XON. I may do a hex dump with listen to see what does appear on the wire.
      >
      > Thanks for your help. Thanks for the software.
      >
    • C Schuman
      I wonder is something may have happened to reset the flow ctl settings.
      Message 2 of 23 , Jan 14, 2013
        I wonder is something may have happened to reset the flow ctl settings.
        <<Charley>>

        n8gfo wrote:
        > Wrote too soon. After handling a few messages, the system is back to the nearly-endless looping when trying to deliver a message.
        >
        > --- In LinuxRMS@yahoogroups.com, "n8gfo" wrote:
        >>
        >> I think I've found the issue. The TNC in TERMINAL interface mode (KPC3+) had XFLOW turned on. I came out of KISS mode and turned XFLOW off, and I've been able to pass messages ok since.
        >>
        >> It would appear that the KPC3+ firmware doesn't ignore the parameters that would interfere with binary data when put in a binary data mode. I'm guessing that the string "FS Y" encodes into something that looks like an XOFF or XON. I may do a hex dump with listen to see what does appear on the wire.
        >>
        >> Thanks for your help. Thanks for the software.
        >>
        >
        >
        >
        >
        > ------------------------------------
        >
        > Yahoo! Groups Links
        >
        >
        >
        >
      • n8gfo
        Nope. Still off. As are the streamsw, xon, xoff characters, flow and echo, trflow, and ax25lvl2.
        Message 3 of 23 , Jan 16, 2013
          Nope. Still off. As are the streamsw, xon, xoff characters, flow and echo, trflow, and ax25lvl2.

          --- In LinuxRMS@yahoogroups.com, C Schuman wrote:
          >
          > I wonder is something may have happened to reset the flow ctl settings.
          > < >
          >
        Your message has been successfully submitted and would be delivered to recipients shortly.