Loading ...
Sorry, an error occurred while loading the content.

Re: No SP in keyboard mode (Pactor?)

Expand Messages
  • Hans
    Hi Charles! It is the setting which tells the server if it is Packet-Radio or Pactor. Mode 6 should be Packet-Radio. But there are 2 mistakes in your
    Message 1 of 17 , Jul 20, 2012
    • 0 Attachment
      Hi Charles!

      It is the <mode> setting which tells the server if it is Packet-Radio or Pactor.
      Mode 6 should be Packet-Radio.

      But there are 2 mistakes in your configfile which might cause issues in general. You should see errors in your logfile:

      I would have to dig in very old specs to find out if probably the frequency has any influence.
      You set the frequency to roughly 1 MHz (999.999 Hz) and you used decimals which is not OK.
      The frequency has to be set in Hertz without decimals.

      I also see that you obviously run 2 interfaces with the same callsign settings. See what the nice manpage tells you on that:

      callsign
      Callsign defines the full callsign, with SSID, for the channel. This
      must be unique for all active channel definitions in the file.


      This link shows that AD7UF-10 is using Packet-Radio:
      http://www.winlink.org/dotnet/status/RMSDetails.aspx?callsign=AD7UF-10&stationcall=AD7UF-10

      Whatever AD7UF-10 channel it may be :-)

      Hans, DL5DI

      --- In LinuxRMS@yahoogroups.com, "charles_boling" <charles-yahoo@...> wrote:
      >
      >
      >
      > Notice the difference in wording between these two servers:
      >
      > > WL2K is designed for automatic message transfer using WL2K's B2 Forwarding protocol but
      > > supports limited keyboard commands on HF Pactor:
      >
      > vs.
      >
      > > Winlink 2000 is designed for automatic message transfer using Airmail, Paclink, or
      > > other client programs that support the B2F protocol. It will also accept limited
      > > keyboard commands on telnet and VHF connections.
      >
      >
      > Elsewhere* I saw a comment from a WL2k developer (KN6KB) noting that "Keyboard commands on HF Pactor are very limited to basically just killing a pending message."
      > * http://groups.yahoo.com/group/BPQ32/message/2556
      >
      > My mode is set to 6 (Packet > 38400 baud), but I wonder if there's something else in my config that's making the CMS think the client's coming in via Pactor, rather than VHF-or-better packet?
      >
      > Here's what my channels look like:
      > <rmschannels>
      > <channel name="sm0" type="ax25" active="yes">
      > <basecall>AD7UF</basecall>
      > <callsign>AD7UF-10</callsign>
      > <gridsquare>CN86pa</gridsquare>
      > <frequency>144950000</frequency>
      > <mode>0</mode>
      > <autoonly>0</autoonly>
      > <baud>1200</baud>
      > <power>55</power>
      > <height>30</height>
      > <gain>0</gain>
      > <direction>0</direction>
      > <hours>24/7</hours>
      > <groupreference>1</groupreference>
      > <statuschecker>
      > /usr/local/bin/rmschanstat $type $name $callsign
      > </statuschecker>
      > </channel>
      > <channel name="bpq0" type="ax25" active="yes">
      > <basecall>AD7UF</basecall>
      > <callsign>AD7UF-10</callsign>
      > <gridsquare>CN86pa</gridsquare>
      > <frequency>999.999</frequency>
      > <mode>6</mode>
      > <autoonly>0</autoonly>
      > <baud>9600</baud>
      > <power>0</power>
      > <height>0</height>
      > <gain>0</gain>
      > <direction>0</direction>
      > <hours>24/7</hours>
      > <groupreference>1</groupreference>
      > <statuschecker>
      > /usr/local/bin/rmschanstat $type $name $callsign
      > </statuschecker>
      > </channel></rmschannels>
      >
      > gateway.conf doesn't have anything that should relate, but here it is, just for completeness:
      > GWCALL=AD7UF-10
      > GRIDSQUARE=CN86pa
      > CHANNELFILE=/etc/rmsgw/channels.xml
      > BANNERFILE=/etc/rmsgw/banner
      > LOGFACILITY=rms
      > LOGMASK=DEBUG
      >
    • charles_boling
      ... Oops, I since fixed that; it s now 999999999 on the BPQ channel. ... Oops #2. I originally only had one active at a time, but somewhere along the line, I
      Message 2 of 17 , Jul 21, 2012
      • 0 Attachment
        > You set the frequency to roughly 1 MHz (999.999 Hz) and you used decimals which is not OK.

        Oops, I since fixed that; it's now 999999999 on the BPQ channel.

        > I also see that you obviously run 2 interfaces with the same callsign settings.

        Oops #2. I originally only had one active at a time, but somewhere along the line, I activated them both with the same SSID. (I actually had SSID #11 set aside for WL2k on BPQ, but wasn't using it. I'm going to discuss *that* a new thread.)


        Now, I tried this again tonight, and here's the weird part:

        Leaving both channels set to SSID #10 (which matches what's in gateway.conf and is what I registered) -- I know I'm not supposed to do that -- IT NOW WORKS NORMALLY! I see the full range of options for the CMS, and can send mail, etc. I no longer get the restricted set of options that started this thread, and I have no idea why it changed. One part of me is just really happy that it's working now and wants to just forget about it; the other part is really bothered by it. I think the first part is winning, though...

        Thanks for your advise, everyone!
      • charles_boling
        ... Never mind; it s been so long since I messed with the file that I forgot, is only for the benefit of rmsgw_aci, and setting it to no doesn t
        Message 3 of 17 , Jul 21, 2012
        • 0 Attachment
          > Oops #2. I originally only had one active at a time, but somewhere along the line, I activated them both with the same SSID. (I actually had SSID #11 set aside for WL2k on BPQ, but wasn't using it. I'm going to discuss *that* a new thread.)

          Never mind; it's been so long since I messed with the file that I forgot, <active> is only for the benefit of rmsgw_aci, and setting it to "no" doesn't disable it or anything. So, I set both ports to #10, but only one is declared active. I believe life is good!
        Your message has been successfully submitted and would be delivered to recipients shortly.