Loading ...
Sorry, an error occurred while loading the content.

Re: Triyng to-do a make to compile perl module and getting error?

Expand Messages
  • eykamp
    Have you installed gcc? You can either compile it yourself, or (as I did) install a copy from the Kuro binaries file. # tar xvfz /mnt/share/gcc-2.95.3.tar.gz
    Message 1 of 3 , Jan 3, 2005
    • 0 Attachment
      Have you installed gcc? You can either compile it yourself, or (as I
      did) install a copy from the Kuro binaries file.

      # tar xvfz /mnt/share/gcc-2.95.3.tar.gz

      Chris



      --- In LinkStation_General@yahoogroups.com, "rd_montavon"
      <rd_montavon@r...> wrote:
      >
      > Im tring to complie the IO-Tty perl module and are getting this:
      >
      > root@NAS001:/mnt/share/perl-modules/IO-Tty-1.02# perl Makefile.PL
      > Now let's see what we can find out about your system
      > (logfiles of failing tests are available in the conf/ dir)...
      >
      > ERROR: cannot run the configured compiler 'ppc_82xx-gcc'
      > (see conf/compilerok.log). Please fix this by adjusting
      > perls Config.pm, creating a symlink to the right location
      > or maybe by just adding it to your PATH. You could also build
      > perl yourself.
      >
      > root@NAS001:/mnt/share/perl-modules/IO-Tty-1.02#
      > cat ./conf/compilerok.log
      > ppc_82xx-gcc: installation problem, cannot exec `/usr/lib/gcc-
      > lib/powerpc-hardhat-linux/2.95.3/cc1': Exec format error
      > root@NAS001:/mnt/share/perl-modules/IO-Tty-1.02#
      >
      > Im on fireware 1.45 and untared the make and perl from binary as
      > instructed for other utils...any help would be appreciated.
    • Christopher Eykamp
      Perhaps I should clarify: # cd / # tar xvfz /mnt/share/gcc-2.95.3.tar.gz Carry on, Chris ... Perhaps I should clarify: # cd / # tar xvfz
      Message 2 of 3 , Jan 4, 2005
      • 0 Attachment

        Perhaps I should clarify:

         

        # cd /

        # tar xvfz /mnt/share/gcc-2.95.3.tar.gz

        Carry on,

         

        Chris

         

         


        On Tue, 04 Jan 2005 06:20:46 -0000, eykamp wrote:
        >�Have you installed gcc?��You can either compile it yourself, or (as
        >�I did) install a copy from the Kuro binaries file.
        >
        >�# tar xvfz /mnt/share/gcc-2.95.3.tar.gz
        >
        >�Chris
        >
        >
        >�--- In LinkStation_General@yahoogroups.com, "rd_montavon"
        >�<rd_montavon@r...>�wrote:
        >
        >>
        >>�Im tring to complie the IO-Tty perl module and are getting this:
        >>
        >>�root@NAS001:/mnt/share/perl-modules/IO-Tty-1.02# perl Makefile.PL
        >>�Now let's see what we can find out about your system
        >>�(logfiles of failing tests are available in the conf/ dir)...
        >>
        >>�ERROR: cannot run the configured compiler 'ppc_82xx-gcc' (see
        >>�conf/compilerok.log).��Please fix this by adjusting perls
        >>�Config.pm, creating a symlink to the right location or maybe by
        >>�just adding it to your PATH.��You could also build perl yourself.
        >>
        >>�root@NAS001:/mnt/share/perl-modules/IO-Tty-1.02#
        >>�cat ./conf/compilerok.log
        >>�ppc_82xx-gcc: installation problem, cannot exec `/usr/lib/gcc-
        >>�lib/powerpc-hardhat-linux/2.95.3/cc1': Exec format error
        >>�root@NAS001:/mnt/share/perl-modules/IO-Tty-1.02#
        >>
        >>�Im on fireware 1.45 and untared the make and perl from binary as
        >>�instructed for other utils...any help would be appreciated.
        >
        >
        >�Yahoo! Groups Links
        >
        >�To visit your group on the web, go to:
        >�http://groups.yahoo.com/group/LinkStation_General/
        >
        >�To unsubscribe from this group, send an email to:
        >�LinkStation_General-unsubscribe@yahoogroups.com
        >
        >�Your use of Yahoo! Groups is subject to the Yahoo! Terms of Service.

      Your message has been successfully submitted and would be delivered to recipients shortly.