Loading ...
Sorry, an error occurred while loading the content.

Re: [ARM] uboot not loading kernel from hd on kurobox-pro

Expand Messages
  • purdyd_at_wisheights
    ... circumstances) ... kurobox-pro ... hi lyahk, what are you env var settings? From my experience, I seem to be able to boot about anything bootable from the
    Message 1 of 3 , Mar 21, 2008
    • 0 Attachment
      --- In LinkStation_General@yahoogroups.com, Guennadi Liakhovetski
      <g.liakhovetski@...> wrote:
      >
      > Hi,
      >
      > haven't found an answer in the wiki nor in the forums. From some wiki
      > pages it seems U-Boot on ARM-based systems should be able to load the
      > kernel from the SATA disk with the (confusing under these
      circumstances)
      > "ext2load ide" command. However, this doesn't work for me on a
      kurobox-pro
      > with the stock u-boot. Do I need a newer u-boot? Or can I replace the
      > kernel in NAND with a self-compiled one?
      >
      > Thanks
      > Guennadi
      > ---
      > Guennadi Liakhovetski
      >

      hi lyahk,

      what are you env var settings?

      From my experience, I seem to be able to boot about anything bootable
      from the SATA drive using the command sequence:

      ext2load ide 0:1 0x00100000 /boot/uImage
      setenv bootargs console=ttyS0,115200 root=/dev/sda1 rw
      bootm 0x00100000


      My kurpro is disassemble now (ready to solder on JTAG headers) so I
      can't check it for sure... I seem to remember something about the
      kuropro needing ext2load ide 0:1 and teh LSpro needing 1:1 instead...
      can't remember for sure...

      HTH

      davygravy
    • purdyd_at_wisheights
      ... circumstances) ... kurobox-pro ... Oh, BTW, the 0:1 and 1:1 are for when I was booting foonas from the hdd, not any kind of stockish firmware that used
      Message 2 of 3 , Mar 21, 2008
      • 0 Attachment
        --- In LinkStation_General@yahoogroups.com, Guennadi Liakhovetski
        <g.liakhovetski@...> wrote:
        >
        > Hi,
        >
        > haven't found an answer in the wiki nor in the forums. From some wiki
        > pages it seems U-Boot on ARM-based systems should be able to load the
        > kernel from the SATA disk with the (confusing under these
        circumstances)
        > "ext2load ide" command. However, this doesn't work for me on a
        kurobox-pro
        > with the stock u-boot. Do I need a newer u-boot? Or can I replace the
        > kernel in NAND with a self-compiled one?
        >
        > Thanks
        > Guennadi
        > ---
        > Guennadi Liakhovetski
        >


        Oh, BTW, the 0:1 and 1:1 are for when I was booting foonas from the
        hdd, not any kind of stockish firmware that used Buffalo's/Revogear's
        partition setup that we are familiar w/ in the LSPro's, for instance.
        ... for foonas I was using sda1 as the root partition, with kernel and
        rootfs all on sda1.
      Your message has been successfully submitted and would be delivered to recipients shortly.