Loading ...
Sorry, an error occurred while loading the content.

Re: Retrave data after firmware update

Expand Messages
  • djprice1973
    SUCCESS! Ignore my last post. Your instructions worked perfectly, I just hadn t realised that the CASE of the letters of the shares was important, Media didn t
    Message 1 of 4 , Jan 28, 2008
      SUCCESS! Ignore my last post. Your instructions worked perfectly, I
      just hadn't realised that the CASE of the letters of the shares was
      important, Media didn't work the same as MEDIA. Who'd of thunk it!
      Well probably lots of people but this telnet stuff is slightly out of
      my techie comfort zone!

      Once again, many thanks, I am sooooo relived to have that data back.


      --- In LinkStation_General@yahoogroups.com, "musikgoat"
      <musikgoat@...> wrote:
      > --- In LinkStation_General@yahoogroups.com, "djprice1973" <djp@> wrote:
      > >
      > > I've just re-applied firmware 2.06 to my week old 500GB Linkstation
      > > HS-DHGL after it stopped working properly and it has removed all my
      > > old shares and replaced the root directory with an empty 'share'
      > > directory.
      > >
      > > The Navi program is still showing the drive as 41% full with 195GB of
      > > data stored on it but I can't see any of it.
      > >
      > > Prior to reapplying the firmware I pressed the reset button on the
      > > back of the unit to see if this would solve the original problem but
      > > it didn't.
      > >
      > > Has anyone got any idea how to retrieve the old data? I've bought a
      > > 500GB Drivestation to back the stuff up on but only had half of it
      > > backed up before the problem happened so will be gutted if I loose the
      > > other half. Please help!
      > >
      > Hi, good news!!
      > If the drive space is showing as being used, you can likely gain
      > access and look at the location of where the shares are actually
      > stored and retrieve any data.
      > ACP_commander
      > http://downloads.nas-central.org/TOOLS/ALL_LS_KB_ARM9/ACP_COMMANDER/
      > works as a perfect means to get access.
      > ACP Commander needs Java (on your PC) to run. See java.com for the
      > latest runtime version for your operating system.
      > Once (java) installed, enter the following in a command (cmd) window
      > from the same directory that contains your downloaded
      > acp_commander.jar file.
      > java -jar acp_commander.jar -t <IP ADDRESS> -o
      > Replace <IP ADDRESS> with the address of your Linkstation.
      > You should see something similar to the following:
      > Using random connID VALUE = FB6A7FCF57E6
      > Using target: (your IP address)
      > ** NO message **
      > ** NO message **
      > Password changed.
      > You now have telnet access with a blank (null) password until next
      > If it doesn't work, try again. It could take up 5 times before
      > acp_commander works.
      > You can now telnet into the IP address as root with no password.
      > From the command window enter:
      > telnet <ip linkstation>
      > you should get to a shell in the linkstation.
      > it will start with sh# and likely the hostname. here type:
      > ls -a /mnt/disk1/
      > likely your directories should show. All of the shared folders that
      > you used instead of the default share folder that the device uses.
      > You can likely just re connect the Samba share connection that the Web
      > interface establishes in Shared Folders settings. Just create a new
      > shared folder, and name it the exact same name as the old one. At
      > this point your windows computers should be able to access it.
      > Remember to reboot your Linkstation after all of this, as the ACP
      > commander utilities methods can cause a firmware update to cause
      > troublesome errors.
      > -goat
    Your message has been successfully submitted and would be delivered to recipients shortly.