Loading ...
Sorry, an error occurred while loading the content.

rendezvous and Linkstation PPC (v.1)

Expand Messages
  • MB
    Hi everyone, I ve installed the latest rendezvous server on my Linkstation, compiled it, installed the configuration scripts and the startup symbolic links.
    Message 1 of 1 , Nov 25, 2007
    • 0 Attachment
      Hi everyone,

      I've installed the latest rendezvous server on my
      Linkstation, compiled it, installed the configuration scripts and the
      startup symbolic links. The mdnsresponder process is definitely
      running, but no services appear to be advertised according to my Mac
      running 10.4.11. My rendezvous.conf file looks like this:

      linkafp
      _afpovertcp._tcp
      path=/
      548

      linkftp
      _ftp._tcp
      none
      21

      linkstation
      _telnet._tcp
      none
      23

      My startup script looks like this:

      # cat /etc/rc.d/init.d/rendezvous

      #!/bin/sh
      #
      # A startup script for the Rendezvous mDNS Responder
      #
      # chkconfig: 345 98 2
      # description: This script is used to start the rendezvous \
      # server as a background process.\
      #
      # Usage /etc/init.d/mdnsresponder start|stop|reload|restart|status

      # Source function library.
      #. /etc/rc.d/init.d/functions

      RDV_CONF=/etc/rendezvous.conf
      RDV_PID=/var/run/mDNSResponder.pid
      prog=Rendezvous
      exe=/usr/local/sbin/mDNSResponderPosix

      start() {
      echo -n "Starting $prog: "
      $exe -f $RDV_CONF -b
      RETVAL=$?
      echo
      }

      stop() {
      echo -n "Stopping $prog: "
      /sbin/killall -s KILL $exe
      RETVAL=$?
      echo
      }
      RETVAL=$?
      echo
      }

      reload()
      {
      echo -n $"Reloading $prog:"
      /sbin/killall -s HUP $exe
      RETVAL=$?
      echo
      }


      case "$1" in
      start)
      start
      ;;
      stop)
      stop
      ;;
      reload)
      reload
      ;;
      restart)
      stop
      start
      ;;
      status)
      status $exe
      RETVAL=$?
      ;;
      *)
      echo "Usage: mdnsresponder {start|stop|reload|restart|status}"
      exit 1
      esac



      Does anyone have any ideas as to how to troubleshoot this?

      Many thanks in advance,
      MB
    Your message has been successfully submitted and would be delivered to recipients shortly.