Loading ...
Sorry, an error occurred while loading the content.

Re: How do I find an expert to help with a Debian + software install?

Expand Messages
  • James Stewart
    ... Note I m not using Freelink, but instead it s predecessor which was a Debian Woody image assembled by a Japanese person back in the beginning of time as
    Message 1 of 2 , Oct 23, 2007
    • 0 Attachment
      --- In LinkStation_General@yahoogroups.com, "aliishaq" <aliishaq@...> wrote:
      > Basically, I have an HG250 (PPC) Buffalo Linkstation NAS connected to
      > my home network. I installed Freelink firmware v1.11, Debian v2.4, and
      > Webmin before I ran out of time.

      Note I'm not using Freelink, but instead it's predecessor which was a Debian "Woody"
      image assembled by a Japanese person back in the beginning of time as for as the LS
      is concerned. Since it is Debian, it as since been greatly enhanced and updated to
      the current Debian "stable" (etch), thanks to Debian's good package management
      tools. That said, even though I'm not exactly Freelink, I should be close to it.

      > When I run apt-get upgrade the process aborts because it needs the
      > kernel to version 2.6 while when I try to install the upgrade

      Yes, the Debian "Unstable" and "Testing" versions now require the 2.6 version kernel.
      You can (as I have for now) downgrade slightly to Debian "stable" (Etch) which will
      run fine on the 2.4 series kernel. To do this, edit the /etc/apt/sources.list file replacing
      all words that say "unstable" or "testing" with "stable". They may also be using the
      Toy Story names like "Sid", in which case replace it with "etch". Then run "apt-get
      update" followed by "apt-get dist-upgrade" and you will end up with Debian "Stable".
      The current "Stable" isn't too out-of-date at the moment, at least not as bad as it
      usually is.

      > Also I installed webmin and the Samba module within it and have made
      > users and done everything that the samba file sharing module wiki
      > tells me, but my windoes xp computer does not see the share...

      I don't use Webmin myself (even though I'm the one that originally suggested it to
      this users group!), I use "swat" instead which is an optional component of the Samba
      suite to configure Samba. To use it, install it (apt-get install swat) then
      edit /etc/inetd.conf and uncoment the line at the bottom that says "swat", then
      restart inetd (/etc/init.d/inetd restart). After this you can bring up the Samba config
      page from any browser that can reach your machine at port 901
      (http://linkstationIP:901). It is really quite nice.

      That said, all these programs do is edit the file /etc/samba/smb.conf anyway, so you
      might try posting it and we can take a look and tell you what is wrong with it.

      You also normally need to create users that match your Windows users and set the
      passwords for access, but the shares should at least show up even without this step.
      They keep changing the "backend" method of how this is done, I still use the old
      command of "smbpasswd -a <username>", and enter all the passwords manually
      which still works even though there are now better methods, like I think you can new
      use the Microsoft tools from a Windows machine to do this if you have things set up
      right, I've never done it however. I've gotten real rusty with Windows these days.

      > 1. Update Debian to Kernel version 2.6

      I know this post is a few days old, but I guess I too need to upgrade my PPC based LS
      to 2.6, so keep reminding me and maybe I'll work on it this weekend or so and let you
      know what I find out. I've been a little scared about it and have been putting it off but
      would really like to get a few things working again. (like DHCP server and USB CD
      writers, that don't work on my currently installed kernel.

      > 2. Get Samba shares working and accessible to other users on the network

      Samba is under constant change "under-the-hood", as it tries to keep up with all the
      changes in implementation over on the Microsoft side, but post your smb.conf file
      and we'll have a look. Perhaps Webmin isn't correctly configuring the version of
      Samba you have.

      > 3. Install and get torrentflux or other comparable torrent client working

      Hmm Torrentflux looks pretty neat. Putting the client on a web page looks like a
      good idea. I just worry about all the overhead with PHP and MySQL needed to be
      running in the backend. I've been just using bittoranado directly on my LS, either in
      the X based GUI using VNC or more often just the command-line version, (inside
      of "screen" so it will run by itself detached from a terminal session) because
      bittorrent seems to tax the poor LS pretty heavily so I try to keep things a light as
      possible, especially if I'm running more than one torrent. Maybe I should give it a try
      anyway. Anyone care to comment about how well all this would likely run on a LS
      with 64 megs of RAM? At least it should be better than trying to run one of those
      many Java based clients.

      > 4. Be able to connect external USB drives

      That should be working. Although my DVD recorder isn't detected with the factory
      2.4 kernel, although it did with the Kurobox kernel, but at USB 1.1 speeds. You do
      know that you have to manually "mount" these drives however unless you install a
      service that does this automatically for you? I don't have one working on my LS at
      the moment, probably another thing I should work on, perhaps after the 2.6 kernel
      upgrade so it will be working with udev which should be less problematic. This all
      seems to work good on a Ubuntu running Laptop I have, so I'll see how they are doing
      it. Hopefully it isn't a Gnome-desktop only feature.

      > 5. get uPNP server working

      I'm probably not the right guy for this sort of thing. What are you trying to do
      exactly, make the LS be a media server to some uPNP capable client devices? If so
      lots of others have done this on a LS, I'm just not one of them.


      Anyway, I'll be real busy the later part of this week, but I can help you work through
      some if this as long as you are willing to learn and work on some of it too. All this
      Unix/Linux stuff has a steep learning curve, but I've found it quite rewarding.

      I don't check messages on this group quite as well as I used to, and generally get
      them from a RSS feed to my yahoo custom page, but they are delayed be a couple
      of days by the time they show up, so feel free to email me directly at
      wartstew@... if you don't get fast enough response on this group. I'll keep
      posting back to this group so the discussion can remain public.

    Your message has been successfully submitted and would be delivered to recipients shortly.