Loading ...
Sorry, an error occurred while loading the content.

Adding External Drive to Linkstation

Expand Messages
  • davidhomfray
    I have added a 500Gb external drive to the back of the linkstation and it works fine. The only problem is I see it on the root, which basically shows info,
    Message 1 of 2 , Jul 20, 2007
    View Source
    • 0 Attachment
      I have added a 500Gb external drive to the back of the linkstation and
      it works fine. The only problem is I see it on the root, which
      basically shows info, share, LPT and the USB Disk and when I map it it
      is given its own drive.

      I pretty positive this is impossible but is there away where the USB
      drive is seen as part of the main disk. I use a linkTheatre which looks
      at only the main drive and can't look at the usb disk as well.

      If there was a way where I could somehow get both the main and the USB
      drive seen on the Linktheatre without having to have a PC on that would
      be brilliant.

      nice
    • James Stewart
      Do you have a hacked LS with shell access? If so do this: ln -s I just verified it with a Linux machine I
      Message 2 of 2 , Jul 20, 2007
      View Source
      • 0 Attachment
        Do you have a hacked LS with shell access? If so do this:

        ln -s <path where drive is now> <path where you want it>

        I just verified it with a Linux machine I have sitting in the same
        room where I just made the cdrom drive which is normally mounted at
        /mnt/cdrom show up at /home/jstewart/cdrom through the windows share
        to \\linux\jstewart. In this case the command was:

        ln -s /mnt/cdrom /home/jstewart/cdrom

        If you DON'T have shell access to the LS you can still do this by
        removing the drive and putting it in another computer running Linux.
        (Do you still have to run the "fix-magic" utility to unlock the
        drive?). Then just create the sym-link there and put the drive back
        into the Linkstation.

        If for some reason it still doesn't work then there may be an option
        set in the samba config on the linkstation to NOT follow sym-links. I
        doubt that this will be a problem however. It is possible change this
        if you can keep the web interface from changing it back.

        Good Luck

        James

        --- In LinkStation_General@yahoogroups.com, "davidhomfray"
        <homfray@...> wrote:
        >
        > I have added a 500Gb external drive to the back of the linkstation and
        > it works fine. The only problem is I see it on the root, which
        > basically shows info, share, LPT and the USB Disk and when I map it it
        > is given its own drive.
        >
        > I pretty positive this is impossible but is there away where the USB
        > drive is seen as part of the main disk. I use a linkTheatre which looks
        > at only the main drive and can't look at the usb disk as well.
        >
        > If there was a way where I could somehow get both the main and the USB
        > drive seen on the Linktheatre without having to have a PC on that would
        > be brilliant.
        >
        > nice
        >
      Your message has been successfully submitted and would be delivered to recipients shortly.