Loading ...
Sorry, an error occurred while loading the content.

Re: [LinkStation_General] Re: Mount WINDOWS (SMB) share

Expand Messages
  • javamarket
    Hi Andre, It is a Linkstation PPC. I have managed to realize that a) samba isn t installed b) if downloaded it and am trying to get it installed. Any help in
    Message 1 of 14 , Jul 19, 2007
    • 0 Attachment
      Hi Andre,
       
      It is a Linkstation PPC.
       
      I have managed to realize that
       
      a) samba isn't installed
       
      b) if downloaded it and am trying to get it installed.
       
      Any help in this regard would be great.
       
      At this point I have extracted the "latest" from samba.org and when I run the ./configure command that should create the makefile I receive:
       
      bash-2.05a# ./configure
      SAMBA VERSION: 3.0.25b
      LIBREPLACE_LOCATION_CHECKS: START
      checking build system type... powerpc-unknown-linux-gnu
      checking host system type... powerpc-unknown-linux-gnu
      checking target system type... powerpc-unknown-linux-gnu
      LIBREPLACE_LOCATION_CHECKS: END
      LIBREPLACE_CC_CHECKS: START
      checking for gcc... no
      checking for cc... no
      checking for cl.exe... no
      configure: error: no acceptable C compiler found in $PATH
      See `config.log' for more details.

      ----- Original Message ----
      From: lalunas10 <lalunas10@...>
      To: LinkStation_General@yahoogroups.com
      Sent: Thursday, July 19, 2007 5:49:37 AM
      Subject: [LinkStation_General] Re: Mount WINDOWS (SMB) share

      --- In LinkStation_ General@yahoogro ups.com, "-" <javamarket@ ...> wrote:
      >
      > Hello All -
      >
      > I'm able to mount NFS shares with
      >
      > mount somesource/share /mnt/share/somewher e
      >
      > without any issues.
      >
      > I'd like to do the same with a Windows share but am having difficulty.
      >
      > When I try
      >
      > mount -t smbfs somesource/share /mnt/share/somewher e
      >
      > I get "wrong fs type, bad option, bad superblock ..."

      What system is this, exactly?

      -Andre




      Shape Yahoo! in your own image. Join our Network Research Panel today!
    • James Stewart
      Sorry I didn t notice this thread until it got way long, and I haven t read all the replies to it so excuse me if I miss a few things. I ll try to give my 2
      Message 2 of 14 , Jul 19, 2007
      • 0 Attachment
        Sorry I didn't notice this thread until it got way long, and I haven't read all the replies
        to it so excuse me if I miss a few things. I'll try to give my 2 cents worth:

        1) That old LS Linux 2.4 kernel does NOT support CIFS, but it does support smbfs
        which is it's predecessor which works more like Windows98 filesharing.

        2) I'm not completely up on what is going on with MS-Windows these days, but I've
        always been able to connect to shares from Linux using smbfs. This includes Domain
        controllers running Server-2003.

        3) One of many things that might be missing is an encrypted password generated in a
        file on the LS to match against what the Windows machine is going to want for that
        share for a given user. This is unless you have it configured as a simple "open"
        share. To create a password, you normally use the command:

        smbpasswd -a <username>

        you even need this if there is no password for that user. (No password is still
        considered a password choice). In this case use the command:

        smbpasswd -a -n <username>

        If you only want to change an existing password, remove the "-a".

        Now this assumes you HAVE the smbpasswd on the LS. It this OpenLink or FreeLink? I
        never read the thread enough to find out.

        4) You also might have something set wrong in the rest of the samba (Windows files
        sharing suite for Linux) configuration. The raw config file should be
        at /etc/samba/smb.conf, which is a simple text file you could post here for community
        inspection. This is where it should be for Freelink, on OpenLink, who knows, the "real"
        one is probably buried over in the web interface area somewhere. (I thew out the
        original OS on my LS soon after I bought it.)

        5) To test some things, try connecting to one of the Linkstations own shares! At least
        there should be no permissions or strange Windows problems with this. Then work
        foreward from there.

        6) Yes, you DO need "smbmount", which is ususally "syn-linked" to "mount.smbfs" for
        the mount program to find it. You can do this manually if it isn't there:

        ln -s /usr/bin/smbmount /sbin/mount.smbfs

        7) Yes you can use the "smbclient" program too, but I'm guessing you want a
        permanent mount so this would only be useful in testing.

        8) All of these things are part of the the whole "samba" package, all of which may or
        may not be fully installed on your Linkstation. This would include the manual pages
        for this stuff too. If the later is missing you can either consult www.samba.org, or you
        could even look at the manual pages for what I have on my LS that I have publically
        available on my LS server. Here might be some interesting links:

        http://wartstew.homelinux.net/cgi-bin/man/man2html
        http://wartstew.homelinux.net/cgi-bin/man/man2html?smbmount+8
        http://wartstew.homelinux.net/cgi-bin/man/man2html?smb.conf+5
        http://wartstew.homelinux.net/cgi-bin/man/man2html?smbpasswd+5
        http://wartstew.homelinux.net/cgi-bin/man/man2html?smbpasswd+8
        http://wartstew.homelinux.net/cgi-bin/man/man2html?mount+8
        http://wartstew.homelinux.net/cgi-bin/man/mansearch?query=samba

        You probably get the idea.

        I even have a bunch of general Samba Documentation in this area:
        http://wartstew.homelinux.net/dwww/menu/sapps_net.html

        James
      • javamarket
        Hi Thomas, Just a followup thank you. After your contribution I was able to a) put in a full instance of Debian b) mount using mount smbfs Thanks for your
        Message 3 of 14 , Jul 21, 2007
        • 0 Attachment
          Hi Thomas,

          Just a followup thank you.
          After your contribution I was able to
           
          a) put in a full instance of Debian
          b) mount using mount smbfs
           
          Thanks for your pieces!

          ----- Original Message ----
          From: Thomas Ilnseher <illth@...>
          To: LinkStation_General@yahoogroups.com
          Sent: Tuesday, July 17, 2007 7:43:28 AM
          Subject: Re: [LinkStation_General] Re: Mount WINDOWS (SMB) share

          Am Dienstag, den 17.07.2007, 08:44 +0000 schrieb -:

          > Hi Thomas -
          >
          > Thanks for you ideas.
          >
          > When trying CIFS - "fs type cifs not supported by kernel"
          >
          > I have no real experience with LINUX so I'm walking mostly blind.
          > Can you tell me how / where to access the log file you mentioned?
          you should really try the following:

          try mounting your smb share as you did, and after it failed, run "dmesg"
          to see what went wrong.

          You can also post the relevant parts of the dmesg output here.

          one note: if you wont give the URI in a form of
          \\myserver\myshare, you have to type:

          \\\\myserver\ \myshare
          in bash. bash interprets \ as an escape character.
          >
          > Please forgive this old windows user (smile).
          >
          > --- In LinkStation_ General@yahoogro ups.com, Thomas
          Ilnseher
          > <illth@...> wrote:
          > >
          > > Am Dienstag, den 17.07.2007, 00:04 +0000 schrieb -:
          > > > Hello All -
          > > >
          > > > I'm able to mount NFS shares with
          > > >
          > > > mount somesource/share /mnt/share/somewher e
          > > >
          > > > without any issues.
          > > >
          > > > I'd like to do the same with a Windows share but am having
          > difficulty.
          > > >
          > > > When I try
          > > >
          > > > mount -t smbfs somesource/share /mnt/share/somewher e
          > > maybe you should try "-t cifs" instead of "-t smbfs". at least SuSE
          > > ships only the cifs driver...
          > > >
          > > > I get "wrong fs type, bad option, bad superblock ..."
          > > You might check the output of "dmesg" to see what exactly fails
          > > >
          > > > any help would be
          great.
          > > >
          > > > Thanks!
          > > >
          > > >
          > > >
          > > >
          > > >
          > >
          >
          >
          >
          >
          >




          Sick sense of humor? Visit Yahoo! TV's Comedy with an Edge to see what's on, when.
        Your message has been successfully submitted and would be delivered to recipients shortly.