Loading ...
Sorry, an error occurred while loading the content.

Re: [LinkStation_General] Re: Mount WINDOWS (SMB) share

Expand Messages
  • Thomas Ilnseher
    Am Dienstag, den 17.07.2007, 14:13 -0700 schrieb javamarket: ... although i have no clue about this (tm), a quick search at google turned out that you might be
    Message 1 of 14 , Jul 18, 2007
    • 0 Attachment
      Am Dienstag, den 17.07.2007, 14:13 -0700 schrieb javamarket:

      This seems to be the problem:

      > <3>smb_read_super: missing data argument
      > <3>smb_read_super: missing data argument
      > <3>smbfs: mount_data version 1970496882 is not supported
      > <3>smb_read_super: missing data argument
      > <3>smb_read_super: missing data argument
      > <3>smb_read_super: missing data argument
      although i have no clue about this (tm), a quick search at google turned
      out that you might be missing an helper program.

      this program is called mount.smbfs or smbmount.

      steps:

      a) look if mount.smbfs or smbmount are available. do this
      by typing mount.smbfs and/or smbmount in the console. if you get an
      error message like "command not found", these progs aren't there. you
      need to get them. if the programs are found otoh, they'll display some
      usage information.

      b) if you have only the smbmount program, use smbmount as mount command.

      c) if you don't have these programs, you need to find them.

      d) another topic by google said that this might also be an compatibility
      problem between Windows XP and the smbfs driver, in which case you'd
      have to get the cifs driver for your box.

      Thomas
    • javamarket
      Hi Thomas - Ok, both of these programs (commands) return a command not found. I guess I m at a loss until I can figure out how to get / install what you
      Message 2 of 14 , Jul 18, 2007
      • 0 Attachment
        Hi Thomas -
         
        Ok, both of these programs (commands) return a command not found.
         
        I guess I'm at a loss until I can figure out how to get / install what you mentioned.
         
        Thanks for your efforts.

        ----- Original Message ----
        From: Thomas Ilnseher <illth@...>
        To: LinkStation_General@yahoogroups.com
        Sent: Wednesday, July 18, 2007 3:50:25 AM
        Subject: Re: [LinkStation_General] Re: Mount WINDOWS (SMB) share

        Am Dienstag, den 17.07.2007, 14:13 -0700 schrieb javamarket:

        This seems to be the problem:

        > <3>smb_read_ super: missing data argument
        > <3>smb_read_ super: missing data argument
        > <3>smbfs: mount_data version 1970496882 is not supported
        > <3>smb_read_ super: missing data argument
        > <3>smb_read_ super: missing data argument
        > <3>smb_read_ super: missing data argument
        although i have no clue about this (tm), a quick search at google turned
        out that you might be missing an helper program.

        this program is called mount.smbfs or smbmount.

        steps:

        a) look if mount.smbfs or smbmount are available. do this
        by typing mount.smbfs and/or smbmount in the console. if you get an
        error message like "command not found", these progs aren't there. you
        need to get them. if the programs are found otoh, they'll display some
        usage information.

        b) if you have only the smbmount program, use smbmount as mount command.

        c) if you don't have these programs, you need to find them.

        d) another topic by google said that this might also be an compatibility
        problem between Windows XP and the smbfs driver, in which case you'd
        have to get the cifs driver for your box.

        Thomas




        Yahoo! oneSearch: Finally, mobile search that gives answers, not web links.
      • mike redman
        Hi, you might have to start smbclient (if I remember correctly). If the distro you are using doesn t use smb then you might have to install it. Try going on
        Message 3 of 14 , Jul 18, 2007
        • 0 Attachment
          Hi,
          you might have to start smbclient (if I remember
          correctly). If the distro you are using doesn't use smb
          then you might have to install it. Try going on the wiki
          for your distro or use a manual for a distro that uses your
          base system. I use kubuntu which is often close to ubuntu
          which is based on Debian.

          mike.
          --- javamarket <javamarket@...> wrote:

          > Hi Thomas -
          >
          > Ok, both of these programs (commands) return a command
          > not found.
          >
          > I guess I'm at a loss until I can figure out how to get /
          > install what you mentioned.
          >
          > Thanks for your efforts.
          >
          >
          > ----- Original Message ----
          > From: Thomas Ilnseher <illth@...>
          > To: LinkStation_General@yahoogroups.com
          > Sent: Wednesday, July 18, 2007 3:50:25 AM
          > Subject: Re: [LinkStation_General] Re: Mount WINDOWS
          > (SMB) share
          >
          > Am Dienstag, den 17.07.2007, 14:13 -0700 schrieb
          > javamarket:
          >
          > This seems to be the problem:
          >
          > > <3>smb_read_ super: missing data argument
          > > <3>smb_read_ super: missing data argument
          > > <3>smbfs: mount_data version 1970496882 is not
          > supported
          > > <3>smb_read_ super: missing data argument
          > > <3>smb_read_ super: missing data argument
          > > <3>smb_read_ super: missing data argument
          > although i have no clue about this (tm), a quick search
          > at google turned
          > out that you might be missing an helper program.
          >
          > this program is called mount.smbfs or smbmount.
          >
          > steps:
          >
          > a) look if mount.smbfs or smbmount are available. do this
          >
          > by typing mount.smbfs and/or smbmount in the console. if
          > you get an
          > error message like "command not found", these progs
          > aren't there. you
          > need to get them. if the programs are found otoh, they'll
          > display some
          > usage information.
          >
          > b) if you have only the smbmount program, use smbmount as
          > mount command.
          >
          > c) if you don't have these programs, you need to find
          > them.
          >
          > d) another topic by google said that this might also be
          > an compatibility
          > problem between Windows XP and the smbfs driver, in which
          > case you'd
          > have to get the cifs driver for your box.
          >
          > Thomas
          >
          >
          >
          >
          >
          >
          >
          ____________________________________________________________________________________Ready
          > for the edge of your seat?
          > Check out tonight's top picks on Yahoo! TV.
          > http://tv.yahoo.com/
        • javamarket
          Hi Mike, Thank you for your below. It really proved have pure windows I am because I understood so very little of what you were saying. Thanks for the
          Message 4 of 14 , Jul 18, 2007
          • 0 Attachment
            Hi Mike,
             
            Thank you for your below.  It really proved have pure windows I am because I understood so very little of what you were saying.  Thanks for the attempt tho.  I'll have to get myself some basic understanding unfotunately.
             
            This group has allowed me to get the device to a point where it is a Upnp for me and its great.
             
            I'm just hoping I can sort out this mapping to a windows box.
             
            Mark

            ----- Original Message ----
            From: mike redman <michaelredman@...>
            To: LinkStation_General@yahoogroups.com
            Sent: Wednesday, July 18, 2007 6:23:12 AM
            Subject: Re: [LinkStation_General] Re: Mount WINDOWS (SMB) share

            Hi,
            you might have to start smbclient (if I remember
            correctly). If the distro you are using doesn't use smb
            then you might have to install it. Try going on the wiki
            for your distro or use a manual for a distro that uses your
            base system. I use kubuntu which is often close to ubuntu
            which is based on Debian.

            mike.
            --- javamarket <javamarket@yahoo. com> wrote:

            > Hi Thomas -
            >
            > Ok, both of these programs (commands) return a command
            > not found.
            >
            > I guess I'm at a loss until I can figure out how to get /
            > install what you mentioned.
            >
            > Thanks for your efforts.
            >
            >
            > ----- Original Message ----
            > From: Thomas Ilnseher <illth@...>
            > To:
            href="mailto:LinkStation_General%40yahoogroups.com" target=_blank rel=nofollow>LinkStation_ General@yahoogro ups.com
            > Sent: Wednesday, July 18, 2007 3:50:25 AM
            > Subject: Re: [LinkStation_ General] Re: Mount WINDOWS
            > (SMB) share
            >
            > Am Dienstag, den 17.07.2007, 14:13 -0700 schrieb
            > javamarket:
            >
            > This seems to be the problem:
            >
            > > <3>smb_read_ super: missing data argument
            > > <3>smb_read_ super: missing data argument
            > > <3>smbfs: mount_data version 1970496882 is not
            > supported
            > > <3>smb_read_ super: missing data argument
            > > <3>smb_read_ super: missing data argument
            > > <3>smb_read_ super: missing data argument
            > although i have no clue about this (tm), a quick search
            > at google turned
            > out that you might be missing an helper program.
            >
            > this program is
            called mount.smbfs or smbmount.
            >
            > steps:
            >
            > a) look if mount.smbfs or smbmount are available. do this
            >
            > by typing mount.smbfs and/or smbmount in the console. if
            > you get an
            > error message like "command not found", these progs
            > aren't there. you
            > need to get them. if the programs are found otoh, they'll
            > display some
            > usage information.
            >
            > b) if you have only the smbmount program, use smbmount as
            > mount command.
            >
            > c) if you don't have these programs, you need to find
            > them.
            >
            > d) another topic by google said that this might also be
            > an compatibility
            > problem between Windows XP and the smbfs driver, in which
            > case you'd
            > have to get the cifs driver for your box.
            >
            > Thomas
            >
            >
            >
            >
            >
            >
            >
            ____________ _________ _________ _________ _________ _________ _Ready
            > for the edge of your seat?
            > Check out tonight's top picks on Yahoo! TV.
            > http://tv.yahoo. com/




            Got a little couch potato?
            Check out fun summer activities for kids.
          • mike redman
            Mark, There is lots of help out there. Try looking at the linux section of the slim devices help forum. for basic linux i use a book called the Linux bible.
            Message 5 of 14 , Jul 19, 2007
            • 0 Attachment
              Mark,

              There is lots of help out there. Try looking at the linux
              section of the slim devices help forum.

              for basic linux i use a book called the Linux bible. Try
              also the wiki for your distro or the documentation pages.

              Mike.
              --- javamarket <javamarket@...> wrote:

              > Hi Mike,
              >
              > Thank you for your below. It really proved have pure
              > windows I am because I understood so very little of what
              > you were saying. Thanks for the attempt tho. I'll have
              > to get myself some basic understanding unfotunately.
              >
              > This group has allowed me to get the device to a point
              > where it is a Upnp for me and its great.
              >
              > I'm just hoping I can sort out this mapping to a windows
              > box.
              >
              > Mark
              >
              >
              > ----- Original Message ----
              > From: mike redman <michaelredman@...>
              > To: LinkStation_General@yahoogroups.com
              > Sent: Wednesday, July 18, 2007 6:23:12 AM
              > Subject: Re: [LinkStation_General] Re: Mount WINDOWS
              > (SMB) share
              >
              > Hi,
              > you might have to start smbclient (if I remember
              > correctly). If the distro you are using doesn't use smb
              > then you might have to install it. Try going on the wiki
              > for your distro or use a manual for a distro that uses
              > your
              > base system. I use kubuntu which is often close to ubuntu
              > which is based on Debian.
              >
              > mike.
              > --- javamarket <javamarket@yahoo. com> wrote:
              >
              > > Hi Thomas -
              > >
              > > Ok, both of these programs (commands) return a command
              > > not found.
              > >
              > > I guess I'm at a loss until I can figure out how to get
              > /
              > > install what you mentioned.
              > >
              > > Thanks for your efforts.
              > >
              > >
              > > ----- Original Message ----
              > > From: Thomas Ilnseher <illth@...>
              > > To: LinkStation_ General@yahoogro ups.com
              > > Sent: Wednesday, July 18, 2007 3:50:25 AM
              > > Subject: Re: [LinkStation_ General] Re: Mount WINDOWS
              > > (SMB) share
              > >
              > > Am Dienstag, den 17.07.2007, 14:13 -0700 schrieb
              > > javamarket:
              > >
              > > This seems to be the problem:
              > >
              > > > <3>smb_read_ super: missing data argument
              > > > <3>smb_read_ super: missing data argument
              > > > <3>smbfs: mount_data version 1970496882 is not
              > > supported
              > > > <3>smb_read_ super: missing data argument
              > > > <3>smb_read_ super: missing data argument
              > > > <3>smb_read_ super: missing data argument
              > > although i have no clue about this (tm), a quick search
              > > at google turned
              > > out that you might be missing an helper program.
              > >
              > > this program is called mount.smbfs or smbmount.
              > >
              > > steps:
              > >
              > > a) look if mount.smbfs or smbmount are available. do
              > this
              > >
              > > by typing mount.smbfs and/or smbmount in the console.
              > if
              > > you get an
              > > error message like "command not found", these progs
              > > aren't there. you
              > > need to get them. if the programs are found otoh,
              > they'll
              > > display some
              > > usage information.
              > >
              > > b) if you have only the smbmount program, use smbmount
              > as
              > > mount command.
              > >
              > > c) if you don't have these programs, you need to find
              > > them.
              > >
              > > d) another topic by google said that this might also be
              > > an compatibility
              > > problem between Windows XP and the smbfs driver, in
              > which
              > > case you'd
              > > have to get the cifs driver for your box.
              > >
              > > Thomas
              > >
              > >
              > >
              > >
              > >
              > >
              > >
              > ____________ _________ _________ _________ _________
              > _________ _Ready
              > > for the edge of your seat?
              > > Check out tonight's top picks on Yahoo! TV.
              > > http://tv.yahoo com/
              >
              >
              >
              >
              >
              >
              >
              ____________________________________________________________________________________
              > Building a website is a piece of cake. Yahoo! Small
              > Business gives you all the tools to get online.
              > http://smallbusiness.yahoo.com/webhosting
            • lalunas10
              ... What system is this, exactly? -Andre
              Message 6 of 14 , Jul 19, 2007
              • 0 Attachment
                --- In LinkStation_General@yahoogroups.com, "-" <javamarket@...> wrote:
                >
                > Hello All -
                >
                > I'm able to mount NFS shares with
                >
                > mount somesource/share /mnt/share/somewhere
                >
                > without any issues.
                >
                > I'd like to do the same with a Windows share but am having difficulty.
                >
                > When I try
                >
                > mount -t smbfs somesource/share /mnt/share/somewhere
                >
                > I get "wrong fs type, bad option, bad superblock ..."

                What system is this, exactly?

                -Andre
              • javamarket
                Hi Andre, It is a Linkstation PPC. I have managed to realize that a) samba isn t installed b) if downloaded it and am trying to get it installed. Any help in
                Message 7 of 14 , Jul 19, 2007
                • 0 Attachment
                  Hi Andre,
                   
                  It is a Linkstation PPC.
                   
                  I have managed to realize that
                   
                  a) samba isn't installed
                   
                  b) if downloaded it and am trying to get it installed.
                   
                  Any help in this regard would be great.
                   
                  At this point I have extracted the "latest" from samba.org and when I run the ./configure command that should create the makefile I receive:
                   
                  bash-2.05a# ./configure
                  SAMBA VERSION: 3.0.25b
                  LIBREPLACE_LOCATION_CHECKS: START
                  checking build system type... powerpc-unknown-linux-gnu
                  checking host system type... powerpc-unknown-linux-gnu
                  checking target system type... powerpc-unknown-linux-gnu
                  LIBREPLACE_LOCATION_CHECKS: END
                  LIBREPLACE_CC_CHECKS: START
                  checking for gcc... no
                  checking for cc... no
                  checking for cl.exe... no
                  configure: error: no acceptable C compiler found in $PATH
                  See `config.log' for more details.

                  ----- Original Message ----
                  From: lalunas10 <lalunas10@...>
                  To: LinkStation_General@yahoogroups.com
                  Sent: Thursday, July 19, 2007 5:49:37 AM
                  Subject: [LinkStation_General] Re: Mount WINDOWS (SMB) share

                  --- In LinkStation_ General@yahoogro ups.com, "-" <javamarket@ ...> wrote:
                  >
                  > Hello All -
                  >
                  > I'm able to mount NFS shares with
                  >
                  > mount somesource/share /mnt/share/somewher e
                  >
                  > without any issues.
                  >
                  > I'd like to do the same with a Windows share but am having difficulty.
                  >
                  > When I try
                  >
                  > mount -t smbfs somesource/share /mnt/share/somewher e
                  >
                  > I get "wrong fs type, bad option, bad superblock ..."

                  What system is this, exactly?

                  -Andre




                  Shape Yahoo! in your own image. Join our Network Research Panel today!
                • James Stewart
                  Sorry I didn t notice this thread until it got way long, and I haven t read all the replies to it so excuse me if I miss a few things. I ll try to give my 2
                  Message 8 of 14 , Jul 19, 2007
                  • 0 Attachment
                    Sorry I didn't notice this thread until it got way long, and I haven't read all the replies
                    to it so excuse me if I miss a few things. I'll try to give my 2 cents worth:

                    1) That old LS Linux 2.4 kernel does NOT support CIFS, but it does support smbfs
                    which is it's predecessor which works more like Windows98 filesharing.

                    2) I'm not completely up on what is going on with MS-Windows these days, but I've
                    always been able to connect to shares from Linux using smbfs. This includes Domain
                    controllers running Server-2003.

                    3) One of many things that might be missing is an encrypted password generated in a
                    file on the LS to match against what the Windows machine is going to want for that
                    share for a given user. This is unless you have it configured as a simple "open"
                    share. To create a password, you normally use the command:

                    smbpasswd -a <username>

                    you even need this if there is no password for that user. (No password is still
                    considered a password choice). In this case use the command:

                    smbpasswd -a -n <username>

                    If you only want to change an existing password, remove the "-a".

                    Now this assumes you HAVE the smbpasswd on the LS. It this OpenLink or FreeLink? I
                    never read the thread enough to find out.

                    4) You also might have something set wrong in the rest of the samba (Windows files
                    sharing suite for Linux) configuration. The raw config file should be
                    at /etc/samba/smb.conf, which is a simple text file you could post here for community
                    inspection. This is where it should be for Freelink, on OpenLink, who knows, the "real"
                    one is probably buried over in the web interface area somewhere. (I thew out the
                    original OS on my LS soon after I bought it.)

                    5) To test some things, try connecting to one of the Linkstations own shares! At least
                    there should be no permissions or strange Windows problems with this. Then work
                    foreward from there.

                    6) Yes, you DO need "smbmount", which is ususally "syn-linked" to "mount.smbfs" for
                    the mount program to find it. You can do this manually if it isn't there:

                    ln -s /usr/bin/smbmount /sbin/mount.smbfs

                    7) Yes you can use the "smbclient" program too, but I'm guessing you want a
                    permanent mount so this would only be useful in testing.

                    8) All of these things are part of the the whole "samba" package, all of which may or
                    may not be fully installed on your Linkstation. This would include the manual pages
                    for this stuff too. If the later is missing you can either consult www.samba.org, or you
                    could even look at the manual pages for what I have on my LS that I have publically
                    available on my LS server. Here might be some interesting links:

                    http://wartstew.homelinux.net/cgi-bin/man/man2html
                    http://wartstew.homelinux.net/cgi-bin/man/man2html?smbmount+8
                    http://wartstew.homelinux.net/cgi-bin/man/man2html?smb.conf+5
                    http://wartstew.homelinux.net/cgi-bin/man/man2html?smbpasswd+5
                    http://wartstew.homelinux.net/cgi-bin/man/man2html?smbpasswd+8
                    http://wartstew.homelinux.net/cgi-bin/man/man2html?mount+8
                    http://wartstew.homelinux.net/cgi-bin/man/mansearch?query=samba

                    You probably get the idea.

                    I even have a bunch of general Samba Documentation in this area:
                    http://wartstew.homelinux.net/dwww/menu/sapps_net.html

                    James
                  • javamarket
                    Hi Thomas, Just a followup thank you. After your contribution I was able to a) put in a full instance of Debian b) mount using mount smbfs Thanks for your
                    Message 9 of 14 , Jul 21, 2007
                    • 0 Attachment
                      Hi Thomas,

                      Just a followup thank you.
                      After your contribution I was able to
                       
                      a) put in a full instance of Debian
                      b) mount using mount smbfs
                       
                      Thanks for your pieces!

                      ----- Original Message ----
                      From: Thomas Ilnseher <illth@...>
                      To: LinkStation_General@yahoogroups.com
                      Sent: Tuesday, July 17, 2007 7:43:28 AM
                      Subject: Re: [LinkStation_General] Re: Mount WINDOWS (SMB) share

                      Am Dienstag, den 17.07.2007, 08:44 +0000 schrieb -:

                      > Hi Thomas -
                      >
                      > Thanks for you ideas.
                      >
                      > When trying CIFS - "fs type cifs not supported by kernel"
                      >
                      > I have no real experience with LINUX so I'm walking mostly blind.
                      > Can you tell me how / where to access the log file you mentioned?
                      you should really try the following:

                      try mounting your smb share as you did, and after it failed, run "dmesg"
                      to see what went wrong.

                      You can also post the relevant parts of the dmesg output here.

                      one note: if you wont give the URI in a form of
                      \\myserver\myshare, you have to type:

                      \\\\myserver\ \myshare
                      in bash. bash interprets \ as an escape character.
                      >
                      > Please forgive this old windows user (smile).
                      >
                      > --- In LinkStation_ General@yahoogro ups.com, Thomas
                      Ilnseher
                      > <illth@...> wrote:
                      > >
                      > > Am Dienstag, den 17.07.2007, 00:04 +0000 schrieb -:
                      > > > Hello All -
                      > > >
                      > > > I'm able to mount NFS shares with
                      > > >
                      > > > mount somesource/share /mnt/share/somewher e
                      > > >
                      > > > without any issues.
                      > > >
                      > > > I'd like to do the same with a Windows share but am having
                      > difficulty.
                      > > >
                      > > > When I try
                      > > >
                      > > > mount -t smbfs somesource/share /mnt/share/somewher e
                      > > maybe you should try "-t cifs" instead of "-t smbfs". at least SuSE
                      > > ships only the cifs driver...
                      > > >
                      > > > I get "wrong fs type, bad option, bad superblock ..."
                      > > You might check the output of "dmesg" to see what exactly fails
                      > > >
                      > > > any help would be
                      great.
                      > > >
                      > > > Thanks!
                      > > >
                      > > >
                      > > >
                      > > >
                      > > >
                      > >
                      >
                      >
                      >
                      >
                      >




                      Sick sense of humor? Visit Yahoo! TV's Comedy with an Edge to see what's on, when.
                    Your message has been successfully submitted and would be delivered to recipients shortly.