Loading ...
Sorry, an error occurred while loading the content.
 

Mount WINDOWS (SMB) share

Expand Messages
  • -
    Hello All - I m able to mount NFS shares with mount somesource/share /mnt/share/somewhere without any issues. I d like to do the same with a Windows share but
    Message 1 of 14 , Jul 16, 2007
      Hello All -

      I'm able to mount NFS shares with

      mount somesource/share /mnt/share/somewhere

      without any issues.

      I'd like to do the same with a Windows share but am having difficulty.

      When I try

      mount -t smbfs somesource/share /mnt/share/somewhere

      I get "wrong fs type, bad option, bad superblock ..."

      any help would be great.

      Thanks!
    • Thomas Ilnseher
      ... maybe you should try -t cifs instead of -t smbfs . at least SuSE ships only the cifs driver... ... You might check the output of dmesg to see what
      Message 2 of 14 , Jul 17, 2007
        Am Dienstag, den 17.07.2007, 00:04 +0000 schrieb -:
        > Hello All -
        >
        > I'm able to mount NFS shares with
        >
        > mount somesource/share /mnt/share/somewhere
        >
        > without any issues.
        >
        > I'd like to do the same with a Windows share but am having difficulty.
        >
        > When I try
        >
        > mount -t smbfs somesource/share /mnt/share/somewhere
        maybe you should try "-t cifs" instead of "-t smbfs". at least SuSE
        ships only the cifs driver...
        >
        > I get "wrong fs type, bad option, bad superblock ..."
        You might check the output of "dmesg" to see what exactly fails
        >
        > any help would be great.
        >
        > Thanks!
        >
        >
        >
        >
        >
      • -
        Hi Thomas - Thanks for you ideas. When trying CIFS - fs type cifs not supported by kernel I have no real experience with LINUX so I m walking mostly blind.
        Message 3 of 14 , Jul 17, 2007
          Hi Thomas -

          Thanks for you ideas.

          When trying CIFS - "fs type cifs not supported by kernel"

          I have no real experience with LINUX so I'm walking mostly blind.
          Can you tell me how / where to access the log file you mentioned?

          Please forgive this old windows user (smile).



          --- In LinkStation_General@yahoogroups.com, Thomas Ilnseher
          <illth@...> wrote:
          >
          > Am Dienstag, den 17.07.2007, 00:04 +0000 schrieb -:
          > > Hello All -
          > >
          > > I'm able to mount NFS shares with
          > >
          > > mount somesource/share /mnt/share/somewhere
          > >
          > > without any issues.
          > >
          > > I'd like to do the same with a Windows share but am having
          difficulty.
          > >
          > > When I try
          > >
          > > mount -t smbfs somesource/share /mnt/share/somewhere
          > maybe you should try "-t cifs" instead of "-t smbfs". at least SuSE
          > ships only the cifs driver...
          > >
          > > I get "wrong fs type, bad option, bad superblock ..."
          > You might check the output of "dmesg" to see what exactly fails
          > >
          > > any help would be great.
          > >
          > > Thanks!
          > >
          > >
          > >
          > >
          > >
          >
        • Thomas Ilnseher
          ... you should really try the following: try mounting your smb share as you did, and after it failed, run dmesg to see what went wrong. You can also post the
          Message 4 of 14 , Jul 17, 2007
            Am Dienstag, den 17.07.2007, 08:44 +0000 schrieb -:
            > Hi Thomas -
            >
            > Thanks for you ideas.
            >
            > When trying CIFS - "fs type cifs not supported by kernel"
            >
            > I have no real experience with LINUX so I'm walking mostly blind.
            > Can you tell me how / where to access the log file you mentioned?
            you should really try the following:

            try mounting your smb share as you did, and after it failed, run "dmesg"
            to see what went wrong.

            You can also post the relevant parts of the dmesg output here.

            one note: if you wont give the URI in a form of
            \\myserver\myshare, you have to type:

            \\\\myserver\\myshare
            in bash. bash interprets \ as an escape character.
            >
            > Please forgive this old windows user (smile).
            >
            > --- In LinkStation_General@yahoogroups.com, Thomas Ilnseher
            > <illth@...> wrote:
            > >
            > > Am Dienstag, den 17.07.2007, 00:04 +0000 schrieb -:
            > > > Hello All -
            > > >
            > > > I'm able to mount NFS shares with
            > > >
            > > > mount somesource/share /mnt/share/somewhere
            > > >
            > > > without any issues.
            > > >
            > > > I'd like to do the same with a Windows share but am having
            > difficulty.
            > > >
            > > > When I try
            > > >
            > > > mount -t smbfs somesource/share /mnt/share/somewhere
            > > maybe you should try "-t cifs" instead of "-t smbfs". at least SuSE
            > > ships only the cifs driver...
            > > >
            > > > I get "wrong fs type, bad option, bad superblock ..."
            > > You might check the output of "dmesg" to see what exactly fails
            > > >
            > > > any help would be great.
            > > >
            > > > Thanks!
            > > >
            > > >
            > > >
            > > >
            > > >
            > >
            >
            >
            >
            >
            >
          • javamarket
            Hi Thomas, Thanks again for you trying to help - - Here is the output: BUFFALO INC. Link Station series HD-HLAN (HIDETADA) bash-2.05a# mount
            Message 5 of 14 , Jul 17, 2007
              Hi Thomas,
               
              Thanks again for you trying to help - -
               
              Here is the output:
               

              BUFFALO INC. Link Station series HD-HLAN (HIDETADA)
              bash-2.05a# mount \\media.worthasset.com:media \mnt\share\Media
              mount: RPC: Unable to receive; errno = Connection refused
              bash-2.05a#
              bash-2.05a# dmesg
              <6>Memory BAT mapping: BAT2=64Mb, BAT3=0Mb, residual: 0Mb
              <4>Linux version 2.4.17_mvl21-sandpoint (root@toda_dev.melcoinc.co.jp) (gcc vers
              ion 2.95.3 20010315 (release/MontaVista)) #997 2005╟» 2╖ε 25╞ⁿ ╢Γ═╦╞ⁿ 19:29:09 J
              ST
              <4>BUFFALO Network Attached Storage Series
              <4>2002-2004 BUFFALO INC.
              <4>On node 0 totalpages: 16384
              <4>zone(0): 16384 pages.
              <4>zone(1): 0 pages.
              <4>zone(2): 0 pages.
              <4>Kernel command line: root=/dev/hda1
              <4>OpenPIC Version 1.2 (1 CPUs and 139 IRQ sources) at 80040000
              <4>decrementer frequency = 24.576000 MHz
              <4>rtc sec count 1184230790
              <4>Calibrating delay loop... 130.66 BogoMIPS
              <4>Memory: 60300k available (1332k kernel code, 580k data, 192k init, 0k highmem
              )
              <4>Dentry-cache hash table entries: 8192 (order: 4, 65536 bytes)
              <4>Inode-cache hash table entries: 4096 (order: 3, 32768 bytes)
              <4>Mount-cache hash table entries: 1024 (order: 1, 8192 bytes)
              <4>Buffer-cache hash table entries: 4096 (order: 2, 16384 bytes)
              <4>Page-cache hash table entries: 16384 (order: 4, 65536 bytes)
              <4>POSIX conformance testing by UNIFIX
              <6>PCI: Probing PCI hardware
              <6>Linux NET4.0 for Linux 2.4
              <6>Based upon Swansea University Computer Society NET3.039
              <4>Initializing RT netlink socket
              <4>Starting kswapd
              <4>Disabling the Out Of Memory Killer
              <6>Journalled Block Device driver loaded
              <4>pty: 256 Unix98 ptys configured
              <6>MELCO INC. RTC driver ver 1.00
              <6>Serial driver version 5.05c (2001-07-08) with MANY_PORTS SHARE_IRQ SERIAL_PCI
               enabled
              <6>ttyS00 at 0x80004600 (irq = 138) is a 16550A
              <6>ttyS01 at 0x80004500 (irq = 137) is a 16550A
              <4>block: 128 slots per queue, batch=32
              <4>RAMDISK driver initialized: 16 RAM disks of 10000K size 1024 blocksize
              <6>Uniform Multi-Platform E-IDE driver Revision: 6.31
              <4>ide: Assuming 33MHz system bus speed for PIO modes; override with idebus=xx
              <4>CMD680: IDE controller on PCI bus 00 dev 60
              <4>CMD680: chipset revision 2
              <4>CMD680: 100% native mode on irq 17
              <4>    ide0: BM-DMA at 0xbffed0-0xbffed7, BIOS settings: hda:pio, hdb:pio
              <4>    ide1: BM-DMA at 0xbffed8-0xbffedf, BIOS settings: hdc:pio, hdd:pio
              <4>hda: WDC WD2500BB-55GUA0, ATA DISK drive
              <4>ide0 at 0xbffef8-0xbffeff,0xbffef6 on irq 17
              <6>hda: 488397168 sectors (250059 MB) w/2048KiB Cache, CHS=30401/255/63, UDMA(10
              0)
              <6>Partition check:
              <6> hda: hda1 hda2 hda3 hda4
              <4>FLASHDISK:Initialized [FUJITSU MBM29PL32TM]
              <6>Linux Tulip driver version 0.9.15-pre9 (Nov 6, 2001)
              <6>tulip0:  MII transceiver #1 config 3100 status 7849 advertising 05e1.
              <6>eth0: ADMtek Comet rev 17 at 0xbfff00, 00:07:40:FB:D0:EE, IRQ 16.
              <6>SCSI subsystem driver Revision: 1.00
              <3>request_module[scsi_hostadapter]: Root fs not mounted
              <3>request_module[scsi_hostadapter]: Root fs not mounted
              <6>usb.c: registered new driver usbdevfs
              <6>usb.c: registered new driver hub
              <6>hcd.c: ehci-hcd @ 00:0e.2, PCI device 1033:00e0 (NEC Corporation)
              <6>hcd.c: irq 19, pci mem c5000f00
              <6>usb.c: new USB bus registered, assigned bus number 1
              <6>hcd/ehci-hcd.c: USB 2.0 support enabled, EHCI rev 1. 0
              <6>hub.c: USB hub found
              <6>hub.c: 5 ports detected
              <6>usb-ohci.c: USB OHCI at membase 0xc5002000, IRQ 19
              <6>usb-ohci.c: usb-00:0e.0, NEC Corporation USB
              <6>usb.c: new USB bus registered, assigned bus number 2
              <6>hub.c: USB hub found
              <6>hub.c: 3 ports detected
              <6>usb-ohci.c: USB OHCI at membase 0xc5004000, IRQ 19
              <6>usb-ohci.c: usb-00:0e.1, NEC Corporation USB (#2)
              <6>usb.c: new USB bus registered, assigned bus number 3
              <6>hub.c: USB hub found
              <6>hub.c: 2 ports detected
              <6>usb.c: registered new driver usblp
              <6>printer.c: v0.11: USB Printer Device Class driver
              <6>Initializing USB Mass Storage driver...
              <6>usb.c: registered new driver usb-storage
              <6>USB Mass Storage support registered.
              <6>NET4: Linux TCP/IP 1.0 for NET4.0
              <6>IP Protocols: ICMP, UDP, TCP, IGMP
              <4>IP: routing cache hash table of 512 buckets, 4Kbytes
              <4>TCP: Hash tables configured (established 4096 bind 4096)
              <6>NET4: Unix domain sockets 1.0/SMP for Linux NET4.0.
              <6>NET4: AppleTalk 0.18a for Linux NET4.0
              <5>RAMDISK: Compressed image found at block 0
              <4>Freeing initrd memory: 2037k freed
              <4>fff70000:4f4b4f4b
              <4>EXT2-fs warning: checktime reached, running e2fsck is recommended
              <4>VFS: Mounted root (ext2 filesystem).
              <4>fff70000:4f4b4f4b
              <6>EXT3-fs: INFO: recovery required on readonly filesystem.
              <6>EXT3-fs: write access will be enabled during recovery.
              <6>kjournald starting.  Commit interval 5 seconds
              <6>EXT3-fs: recovery complete.
              <6>EXT3-fs: mounted filesystem with ordered data mode.
              <4>VFS: Mounted root (ext3 filesystem) readonly.
              <4>change_root: old root has d_count=2
              <5>Trying to unmount old root ... okay
              <4>Freeing unused kernel memory: 192k init
              <6>Adding Swap: 530136k swap-space (priority -1)
              <4>EXT3-fs warning: maximal mount count reached, running e2fsck is recommended
              <6>EXT3 FS 2.4-0.9.17, 10 Jan 2002 on ide0(3,1), internal journal
              <6>kjournald starting.  Commit interval 5 seconds
              <4>EXT3-fs warning: maximal mount count reached, running e2fsck is recommended
              <6>EXT3 FS 2.4-0.9.17, 10 Jan 2002 on ide0(3,3), internal journal
              <6>EXT3-fs: recovery complete.
              <6>EXT3-fs: mounted filesystem with ordered data mode.
              <5>portmap: server localhost not responding, timed out
              <5>portmap: server localhost not responding, timed out
              <4>lockd_up: makesock failed, error=-5
              <5>portmap: server localhost not responding, timed out
              <4>lockd_up: no pid, 2 users??
              <5>portmap: server localhost not responding, timed out
              <5>portmap: server localhost not responding, timed out
              <5>portmap: server localhost not responding, timed out
              <4>lockd_up: no pid, 3 users??
              <5>portmap: server localhost not responding, timed out
              <5>portmap: server localhost not responding, timed out
              <5>portmap: server localhost not responding, timed out
              <3>smb_read_super: missing data argument
              <3>smb_read_super: missing data argument
              <3>smbfs: mount_data version 1970496882 is not supported
              <3>smb_read_super: missing data argument
              <3>smb_read_super: missing data argument
              <3>smb_read_super: missing data argument
              bash-2.05a#
              bash-2.05a#

              ----- Original Message ----
              From: Thomas Ilnseher <illth@...>
              To: LinkStation_General@yahoogroups.com
              Sent: Tuesday, July 17, 2007 7:43:28 AM
              Subject: Re: [LinkStation_General] Re: Mount WINDOWS (SMB) share

              Am Dienstag, den 17.07.2007, 08:44 +0000 schrieb -:

              > Hi Thomas -
              >
              > Thanks for you ideas.
              >
              > When trying CIFS - "fs type cifs not supported by kernel"
              >
              > I have no real experience with LINUX so I'm walking mostly blind.
              > Can you tell me how / where to access the log file you mentioned?
              you should really try the following:

              try mounting your smb share as you did, and after it failed, run "dmesg"
              to see what went wrong.

              You can also post the relevant parts of the dmesg output here.

              one note: if you wont give the URI in a form of
              \\myserver\myshare, you have to type:

              \\\\myserver\ \myshare
              in bash. bash interprets \ as an escape character.
              >
              > Please forgive this old windows user (smile).
              >
              > --- In LinkStation_ General@yahoogro ups.com, Thomas
              Ilnseher
              > <illth@...> wrote:
              > >
              > > Am Dienstag, den 17.07.2007, 00:04 +0000 schrieb -:
              > > > Hello All -
              > > >
              > > > I'm able to mount NFS shares with
              > > >
              > > > mount somesource/share /mnt/share/somewher e
              > > >
              > > > without any issues.
              > > >
              > > > I'd like to do the same with a Windows share but am having
              > difficulty.
              > > >
              > > > When I try
              > > >
              > > > mount -t smbfs somesource/share /mnt/share/somewher e
              > > maybe you should try "-t cifs" instead of "-t smbfs". at least SuSE
              > > ships only the cifs driver...
              > > >
              > > > I get "wrong fs type, bad option, bad superblock ..."
              > > You might check the output of "dmesg" to see what exactly fails
              > > >
              > > > any help would be
              great.
              > > >
              > > > Thanks!
              > > >
              > > >
              > > >
              > > >
              > > >
              > >
              >
              >
              >
              >
              >




              Park yourself in front of a world of choices in alternative vehicles.
              Visit the Yahoo! Auto Green Center.
            • Thomas Ilnseher
              Am Dienstag, den 17.07.2007, 14:13 -0700 schrieb javamarket: ... although i have no clue about this (tm), a quick search at google turned out that you might be
              Message 6 of 14 , Jul 18, 2007
                Am Dienstag, den 17.07.2007, 14:13 -0700 schrieb javamarket:

                This seems to be the problem:

                > <3>smb_read_super: missing data argument
                > <3>smb_read_super: missing data argument
                > <3>smbfs: mount_data version 1970496882 is not supported
                > <3>smb_read_super: missing data argument
                > <3>smb_read_super: missing data argument
                > <3>smb_read_super: missing data argument
                although i have no clue about this (tm), a quick search at google turned
                out that you might be missing an helper program.

                this program is called mount.smbfs or smbmount.

                steps:

                a) look if mount.smbfs or smbmount are available. do this
                by typing mount.smbfs and/or smbmount in the console. if you get an
                error message like "command not found", these progs aren't there. you
                need to get them. if the programs are found otoh, they'll display some
                usage information.

                b) if you have only the smbmount program, use smbmount as mount command.

                c) if you don't have these programs, you need to find them.

                d) another topic by google said that this might also be an compatibility
                problem between Windows XP and the smbfs driver, in which case you'd
                have to get the cifs driver for your box.

                Thomas
              • javamarket
                Hi Thomas - Ok, both of these programs (commands) return a command not found. I guess I m at a loss until I can figure out how to get / install what you
                Message 7 of 14 , Jul 18, 2007
                  Hi Thomas -
                   
                  Ok, both of these programs (commands) return a command not found.
                   
                  I guess I'm at a loss until I can figure out how to get / install what you mentioned.
                   
                  Thanks for your efforts.

                  ----- Original Message ----
                  From: Thomas Ilnseher <illth@...>
                  To: LinkStation_General@yahoogroups.com
                  Sent: Wednesday, July 18, 2007 3:50:25 AM
                  Subject: Re: [LinkStation_General] Re: Mount WINDOWS (SMB) share

                  Am Dienstag, den 17.07.2007, 14:13 -0700 schrieb javamarket:

                  This seems to be the problem:

                  > <3>smb_read_ super: missing data argument
                  > <3>smb_read_ super: missing data argument
                  > <3>smbfs: mount_data version 1970496882 is not supported
                  > <3>smb_read_ super: missing data argument
                  > <3>smb_read_ super: missing data argument
                  > <3>smb_read_ super: missing data argument
                  although i have no clue about this (tm), a quick search at google turned
                  out that you might be missing an helper program.

                  this program is called mount.smbfs or smbmount.

                  steps:

                  a) look if mount.smbfs or smbmount are available. do this
                  by typing mount.smbfs and/or smbmount in the console. if you get an
                  error message like "command not found", these progs aren't there. you
                  need to get them. if the programs are found otoh, they'll display some
                  usage information.

                  b) if you have only the smbmount program, use smbmount as mount command.

                  c) if you don't have these programs, you need to find them.

                  d) another topic by google said that this might also be an compatibility
                  problem between Windows XP and the smbfs driver, in which case you'd
                  have to get the cifs driver for your box.

                  Thomas




                  Yahoo! oneSearch: Finally, mobile search that gives answers, not web links.
                • mike redman
                  Hi, you might have to start smbclient (if I remember correctly). If the distro you are using doesn t use smb then you might have to install it. Try going on
                  Message 8 of 14 , Jul 18, 2007
                    Hi,
                    you might have to start smbclient (if I remember
                    correctly). If the distro you are using doesn't use smb
                    then you might have to install it. Try going on the wiki
                    for your distro or use a manual for a distro that uses your
                    base system. I use kubuntu which is often close to ubuntu
                    which is based on Debian.

                    mike.
                    --- javamarket <javamarket@...> wrote:

                    > Hi Thomas -
                    >
                    > Ok, both of these programs (commands) return a command
                    > not found.
                    >
                    > I guess I'm at a loss until I can figure out how to get /
                    > install what you mentioned.
                    >
                    > Thanks for your efforts.
                    >
                    >
                    > ----- Original Message ----
                    > From: Thomas Ilnseher <illth@...>
                    > To: LinkStation_General@yahoogroups.com
                    > Sent: Wednesday, July 18, 2007 3:50:25 AM
                    > Subject: Re: [LinkStation_General] Re: Mount WINDOWS
                    > (SMB) share
                    >
                    > Am Dienstag, den 17.07.2007, 14:13 -0700 schrieb
                    > javamarket:
                    >
                    > This seems to be the problem:
                    >
                    > > <3>smb_read_ super: missing data argument
                    > > <3>smb_read_ super: missing data argument
                    > > <3>smbfs: mount_data version 1970496882 is not
                    > supported
                    > > <3>smb_read_ super: missing data argument
                    > > <3>smb_read_ super: missing data argument
                    > > <3>smb_read_ super: missing data argument
                    > although i have no clue about this (tm), a quick search
                    > at google turned
                    > out that you might be missing an helper program.
                    >
                    > this program is called mount.smbfs or smbmount.
                    >
                    > steps:
                    >
                    > a) look if mount.smbfs or smbmount are available. do this
                    >
                    > by typing mount.smbfs and/or smbmount in the console. if
                    > you get an
                    > error message like "command not found", these progs
                    > aren't there. you
                    > need to get them. if the programs are found otoh, they'll
                    > display some
                    > usage information.
                    >
                    > b) if you have only the smbmount program, use smbmount as
                    > mount command.
                    >
                    > c) if you don't have these programs, you need to find
                    > them.
                    >
                    > d) another topic by google said that this might also be
                    > an compatibility
                    > problem between Windows XP and the smbfs driver, in which
                    > case you'd
                    > have to get the cifs driver for your box.
                    >
                    > Thomas
                    >
                    >
                    >
                    >
                    >
                    >
                    >
                    ____________________________________________________________________________________Ready
                    > for the edge of your seat?
                    > Check out tonight's top picks on Yahoo! TV.
                    > http://tv.yahoo.com/
                  • javamarket
                    Hi Mike, Thank you for your below. It really proved have pure windows I am because I understood so very little of what you were saying. Thanks for the
                    Message 9 of 14 , Jul 18, 2007
                      Hi Mike,
                       
                      Thank you for your below.  It really proved have pure windows I am because I understood so very little of what you were saying.  Thanks for the attempt tho.  I'll have to get myself some basic understanding unfotunately.
                       
                      This group has allowed me to get the device to a point where it is a Upnp for me and its great.
                       
                      I'm just hoping I can sort out this mapping to a windows box.
                       
                      Mark

                      ----- Original Message ----
                      From: mike redman <michaelredman@...>
                      To: LinkStation_General@yahoogroups.com
                      Sent: Wednesday, July 18, 2007 6:23:12 AM
                      Subject: Re: [LinkStation_General] Re: Mount WINDOWS (SMB) share

                      Hi,
                      you might have to start smbclient (if I remember
                      correctly). If the distro you are using doesn't use smb
                      then you might have to install it. Try going on the wiki
                      for your distro or use a manual for a distro that uses your
                      base system. I use kubuntu which is often close to ubuntu
                      which is based on Debian.

                      mike.
                      --- javamarket <javamarket@yahoo. com> wrote:

                      > Hi Thomas -
                      >
                      > Ok, both of these programs (commands) return a command
                      > not found.
                      >
                      > I guess I'm at a loss until I can figure out how to get /
                      > install what you mentioned.
                      >
                      > Thanks for your efforts.
                      >
                      >
                      > ----- Original Message ----
                      > From: Thomas Ilnseher <illth@...>
                      > To:
                      href="mailto:LinkStation_General%40yahoogroups.com" target=_blank rel=nofollow>LinkStation_ General@yahoogro ups.com
                      > Sent: Wednesday, July 18, 2007 3:50:25 AM
                      > Subject: Re: [LinkStation_ General] Re: Mount WINDOWS
                      > (SMB) share
                      >
                      > Am Dienstag, den 17.07.2007, 14:13 -0700 schrieb
                      > javamarket:
                      >
                      > This seems to be the problem:
                      >
                      > > <3>smb_read_ super: missing data argument
                      > > <3>smb_read_ super: missing data argument
                      > > <3>smbfs: mount_data version 1970496882 is not
                      > supported
                      > > <3>smb_read_ super: missing data argument
                      > > <3>smb_read_ super: missing data argument
                      > > <3>smb_read_ super: missing data argument
                      > although i have no clue about this (tm), a quick search
                      > at google turned
                      > out that you might be missing an helper program.
                      >
                      > this program is
                      called mount.smbfs or smbmount.
                      >
                      > steps:
                      >
                      > a) look if mount.smbfs or smbmount are available. do this
                      >
                      > by typing mount.smbfs and/or smbmount in the console. if
                      > you get an
                      > error message like "command not found", these progs
                      > aren't there. you
                      > need to get them. if the programs are found otoh, they'll
                      > display some
                      > usage information.
                      >
                      > b) if you have only the smbmount program, use smbmount as
                      > mount command.
                      >
                      > c) if you don't have these programs, you need to find
                      > them.
                      >
                      > d) another topic by google said that this might also be
                      > an compatibility
                      > problem between Windows XP and the smbfs driver, in which
                      > case you'd
                      > have to get the cifs driver for your box.
                      >
                      > Thomas
                      >
                      >
                      >
                      >
                      >
                      >
                      >
                      ____________ _________ _________ _________ _________ _________ _Ready
                      > for the edge of your seat?
                      > Check out tonight's top picks on Yahoo! TV.
                      > http://tv.yahoo. com/




                      Got a little couch potato?
                      Check out fun summer activities for kids.
                    • mike redman
                      Mark, There is lots of help out there. Try looking at the linux section of the slim devices help forum. for basic linux i use a book called the Linux bible.
                      Message 10 of 14 , Jul 19, 2007
                        Mark,

                        There is lots of help out there. Try looking at the linux
                        section of the slim devices help forum.

                        for basic linux i use a book called the Linux bible. Try
                        also the wiki for your distro or the documentation pages.

                        Mike.
                        --- javamarket <javamarket@...> wrote:

                        > Hi Mike,
                        >
                        > Thank you for your below. It really proved have pure
                        > windows I am because I understood so very little of what
                        > you were saying. Thanks for the attempt tho. I'll have
                        > to get myself some basic understanding unfotunately.
                        >
                        > This group has allowed me to get the device to a point
                        > where it is a Upnp for me and its great.
                        >
                        > I'm just hoping I can sort out this mapping to a windows
                        > box.
                        >
                        > Mark
                        >
                        >
                        > ----- Original Message ----
                        > From: mike redman <michaelredman@...>
                        > To: LinkStation_General@yahoogroups.com
                        > Sent: Wednesday, July 18, 2007 6:23:12 AM
                        > Subject: Re: [LinkStation_General] Re: Mount WINDOWS
                        > (SMB) share
                        >
                        > Hi,
                        > you might have to start smbclient (if I remember
                        > correctly). If the distro you are using doesn't use smb
                        > then you might have to install it. Try going on the wiki
                        > for your distro or use a manual for a distro that uses
                        > your
                        > base system. I use kubuntu which is often close to ubuntu
                        > which is based on Debian.
                        >
                        > mike.
                        > --- javamarket <javamarket@yahoo. com> wrote:
                        >
                        > > Hi Thomas -
                        > >
                        > > Ok, both of these programs (commands) return a command
                        > > not found.
                        > >
                        > > I guess I'm at a loss until I can figure out how to get
                        > /
                        > > install what you mentioned.
                        > >
                        > > Thanks for your efforts.
                        > >
                        > >
                        > > ----- Original Message ----
                        > > From: Thomas Ilnseher <illth@...>
                        > > To: LinkStation_ General@yahoogro ups.com
                        > > Sent: Wednesday, July 18, 2007 3:50:25 AM
                        > > Subject: Re: [LinkStation_ General] Re: Mount WINDOWS
                        > > (SMB) share
                        > >
                        > > Am Dienstag, den 17.07.2007, 14:13 -0700 schrieb
                        > > javamarket:
                        > >
                        > > This seems to be the problem:
                        > >
                        > > > <3>smb_read_ super: missing data argument
                        > > > <3>smb_read_ super: missing data argument
                        > > > <3>smbfs: mount_data version 1970496882 is not
                        > > supported
                        > > > <3>smb_read_ super: missing data argument
                        > > > <3>smb_read_ super: missing data argument
                        > > > <3>smb_read_ super: missing data argument
                        > > although i have no clue about this (tm), a quick search
                        > > at google turned
                        > > out that you might be missing an helper program.
                        > >
                        > > this program is called mount.smbfs or smbmount.
                        > >
                        > > steps:
                        > >
                        > > a) look if mount.smbfs or smbmount are available. do
                        > this
                        > >
                        > > by typing mount.smbfs and/or smbmount in the console.
                        > if
                        > > you get an
                        > > error message like "command not found", these progs
                        > > aren't there. you
                        > > need to get them. if the programs are found otoh,
                        > they'll
                        > > display some
                        > > usage information.
                        > >
                        > > b) if you have only the smbmount program, use smbmount
                        > as
                        > > mount command.
                        > >
                        > > c) if you don't have these programs, you need to find
                        > > them.
                        > >
                        > > d) another topic by google said that this might also be
                        > > an compatibility
                        > > problem between Windows XP and the smbfs driver, in
                        > which
                        > > case you'd
                        > > have to get the cifs driver for your box.
                        > >
                        > > Thomas
                        > >
                        > >
                        > >
                        > >
                        > >
                        > >
                        > >
                        > ____________ _________ _________ _________ _________
                        > _________ _Ready
                        > > for the edge of your seat?
                        > > Check out tonight's top picks on Yahoo! TV.
                        > > http://tv.yahoo com/
                        >
                        >
                        >
                        >
                        >
                        >
                        >
                        ____________________________________________________________________________________
                        > Building a website is a piece of cake. Yahoo! Small
                        > Business gives you all the tools to get online.
                        > http://smallbusiness.yahoo.com/webhosting
                      • lalunas10
                        ... What system is this, exactly? -Andre
                        Message 11 of 14 , Jul 19, 2007
                          --- In LinkStation_General@yahoogroups.com, "-" <javamarket@...> wrote:
                          >
                          > Hello All -
                          >
                          > I'm able to mount NFS shares with
                          >
                          > mount somesource/share /mnt/share/somewhere
                          >
                          > without any issues.
                          >
                          > I'd like to do the same with a Windows share but am having difficulty.
                          >
                          > When I try
                          >
                          > mount -t smbfs somesource/share /mnt/share/somewhere
                          >
                          > I get "wrong fs type, bad option, bad superblock ..."

                          What system is this, exactly?

                          -Andre
                        • javamarket
                          Hi Andre, It is a Linkstation PPC. I have managed to realize that a) samba isn t installed b) if downloaded it and am trying to get it installed. Any help in
                          Message 12 of 14 , Jul 19, 2007
                            Hi Andre,
                             
                            It is a Linkstation PPC.
                             
                            I have managed to realize that
                             
                            a) samba isn't installed
                             
                            b) if downloaded it and am trying to get it installed.
                             
                            Any help in this regard would be great.
                             
                            At this point I have extracted the "latest" from samba.org and when I run the ./configure command that should create the makefile I receive:
                             
                            bash-2.05a# ./configure
                            SAMBA VERSION: 3.0.25b
                            LIBREPLACE_LOCATION_CHECKS: START
                            checking build system type... powerpc-unknown-linux-gnu
                            checking host system type... powerpc-unknown-linux-gnu
                            checking target system type... powerpc-unknown-linux-gnu
                            LIBREPLACE_LOCATION_CHECKS: END
                            LIBREPLACE_CC_CHECKS: START
                            checking for gcc... no
                            checking for cc... no
                            checking for cl.exe... no
                            configure: error: no acceptable C compiler found in $PATH
                            See `config.log' for more details.

                            ----- Original Message ----
                            From: lalunas10 <lalunas10@...>
                            To: LinkStation_General@yahoogroups.com
                            Sent: Thursday, July 19, 2007 5:49:37 AM
                            Subject: [LinkStation_General] Re: Mount WINDOWS (SMB) share

                            --- In LinkStation_ General@yahoogro ups.com, "-" <javamarket@ ...> wrote:
                            >
                            > Hello All -
                            >
                            > I'm able to mount NFS shares with
                            >
                            > mount somesource/share /mnt/share/somewher e
                            >
                            > without any issues.
                            >
                            > I'd like to do the same with a Windows share but am having difficulty.
                            >
                            > When I try
                            >
                            > mount -t smbfs somesource/share /mnt/share/somewher e
                            >
                            > I get "wrong fs type, bad option, bad superblock ..."

                            What system is this, exactly?

                            -Andre




                            Shape Yahoo! in your own image. Join our Network Research Panel today!
                          • James Stewart
                            Sorry I didn t notice this thread until it got way long, and I haven t read all the replies to it so excuse me if I miss a few things. I ll try to give my 2
                            Message 13 of 14 , Jul 19, 2007
                              Sorry I didn't notice this thread until it got way long, and I haven't read all the replies
                              to it so excuse me if I miss a few things. I'll try to give my 2 cents worth:

                              1) That old LS Linux 2.4 kernel does NOT support CIFS, but it does support smbfs
                              which is it's predecessor which works more like Windows98 filesharing.

                              2) I'm not completely up on what is going on with MS-Windows these days, but I've
                              always been able to connect to shares from Linux using smbfs. This includes Domain
                              controllers running Server-2003.

                              3) One of many things that might be missing is an encrypted password generated in a
                              file on the LS to match against what the Windows machine is going to want for that
                              share for a given user. This is unless you have it configured as a simple "open"
                              share. To create a password, you normally use the command:

                              smbpasswd -a <username>

                              you even need this if there is no password for that user. (No password is still
                              considered a password choice). In this case use the command:

                              smbpasswd -a -n <username>

                              If you only want to change an existing password, remove the "-a".

                              Now this assumes you HAVE the smbpasswd on the LS. It this OpenLink or FreeLink? I
                              never read the thread enough to find out.

                              4) You also might have something set wrong in the rest of the samba (Windows files
                              sharing suite for Linux) configuration. The raw config file should be
                              at /etc/samba/smb.conf, which is a simple text file you could post here for community
                              inspection. This is where it should be for Freelink, on OpenLink, who knows, the "real"
                              one is probably buried over in the web interface area somewhere. (I thew out the
                              original OS on my LS soon after I bought it.)

                              5) To test some things, try connecting to one of the Linkstations own shares! At least
                              there should be no permissions or strange Windows problems with this. Then work
                              foreward from there.

                              6) Yes, you DO need "smbmount", which is ususally "syn-linked" to "mount.smbfs" for
                              the mount program to find it. You can do this manually if it isn't there:

                              ln -s /usr/bin/smbmount /sbin/mount.smbfs

                              7) Yes you can use the "smbclient" program too, but I'm guessing you want a
                              permanent mount so this would only be useful in testing.

                              8) All of these things are part of the the whole "samba" package, all of which may or
                              may not be fully installed on your Linkstation. This would include the manual pages
                              for this stuff too. If the later is missing you can either consult www.samba.org, or you
                              could even look at the manual pages for what I have on my LS that I have publically
                              available on my LS server. Here might be some interesting links:

                              http://wartstew.homelinux.net/cgi-bin/man/man2html
                              http://wartstew.homelinux.net/cgi-bin/man/man2html?smbmount+8
                              http://wartstew.homelinux.net/cgi-bin/man/man2html?smb.conf+5
                              http://wartstew.homelinux.net/cgi-bin/man/man2html?smbpasswd+5
                              http://wartstew.homelinux.net/cgi-bin/man/man2html?smbpasswd+8
                              http://wartstew.homelinux.net/cgi-bin/man/man2html?mount+8
                              http://wartstew.homelinux.net/cgi-bin/man/mansearch?query=samba

                              You probably get the idea.

                              I even have a bunch of general Samba Documentation in this area:
                              http://wartstew.homelinux.net/dwww/menu/sapps_net.html

                              James
                            • javamarket
                              Hi Thomas, Just a followup thank you. After your contribution I was able to a) put in a full instance of Debian b) mount using mount smbfs Thanks for your
                              Message 14 of 14 , Jul 21, 2007
                                Hi Thomas,

                                Just a followup thank you.
                                After your contribution I was able to
                                 
                                a) put in a full instance of Debian
                                b) mount using mount smbfs
                                 
                                Thanks for your pieces!

                                ----- Original Message ----
                                From: Thomas Ilnseher <illth@...>
                                To: LinkStation_General@yahoogroups.com
                                Sent: Tuesday, July 17, 2007 7:43:28 AM
                                Subject: Re: [LinkStation_General] Re: Mount WINDOWS (SMB) share

                                Am Dienstag, den 17.07.2007, 08:44 +0000 schrieb -:

                                > Hi Thomas -
                                >
                                > Thanks for you ideas.
                                >
                                > When trying CIFS - "fs type cifs not supported by kernel"
                                >
                                > I have no real experience with LINUX so I'm walking mostly blind.
                                > Can you tell me how / where to access the log file you mentioned?
                                you should really try the following:

                                try mounting your smb share as you did, and after it failed, run "dmesg"
                                to see what went wrong.

                                You can also post the relevant parts of the dmesg output here.

                                one note: if you wont give the URI in a form of
                                \\myserver\myshare, you have to type:

                                \\\\myserver\ \myshare
                                in bash. bash interprets \ as an escape character.
                                >
                                > Please forgive this old windows user (smile).
                                >
                                > --- In LinkStation_ General@yahoogro ups.com, Thomas
                                Ilnseher
                                > <illth@...> wrote:
                                > >
                                > > Am Dienstag, den 17.07.2007, 00:04 +0000 schrieb -:
                                > > > Hello All -
                                > > >
                                > > > I'm able to mount NFS shares with
                                > > >
                                > > > mount somesource/share /mnt/share/somewher e
                                > > >
                                > > > without any issues.
                                > > >
                                > > > I'd like to do the same with a Windows share but am having
                                > difficulty.
                                > > >
                                > > > When I try
                                > > >
                                > > > mount -t smbfs somesource/share /mnt/share/somewher e
                                > > maybe you should try "-t cifs" instead of "-t smbfs". at least SuSE
                                > > ships only the cifs driver...
                                > > >
                                > > > I get "wrong fs type, bad option, bad superblock ..."
                                > > You might check the output of "dmesg" to see what exactly fails
                                > > >
                                > > > any help would be
                                great.
                                > > >
                                > > > Thanks!
                                > > >
                                > > >
                                > > >
                                > > >
                                > > >
                                > >
                                >
                                >
                                >
                                >
                                >




                                Sick sense of humor? Visit Yahoo! TV's Comedy with an Edge to see what's on, when.
                              Your message has been successfully submitted and would be delivered to recipients shortly.