Loading ...
Sorry, an error occurred while loading the content.

Problems backing up to Linkstation from Mac

Expand Messages
  • David
    Hi, I ve been lurking on this group for a while, but haven t done any of the mods suggested by this group (yet). My key issue is backing up to my Buffalo
    Message 1 of 1 , Jun 3, 2007
    • 0 Attachment
      Hi,

      I've been lurking on this group for a while, but haven't done any of
      the mods suggested by this group (yet). My key issue is backing up to
      my Buffalo Linkstation from a Mac (OS X, version 10.4.9).

      I want to backup my iTunes Music collection to the Linkstation (~
      40GB). I'd like to have access to the individual music files, rather
      than backing up to a special archive. I use Retrospect for my
      backups, and it has a duplicate feature which is just what I want,
      including doing incremental backups of any changes (e.g. additions to
      my iTunes collection).

      I've tried backingup up to the Linkstation both as an Apple share
      (AFP) and as a PC share (SMB), and both of them have problems,
      although they are completely different.

      AFP
      It seems that the Linkstation has an old version of the AFP protocol
      that only allows short file names (< 32 chars) and limitations on
      filename characters. Many of my iTunes song names are long or have
      special characters, so this just doesn't work.

      SMB
      When I mount the Linkstation as a PC share, I have a different
      problem. In this case, I can do the duplicate, but on about half of
      my files I get an error like:

      File "103.1.mp3": different modification date/time (src: 3/6/2003
      4:38:19 PM, dest: 3/6/2003 4:38:18 PM), path: "temp/103.1.mp3".

      Where the modification date/time is off by 1 second. In researching
      this, I believe the Buffalo Linkstation NAS drive is running Linux,
      with a SAMBA server and the SAMBA server has a configuration to always
      round the seconds of the modificaiton date/time to an even number of
      seconds. The config option is called "dos filetime resolution".

      So, about half my files have a time ending in an odd number of
      seconds, which is rounded down to an even number of seconds on the PC
      share. So, when checking if the copy was okay, Retrospect reports an
      error on these files. But, what's worse is that if I go to do an
      incremental backup, Retrospect will try to copy those files (half of
      40GB) over again, since they have different last modification time
      (off by 1 second). Since this is about 20GB, it takes a long time,
      even though I'm only trying to do an incremental backup of say 200MB.

      Any suggestions?

      BTW, I believe I have a "Linkstation Gigabit", or an HD-HGLAN model
      (HD-HG400LAN to be exact). I've never gotten telnet access to the
      device (which seems to be the assumed first step for getting root
      access). I was running firmware 1.42, but just upgraded to 1.61.

      Thanks in advance,
      David Schorow
    Your message has been successfully submitted and would be delivered to recipients shortly.