Loading ...
Sorry, an error occurred while loading the content.

Re: [LinkStation_General] Re: Installed Gentoo (again), system got clobbered by emerge

Expand Messages
  • Christopher Eykamp
    I think I figured out what the problem was. I had not fully wiped my /var folder (which was unaffected by the rm -fr I ran from the root folder because it was
    Message 1 of 4 , Nov 24, 2006
    View Source
    • 0 Attachment
      I think I figured out what the problem was.  I had not fully wiped my /var folder (which was unaffected by the rm -fr I ran from the root folder because it was a separate mounted drive).  Therefore, when I reinstalled. there was still remnants of old emerges floating around, and that caused things to go haywire.

      Completely wiping /var and reinstalling the files on /var from the archive seem to have largely resolved the problem  I'm emerging something now, so we'll see if it works out as well as I think it will.

      Chris



      Christopher Eykamp wrote:

      Yes, it should be possible to take the standard route to installing Gentoo, and that's probably what I'll do.  I had hoped to avoid all the compiling, but I'm thinking that I may have no choice.  The lure of a 15 minute install is compelling.. .  I'm going to look at the outdated image the page links to and see if that has the same problem.  I'm also looking into ways of regenerating the world file, but nothing I've tried to date works very well.



      cherrytreeproductio n wrote:

      shouldn`t it be possible in EM Mode to use the standard gentoo
      installation procedure?

      what box do you have?

      i have enhanced the stock firmimg.bins of the linkstations so that
      they even are more enhanced than the kurobox EM Mode and it is
      possible to telnet + ftp while in EM Mode.

      i already included the EM Mede binaries there (fdisk...)

      what else besides fdisk, chroot and mounting of the hdd do you need
      for installating gentoo? the kernel is in flash so this is also no
      problem...

      avr_evtd can be used to deal with the watchdog timer + button monitoring.

      -- mindbender
      www.linkstationwiki .net

      --- In LinkStation_ General@yahoogro ups.com, Christopher Eykamp
      <chris@...> wrote:
      >
      > Hello,
      >
      > I followed the instructions for installing Gentoo here:
      >
      > http://www.kurobox. com/mwiki/ index.php/ Install_the_ Gentoo_Image
      >
      > It worked great. Until I tried to emerge a package, that is. When I
      > ran emerge, the package I wanted was successfully emerged, but a ton of
      > critical stuff was "autocleaned" out, causing my system to fail
      > catastrophically (things like Python and ssh were removed!!!)
      >
      > I looked at the file /var/lib/portage/ world, and it only had a single
      > entry. I think that emerge is not aware of what has been installed.
      >
      > Has anyone successfully followed these instructions and had emerge
      > work? Any suggestions on how to make emerge aware of what is
      > installed? Any idea how I can find out what has been installed on the
      > image linked from that page? Any ideas on how to fix this situation?
      >
      > Thanks,
      >
      > Chris
      >

    Your message has been successfully submitted and would be delivered to recipients shortly.