Loading ...
Sorry, an error occurred while loading the content.
 

u-boot RAM version CRC error

Expand Messages
  • Guennadi Liakhovetski
    Hi On a kurobox-HG using a pre-built uloader.o for 2.4.17 with laddr=0x07f00000, pre-built or self-compiled u-boot-hg.ram.bin, and a uImage in /boot I get a
    Message 1 of 3 , Sep 24, 2006
      Hi

      On a kurobox-HG using a pre-built uloader.o for 2.4.17 with
      laddr=0x07f00000, pre-built or self-compiled u-boot-hg.ram.bin, and a
      uImage in /boot I get a CRC warning and then after a long delay it boots
      into 2.4 kernel from flash. On the console I get:

      uloader module booting u-boot


      U-Boot 1.1.4 LiSt 2.1.0 (Sep 22 2006 - 23:17:02) LinkStation HG / KuroBox HG

      CPU: MPC8245 Revision 1.4 at 262.144 MHz: 16 kB I-Cache 16 kB D-Cache
      DRAM: 128 MB
      FLASH: 4 MB
      *** Warning - bad CRC, using default environment

      00 0b 10ec 8169 0200 ff
      00 0c 1095 0680 0101 ff
      00 0e 1033 0035 0c03 ff
      00 0e 1033 0035 0c03 ff
      00 0e 1033 00e0 0c03 ff
      Net: RTL8169#0
      Memory BAT mapping: BAT2=128Mb, BAT3=0Mb, residual: 0Mb
      Linux version 2.4.17_mvl21 (root@toda_dev.melcoinc.co.jp) (gcc version
      2.95.3 20010315 (release/MontaVista)) #24 2004...

      What's the problem? I'd like to get the RAM u-boot to work for me as I've
      to be able to compile u-boot myself and would prefer not to have to solder
      also the JTag header onto the board.

      Great work, by the way!

      Thanks
      Guennadi
      ---
      Guennadi Liakhovetski
    • Guennadi Liakhovetski
      ... Ok, this seems normal , now, the question is why it doesn t work with IDE... Thanks Guennadi ... Guennadi Liakhovetski
      Message 2 of 3 , Sep 24, 2006
        On Sun, 24 Sep 2006, Guennadi Liakhovetski wrote:

        > U-Boot 1.1.4 LiSt 2.1.0 (Sep 22 2006 - 23:17:02) LinkStation HG / KuroBox HG
        >
        > CPU: MPC8245 Revision 1.4 at 262.144 MHz: 16 kB I-Cache 16 kB D-Cache
        > DRAM: 128 MB
        > FLASH: 4 MB
        > *** Warning - bad CRC, using default environment

        Ok, this seems "normal", now, the question is why it doesn't work with
        IDE...

        Thanks
        Guennadi
        ---
        Guennadi Liakhovetski
      • Guennadi Liakhovetski
        ... Actually, it does. I didn t see the messages because after initialising eth it switched to netconsole and further messages, including IDE were sent to it,
        Message 3 of 3 , Sep 24, 2006
          On Sun, 24 Sep 2006, Guennadi Liakhovetski wrote:

          > On Sun, 24 Sep 2006, Guennadi Liakhovetski wrote:
          >
          > > U-Boot 1.1.4 LiSt 2.1.0 (Sep 22 2006 - 23:17:02) LinkStation HG / KuroBox HG
          > >
          > > CPU: MPC8245 Revision 1.4 at 262.144 MHz: 16 kB I-Cache 16 kB D-Cache
          > > DRAM: 128 MB
          > > FLASH: 4 MB
          > > *** Warning - bad CRC, using default environment
          >
          > Ok, this seems "normal", now, the question is why it doesn't work with
          > IDE...

          Actually, it does. I didn't see the messages because after initialising
          eth it switched to netconsole and further messages, including IDE were
          sent to it, and then it looked for /boot/vmlinux.UBoot and not for uImage
          as I thought. Now it works!

          Thanks
          Guennadi
          ---
          Guennadi Liakhovetski
        Your message has been successfully submitted and would be delivered to recipients shortly.