Loading ...
Sorry, an error occurred while loading the content.

need help in mounting Linkstation to my Linux machine

Expand Messages
  • Dirk
    Hi all, as Linux Newby i have problems in linking my Linkstation to my Linux machine (running with debian). I want to mount a share to the linux machine but do
    Message 1 of 6 , Aug 9, 2006
    • 0 Attachment
      Hi all,

      as Linux Newby i have problems in linking my Linkstation to my Linux
      machine (running with debian). I want to mount a share to the linux
      machine but do not succeed. Any hints on how to start??
    • lalunas10
      ... Look for fix_ext_magic in the downloads section of linkstationwiki.net, if the LS partition you want to mount happens to be the first one. -Andre
      Message 2 of 6 , Aug 9, 2006
      • 0 Attachment
        --- In LinkStation_General@yahoogroups.com, "Dirk" <dirk_ffm@...> wrote:
        >
        > Hi all,
        >
        > as Linux Newby i have problems in linking my Linkstation to my Linux
        > machine (running with debian). I want to mount a share to the linux
        > machine but do not succeed. Any hints on how to start??

        Look for fix_ext_magic in the downloads section of linkstationwiki.net, if the LS partition you
        want to mount happens to be the first one.

        -Andre
      • James Stewart
        I m not sure who is the most confused here, but it s probably me. The last reply to your post assummed that what you are trying to do is to remove the hard
        Message 3 of 6 , Aug 10, 2006
        • 0 Attachment
          I'm not sure who is the most confused here, but it's probably me. The
          last reply to your post assummed that what you are trying to do is to
          remove the hard drive from your LS and physically attach it to your
          desktop running Linux. In this case he is right, you need to run the
          fix magic program (found in the "files" section of this group).

          If instead you are trying to mount the share (over the network), then
          on the linux machine, and from a shell prompt here is ONE way to do it:

          cd /mnt
          mkdir share
          mount -t smbfs //yourlinkstaion_netbios_name_or_ip/share share
          cd share
          ls # at this point you should see a list of your share.


          Another way is if you are running KDE, then run Konqueror and enter:

          smb://yourlinkstation_netbios_name or_ip/share

          in the url address field.

          Hope this helps.

          --- In LinkStation_General@yahoogroups.com, "lalunas10"
          <lalunas10@...> wrote:
          >
          > --- In LinkStation_General@yahoogroups.com, "Dirk" <dirk_ffm@> wrote:
          > >
          > > Hi all,
          > >
          > > as Linux Newby i have problems in linking my Linkstation to my Linux
          > > machine (running with debian). I want to mount a share to the linux
          > > machine but do not succeed. Any hints on how to start??
          >
          > Look for fix_ext_magic in the downloads section of
          linkstationwiki.net, if the LS partition you
          > want to mount happens to be the first one.
          >
          > -Andre
          >
        • Dirk
          thanks for your help, but that does not work. When i do a mount -t smbfs //NETDISK1/share share i get the following error: smb_fil_super: missing data argument
          Message 4 of 6 , Aug 10, 2006
          • 0 Attachment
            thanks for your help, but that does not work. When i do a

            mount -t smbfs //NETDISK1/share share

            i get the following error:

            smb_fil_super: missing data argument
            mount: wrong fstype, bad option, bad superblock on //NETDISK1/share
            missing codepage or other error

            Any ideas?


            --- In LinkStation_General@yahoogroups.com, "James Stewart"
            <wartstew@...> wrote:
            >
            > I'm not sure who is the most confused here, but it's probably me. The
            > last reply to your post assummed that what you are trying to do is to
            > remove the hard drive from your LS and physically attach it to your
            > desktop running Linux. In this case he is right, you need to run the
            > fix magic program (found in the "files" section of this group).
            >
            > If instead you are trying to mount the share (over the network), then
            > on the linux machine, and from a shell prompt here is ONE way to do it:
            >
            > cd /mnt
            > mkdir share
            > mount -t smbfs //yourlinkstaion_netbios_name_or_ip/share share
            > cd share
            > ls # at this point you should see a list of your share.
            >
            >
            > Another way is if you are running KDE, then run Konqueror and enter:
            >
            > smb://yourlinkstation_netbios_name or_ip/share
            >
            > in the url address field.
            >
            > Hope this helps.
            >
            > --- In LinkStation_General@yahoogroups.com, "lalunas10"
            > <lalunas10@> wrote:
            > >
            > > --- In LinkStation_General@yahoogroups.com, "Dirk" <dirk_ffm@> wrote:
            > > >
            > > > Hi all,
            > > >
            > > > as Linux Newby i have problems in linking my Linkstation to my Linux
            > > > machine (running with debian). I want to mount a share to the linux
            > > > machine but do not succeed. Any hints on how to start??
            > >
            > > Look for fix_ext_magic in the downloads section of
            > linkstationwiki.net, if the LS partition you
            > > want to mount happens to be the first one.
            > >
            > > -Andre
            > >
            >
          • musikgoat
            make sure your boot sequence starts smbfs. ... Linux ... linux
            Message 5 of 6 , Aug 17, 2006
            • 0 Attachment
              make sure your boot sequence starts smbfs.



              --- In LinkStation_General@yahoogroups.com, "Dirk" <dirk_ffm@...> wrote:
              >
              >
              > thanks for your help, but that does not work. When i do a
              >
              > mount -t smbfs //NETDISK1/share share
              >
              > i get the following error:
              >
              > smb_fil_super: missing data argument
              > mount: wrong fstype, bad option, bad superblock on //NETDISK1/share
              > missing codepage or other error
              >
              > Any ideas?
              >
              >
              > --- In LinkStation_General@yahoogroups.com, "James Stewart"
              > <wartstew@> wrote:
              > >
              > > I'm not sure who is the most confused here, but it's probably me. The
              > > last reply to your post assummed that what you are trying to do is to
              > > remove the hard drive from your LS and physically attach it to your
              > > desktop running Linux. In this case he is right, you need to run the
              > > fix magic program (found in the "files" section of this group).
              > >
              > > If instead you are trying to mount the share (over the network), then
              > > on the linux machine, and from a shell prompt here is ONE way to
              do it:
              > >
              > > cd /mnt
              > > mkdir share
              > > mount -t smbfs //yourlinkstaion_netbios_name_or_ip/share share
              > > cd share
              > > ls # at this point you should see a list of your share.
              > >
              > >
              > > Another way is if you are running KDE, then run Konqueror and enter:
              > >
              > > smb://yourlinkstation_netbios_name or_ip/share
              > >
              > > in the url address field.
              > >
              > > Hope this helps.
              > >
              > > --- In LinkStation_General@yahoogroups.com, "lalunas10"
              > > <lalunas10@> wrote:
              > > >
              > > > --- In LinkStation_General@yahoogroups.com, "Dirk" <dirk_ffm@>
              wrote:
              > > > >
              > > > > Hi all,
              > > > >
              > > > > as Linux Newby i have problems in linking my Linkstation to my
              Linux
              > > > > machine (running with debian). I want to mount a share to the
              linux
              > > > > machine but do not succeed. Any hints on how to start??
              > > >
              > > > Look for fix_ext_magic in the downloads section of
              > > linkstationwiki.net, if the LS partition you
              > > > want to mount happens to be the first one.
              > > >
              > > > -Andre
              > > >
              > >
              >
            • James Stewart
              Yes, if you do a ps -a you should see nmbd listed. If not, install and/or start samba. You may also need to configure it with: http://localhost:901
              Message 6 of 6 , Aug 20, 2006
              • 0 Attachment
                Yes, if you do a "ps -a" you should see "nmbd" listed. If not,
                install and/or start samba. You may also need to configure it
                with: "http://localhost:901" (swat) to set things like your
                workgroup. Oh and swat needs to be enabled using a line
                in /etc/inetd.conf)

                Also make sure that smbfs support is in your kernel. Often it is
                included as a module, so doing an "lsmod" should list it. If not
                try doing a "modprobe smbfs" before you do a mount.

                Of course all this can be automated, but those details are specific
                to the Linux distribution that you are running.

                --- In LinkStation_General@yahoogroups.com, "musikgoat"
                <musikgoat@...> wrote:
                >
                > make sure your boot sequence starts smbfs.
                >
                >
                >
                > --- In LinkStation_General@yahoogroups.com, "Dirk" <dirk_ffm@>
                wrote:
                > >
                > >
                > > thanks for your help, but that does not work. When i do a
                > >
                > > mount -t smbfs //NETDISK1/share share
                > >
                > > i get the following error:
                > >
                > > smb_fil_super: missing data argument
                > > mount: wrong fstype, bad option, bad superblock
                on //NETDISK1/share
                > > missing codepage or other error
                > >
                > > Any ideas?
                > >
                > >
                > > --- In LinkStation_General@yahoogroups.com, "James Stewart"
                > > <wartstew@> wrote:
                > > >
                > > > I'm not sure who is the most confused here, but it's probably
                me. The
                > > > last reply to your post assummed that what you are trying to
                do is to
                > > > remove the hard drive from your LS and physically attach it to
                your
                > > > desktop running Linux. In this case he is right, you need to
                run the
                > > > fix magic program (found in the "files" section of this
                group).
                > > >
                > > > If instead you are trying to mount the share (over the
                network), then
                > > > on the linux machine, and from a shell prompt here is ONE way
                to
                > do it:
                > > >
                > > > cd /mnt
                > > > mkdir share
                > > > mount -t smbfs //yourlinkstaion_netbios_name_or_ip/share share
                > > > cd share
                > > > ls # at this point you should see a list of your share.
                > > >
                > > >
                > > > Another way is if you are running KDE, then run Konqueror and
                enter:
                > > >
                > > > smb://yourlinkstation_netbios_name or_ip/share
                > > >
                > > > in the url address field.
                > > >
                > > > Hope this helps.
                > > >
                > > > --- In LinkStation_General@yahoogroups.com, "lalunas10"
                > > > <lalunas10@> wrote:
                > > > >
                > > > > --- In LinkStation_General@yahoogroups.com, "Dirk"
                <dirk_ffm@>
                > wrote:
                > > > > >
                > > > > > Hi all,
                > > > > >
                > > > > > as Linux Newby i have problems in linking my Linkstation
                to my
                > Linux
                > > > > > machine (running with debian). I want to mount a share to
                the
                > linux
                > > > > > machine but do not succeed. Any hints on how to start??
                > > > >
                > > > > Look for fix_ext_magic in the downloads section of
                > > > linkstationwiki.net, if the LS partition you
                > > > > want to mount happens to be the first one.
                > > > >
                > > > > -Andre
                > > > >
                > > >
                > >
                >
              Your message has been successfully submitted and would be delivered to recipients shortly.