Loading ...
Sorry, an error occurred while loading the content.

Re: Need autofan help for LS2 (MIPS)

Expand Messages
  • j_k_orr
    ... Sorted - a stupid typo on my part. Now it s running but the fan never seems to go into quiet mode. Where do I start? John
    Message 1 of 4 , Aug 9, 2006
    • 0 Attachment
      --- In LinkStation_General@yahoogroups.com, "j_k_orr" <john@...> wrote:
      >
      > I've tried setting up the Cool'n Quiet scripts but I'm having a bit of
      > a problem.
      >
      > I have an LS2 flashed with Openlink.
      > I manually installed the Cool'n Quiet scripts, following the shell
      > script but it doesn't seem to be behaving - the fan remains running on
      > high the whole time.
      >
      > When I manually do an Autofand stop, the process ends, but when I then
      > restart it with AutoFand start I get a whole bunch of errors:
      > /etc/init.d/AutoFan: [: - unary operator expected
      > The logfile, linkstation.log, has a message that the AutoFan script
      > has started.
      >
      > Can someone please help me to figure out what's not working and how to
      > fix it?
      > Thanks,
      > John
      >

      Sorted - a stupid typo on my part.
      Now it's running but the fan never seems to go into quiet mode.
      Where do I start?
      John
    • lalunas10
      ... http://linkstationwiki.net/index.php?title=Information/MIPSelAVR (wrong /dev/ttyS* probably, wrong command maybe) -Andre
      Message 2 of 4 , Aug 9, 2006
      • 0 Attachment
        --- In LinkStation_General@yahoogroups.com, "j_k_orr" <john@...> wrote:
        >
        > --- In LinkStation_General@yahoogroups.com, "j_k_orr" <john@> wrote:
        > >
        > > I've tried setting up the Cool'n Quiet scripts but I'm having a bit of
        > > a problem.
        > >
        > > I have an LS2 flashed with Openlink.
        > > I manually installed the Cool'n Quiet scripts, following the shell
        > > script but it doesn't seem to be behaving - the fan remains running on
        > > high the whole time.
        > >
        > > When I manually do an Autofand stop, the process ends, but when I then
        > > restart it with AutoFand start I get a whole bunch of errors:
        > > /etc/init.d/AutoFan: [: - unary operator expected
        > > The logfile, linkstation.log, has a message that the AutoFan script
        > > has started.
        > >
        > > Can someone please help me to figure out what's not working and how to
        > > fix it?
        > > Thanks,
        > > John
        > >
        >
        > Sorted - a stupid typo on my part.
        > Now it's running but the fan never seems to go into quiet mode.
        > Where do I start?
        > John

        http://linkstationwiki.net/index.php?title=Information/MIPSelAVR

        (wrong /dev/ttyS* probably, wrong command maybe)

        -Andre
      • j_k_orr
        ... bit of ... shell ... running on ... I then ... script ... how to ... Thanks Andre, The command looks correct. I have put in additional logging points to
        Message 3 of 4 , Aug 10, 2006
        • 0 Attachment
          --- In LinkStation_General@yahoogroups.com, "lalunas10"
          <lalunas10@...> wrote:
          >
          > --- In LinkStation_General@yahoogroups.com, "j_k_orr" <john@> wrote:
          > >
          > > --- In LinkStation_General@yahoogroups.com, "j_k_orr" <john@>
          wrote:
          > > >
          > > > I've tried setting up the Cool'n Quiet scripts but I'm having a
          bit of
          > > > a problem.
          > > >
          > > > I have an LS2 flashed with Openlink.
          > > > I manually installed the Cool'n Quiet scripts, following the
          shell
          > > > script but it doesn't seem to be behaving - the fan remains
          running on
          > > > high the whole time.
          > > >
          > > > When I manually do an Autofand stop, the process ends, but when
          I then
          > > > restart it with AutoFand start I get a whole bunch of errors:
          > > > /etc/init.d/AutoFan: [: - unary operator expected
          > > > The logfile, linkstation.log, has a message that the AutoFan
          script
          > > > has started.
          > > >
          > > > Can someone please help me to figure out what's not working and
          how to
          > > > fix it?
          > > > Thanks,
          > > > John
          > > >
          > >
          > > Sorted - a stupid typo on my part.
          > > Now it's running but the fan never seems to go into quiet mode.
          > > Where do I start?
          > > John
          >
          > http://linkstationwiki.net/index.php?title=Information/MIPSelAVR
          >
          > (wrong /dev/ttyS* probably, wrong command maybe)
          >
          > -Andre
          >
          Thanks Andre,
          The command looks correct.
          I have put in additional logging points to try and figure out what is
          happening and it looks like it's simply a case of the hard drive
          spinning up on a regular basis and the script catching it at
          the 'wrong time'.
          I've tried killing off various processes to see what is initiating
          the disk access. I haven't quite narrowed it down, but killing
          thttpd, ftp and samba means that it does eventually quieten down. But
          I need these running even though real access is infrequent.
          Is there a more 'intelligent' autofan utility which relies on drive
          temperature or some other method to optimise fan speed?
          I have seen mention of using smartmon but douldn't find any
          definitive scripts with it working.
          John
        Your message has been successfully submitted and would be delivered to recipients shortly.