Loading ...
Sorry, an error occurred while loading the content.

Problem installng SlimServer on Linkstation II

Expand Messages
  • mkagoston
    I recently bought a Linkstation II and wanted to install the Slimserver software on it. I followed the instructions in the wiki, got root access, installed the
    Message 1 of 3 , Jul 23, 2006
    • 0 Attachment
      I recently bought a Linkstation II and wanted to install the Slimserver
      software on it. I followed the instructions in the wiki, got root
      access, installed the openlink software, and slimserver 6.2.2. When I
      tried to run slimserver I got the known "SQLite, etc. modules failed to
      load" error and could not get slimserver to run. Then I read about
      potential problems with Perl5.8.7, so I installed Perl5.8.5 and
      reinstalled slimserver. Trying to run slimserver now gives me errors on
      the first few lines of the slimserver.pl file:

      require 5.006.000;
      use strict;
      use warning;
      ..
      package PerlSvc;

      It says that these commands are not found. Help.
      Any suggestions?
      Thanks.
    • mkagoston
      Anybody? I m really stuck here. I tried changing the first line of slimserver.pl to #!/usr/local/bin/perl -w which is where perl5.8.5 is but that did not help.
      Message 2 of 3 , Jul 26, 2006
      • 0 Attachment
        Anybody? I'm really stuck here. I tried changing the first line of
        slimserver.pl to

        #!/usr/local/bin/perl -w

        which is where perl5.8.5 is but that did not help.

        --- In LinkStation_General@yahoogroups.com, "mkagoston"
        <mkagoston@...> wrote:
        >
        > I recently bought a Linkstation II and wanted to install the
        Slimserver
        > software on it. I followed the instructions in the wiki, got root
        > access, installed the openlink software, and slimserver 6.2.2.
        When I
        > tried to run slimserver I got the known "SQLite, etc. modules
        failed to
        > load" error and could not get slimserver to run. Then I read about
        > potential problems with Perl5.8.7, so I installed Perl5.8.5 and
        > reinstalled slimserver. Trying to run slimserver now gives me
        errors on
        > the first few lines of the slimserver.pl file:
        >
        > require 5.006.000;
        > use strict;
        > use warning;
        > ..
        > package PerlSvc;
        >
        > It says that these commands are not found. Help.
        > Any suggestions?
        > Thanks.
        >
      • mkagoston
        To clarify: I have the MIPS Linkstation. I don t know if that is called a Linkstation II. ... Slimserver ... When I ... failed to ... errors on
        Message 3 of 3 , Jul 27, 2006
        • 0 Attachment
          To clarify: I have the MIPS Linkstation. I don't know if that is
          called a Linkstation II.

          --- In LinkStation_General@yahoogroups.com, "mkagoston"
          <mkagoston@...> wrote:
          >
          > I recently bought a Linkstation II and wanted to install the
          Slimserver
          > software on it. I followed the instructions in the wiki, got root
          > access, installed the openlink software, and slimserver 6.2.2.
          When I
          > tried to run slimserver I got the known "SQLite, etc. modules
          failed to
          > load" error and could not get slimserver to run. Then I read about
          > potential problems with Perl5.8.7, so I installed Perl5.8.5 and
          > reinstalled slimserver. Trying to run slimserver now gives me
          errors on
          > the first few lines of the slimserver.pl file:
          >
          > require 5.006.000;
          > use strict;
          > use warning;
          > ..
          > package PerlSvc;
          >
          > It says that these commands are not found. Help.
          > Any suggestions?
          > Thanks.
          >
        Your message has been successfully submitted and would be delivered to recipients shortly.