Loading ...
Sorry, an error occurred while loading the content.

Re: [LinkStation_General] Re: Problems accessing LS outside LAN

Expand Messages
  • pfink
    ... If your FTP client is trying to connect to the LS in passive mode, try switching to active (or vice-versa.)
    Message 1 of 23 , Apr 5, 2006
    • 0 Attachment
      Jeff wrote:
      > I have not been able to FTP into the LS from outside our LAN. I've
      > scoured the help guides and this message board and seem to have
      > everything set up right, but I always get a "timeout" when trying to
      > FTP from the internet. We can do everything internally over the
      > network and using Local IP as FTP.
      >
      > I'm using a D-Link Router that I set up to allow ports 20-21 to FTP to
      > the local IP address of the LS and I set up the NAT (virtual server)
      > to forward ports 20 and 21 to the local IP address of the LS. I
      > enabled FTP on the LS and set the IP address to a static address and
      > enabled the gateway address to the local IP address of the D-Link
      > router. But when I FTP to the WAN address from the internet (with
      > username/password or anonymously) I get nothing. I'm stuck... any
      > advice out there?

      If your FTP client is trying to connect to the LS in
      "passive" mode, try switching to "active" (or vice-versa.)
    • Scott Griswold
      I too am getting the same issue, however, after some time, about 2 or 3 minutes, the server will prompt me for a username and password. However, when I enter
      Message 2 of 23 , Apr 5, 2006
      • 0 Attachment
        I too am getting the same issue, however, after some time, about 2 or
        3 minutes, the server will prompt me for a username and password.
        However, when I enter them, I am told that they are incorrect. I have
        reset them and double and triple checked that they are correct.
        Same result. I'll try the Active/Passive suggestion made in a
        subsequent message. But the fact that it gets as far as the prompt
        makes me wonder if the problem is with the FTP server on the LS.
        Thanks for the help,
        -Scott

        On Apr 5, 2006, at 7:21 PM, Jeff wrote:

        > I have not been able to FTP into the LS from outside our LAN. I've
        > scoured the help guides and this message board and seem to have
        > everything set up right, but I always get a "timeout" when trying to
        > FTP from the internet. We can do everything internally over the
        > network and using Local IP as FTP.
        >
        > I'm using a D-Link Router that I set up to allow ports 20-21 to FTP to
        > the local IP address of the LS and I set up the NAT (virtual server)
        > to forward ports 20 and 21 to the local IP address of the LS. I
        > enabled FTP on the LS and set the IP address to a static address and
        > enabled the gateway address to the local IP address of the D-Link
        > router. But when I FTP to the WAN address from the internet (with
        > username/password or anonymously) I get nothing. I'm stuck... any
        > advice out there?
        >
        >
        > --- In LinkStation_General@yahoogroups.com, "han320yah" <b747@...>
        > wrote:
        >>
        >> Problem solved and a very stupid error on my part! The default
        >> gateway function within my LS had been disabled. Just re-enabled it
        >> and set the gateway to my router address. All now working as
        >> advertised.
        >>
        >> --- In LinkStation_General@yahoogroups.com, "han320yah" <b747@o...>
        >> wrote:
        >>> I'm having difficulties accessing my LS from outside my LAN. Last
        >>> week the LS was accessible outside via FTP. However it has since
        >>> stopped and I can't ascertain why. I also have my website hosted on
        >>> the LS but this can't be accessed outside either. I can ftp and
        >>> access the webserver from within my home network using either ip
        >>> address or my domain name. I have port forwarding set up on my
        >> router
        >>> (Linksys WRT54G) so that ports 20 & 21 are forwarded to the ip
        >> address
        >>> of my LS (192.168.1.120). Ports 80 & 81 are also forwarded for the
        >>> webserver (I installed a second webserver thttpd2). I have the
        >> router
        >>> firewall disabled.
        >>>
        >>> I simply can't work out why access from outside is not working.
        >>> Anyone any ideas what might be causing this?
        >>
        >
        >
        >
        >
        >
        >
        >
        >
        > Yahoo! Groups Links
        >
        >
        >
        >
        >
        >
      • pfink
        ... That sounds like the FTP server may be trying to do a reverse lookup before prompting you to login. If you re using ProFTPd on the server try adding these
        Message 3 of 23 , Apr 5, 2006
        • 0 Attachment
          Scott Griswold wrote:
          > I too am getting the same issue, however, after some time, about 2 or
          > 3 minutes, the server will prompt me for a username and password.
          > However, when I enter them, I am told that they are incorrect. I have
          > reset them and double and triple checked that they are correct.
          > Same result. I'll try the Active/Passive suggestion made in a
          > subsequent message. But the fact that it gets as far as the prompt
          > makes me wonder if the problem is with the FTP server on the LS.

          That sounds like the FTP server may be trying to do a
          reverse lookup before prompting you to login.

          If you're using ProFTPd on the server try adding these
          two lines to the proftp.conf file and then restart the
          FTP daemon:

          UseReverseDNS off
          IdentLookups off


          If you're using some other FTP daemon then you'll have
          to check the documentation for the appropriate settings.
        • Scott Griswold
          I am using the built in FTP server option. This is not a hacked LS, but a Stock HD-HG250LAN. -Scott
          Message 4 of 23 , Apr 5, 2006
          • 0 Attachment
            I am using the built in FTP server option. This is not a hacked LS,
            but a Stock HD-HG250LAN.

            -Scott

            On Apr 5, 2006, at 9:37 PM, pfink wrote:

            > Scott Griswold wrote:
            >> I too am getting the same issue, however, after some time, about 2 or
            >> 3 minutes, the server will prompt me for a username and password.
            >> However, when I enter them, I am told that they are incorrect. I have
            >> reset them and double and triple checked that they are correct.
            >> Same result. I'll try the Active/Passive suggestion made in a
            >> subsequent message. But the fact that it gets as far as the prompt
            >> makes me wonder if the problem is with the FTP server on the LS.
            >
            > That sounds like the FTP server may be trying to do a
            > reverse lookup before prompting you to login.
            >
            > If you're using ProFTPd on the server try adding these
            > two lines to the proftp.conf file and then restart the
            > FTP daemon:
            >
            > UseReverseDNS off
            > IdentLookups off
            >
            >
            > If you're using some other FTP daemon then you'll have
            > to check the documentation for the appropriate settings.
            >
            >
            >
            >
            > Yahoo! Groups Links
            >
            >
            >
            >
            >
            >
            >
          • Larry Adams
            FTP requires you to open ports 20 and 21. TheWitness _____ From: LinkStation_General@yahoogroups.com [mailto:LinkStation_General@yahoogroups.com] On Behalf Of
            Message 5 of 23 , Apr 5, 2006
            • 0 Attachment

              FTP requires you to open ports 20 and 21.

               

              TheWitness

               


              From: LinkStation_General@yahoogroups.com [mailto: LinkStation_General@yahoogroups.com ] On Behalf Of Scott Griswold
              Sent: Wednesday, April 05, 2006 10:01 PM
              To: LinkStation_General@yahoogroups.com
              Subject: Re: [LinkStation_General] Re: Problems accessing LS outside LAN

               

              I am using the built in FTP server option. This is not a hacked LS, 
              but a Stock HD-HG250LAN.

              -Scott

              On Apr 5, 2006, at 9:37 PM, pfink wrote:

              > Scott Griswold wrote:
              >> I too am getting the same issue, however, after some time, about 2 or
              >> 3 minutes, the server will prompt me for a username and password.
              >> However, when I enter them, I am told that they are incorrect. I have
              >> reset them and double and triple checked that they are correct.
              >> Same result. I'll try the Active/Passive suggestion made in a
              >> subsequent message. But the fact that it gets as far as the prompt
              >> makes me wonder if the problem is with the FTP server on the LS.
              >
              > That sounds like the FTP server may be trying to do a
              > reverse lookup before prompting you to login.
              >
              > If you're using ProFTPd on the server try adding these
              > two lines to the proftp.conf file and then restart the
              > FTP daemon:
              >
              > UseReverseDNS                   off
              > IdentLookups                    off
              >
              >
              > If you're using some other FTP daemon then you'll have
              > to check the documentation for the appropriate settings.
              >
              >
              >
              >
              > Yahoo! Groups Links
              >
              >
              >
              >
              >
              >
              >


            • Scott Griswold
              20 and 21? I did open 21, but not 20. Could that be the issue? -Scott
              Message 6 of 23 , Apr 5, 2006
              • 0 Attachment
                20 and 21? I did open 21, but not 20. Could that be the issue?
                -Scott

                On Apr 5, 2006, at 10:16 PM, Larry Adams wrote:

                FTP requires you to open ports 20 and 21.

                 

                TheWitness

                 


                From: LinkStation_General@yahoogroups.com [mailto:LinkStation_General@yahoogroups.com] On Behalf Of Scott Griswold
                Sent: Wednesday, April 05, 2006 10:01 PM
                To: LinkStation_General@yahoogroups.com
                Subject: Re: [LinkStation_General] Re: Problems accessing LS outside LAN

                 

                I am using the built in FTP server option. This is not a hacked LS, 
                but a Stock HD-HG250LAN.

                -Scott

                On Apr 5, 2006, at 9:37 PM, pfink wrote:

                > Scott Griswold wrote:
                >> I too am getting the same issue, however, after some time, about 2 or
                >> 3 minutes, the server will prompt me for a username and password.
                >> However, when I enter them, I am told that they are incorrect. I have
                >> reset them and double and triple checked that they are correct.
                >> Same result. I'll try the Active/Passive suggestion made in a
                >> subsequent message. But the fact that it gets as far as the prompt
                >> makes me wonder if the problem is with the FTP server on the LS.
                >
                > That sounds like the FTP server may be trying to do a
                > reverse lookup before prompting you to login.
                >
                > If you're using ProFTPd on the server try adding these
                > two lines to the proftp.conf file and then restart the
                > FTP daemon:
                >
                > UseReverseDNS                   off
                > IdentLookups                    off
                >
                >
                > If you're using some other FTP daemon then you'll have
                > to check the documentation for the appropriate settings.
                >
                >
                >
                >
                > Yahoo! Groups Links
                >
                >
                >
                >
                >
                >
                >




                YAHOO! GROUPS LINKS






              • Jeff
                I have tried both passive and active modes and still cannot get a connection.
                Message 7 of 23 , Apr 5, 2006
                • 0 Attachment
                  I have tried both passive and active modes and still cannot get a
                  connection.

                  >
                  > If your FTP client is trying to connect to the LS in
                  > "passive" mode, try switching to "active" (or vice-versa.)
                  >
                • KeepIt SimpleStupid
                  Opening ports 20-21 is not enough to get FTP to work. You need to open a few (say 3) higher number ports. Try opening 1025, 1026 and 1027 as well. I just
                  Message 8 of 23 , Apr 5, 2006
                  • 0 Attachment
                    Opening ports 20-21 is not enough to get FTP to work.
                    You need to open a few (say 3) higher number ports.
                    Try opening 1025, 1026 and 1027 as well. I just
                    looked at what I had forwarded on my router. For more
                    info look at the RFC for FTP. You also need to use
                    the right mode of FTP.

                    It's also difficult to test since you can't ftp from
                    inside to your public IP address. I was able to ssh
                    to a unix host and then ftp back into my LAN from that
                    host to test.

                    --- Jeff <jfish_berean@...> wrote:

                    > I have not been able to FTP into the LS from outside
                    > our LAN. I've
                    > scoured the help guides and this message board and
                    > seem to have
                    > everything set up right, but I always get a
                    > "timeout" when trying to
                    > FTP from the internet. We can do everything
                    > internally over the
                    > network and using Local IP as FTP.
                    >
                    > I'm using a D-Link Router that I set up to allow
                    > ports 20-21 to FTP to
                    > the local IP address of the LS and I set up the NAT
                    > (virtual server)
                    > to forward ports 20 and 21 to the local IP address
                    > of the LS. I
                    > enabled FTP on the LS and set the IP address to a
                    > static address and
                    > enabled the gateway address to the local IP address
                    > of the D-Link
                    > router. But when I FTP to the WAN address from the
                    > internet (with
                    > username/password or anonymously) I get nothing.
                    > I'm stuck... any
                    > advice out there?
                    >
                    >
                    > --- In LinkStation_General@yahoogroups.com,
                    > "han320yah" <b747@...> wrote:
                    > >
                    > > Problem solved and a very stupid error on my part!
                    > The default
                    > > gateway function within my LS had been disabled.
                    > Just re-enabled it
                    > > and set the gateway to my router address. All now
                    > working as
                    > > advertised.
                    > >
                    > > --- In LinkStation_General@yahoogroups.com,
                    > "han320yah" <b747@o...>
                    > > wrote:
                    > > > I'm having difficulties accessing my LS from
                    > outside my LAN. Last
                    > > > week the LS was accessible outside via FTP.
                    > However it has since
                    > > > stopped and I can't ascertain why. I also have
                    > my website hosted on
                    > > > the LS but this can't be accessed outside
                    > either. I can ftp and
                    > > > access the webserver from within my home network
                    > using either ip
                    > > > address or my domain name. I have port
                    > forwarding set up on my
                    > > router
                    > > > (Linksys WRT54G) so that ports 20 & 21 are
                    > forwarded to the ip
                    > > address
                    > > > of my LS (192.168.1.120). Ports 80 & 81 are
                    > also forwarded for the
                    > > > webserver (I installed a second webserver
                    > thttpd2). I have the
                    > > router
                    > > > firewall disabled.
                    > > >
                    > > > I simply can't work out why access from outside
                    > is not working.
                    > > > Anyone any ideas what might be causing this?
                    > >
                    >
                    >
                    >
                    >
                    >
                    >


                    __________________________________________________
                    Do You Yahoo!?
                    Tired of spam? Yahoo! Mail has the best spam protection around
                    http://mail.yahoo.com
                  • Larry Adams
                    Yes _____ From: LinkStation_General@yahoogroups.com [mailto:LinkStation_General@yahoogroups.com] On Behalf Of Scott Griswold Sent: Wednesday, April 05, 2006
                    Message 9 of 23 , Apr 6, 2006
                    • 0 Attachment

                      Yes

                       


                      From: LinkStation_General@yahoogroups.com [mailto:LinkStation_General@yahoogroups.com] On Behalf Of Scott Griswold
                      Sent: Wednesday, April 05, 2006 10:35 PM
                      To: LinkStation_General@yahoogroups.com
                      Subject: Re: [LinkStation_General] Re: Problems accessing LS outside LAN

                       

                      20 and 21? I did open 21, but not 20. Could that be the issue?

                      -Scott

                       

                      On Apr 5, 2006, at 10:16 PM, Larry Adams wrote:



                      FTP requires you to open ports 20 and 21.

                      TheWitness


                      From: LinkStation_General@yahoogroups.com [mailto:LinkStation_General@yahoogroups.com ] On Behalf Of Scott Griswold
                      Sent: Wednesday, April 05, 2006 10:01 PM
                      To: LinkStation_General@yahoogroups.com
                      Subject: Re: [LinkStation_General] Re: Problems accessing LS outside LAN

                      I am using the built in FTP server option. This is not a hacked LS, LinkStation_General" on the web.

                      ·  To unsubscribe from this group, send an email to:
                      LinkStation_General-unsubscribe@yahoogroups.com

                      ·  Your use of Yahoo! Groups is subject to the Yahoo! Terms of Service.

                       


                       





                    • Jeff
                      I still cannot FTP from the Internet from an outside location. When I enter in my username/password combo with the WAN IP that the newtwork with the
                      Message 10 of 23 , Apr 18, 2006
                      • 0 Attachment
                        I still cannot FTP from the Internet from an outside location. When I
                        enter in my username/password combo with the WAN IP that the newtwork
                        with the LinkStation is on (i.e. ftp://username:password@65.a.b.123)
                        it times out every time.

                        I set up my Linkstation to have a static IP address of 192.168.x.y and
                        a Gateway of 192.168.x.1 (which is the same as the IP address of my
                        router). I can access the Linkstation locally either through the
                        Workgroup, as a Network Drive, and by FTP using the local LAN IP
                        192.168.x.y. I configured my D-Link router to allow ports 20, 21, and
                        1025-1027 for FTP access and set up the Virtual FTP Server to point to
                        the IP address of my LinkStation 192.168.x.y, but I still can't access
                        it from the internet - using passive or active modes of any FTP
                        program or web browser...

                        Neither Buffalo nor D-Link has been helpful at all. Any other
                        thoughts out there? I'm still tinkering around with it to see if I
                        can discover something I overlooked.



                        --- In LinkStation_General@yahoogroups.com, KeepIt SimpleStupid
                        <keepitsimplestupid@...> wrote:
                        >
                        > Opening ports 20-21 is not enough to get FTP to work.
                        > You need to open a few (say 3) higher number ports.
                        > Try opening 1025, 1026 and 1027 as well. I just
                        > looked at what I had forwarded on my router. For more
                        > info look at the RFC for FTP. You also need to use
                        > the right mode of FTP.
                        >
                        > It's also difficult to test since you can't ftp from
                        > inside to your public IP address. I was able to ssh
                        > to a unix host and then ftp back into my LAN from that
                        > host to test.
                      • pfink
                        ... Could your ISP possibly be blocking incoming FTP traffic?
                        Message 11 of 23 , Apr 18, 2006
                        • 0 Attachment
                          Jeff wrote:
                          > I still cannot FTP from the Internet from an outside location. When I
                          > enter in my username/password combo with the WAN IP that the newtwork
                          > with the LinkStation is on (i.e. ftp://username:password@65.a.b.123)
                          > it times out every time.
                          >
                          > I set up my Linkstation to have a static IP address of 192.168.x.y and
                          > a Gateway of 192.168.x.1 (which is the same as the IP address of my
                          > router). I can access the Linkstation locally either through the
                          > Workgroup, as a Network Drive, and by FTP using the local LAN IP
                          > 192.168.x.y. I configured my D-Link router to allow ports 20, 21, and
                          > 1025-1027 for FTP access and set up the Virtual FTP Server to point to
                          > the IP address of my LinkStation 192.168.x.y, but I still can't access
                          > it from the internet - using passive or active modes of any FTP
                          > program or web browser...
                          >
                          > Neither Buffalo nor D-Link has been helpful at all. Any other
                          > thoughts out there? I'm still tinkering around with it to see if I
                          > can discover something I overlooked.

                          Could your ISP possibly be blocking incoming FTP traffic?
                        • KeepIt SimpleStupid
                          Lets go way basic. DSL/Cable providers will close the connection if it doesn t see traffic from the inside of the LAN. That s where dyndys.org type systems
                          Message 12 of 23 , Apr 18, 2006
                          • 0 Attachment
                            Lets go way basic. DSL/Cable providers will close the
                            connection if it doesn't see traffic from the inside
                            of the LAN. That's where dyndys.org type systems come
                            into play. Alternatively, a slingbox from
                            www.slingbox.com or Best Buy has mechanisms that can
                            allow you to get your IP address at home once you
                            connect remotely. It does work.


                            Or try this:

                            From windows cmd prompt run telnet

                            open 65.a.b.123 21

                            or from a unix box:

                            % telnet 65.a.b.123 21

                            This will just try to open port 21. It doesn't know
                            about FTP or the protocal or anything so don't let the
                            word telnet fool you. Your telnetiing to port 21
                            which is an FTP port and not a telnet port. This
                            doesn't know about any of the other ports required for
                            FTP.

                            you might see:

                            Trying 65.a.b.123...
                            Connected to (somewhere.com).
                            Escape character is '^]'.
                            220 Somewhere.com FTP server (Version wu-2.6.2+Sun)
                            ready.
                            (I typed a return here)
                            530 Please login with USER and PASS.

                            This is an actual response from a Sun unix machine to
                            itself. I also tried using windows to the sun and got
                            the same result. You won't be able to log on.

                            Get simple connectivity, then get the protocol to
                            work.

                            If you suspect FTP is being blocked try a finger
                            client and server which uses port 79.

                            If you have a Windows PC or whatever and get a finger
                            server to work.

                            So
                            1) your ISP could be blocking FTP.
                            2) your ISP has a short lease on your IP address.




                            --- Jeff <jfish_berean@...> wrote:

                            > I still cannot FTP from the Internet from an outside
                            > location. When I
                            > enter in my username/password combo with the WAN IP
                            > that the newtwork
                            > with the LinkStation is on (i.e.
                            > ftp://username:password@65.a.b.123)
                            > it times out every time.
                            >
                            > I set up my Linkstation to have a static IP address
                            > of 192.168.x.y and
                            > a Gateway of 192.168.x.1 (which is the same as the
                            > IP address of my
                            > router). I can access the Linkstation locally
                            > either through the
                            > Workgroup, as a Network Drive, and by FTP using the
                            > local LAN IP
                            > 192.168.x.y. I configured my D-Link router to allow
                            > ports 20, 21, and
                            > 1025-1027 for FTP access and set up the Virtual FTP
                            > Server to point to
                            > the IP address of my LinkStation 192.168.x.y, but I
                            > still can't access
                            > it from the internet - using passive or active modes
                            > of any FTP
                            > program or web browser...
                            >
                            > Neither Buffalo nor D-Link has been helpful at all.
                            > Any other
                            > thoughts out there? I'm still tinkering around with
                            > it to see if I
                            > can discover something I overlooked.
                            >
                            >
                            >
                            > --- In LinkStation_General@yahoogroups.com, KeepIt
                            > SimpleStupid
                            > <keepitsimplestupid@...> wrote:
                            > >
                            > > Opening ports 20-21 is not enough to get FTP to
                            > work.
                            > > You need to open a few (say 3) higher number
                            > ports.
                            > > Try opening 1025, 1026 and 1027 as well. I just
                            > > looked at what I had forwarded on my router. For
                            > more
                            > > info look at the RFC for FTP. You also need to
                            > use
                            > > the right mode of FTP.
                            > >
                            > > It's also difficult to test since you can't ftp
                            > from
                            > > inside to your public IP address. I was able to
                            > ssh
                            > > to a unix host and then ftp back into my LAN from
                            > that
                            > > host to test.
                            >



                            __________________________________________________
                            Do You Yahoo!?
                            Tired of spam? Yahoo! Mail has the best spam protection around
                            http://mail.yahoo.com
                          • socaljbeezer
                            I too have a d-link router but my FTP setup is working flawlessly. I only forward port 21 thru the vitual server setup. I confirmed my settings against your
                            Message 13 of 23 , Apr 18, 2006
                            • 0 Attachment
                              I too have a d-link router but my FTP setup is working flawlessly. I
                              only forward port 21 thru the vitual server setup. I confirmed my
                              settings against your post and it appears that you have everything
                              correct. My linkstation gateway setting is disabled but Im not sure
                              of this makes any difference in this system. I guess my only advice
                              is to double check your access to the ftp share internally. I really
                              doubt that your ISP could block access, so I would rule that out.

                              --- In LinkStation_General@yahoogroups.com, "Jeff" <jfish_berean@...>
                              wrote:
                              >
                              > I still cannot FTP from the Internet from an outside location.
                              When I
                              > enter in my username/password combo with the WAN IP that the
                              newtwork
                              > with the LinkStation is on (i.e. ftp://username:password@...)
                              > it times out every time.
                              >
                              > I set up my Linkstation to have a static IP address of 192.168.x.y
                              and
                              > a Gateway of 192.168.x.1 (which is the same as the IP address of my
                              > router). I can access the Linkstation locally either through the
                              > Workgroup, as a Network Drive, and by FTP using the local LAN IP
                              > 192.168.x.y. I configured my D-Link router to allow ports 20, 21,
                              and
                              > 1025-1027 for FTP access and set up the Virtual FTP Server to point
                              to
                              > the IP address of my LinkStation 192.168.x.y, but I still can't
                              access
                              > it from the internet - using passive or active modes of any FTP
                              > program or web browser...
                              >
                              > Neither Buffalo nor D-Link has been helpful at all. Any other
                              > thoughts out there? I'm still tinkering around with it to see if I
                              > can discover something I overlooked.
                              >
                              >
                              >
                              > --- In LinkStation_General@yahoogroups.com, KeepIt SimpleStupid
                              > <keepitsimplestupid@> wrote:
                              > >
                              > > Opening ports 20-21 is not enough to get FTP to work.
                              > > You need to open a few (say 3) higher number ports.
                              > > Try opening 1025, 1026 and 1027 as well. I just
                              > > looked at what I had forwarded on my router. For more
                              > > info look at the RFC for FTP. You also need to use
                              > > the right mode of FTP.
                              > >
                              > > It's also difficult to test since you can't ftp from
                              > > inside to your public IP address. I was able to ssh
                              > > to a unix host and then ftp back into my LAN from that
                              > > host to test.
                              >
                            • KeepIt SimpleStupid
                              ... I really ... If you really doubt it, take a look here at a manual for IPfilter.
                              Message 14 of 23 , Apr 18, 2006
                              • 0 Attachment
                                --- socaljbeezer <jeff.baler@...> wrote:

                                I really
                                > doubt that your ISP could block access, so I would
                                > rule that out.

                                If you really doubt it, take a look here at a manual
                                for IPfilter.

                                http://techpubs.sgi.com/library/manuals/4000/007-4599-002/pdf/007-4599-002.pdf

                                What we have as consumers that we call a "router" is
                                only a small subset. At work their are 3 networks on
                                single "wire". A private one starting in 10 served by
                                DHCP that can only access the LAN unless the MAC
                                address is known by the router and a public one served
                                by DHCP and yet another public one that has static IP
                                addresses.

                                T-mobile WIFI hotspots like those at Borders Books and
                                Music forbid access to the standard SMTP port so you
                                can only use web mail applications.



                                __________________________________________________
                                Do You Yahoo!?
                                Tired of spam? Yahoo! Mail has the best spam protection around
                                http://mail.yahoo.com
                              • oseyboldt
                                Hi Jeff, I had the same problem and I solved it by adding the router-IP adress as a nameserver to the resolv.conf. To do so log in via telnet/ssh, cd /etc vi
                                Message 15 of 23 , Apr 19, 2006
                                • 0 Attachment
                                  Hi Jeff,
                                  I had the same problem and I solved it by adding the router-IP
                                  adress as a nameserver to the resolv.conf.

                                  To do so log in via telnet/ssh,
                                  cd /etc
                                  vi resolv.conf (the file was empty in my case)
                                  "i" (for insert text)
                                  type "nameserver your.own.router.ip"
                                  press "esc", ":" and "x"

                                  then reboot and it should work (it did in my case).

                                  Good luck,
                                  Oliver

                                  --- In LinkStation_General@yahoogroups.com, "Jeff"
                                  <jfish_berean@...> wrote:
                                  >
                                  > I still cannot FTP from the Internet from an outside location.
                                  When I
                                  > enter in my username/password combo with the WAN IP that the
                                  newtwork
                                  > with the LinkStation is on (i.e. ftp://username:password@...)
                                  > it times out every time.
                                  >
                                  > I set up my Linkstation to have a static IP address of 192.168.x.y
                                  and
                                  > a Gateway of 192.168.x.1 (which is the same as the IP address of my
                                  > router). I can access the Linkstation locally either through the
                                  > Workgroup, as a Network Drive, and by FTP using the local LAN IP
                                  > 192.168.x.y. I configured my D-Link router to allow ports 20, 21,
                                  and
                                  > 1025-1027 for FTP access and set up the Virtual FTP Server to
                                  point to
                                  > the IP address of my LinkStation 192.168.x.y, but I still can't
                                  access
                                  > it from the internet - using passive or active modes of any FTP
                                  > program or web browser...
                                  >
                                  > Neither Buffalo nor D-Link has been helpful at all. Any other
                                  > thoughts out there? I'm still tinkering around with it to see if I
                                  > can discover something I overlooked.
                                  >
                                  >
                                  >
                                  > --- In LinkStation_General@yahoogroups.com, KeepIt SimpleStupid
                                  > <keepitsimplestupid@> wrote:
                                  > >
                                  > > Opening ports 20-21 is not enough to get FTP to work.
                                  > > You need to open a few (say 3) higher number ports.
                                  > > Try opening 1025, 1026 and 1027 as well. I just
                                  > > looked at what I had forwarded on my router. For more
                                  > > info look at the RFC for FTP. You also need to use
                                  > > the right mode of FTP.
                                  > >
                                  > > It's also difficult to test since you can't ftp from
                                  > > inside to your public IP address. I was able to ssh
                                  > > to a unix host and then ftp back into my LAN from that
                                  > > host to test.
                                  >
                                • Jeff
                                  By doing what you suggested, I could open the port and got 220 FTP Server Ready . But when I finger the IP address, I get The name of the network and then
                                  Message 16 of 23 , Apr 23, 2006
                                  • 0 Attachment
                                    By doing what you suggested, I could open the port and got
                                    "220 FTP Server Ready".

                                    But when I finger the IP address, I get The name of the network and
                                    then ">Finger:Connect::Connection Refused". I'm assuming that's
                                    because I'm trying to finger the IP that I'm already using. And
                                    doesn't necessarily tell me if our ISP is blocking FTP.

                                    I know that it is not that the ISP has a short lease on the IP
                                    address, because it has been the same for about 4 weeks now. And every
                                    time I work on this project I check the WAN IP.


                                    >
                                    > From windows cmd prompt run telnet
                                    >
                                    > open 65.a.b.123 21
                                    >
                                    > This will just try to open port 21. It doesn't know
                                    > about FTP or the protocal or anything so don't let the
                                    > word telnet fool you. Your telnetiing to port 21
                                    > which is an FTP port and not a telnet port. This
                                    > doesn't know about any of the other ports required for
                                    > FTP.
                                    >
                                    > you might see:
                                    >
                                    > Trying 65.a.b.123...
                                    > Connected to (somewhere.com).
                                    > Escape character is '^]'.
                                    > 220 Somewhere.com FTP server (Version wu-2.6.2+Sun)
                                    > ready.
                                    > (I typed a return here)
                                    > 530 Please login with USER and PASS.
                                    >
                                    > This is an actual response from a Sun unix machine to
                                    > itself. I also tried using windows to the sun and got
                                    > the same result. You won't be able to log on.
                                    >
                                    > Get simple connectivity, then get the protocol to
                                    > work.
                                    >
                                    > If you suspect FTP is being blocked try a finger
                                    > client and server which uses port 79.
                                    >
                                    > If you have a Windows PC or whatever and get a finger
                                    > server to work.
                                    >
                                    > So
                                    > 1) your ISP could be blocking FTP.
                                    > 2) your ISP has a short lease on your IP address.
                                    >
                                    >
                                    >
                                    >
                                    > --- Jeff <jfish_berean@...> wrote:
                                    >
                                    > > I still cannot FTP from the Internet from an outside
                                    > > location. When I
                                    > > enter in my username/password combo with the WAN IP
                                    > > that the newtwork
                                    > > with the LinkStation is on (i.e.
                                    > > ftp://username:password@...)
                                    > > it times out every time.
                                    > >
                                    > > I set up my Linkstation to have a static IP address
                                    > > of 192.168.x.y and
                                    > > a Gateway of 192.168.x.1 (which is the same as the
                                    > > IP address of my
                                    > > router). I can access the Linkstation locally
                                    > > either through the
                                    > > Workgroup, as a Network Drive, and by FTP using the
                                    > > local LAN IP
                                    > > 192.168.x.y. I configured my D-Link router to allow
                                    > > ports 20, 21, and
                                    > > 1025-1027 for FTP access and set up the Virtual FTP
                                    > > Server to point to
                                    > > the IP address of my LinkStation 192.168.x.y, but I
                                    > > still can't access
                                    > > it from the internet - using passive or active modes
                                    > > of any FTP
                                    > > program or web browser...
                                    > >
                                    > > Neither Buffalo nor D-Link has been helpful at all.
                                    > > Any other
                                    > > thoughts out there? I'm still tinkering around with
                                    > > it to see if I
                                    > > can discover something I overlooked.
                                    > >
                                    > >
                                    > >
                                    > > --- In LinkStation_General@yahoogroups.com, KeepIt
                                    > > SimpleStupid
                                    > > <keepitsimplestupid@> wrote:
                                    > > >
                                    > > > Opening ports 20-21 is not enough to get FTP to
                                    > > work.
                                    > > > You need to open a few (say 3) higher number
                                    > > ports.
                                    > > > Try opening 1025, 1026 and 1027 as well. I just
                                    > > > looked at what I had forwarded on my router. For
                                    > > more
                                    > > > info look at the RFC for FTP. You also need to
                                    > > use
                                    > > > the right mode of FTP.
                                    > > >
                                    > > > It's also difficult to test since you can't ftp
                                    > > from
                                    > > > inside to your public IP address. I was able to
                                    > > ssh
                                    > > > to a unix host and then ftp back into my LAN from
                                    > > that
                                    > > > host to test.
                                    > >
                                    >
                                    >
                                    >
                                    > __________________________________________________
                                    > Do You Yahoo!?
                                    > Tired of spam? Yahoo! Mail has the best spam protection around
                                    > http://mail.yahoo.com
                                    >
                                  • Jeff
                                    I m anticipating this would solve my problem, but I can t login to find out. I m assuming I need to telnet the WAN IP address to get into configure the modem
                                    Message 17 of 23 , Apr 25, 2006
                                    • 0 Attachment
                                      I'm anticipating this would solve my problem, but I can't login to
                                      find out. I'm assuming I need to telnet the WAN IP address to get into
                                      configure the modem itself to include the LS's IP address as a
                                      nameserver? I either have a different username/password for the modem
                                      than I thought I did or I don't have access to do this. If I can
                                      figure out how to login, I'll let you know if this works.

                                      --- In LinkStation_General@yahoogroups.com, "oseyboldt" <oli@...> wrote:
                                      >
                                      > Hi Jeff,
                                      > I had the same problem and I solved it by adding the router-IP
                                      > adress as a nameserver to the resolv.conf.
                                      >
                                      > To do so log in via telnet/ssh,
                                      > cd /etc
                                      > vi resolv.conf (the file was empty in my case)
                                      > "i" (for insert text)
                                      > type "nameserver your.own.router.ip"
                                      > press "esc", ":" and "x"
                                      >
                                      > then reboot and it should work (it did in my case).
                                      >
                                      > Good luck,
                                      > Oliver
                                      >
                                      > --- In LinkStation_General@yahoogroups.com, "Jeff"
                                      > <jfish_berean@> wrote:
                                      > >
                                      > > I still cannot FTP from the Internet from an outside location.
                                      > When I
                                      > > enter in my username/password combo with the WAN IP that the
                                      > newtwork
                                      > > with the LinkStation is on (i.e. ftp://username:password@)
                                      > > it times out every time.
                                      > >
                                      > > I set up my Linkstation to have a static IP address of 192.168.x.y
                                      > and
                                      > > a Gateway of 192.168.x.1 (which is the same as the IP address of my
                                      > > router). I can access the Linkstation locally either through the
                                      > > Workgroup, as a Network Drive, and by FTP using the local LAN IP
                                      > > 192.168.x.y. I configured my D-Link router to allow ports 20, 21,
                                      > and
                                      > > 1025-1027 for FTP access and set up the Virtual FTP Server to
                                      > point to
                                      > > the IP address of my LinkStation 192.168.x.y, but I still can't
                                      > access
                                      > > it from the internet - using passive or active modes of any FTP
                                      > > program or web browser...
                                      > >
                                      > > Neither Buffalo nor D-Link has been helpful at all. Any other
                                      > > thoughts out there? I'm still tinkering around with it to see if I
                                      > > can discover something I overlooked.
                                      > >
                                      > >
                                      > >
                                      > > --- In LinkStation_General@yahoogroups.com, KeepIt SimpleStupid
                                      > > <keepitsimplestupid@> wrote:
                                      > > >
                                      > > > Opening ports 20-21 is not enough to get FTP to work.
                                      > > > You need to open a few (say 3) higher number ports.
                                      > > > Try opening 1025, 1026 and 1027 as well. I just
                                      > > > looked at what I had forwarded on my router. For more
                                      > > > info look at the RFC for FTP. You also need to use
                                      > > > the right mode of FTP.
                                      > > >
                                      > > > It's also difficult to test since you can't ftp from
                                      > > > inside to your public IP address. I was able to ssh
                                      > > > to a unix host and then ftp back into my LAN from that
                                      > > > host to test.
                                      > >
                                      >
                                    • KeepIt SimpleStupid
                                      Modems can be weird like mine. I have my DSL configured in bridge mode. The only way I can configure it is with a crossover cable directly connected to the
                                      Message 18 of 23 , Apr 25, 2006
                                      • 0 Attachment
                                        Modems can be weird like mine. I have my DSL
                                        configured in bridge mode. The only way I can
                                        configure it is with a crossover cable directly
                                        connected to the modem. This is neither here nor
                                        there, though.

                                        Routers on the other hand might be configured by
                                        telnet or http. They usually have an option to allow
                                        configuration from the WAN, otherwise they must be
                                        configured from the LAN side only.

                                        Your internal LAN when using DHCP gets the name server
                                        address using DHCP. When you have a static IP
                                        address, your nameserver and gateway for your LAN is
                                        generally your router's IP address.

                                        Without a gateway defined, you can't get outside your
                                        LAN. Without a nameserver defined things like
                                        www.google.com makes no sense, but 64.233.161.104
                                        does.

                                        The subnet mask determines what addresses the devices
                                        on your LAN respond to. So, the most common subnet
                                        mask of 255.255.255.0 means anything that matches the
                                        first 3 digits of the IP address. Anything else the
                                        router processes.

                                        I checked on a Unix system "ifconfig -a" lists some of
                                        the configuration parameters in a different form, but
                                        not the gateway.

                                        --- Jeff <jfish_berean@...> wrote:

                                        > I'm anticipating this would solve my problem, but I
                                        > can't login to
                                        > find out. I'm assuming I need to telnet the WAN IP
                                        > address to get into
                                        > configure the modem itself to include the LS's IP
                                        > address as a
                                        > nameserver? I either have a different
                                        > username/password for the modem
                                        > than I thought I did or I don't have access to do
                                        > this. If I can
                                        > figure out how to login, I'll let you know if this
                                        > works.
                                        >
                                        > --- In LinkStation_General@yahoogroups.com,
                                        > "oseyboldt" <oli@...> wrote:
                                        > >
                                        > > Hi Jeff,
                                        > > I had the same problem and I solved it by adding
                                        > the router-IP
                                        > > adress as a nameserver to the resolv.conf.
                                        > >
                                        > > To do so log in via telnet/ssh,
                                        > > cd /etc
                                        > > vi resolv.conf (the file was empty in my case)
                                        > > "i" (for insert text)
                                        > > type "nameserver your.own.router.ip"
                                        > > press "esc", ":" and "x"
                                        > >
                                        > > then reboot and it should work (it did in my
                                        > case).
                                        > >
                                        > > Good luck,
                                        > > Oliver
                                        > >
                                        > > --- In LinkStation_General@yahoogroups.com, "Jeff"
                                        >
                                        > > <jfish_berean@> wrote:
                                        > > >
                                        > > > I still cannot FTP from the Internet from an
                                        > outside location.
                                        > > When I
                                        > > > enter in my username/password combo with the WAN
                                        > IP that the
                                        > > newtwork
                                        > > > with the LinkStation is on (i.e.
                                        > ftp://username:password@)
                                        > > > it times out every time.
                                        > > >
                                        > > > I set up my Linkstation to have a static IP
                                        > address of 192.168.x.y
                                        > > and
                                        > > > a Gateway of 192.168.x.1 (which is the same as
                                        > the IP address of my
                                        > > > router). I can access the Linkstation locally
                                        > either through the
                                        > > > Workgroup, as a Network Drive, and by FTP using
                                        > the local LAN IP
                                        > > > 192.168.x.y. I configured my D-Link router to
                                        > allow ports 20, 21,
                                        > > and
                                        > > > 1025-1027 for FTP access and set up the Virtual
                                        > FTP Server to
                                        > > point to
                                        > > > the IP address of my LinkStation 192.168.x.y,
                                        > but I still can't
                                        > > access
                                        > > > it from the internet - using passive or active
                                        > modes of any FTP
                                        > > > program or web browser...
                                        > > >
                                        > > > Neither Buffalo nor D-Link has been helpful at
                                        > all. Any other
                                        > > > thoughts out there? I'm still tinkering around
                                        > with it to see if I
                                        > > > can discover something I overlooked.
                                        > > >
                                        > > >
                                        > > >
                                        > > > --- In LinkStation_General@yahoogroups.com,
                                        > KeepIt SimpleStupid
                                        > > > <keepitsimplestupid@> wrote:
                                        > > > >
                                        > > > > Opening ports 20-21 is not enough to get FTP
                                        > to work.
                                        > > > > You need to open a few (say 3) higher number
                                        > ports.
                                        > > > > Try opening 1025, 1026 and 1027 as well. I
                                        > just
                                        > > > > looked at what I had forwarded on my router.
                                        > For more
                                        > > > > info look at the RFC for FTP. You also need
                                        > to use
                                        > > > > the right mode of FTP.
                                        > > > >
                                        > > > > It's also difficult to test since you can't
                                        > ftp from
                                        > > > > inside to your public IP address. I was able
                                        > to ssh
                                        > > > > to a unix host and then ftp back into my LAN
                                        > from that
                                        > > > > host to test.
                                        > > >
                                        > >
                                        >
                                        >
                                        >
                                        >
                                        >


                                        __________________________________________________
                                        Do You Yahoo!?
                                        Tired of spam? Yahoo! Mail has the best spam protection around
                                        http://mail.yahoo.com
                                      • bill fumerola
                                        ... it masks away the last octet of the IP address. a network of 1.1.1.0 with a mask of 255.255.255.0 means that addresses belonging to that network are
                                        Message 19 of 23 , Apr 25, 2006
                                        • 0 Attachment
                                          On Tue, Apr 25, 2006 at 07:17:22PM -0700, KeepIt SimpleStupid wrote:
                                          > The subnet mask determines what addresses the devices
                                          > on your LAN respond to. So, the most common subnet
                                          > mask of 255.255.255.0 means anything that matches the
                                          > first 3 digits of the IP address. Anything else the
                                          > router processes.

                                          it masks away the last octet of the IP address. a network of 1.1.1.0
                                          with a mask of 255.255.255.0 means that addresses belonging to that
                                          network are 1.1.1.0 through 1.1.1.255.

                                          it's easier to think of it as a mask not as the decimal 255.255.255.0
                                          but the hex 0xffffff00. 1.1.1.0 is 0x01010100. with our netmask in mind,
                                          0x01010100 through 0x010101ff are part of the same network.

                                          > I checked on a Unix system "ifconfig -a" lists some of
                                          > the configuration parameters in a different form, but
                                          > not the gateway.

                                          interface ip assignment and routing are related but are two different
                                          concepts and are tracked in different structures.

                                          to see the a machine's gateway:
                                          as an unprivleged user: 'netstat -nrt | grep default'
                                          as root: 'route get 0.0.0.0'

                                          -- bill
                                        • KeepIt SimpleStupid
                                          ... Nice job: So to get the deafult nameserver: dig | grep default To get the default gateway netstat -nr | grep default and to find the IP address
                                          Message 20 of 23 , Apr 26, 2006
                                          • 0 Attachment
                                            --- bill fumerola <billf@...> wrote:

                                            <snip>

                                            Nice job:

                                            So to get the deafult nameserver: "dig | grep default"

                                            To get the default gateway
                                            "netstat -nr | grep default"

                                            and to find the IP address of the interfaces:
                                            "ifconfig -a", a netmask of ffffff00 hex is really
                                            255.255.255.0 in dotted decimal

                                            Simplistic, but it's a place to start. The -t option
                                            for netstat didn't work under SunOS.

                                            __________________________________________________
                                            Do You Yahoo!?
                                            Tired of spam? Yahoo! Mail has the best spam protection around
                                            http://mail.yahoo.com
                                          Your message has been successfully submitted and would be delivered to recipients shortly.