Loading ...
Sorry, an error occurred while loading the content.
 

Re: [LinkStation_General] Getting root access - Login problems with web browser

Expand Messages
  • C. Scott Ananian
    ... You might add the if this happens to you, do this bit to the official docs, but I (for one) managed to change my root password w/o screwing up the web
    Message 1 of 22 , Dec 7, 2004
      On Tue, 7 Dec 2004, James Stewart wrote:

      > Do we need to modify the instructions on this or did
      > Rod and I simply do something wrong that could
      > otherwise be avoided?

      You might add the 'if this happens to you, do this' bit to the 'official'
      docs, but I (for one) managed to change my root password w/o screwing up
      the web interface. Not sure what you did differently... the web interface
      password should be completely unaffected by any change to /etc/passwd.
      --scott

      early warning KUJUMP MKSEARCH cryptographic Panama radar quiche JMTIDE
      Register to vote! http://www.yourvotematters.org/VerifiedVoting
      ( http://cscott.net/ )
    • rod_tucker
      Scott, I am gald that you didn t screw up the web interface. Perhaps you are not a novice like me. I must say that I found the instructions on the how to
      Message 2 of 22 , Dec 8, 2004
        Scott,

        I am gald that you didn't "screw up" the web interface. Perhaps you
        are not a novice like me. I must say that I found the instructions
        on the "how to" folder to be quite cryptic and hard to understand.
        In addition, I have no real experience with the vi editor, so I
        bought a book on linux. But I found that when using telnet, the vi
        editor on the linkstation behaves very strangely - nothing like my
        linux book descrbes it should. Some times whole lines went missing
        and often vi seems to over-write other lines. What was worse, vi
        seems to do different things each time I open it, even with exactly
        the same file. If I edit a file and store it and then loook at the
        file with a cat command, the cat command lists something different
        from what vi says the file is!!! It is really weird. It is quite
        likely that something went wrong, with vi and this "screwed up" my
        web site passwords.

        So it I think that any detailed advice for other novices would be
        very helpful.

        BTW, I still haven't worked out how to get my web interface working.

        Rod Tucker


        --- In LinkStation_General@yahoogroups.com, "C. Scott Ananian"
        <cananian@l...> wrote:
        > On Tue, 7 Dec 2004, James Stewart wrote:
        >
        > > Do we need to modify the instructions on this or did
        > > Rod and I simply do something wrong that could
        > > otherwise be avoided?
        >
        > You might add the 'if this happens to you, do this' bit to
        the 'official'
        > docs, but I (for one) managed to change my root password w/o
        screwing up
        > the web interface. Not sure what you did differently... the web
        interface
        > password should be completely unaffected by any change
        to /etc/passwd.
        > --scott
        >
        > early warning KUJUMP MKSEARCH cryptographic Panama radar quiche
        JMTIDE
        > Register to vote!
        http://www.yourvotematters.org/VerifiedVoting
        > ( http://cscott.net/ )
      • rod_tucker
        Thanks for this advice. I found the two .htpasswd files. One is in /www and one is in /www/cgi-bin2. I am a bit nervous about deleting files. But I ll
        Message 3 of 22 , Dec 8, 2004
          Thanks for this advice. I found the two ".htpasswd" files. One is
          in /www and one is in /www/cgi-bin2. I am a bit nervous about
          deleting files. But I'll take a deep breath and give it a go!

          --- In LinkStation_General@yahoogroups.com, James Stewart
          <wartstew@y...> wrote:
          > That happened to me when I did it too. How I fixed it
          > was to dig around in the /www directory until I found
          > an "htpasswd" file (or was it ".htpasswd", in which
          > case it is considered hidden and won't list unless you
          > use "ls -a" to list it). I simply deleted them (I
          > think they were in two places if I remember) using the
          > command "rm <filename>" This then cleared the passwd
          > for the web login to a null password. After that I
          > logged in using the Web interface and changed the
          > password to match what I was using for the telnet root
          > password and everything worked from then on.
          >
          > Do we need to modify the instructions on this or did
          > Rod and I simply do something wrong that could
          > otherwise be avoided?
          >
          > --- rod_tucker <rod_tucker@y...> wrote:
          >
          > >
          > > I am a bit of a novice, and I'm trying to get root
          > > access so I can
          > > load the slimserver.
          > >
          > > I followed the various suggestions on how to get
          > > root access through
          > > telnet, and tonight I successfully used a script in
          > > /www/cgi-bin3 to
          > > enable me to change the encrypted root password on
          > > the /etc/passwd
          > > file to the encrypted root password for known user1
          > > password.
          > >
          > > Bingo! it works. I can now log in as root using
          > > telnet.
          > >
          > > **BUT** I now have a problem. For some reason, I
          > > can't log in to
          > > my linkstation using a web browser any more. Up to
          > > a couple of days
          > > ago I could do this either using "root" with a blank
          > > password, or my
          > > user1 login with my known password (the one I now
          > > use for telnet).
          > > But it now won't work - after trying the known
          > > passwords on the
          > > login window a fe times I get an error message -
          > > password incorrect.
          > >
          > > I tried deleting the /www/cgi-bin3 directory, but
          > > this didn't help.
          > >
          > > This seems like it could be a fairly serious problem
          > > - without
          > > browser login, I don't know how to reconfigure my
          > > linkstation,
          > > change the network settings, and add users etc. Can
          > > anyone help??
          > >
          > > Rod Tucker
          > >
          > >
          > >
          > >
          > >
          > >
          >
          >
          >
          >
          > __________________________________
          > Do you Yahoo!?
          > Meet the all-new My Yahoo! - Try it today!
          > http://my.yahoo.com
        • irvine_stock
          Scott, VI does not work in the telnet window unless its vt100. The native is not VT100. Hopefully one of these pros can tell us how to get the term variable
          Message 4 of 22 , Dec 9, 2004
            Scott,
            VI does not work in the telnet window unless its vt100.
            The native is not VT100.
            Hopefully one of these pros can tell us how to get the term variable
            changed to VT100 by default. I have set the varible but it does not
            take, so I am lost.
            This is of coarse if you care. VI has been a terrible editor since
            day one! Unless of course you love it then I have seen magic
            fingers at doing fast edits and changes. Personally I can't
            remember the keys except for HJKL and then shift ZZ to get out.
            I think somebody wise posted nano in the files section. Try that!

            Be warned that if you use a windoze editor (notepad or wordpad) on
            any of the files it will insert control-M at the end of every line.
            IT will destroy your password file. (I know) Then you can't log
            back in to fix it. It does break a lot of the other cgi and SH
            files to0. Some worse than others.
            You have to run dos2unix to fix it back.

            Rich
            --- In LinkStation_General@yahoogroups.com, "rod_tucker"
            <rod_tucker@y...> wrote:
            >
            > Scott,
            >
            > I am gald that you didn't "screw up" the web interface. Perhaps
            you
            > are not a novice like me. I must say that I found the instructions
            > on the "how to" folder to be quite cryptic and hard to
            understand.
            > In addition, I have no real experience with the vi editor, so I
            > bought a book on linux. But I found that when using telnet, the
            vi
            > editor on the linkstation behaves very strangely - nothing like my
            > linux book descrbes it should. Some times whole lines went
            missing
            > and often vi seems to over-write other lines. What was worse, vi
            > seems to do different things each time I open it, even with
            exactly
            > the same file. If I edit a file and store it and then loook at the
            > file with a cat command, the cat command lists something
            different
            > from what vi says the file is!!! It is really weird. It is quite
            > likely that something went wrong, with vi and this "screwed up" my
            > web site passwords.
            >
            > So it I think that any detailed advice for other novices would be
            > very helpful.
            >
            > BTW, I still haven't worked out how to get my web interface
            working.
            >
            > Rod Tucker
            >
            >
            > --- In LinkStation_General@yahoogroups.com, "C. Scott Ananian"
            > <cananian@l...> wrote:
            > > On Tue, 7 Dec 2004, James Stewart wrote:
            > >
            > > > Do we need to modify the instructions on this or did
            > > > Rod and I simply do something wrong that could
            > > > otherwise be avoided?
            > >
            > > You might add the 'if this happens to you, do this' bit to
            > the 'official'
            > > docs, but I (for one) managed to change my root password w/o
            > screwing up
            > > the web interface. Not sure what you did differently... the web
            > interface
            > > password should be completely unaffected by any change
            > to /etc/passwd.
            > > --scott
            > >
            > > early warning KUJUMP MKSEARCH cryptographic Panama radar quiche
            > JMTIDE
            > > Register to vote!
            > http://www.yourvotematters.org/VerifiedVoting
            > > ( http://cscott.net/ )
          • C. Scott Ananian
            On Thu, 9 Dec 2004, irvine_stock wrote:VI does not work in the telnet window unless its vt100.Every time you log in, type # export TERM=vt100 as the
            Message 5 of 22 , Dec 9, 2004
              On Thu, 9 Dec 2004, irvine_stock wrote:

              > VI does not work in the telnet window unless its vt100.

              Every time you log in, type
              # export TERM=vt100
              as the first thing you do.

              That's the simplest way to fix that up.

              > This is of coarse if you care. VI has been a terrible editor since

              yes, i'd avoid using vi if you can help it. something like this should
              work:
              $ cp /etc/passwd /www/passwd.old
              $ sed -e 's:r.4feIpNeMISQ::' < /www/passwd.old > /etc/passwd

              then telnet in as root (no passwd) and use
              # passwd
              to set your new root password.
              [NOTE! I haven't actualy tested this! Use at your own risk. If you've
              already edited your passwd file, the string between the colons in the
              above command is likely not right for you.]

              No vi required.
              I've attached the original LinkStation passwd file, in case it helps those
              of you who seem to have mucked it up.
              --scott

              NSA Attache KUSODA IDEA ODOATH WSBURNT KMFLUSH fissionable MI5 LA
              Register to vote! http://www.yourvotematters.org/VerifiedVoting
              ( http://cscott.net/ )
            • James Ronald
              I found an easy fix for those wanting to use something better than MS Telnet but are getting the dreaded vi: xterm: unknown terminal type message. The fix
              Message 6 of 22 , Dec 9, 2004
                I found an easy fix for those wanting to use something better than MS Telnet
                but are getting the dreaded 'vi: xterm: unknown terminal type' message. The
                fix is to 'cp /usr/share/terminfo/v/vt100 to ../x/xterm' or copy the
                /usr/share/terminfo/X/xterm from the Kuro binaries to
                /usr/share/terminfo/x/xterm.

                This works 100% better and makes me more confident editing critical files
                with vi. Also, if your still using MS Telnet give PuTTY a try.

                JR

                ----- Original Message -----
                From: "irvine_stock" <r_obermeyer@...>
                To: <LinkStation_General@yahoogroups.com>
                Sent: Thursday, December 09, 2004 3:08 AM
                Subject: [LinkStation_General] Re: Getting root access - Login problems with
                web browser


                >
                >
                > Scott,
                > VI does not work in the telnet window unless its vt100.
                > The native is not VT100.
                > Hopefully one of these pros can tell us how to get the term variable
                > changed to VT100 by default. I have set the varible but it does not
                > take, so I am lost.
                > This is of coarse if you care. VI has been a terrible editor since
                > day one! Unless of course you love it then I have seen magic
                > fingers at doing fast edits and changes. Personally I can't
                > remember the keys except for HJKL and then shift ZZ to get out.
                > I think somebody wise posted nano in the files section. Try that!
                >
                > Be warned that if you use a windoze editor (notepad or wordpad) on
                > any of the files it will insert control-M at the end of every line.
                > IT will destroy your password file. (I know) Then you can't log
                > back in to fix it. It does break a lot of the other cgi and SH
                > files to0. Some worse than others.
                > You have to run dos2unix to fix it back.
                >
                > Rich
                > --- In LinkStation_General@yahoogroups.com, "rod_tucker"
                > <rod_tucker@y...> wrote:
                >>
                >> Scott,
                >>
                >> I am gald that you didn't "screw up" the web interface. Perhaps
                > you
                >> are not a novice like me. I must say that I found the instructions
                >> on the "how to" folder to be quite cryptic and hard to
                > understand.
                >> In addition, I have no real experience with the vi editor, so I
                >> bought a book on linux. But I found that when using telnet, the
                > vi
                >> editor on the linkstation behaves very strangely - nothing like my
                >> linux book descrbes it should. Some times whole lines went
                > missing
                >> and often vi seems to over-write other lines. What was worse, vi
                >> seems to do different things each time I open it, even with
                > exactly
                >> the same file. If I edit a file and store it and then loook at the
                >> file with a cat command, the cat command lists something
                > different
                >> from what vi says the file is!!! It is really weird. It is quite
                >> likely that something went wrong, with vi and this "screwed up" my
                >> web site passwords.
                >>
                >> So it I think that any detailed advice for other novices would be
                >> very helpful.
                >>
                >> BTW, I still haven't worked out how to get my web interface
                > working.
                >>
                >> Rod Tucker
                >>
                >>
                >> --- In LinkStation_General@yahoogroups.com, "C. Scott Ananian"
                >> <cananian@l...> wrote:
                >> > On Tue, 7 Dec 2004, James Stewart wrote:
                >> >
                >> > > Do we need to modify the instructions on this or did
                >> > > Rod and I simply do something wrong that could
                >> > > otherwise be avoided?
                >> >
                >> > You might add the 'if this happens to you, do this' bit to
                >> the 'official'
                >> > docs, but I (for one) managed to change my root password w/o
                >> screwing up
                >> > the web interface. Not sure what you did differently... the web
                >> interface
                >> > password should be completely unaffected by any change
                >> to /etc/passwd.
                >> > --scott
              • Wilson
                Yes, that s what I do as root: echo export TERM=vt100 ~/.bash_profile So whenever I login, it s with the proper term, even the LS doesn t recognize the
                Message 7 of 22 , Dec 9, 2004
                  Yes, that's what I do as root:
                  echo "export TERM=vt100" >> ~/.bash_profile

                  So whenever I login, it's with the proper term, even
                  the LS doesn't recognize the xterm.

                  W
                  --- "C. Scott Ananian"
                  <cananian@...> wrote:

                  > On Thu, 9 Dec 2004, irvine_stock wrote:
                  >
                  > > VI does not work in the telnet window unless its
                  > vt100.
                  >
                  > Every time you log in, type
                  > # export TERM=vt100
                  > as the first thing you do.
                  >
                  > That's the simplest way to fix that up.
                  >
                  > > This is of coarse if you care. VI has been a
                  > terrible editor since
                  >
                  > yes, i'd avoid using vi if you can help it.
                  > something like this should
                  > work:
                  > $ cp /etc/passwd /www/passwd.old
                  > $ sed -e 's:r.4feIpNeMISQ::' < /www/passwd.old >
                  > /etc/passwd
                  >
                  > then telnet in as root (no passwd) and use
                  > # passwd
                  > to set your new root password.
                  > [NOTE! I haven't actualy tested this! Use at your
                  > own risk. If you've
                  > already edited your passwd file, the string between
                  > the colons in the
                  > above command is likely not right for you.]
                  >
                  > No vi required.
                  > I've attached the original LinkStation passwd file,
                  > in case it helps those
                  > of you who seem to have mucked it up.
                  > --scott
                  >
                  > NSA Attache KUSODA IDEA ODOATH WSBURNT KMFLUSH
                  > fissionable MI5 LA
                  > Register to vote!
                  > http://www.yourvotematters.org/VerifiedVoting
                  > ( http://cscott.net/ )>
                  root:r.4feIpNeMISQ:0:0:root:/root:/bin/bash
                  > bin:*:1:1:bin:/bin:
                  > daemon:*:2:2:daemon:/usr/sbin:
                  > sys:*:3:3:sys:/dev:
                  > adm:*:4:4:adm:/var/adm:
                  > sync:*:6:8:sync:/bin:/bin/sync
                  > shutdown:*:7:9:shutdown:/sbin:/sbin/shutdown
                  > halt:*:8:10:halt:/sbin:/sbin/halt
                  > operator:*:12:0:operator:/root:
                  > ftp:*:15:14:ftp:/var/ftp:
                  > nobody:*:99:99:nobody:/home:/bin/sh
                  >




                  __________________________________
                  Do you Yahoo!?
                  All your favorites on one personal page � Try My Yahoo!
                  http://my.yahoo.com
                • Wilson
                  Deleting those .htpasswd won t hurt..as they re optional file for web site...if the file exists, the web server will understand the part of the site may have
                  Message 8 of 22 , Dec 9, 2004
                    Deleting those .htpasswd won't hurt..as they're
                    optional file for web site...if the file exists, the
                    web server will understand the part of the site may
                    have passwd protected....they have .htpasswd in /www
                    because they want to prompt for root password
                    (although it's no password by default) instead of
                    letting anyone goes to the the web page directly
                    without asking for password.

                    Hope this help.

                    Wilson
                    --- rod_tucker <rod_tucker@...> wrote:

                    >
                    > Thanks for this advice. I found the two ".htpasswd"
                    > files. One is
                    > in /www and one is in /www/cgi-bin2. I am a bit
                    > nervous about
                    > deleting files. But I'll take a deep breath and
                    > give it a go!
                    >
                    > --- In LinkStation_General@yahoogroups.com, James
                    > Stewart
                    > <wartstew@y...> wrote:
                    > > That happened to me when I did it too. How I
                    > fixed it
                    > > was to dig around in the /www directory until I
                    > found
                    > > an "htpasswd" file (or was it ".htpasswd", in
                    > which
                    > > case it is considered hidden and won't list unless
                    > you
                    > > use "ls -a" to list it). I simply deleted them (I
                    > > think they were in two places if I remember) using
                    > the
                    > > command "rm <filename>" This then cleared the
                    > passwd
                    > > for the web login to a null password. After that
                    > I
                    > > logged in using the Web interface and changed the
                    > > password to match what I was using for the telnet
                    > root
                    > > password and everything worked from then on.
                    > >
                    > > Do we need to modify the instructions on this or
                    > did
                    > > Rod and I simply do something wrong that could
                    > > otherwise be avoided?
                    > >
                    > > --- rod_tucker <rod_tucker@y...> wrote:
                    > >
                    > > >
                    > > > I am a bit of a novice, and I'm trying to get
                    > root
                    > > > access so I can
                    > > > load the slimserver.
                    > > >
                    > > > I followed the various suggestions on how to get
                    > > > root access through
                    > > > telnet, and tonight I successfully used a script
                    > in
                    > > > /www/cgi-bin3 to
                    > > > enable me to change the encrypted root password
                    > on
                    > > > the /etc/passwd
                    > > > file to the encrypted root password for known
                    > user1
                    > > > password.
                    > > >
                    > > > Bingo! it works. I can now log in as root using
                    > > > telnet.
                    > > >
                    > > > **BUT** I now have a problem. For some reason,
                    > I
                    > > > can't log in to
                    > > > my linkstation using a web browser any more. Up
                    > to
                    > > > a couple of days
                    > > > ago I could do this either using "root" with a
                    > blank
                    > > > password, or my
                    > > > user1 login with my known password (the one I
                    > now
                    > > > use for telnet).
                    > > > But it now won't work - after trying the known
                    > > > passwords on the
                    > > > login window a fe times I get an error message -
                    > > > password incorrect.
                    > > >
                    > > > I tried deleting the /www/cgi-bin3 directory,
                    > but
                    > > > this didn't help.
                    > > >
                    > > > This seems like it could be a fairly serious
                    > problem
                    > > > - without
                    > > > browser login, I don't know how to reconfigure
                    > my
                    > > > linkstation,
                    > > > change the network settings, and add users etc.
                    > Can
                    > > > anyone help??
                    > > >
                    > > > Rod Tucker
                    > > >
                    > > >
                    > > >
                    > > >
                    > > >
                    > > >
                    > >
                    > >
                    > >
                    > >
                    > > __________________________________
                    > > Do you Yahoo!?
                    > > Meet the all-new My Yahoo! - Try it today!
                    > > http://my.yahoo.com
                    >
                    >
                    >
                    >




                    __________________________________
                    Do you Yahoo!?
                    Read only the mail you want - Yahoo! Mail SpamGuard.
                    http://promotions.yahoo.com/new_mail
                  • James Ronald
                    Wilson, See my previous reply it will resolve your issue including the xterm issue. JR ... From: Wilson To:
                    Message 9 of 22 , Dec 9, 2004
                      Wilson,

                      See my previous reply it will resolve your issue including the xterm issue.

                      JR
                      ----- Original Message -----
                      From: "Wilson" <sonsondei@...>
                      To: <LinkStation_General@yahoogroups.com>
                      Sent: Thursday, December 09, 2004 10:04 AM
                      Subject: Re: [LinkStation_General] Re: Getting root access - Login problems
                      with web browser


                      >
                      > Yes, that's what I do as root:
                      > echo "export TERM=vt100" >> ~/.bash_profile
                      >
                      > So whenever I login, it's with the proper term, even
                      > the LS doesn't recognize the xterm.
                      >
                      > W
                      > --- "C. Scott Ananian"
                      > <cananian@...> wrote:
                      >
                      >> On Thu, 9 Dec 2004, irvine_stock wrote:
                      >>
                      >> > VI does not work in the telnet window unless its
                      >> vt100.
                      >>
                      >> Every time you log in, type
                      >> # export TERM=vt100
                      >> as the first thing you do.
                      >>
                      >> That's the simplest way to fix that up.
                      >>
                      >> > This is of coarse if you care. VI has been a
                      >> terrible editor since
                      >>
                      >> yes, i'd avoid using vi if you can help it.
                      >> something like this should
                      >> work:
                      >> $ cp /etc/passwd /www/passwd.old
                      >> $ sed -e 's:r.4feIpNeMISQ::' < /www/passwd.old >
                      >> /etc/passwd
                      >>
                      >> then telnet in as root (no passwd) and use
                      >> # passwd
                      >> to set your new root password.
                      >> [NOTE! I haven't actualy tested this! Use at your
                      >> own risk. If you've
                      >> already edited your passwd file, the string between
                      >> the colons in the
                      >> above command is likely not right for you.]
                      >>
                      >> No vi required.
                      >> I've attached the original LinkStation passwd file,
                      >> in case it helps those
                      >> of you who seem to have mucked it up.
                      >> --scott
                      >>
                      >> NSA Attache KUSODA IDEA ODOATH WSBURNT KMFLUSH
                      >> fissionable MI5 LA
                      >> Register to vote!
                      >> http://www.yourvotematters.org/VerifiedVoting
                      >> ( http://cscott.net/ )>
                      > root:r.4feIpNeMISQ:0:0:root:/root:/bin/bash
                      >> bin:*:1:1:bin:/bin:
                      >> daemon:*:2:2:daemon:/usr/sbin:
                      >> sys:*:3:3:sys:/dev:
                      >> adm:*:4:4:adm:/var/adm:
                      >> sync:*:6:8:sync:/bin:/bin/sync
                      >> shutdown:*:7:9:shutdown:/sbin:/sbin/shutdown
                      >> halt:*:8:10:halt:/sbin:/sbin/halt
                      >> operator:*:12:0:operator:/root:
                      >> ftp:*:15:14:ftp:/var/ftp:
                      >> nobody:*:99:99:nobody:/home:/bin/sh
                      >>
                      >
                      >
                      >
                      >
                      > __________________________________
                      > Do you Yahoo!?
                      > All your favorites on one personal page - Try My Yahoo!
                      > http://my.yahoo.com
                      >
                      >
                      >
                      >
                      > Yahoo! Groups Links
                      >
                      >
                      >
                      >
                      >
                      >
                      >
                    • rod_tucker
                      Wilson, Yes, it worked!!!! Rod
                      Message 10 of 22 , Dec 9, 2004
                        Wilson,

                        Yes, it worked!!!!

                        Rod

                        --- In LinkStation_General@yahoogroups.com, Wilson <sonsondei@y...>
                        wrote:
                        > Deleting those .htpasswd won't hurt..as they're
                        > optional file for web site...if the file exists, the
                        > web server will understand the part of the site may
                        > have passwd protected....they have .htpasswd in /www
                        > because they want to prompt for root password
                        > (although it's no password by default) instead of
                        > letting anyone goes to the the web page directly
                        > without asking for password.
                        >
                        > Hope this help.
                        >
                        > Wilson
                        > --- rod_tucker <rod_tucker@y...> wrote:
                        >
                        > >
                        > > Thanks for this advice. I found the two ".htpasswd"
                        > > files. One is
                        > > in /www and one is in /www/cgi-bin2. I am a bit
                        > > nervous about
                        > > deleting files. But I'll take a deep breath and
                        > > give it a go!
                        > >
                        > > --- In LinkStation_General@yahoogroups.com, James
                        > > Stewart
                        > > <wartstew@y...> wrote:
                        > > > That happened to me when I did it too. How I
                        > > fixed it
                        > > > was to dig around in the /www directory until I
                        > > found
                        > > > an "htpasswd" file (or was it ".htpasswd", in
                        > > which
                        > > > case it is considered hidden and won't list unless
                        > > you
                        > > > use "ls -a" to list it). I simply deleted them (I
                        > > > think they were in two places if I remember) using
                        > > the
                        > > > command "rm <filename>" This then cleared the
                        > > passwd
                        > > > for the web login to a null password. After that
                        > > I
                        > > > logged in using the Web interface and changed the
                        > > > password to match what I was using for the telnet
                        > > root
                        > > > password and everything worked from then on.
                        > > >
                        > > > Do we need to modify the instructions on this or
                        > > did
                        > > > Rod and I simply do something wrong that could
                        > > > otherwise be avoided?
                        > > >
                        > > > --- rod_tucker <rod_tucker@y...> wrote:
                        > > >
                        > > > >
                        > > > > I am a bit of a novice, and I'm trying to get
                        > > root
                        > > > > access so I can
                        > > > > load the slimserver.
                        > > > >
                        > > > > I followed the various suggestions on how to get
                        > > > > root access through
                        > > > > telnet, and tonight I successfully used a script
                        > > in
                        > > > > /www/cgi-bin3 to
                        > > > > enable me to change the encrypted root password
                        > > on
                        > > > > the /etc/passwd
                        > > > > file to the encrypted root password for known
                        > > user1
                        > > > > password.
                        > > > >
                        > > > > Bingo! it works. I can now log in as root using
                        > > > > telnet.
                        > > > >
                        > > > > **BUT** I now have a problem. For some reason,
                        > > I
                        > > > > can't log in to
                        > > > > my linkstation using a web browser any more. Up
                        > > to
                        > > > > a couple of days
                        > > > > ago I could do this either using "root" with a
                        > > blank
                        > > > > password, or my
                        > > > > user1 login with my known password (the one I
                        > > now
                        > > > > use for telnet).
                        > > > > But it now won't work - after trying the known
                        > > > > passwords on the
                        > > > > login window a fe times I get an error message -
                        > > > > password incorrect.
                        > > > >
                        > > > > I tried deleting the /www/cgi-bin3 directory,
                        > > but
                        > > > > this didn't help.
                        > > > >
                        > > > > This seems like it could be a fairly serious
                        > > problem
                        > > > > - without
                        > > > > browser login, I don't know how to reconfigure
                        > > my
                        > > > > linkstation,
                        > > > > change the network settings, and add users etc.
                        > > Can
                        > > > > anyone help??
                        > > > >
                        > > > > Rod Tucker
                        > > > >
                        > > > >
                        > > > >
                        > > > >
                        > > > >
                        > > > >
                        > > >
                        > > >
                        > > >
                        > > >
                        > > > __________________________________
                        > > > Do you Yahoo!?
                        > > > Meet the all-new My Yahoo! - Try it today!
                        > > > http://my.yahoo.com
                        > >
                        > >
                        > >
                        > >
                        >
                        >
                        >
                        >
                        > __________________________________
                        > Do you Yahoo!?
                        > Read only the mail you want - Yahoo! Mail SpamGuard.
                        > http://promotions.yahoo.com/new_mail
                      • irocerz28
                        I have found the NT4 telnet.exe works well when connect to a unix host and using vi. You will need telnet.hlp, telnet.exe and telnet.cnt from an nt4
                        Message 11 of 22 , Dec 9, 2004
                          I have found the NT4 telnet.exe works well when connect to a unix
                          host and using vi. You will need telnet.hlp, telnet.exe and
                          telnet.cnt from an nt4 workstation or server.

                          --- In LinkStation_General@yahoogroups.com, "James Ronald"
                          <jronald@c...> wrote:
                          > I found an easy fix for those wanting to use something better than
                          MS Telnet
                          > but are getting the dreaded 'vi: xterm: unknown terminal type'
                          message. The
                          > fix is to 'cp /usr/share/terminfo/v/vt100 to ../x/xterm' or copy
                          the
                          > /usr/share/terminfo/X/xterm from the Kuro binaries to
                          > /usr/share/terminfo/x/xterm.
                          >
                          > This works 100% better and makes me more confident editing
                          critical files
                          > with vi. Also, if your still using MS Telnet give PuTTY a try.
                          >
                          > JR
                          >
                          > ----- Original Message -----
                          > From: "irvine_stock" <r_obermeyer@p...>
                          > To: <LinkStation_General@yahoogroups.com>
                          > Sent: Thursday, December 09, 2004 3:08 AM
                          > Subject: [LinkStation_General] Re: Getting root access - Login
                          problems with
                          > web browser
                          >
                          >
                          > >
                          > >
                          > > Scott,
                          > > VI does not work in the telnet window unless its vt100.
                          > > The native is not VT100.
                          > > Hopefully one of these pros can tell us how to get the term
                          variable
                          > > changed to VT100 by default. I have set the varible but it does
                          not
                          > > take, so I am lost.
                          > > This is of coarse if you care. VI has been a terrible editor
                          since
                          > > day one! Unless of course you love it then I have seen magic
                          > > fingers at doing fast edits and changes. Personally I can't
                          > > remember the keys except for HJKL and then shift ZZ to get out.
                          > > I think somebody wise posted nano in the files section. Try
                          that!
                          > >
                          > > Be warned that if you use a windoze editor (notepad or wordpad)
                          on
                          > > any of the files it will insert control-M at the end of every
                          line.
                          > > IT will destroy your password file. (I know) Then you can't log
                          > > back in to fix it. It does break a lot of the other cgi and SH
                          > > files to0. Some worse than others.
                          > > You have to run dos2unix to fix it back.
                          > >
                          > > Rich
                          > > --- In LinkStation_General@yahoogroups.com, "rod_tucker"
                          > > <rod_tucker@y...> wrote:
                          > >>
                          > >> Scott,
                          > >>
                          > >> I am gald that you didn't "screw up" the web interface. Perhaps
                          > > you
                          > >> are not a novice like me. I must say that I found the
                          instructions
                          > >> on the "how to" folder to be quite cryptic and hard to
                          > > understand.
                          > >> In addition, I have no real experience with the vi editor, so I
                          > >> bought a book on linux. But I found that when using telnet, the
                          > > vi
                          > >> editor on the linkstation behaves very strangely - nothing like
                          my
                          > >> linux book descrbes it should. Some times whole lines went
                          > > missing
                          > >> and often vi seems to over-write other lines. What was worse,
                          vi
                          > >> seems to do different things each time I open it, even with
                          > > exactly
                          > >> the same file. If I edit a file and store it and then loook at
                          the
                          > >> file with a cat command, the cat command lists something
                          > > different
                          > >> from what vi says the file is!!! It is really weird. It is quite
                          > >> likely that something went wrong, with vi and this "screwed up"
                          my
                          > >> web site passwords.
                          > >>
                          > >> So it I think that any detailed advice for other novices would
                          be
                          > >> very helpful.
                          > >>
                          > >> BTW, I still haven't worked out how to get my web interface
                          > > working.
                          > >>
                          > >> Rod Tucker
                          > >>
                          > >>
                          > >> --- In LinkStation_General@yahoogroups.com, "C. Scott Ananian"
                          > >> <cananian@l...> wrote:
                          > >> > On Tue, 7 Dec 2004, James Stewart wrote:
                          > >> >
                          > >> > > Do we need to modify the instructions on this or did
                          > >> > > Rod and I simply do something wrong that could
                          > >> > > otherwise be avoided?
                          > >> >
                          > >> > You might add the 'if this happens to you, do this' bit to
                          > >> the 'official'
                          > >> > docs, but I (for one) managed to change my root password w/o
                          > >> screwing up
                          > >> > the web interface. Not sure what you did differently... the
                          web
                          > >> interface
                          > >> > password should be completely unaffected by any change
                          > >> to /etc/passwd.
                          > >> > --scott
                        • rod_tucker
                          Wilson, For some reason, this doesn t work for me. I confirmed that if I log in as root and execute this command, a file called .bash_profile does indeed
                          Message 12 of 22 , Dec 11, 2004
                            Wilson,

                            For some reason, this doesn't work for me. I confirmed that if I
                            log in as root and execute this command, a file
                            called .bash_profile does indeed appear in the home directory, and
                            it's contents are export TERM=vt11. (in fact I ran the command
                            twice, and export TERM=vt11 appears twice.)

                            But if I log off and log in again, I still have problems with vi. I
                            can fix it by typing export TERM=vt100 every time I log in, but this
                            is a bit of a nuisance.

                            I wonder if I need to do something to enable the file .bash_profile
                            or perhaps the home directory is not the right place for it.

                            Any thoughts?

                            Rod

                            --- In LinkStation_General@yahoogroups.com, Wilson <sonsondei@y...>
                            wrote:
                            > Yes, that's what I do as root:
                            > echo "export TERM=vt100" >> ~/.bash_profile
                            >
                            > So whenever I login, it's with the proper term, even
                            > the LS doesn't recognize the xterm.
                            >
                            > W
                            > --- "C. Scott Ananian"
                            > <cananian@l...> wrote:
                            >
                            > > On Thu, 9 Dec 2004, irvine_stock wrote:
                            > >
                            > > > VI does not work in the telnet window unless its
                            > > vt100.
                            > >
                            > > Every time you log in, type
                            > > # export TERM=vt100
                            > > as the first thing you do.
                            > >
                            > > That's the simplest way to fix that up.
                            > >
                            > > > This is of coarse if you care. VI has been a
                            > > terrible editor since
                            > >
                            > > yes, i'd avoid using vi if you can help it.
                            > > something like this should
                            > > work:
                            > > $ cp /etc/passwd /www/passwd.old
                            > > $ sed -e 's:r.4feIpNeMISQ::' < /www/passwd.old >
                            > > /etc/passwd
                            > >
                            > > then telnet in as root (no passwd) and use
                            > > # passwd
                            > > to set your new root password.
                            > > [NOTE! I haven't actualy tested this! Use at your
                            > > own risk. If you've
                            > > already edited your passwd file, the string between
                            > > the colons in the
                            > > above command is likely not right for you.]
                            > >
                            > > No vi required.
                            > > I've attached the original LinkStation passwd file,
                            > > in case it helps those
                            > > of you who seem to have mucked it up.
                            > > --scott
                            > >
                            > > NSA Attache KUSODA IDEA ODOATH WSBURNT KMFLUSH
                            > > fissionable MI5 LA
                            > > Register to vote!
                            > > http://www.yourvotematters.org/VerifiedVoting
                            > > ( http://cscott.net/ )>
                            > root:r.4feIpNeMISQ:0:0:root:/root:/bin/bash
                            > > bin:*:1:1:bin:/bin:
                            > > daemon:*:2:2:daemon:/usr/sbin:
                            > > sys:*:3:3:sys:/dev:
                            > > adm:*:4:4:adm:/var/adm:
                            > > sync:*:6:8:sync:/bin:/bin/sync
                            > > shutdown:*:7:9:shutdown:/sbin:/sbin/shutdown
                            > > halt:*:8:10:halt:/sbin:/sbin/halt
                            > > operator:*:12:0:operator:/root:
                            > > ftp:*:15:14:ftp:/var/ftp:
                            > > nobody:*:99:99:nobody:/home:/bin/sh
                            > >
                            >
                            >
                            >
                            >
                            > __________________________________
                            > Do you Yahoo!?
                            > All your favorites on one personal page – Try My Yahoo!
                            > http://my.yahoo.com
                          • irvine_stock
                            Rod, I ran Wilsons export to .bash_profile just as he described and it worked great. (Thanks Wilson) After that VI always worked. ALthough I hate it. I see
                            Message 13 of 22 , Dec 12, 2004
                              Rod,
                              I ran Wilsons export to .bash_profile just as he described and it
                              worked great. (Thanks Wilson) After that VI always worked.
                              ALthough I hate it.
                              I see that you are showing TERM=vt11. It has to be TERM=vt100 to
                              work. If that is not it, then I don't know what it could be.

                              Rich
                              --- In LinkStation_General@yahoogroups.com, "rod_tucker"
                              <rod_tucker@y...> wrote:
                              >
                              > Wilson,
                              >
                              > For some reason, this doesn't work for me. I confirmed that if I
                              > log in as root and execute this command, a file
                              > called .bash_profile does indeed appear in the home directory,
                              and
                              > it's contents are export TERM=vt11. (in fact I ran the command
                              > twice, and export TERM=vt11 appears twice.)
                              >
                              > But if I log off and log in again, I still have problems with vi.
                              I
                              > can fix it by typing export TERM=vt100 every time I log in, but
                              this
                              > is a bit of a nuisance.
                              >
                              > I wonder if I need to do something to enable the
                              file .bash_profile
                              > or perhaps the home directory is not the right place for it.
                              >
                              > Any thoughts?
                              >
                              > Rod
                              >
                              > --- In LinkStation_General@yahoogroups.com, Wilson
                              <sonsondei@y...>
                              > wrote:
                              > > Yes, that's what I do as root:
                              > > echo "export TERM=vt100" >> ~/.bash_profile
                              > >
                              > > So whenever I login, it's with the proper term, even
                              > > the LS doesn't recognize the xterm.
                              > >
                              > > W
                              > > --- "C. Scott Ananian"
                              > > <cananian@l...> wrote:
                              > >
                              > > > On Thu, 9 Dec 2004, irvine_stock wrote:
                              > > >
                              > > > > VI does not work in the telnet window unless its
                              > > > vt100.
                              > > >
                              > > > Every time you log in, type
                              > > > # export TERM=vt100
                              > > > as the first thing you do.
                              > > >
                              > > > That's the simplest way to fix that up.
                              > > >
                              > > > > This is of coarse if you care. VI has been a
                              > > > terrible editor since
                              > > >
                              > > > yes, i'd avoid using vi if you can help it.
                              > > > something like this should
                              > > > work:
                              > > > $ cp /etc/passwd /www/passwd.old
                              > > > $ sed -e 's:r.4feIpNeMISQ::' < /www/passwd.old >
                              > > > /etc/passwd
                              > > >
                              > > > then telnet in as root (no passwd) and use
                              > > > # passwd
                              > > > to set your new root password.
                              > > > [NOTE! I haven't actualy tested this! Use at your
                              > > > own risk. If you've
                              > > > already edited your passwd file, the string between
                              > > > the colons in the
                              > > > above command is likely not right for you.]
                              > > >
                              > > > No vi required.
                              > > > I've attached the original LinkStation passwd file,
                              > > > in case it helps those
                              > > > of you who seem to have mucked it up.
                              > > > --scott
                              > > >
                              > > > NSA Attache KUSODA IDEA ODOATH WSBURNT KMFLUSH
                              > > > fissionable MI5 LA
                              > > > Register to vote!
                              > > > http://www.yourvotematters.org/VerifiedVoting
                              > > > ( http://cscott.net/ )>
                              > > root:r.4feIpNeMISQ:0:0:root:/root:/bin/bash
                              > > > bin:*:1:1:bin:/bin:
                              > > > daemon:*:2:2:daemon:/usr/sbin:
                              > > > sys:*:3:3:sys:/dev:
                              > > > adm:*:4:4:adm:/var/adm:
                              > > > sync:*:6:8:sync:/bin:/bin/sync
                              > > > shutdown:*:7:9:shutdown:/sbin:/sbin/shutdown
                              > > > halt:*:8:10:halt:/sbin:/sbin/halt
                              > > > operator:*:12:0:operator:/root:
                              > > > ftp:*:15:14:ftp:/var/ftp:
                              > > > nobody:*:99:99:nobody:/home:/bin/sh
                              > > >
                              > >
                              > >
                              > >
                              > >
                              > > __________________________________
                              > > Do you Yahoo!?
                              > > All your favorites on one personal page – Try My Yahoo!
                              > > http://my.yahoo.com
                            • James Stewart
                              ... Notice that some time ago, I uploaded nano to the files section of this group. Although it is a much simpler editor than vi, it has a much more
                              Message 14 of 22 , Dec 12, 2004
                                --- irvine_stock <r_obermeyer@...> wrote:

                                > After that VI always worked.
                                > ALthough I hate it.

                                Notice that some time ago, I uploaded "nano" to the
                                files section of this group. Although it is a much
                                simpler editor than vi, it has a much more intuitive
                                command set and a simple help screen besides. To use
                                just put it on you LS then untar it in one of the
                                executible directories like /usr/bin.

                                __________________________________________________
                                Do You Yahoo!?
                                Tired of spam? Yahoo! Mail has the best spam protection around
                                http://mail.yahoo.com
                              • Wilson
                                Yes Rod, I don t know how did you come out with vt11... try to cat ~/.bash_profile and see if you actually have a typo in the file for vt11 instead of
                                Message 15 of 22 , Dec 12, 2004
                                  Yes Rod, I don't know how did you come out with
                                  vt11... try to 'cat ~/.bash_profile' and see if you
                                  actually have a typo in the file for vt11 instead of
                                  vt100....just edit the file and save it..should solve
                                  your problem.

                                  Wilson
                                  --- irvine_stock <r_obermeyer@...> wrote:

                                  >
                                  > Rod,
                                  > I ran Wilsons export to .bash_profile just as he
                                  > described and it
                                  > worked great. (Thanks Wilson) After that VI always
                                  > worked.
                                  > ALthough I hate it.
                                  > I see that you are showing TERM=vt11. It has to be
                                  > TERM=vt100 to
                                  > work. If that is not it, then I don't know what it
                                  > could be.
                                  >
                                  > Rich
                                  > --- In LinkStation_General@yahoogroups.com,
                                  > "rod_tucker"
                                  > <rod_tucker@y...> wrote:
                                  > >
                                  > > Wilson,
                                  > >
                                  > > For some reason, this doesn't work for me. I
                                  > confirmed that if I
                                  > > log in as root and execute this command, a file
                                  > > called .bash_profile does indeed appear in the
                                  > home directory,
                                  > and
                                  > > it's contents are export TERM=vt11. (in fact I
                                  > ran the command
                                  > > twice, and export TERM=vt11 appears twice.)
                                  > >
                                  > > But if I log off and log in again, I still have
                                  > problems with vi.
                                  > I
                                  > > can fix it by typing export TERM=vt100 every time
                                  > I log in, but
                                  > this
                                  > > is a bit of a nuisance.
                                  > >
                                  > > I wonder if I need to do something to enable the
                                  > file .bash_profile
                                  > > or perhaps the home directory is not the right
                                  > place for it.
                                  > >
                                  > > Any thoughts?
                                  > >
                                  > > Rod
                                  > >
                                  > > --- In LinkStation_General@yahoogroups.com,
                                  > Wilson
                                  > <sonsondei@y...>
                                  > > wrote:
                                  > > > Yes, that's what I do as root:
                                  > > > echo "export TERM=vt100" >> ~/.bash_profile
                                  > > >
                                  > > > So whenever I login, it's with the proper term,
                                  > even
                                  > > > the LS doesn't recognize the xterm.
                                  > > >
                                  > > > W
                                  > > > --- "C. Scott Ananian"
                                  > > > <cananian@l...> wrote:
                                  > > >
                                  > > > > On Thu, 9 Dec 2004, irvine_stock wrote:
                                  > > > >
                                  > > > > > VI does not work in the telnet window unless
                                  > its
                                  > > > > vt100.
                                  > > > >
                                  > > > > Every time you log in, type
                                  > > > > # export TERM=vt100
                                  > > > > as the first thing you do.
                                  > > > >
                                  > > > > That's the simplest way to fix that up.
                                  > > > >
                                  > > > > > This is of coarse if you care. VI has been
                                  > a
                                  > > > > terrible editor since
                                  > > > >
                                  > > > > yes, i'd avoid using vi if you can help it.
                                  > > > > something like this should
                                  > > > > work:
                                  > > > > $ cp /etc/passwd /www/passwd.old
                                  > > > > $ sed -e 's:r.4feIpNeMISQ::' < /www/passwd.old
                                  > >
                                  > > > > /etc/passwd
                                  > > > >
                                  > > > > then telnet in as root (no passwd) and use
                                  > > > > # passwd
                                  > > > > to set your new root password.
                                  > > > > [NOTE! I haven't actualy tested this! Use at
                                  > your
                                  > > > > own risk. If you've
                                  > > > > already edited your passwd file, the string
                                  > between
                                  > > > > the colons in the
                                  > > > > above command is likely not right for you.]
                                  > > > >
                                  > > > > No vi required.
                                  > > > > I've attached the original LinkStation passwd
                                  > file,
                                  > > > > in case it helps those
                                  > > > > of you who seem to have mucked it up.
                                  > > > > --scott
                                  > > > >
                                  > > > > NSA Attache KUSODA IDEA ODOATH WSBURNT KMFLUSH
                                  > > > > fissionable MI5 LA
                                  > > > > Register to vote!
                                  > > > > http://www.yourvotematters.org/VerifiedVoting
                                  > > > > ( http://cscott.net/
                                  > )>
                                  > > > root:r.4feIpNeMISQ:0:0:root:/root:/bin/bash
                                  > > > > bin:*:1:1:bin:/bin:
                                  > > > > daemon:*:2:2:daemon:/usr/sbin:
                                  > > > > sys:*:3:3:sys:/dev:
                                  > > > > adm:*:4:4:adm:/var/adm:
                                  > > > > sync:*:6:8:sync:/bin:/bin/sync
                                  > > > > shutdown:*:7:9:shutdown:/sbin:/sbin/shutdown
                                  > > > > halt:*:8:10:halt:/sbin:/sbin/halt
                                  > > > > operator:*:12:0:operator:/root:
                                  > > > > ftp:*:15:14:ftp:/var/ftp:
                                  > > > > nobody:*:99:99:nobody:/home:/bin/sh
                                  > > > >
                                  > > >
                                  > > >
                                  > > >
                                  > > >
                                  > > > __________________________________
                                  > > > Do you Yahoo!?
                                  > > > All your favorites on one personal page � Try My
                                  > Yahoo!
                                  > > > http://my.yahoo.com
                                  >
                                  >
                                  >
                                  >





                                  __________________________________
                                  Do you Yahoo!?
                                  Yahoo! Mail - You care about security. So do we.
                                  http://promotions.yahoo.com/new_mail
                                • rod_tucker
                                  -Wilson, The vt11 on my post to this users group was a ***typo***. Oops, sorry! But I have been very careful to use vt100 in all of my linkstation
                                  Message 16 of 22 , Dec 12, 2004
                                    -Wilson,

                                    The "vt11" on my post to this users group was a ***typo***. Oops,
                                    sorry! But I have been very careful to use "vt100" in all of my
                                    linkstation commands.

                                    But still it doesn't work. I have tried changing the file name
                                    to .bash-profile instead of .bash_profile, but that didn't work.

                                    I have tried deleting the file and re-inserted it using the echo
                                    command, and I have have tried deleting it and re-inserted it using
                                    vi (after first manually typing: export TERM=vt11) . But all to
                                    no avail. It just won't work.

                                    Does .bash_profile need to be an executable file? Using the ls -l
                                    command, I see that .bash_profile is rated as -rw-r--r--. I wonder
                                    if this is the problem. Should it be -rwxr--r--? I have also tried
                                    using "term" instead of "TERM" in the command, but that didn't work
                                    either.

                                    I guess that I could forget about this and just type every time I
                                    log in. But I worry that what I am seeing is might be a symptom of
                                    a bigger problem.

                                    Rod

                                    In LinkStation_General@yahoogroups.com, Wilson <sonsondei@y...>
                                    wrote:
                                    > Yes Rod, I don't know how did you come out with
                                    > vt11... try to 'cat ~/.bash_profile' and see if you
                                    > actually have a typo in the file for vt11 instead of
                                    > vt100....just edit the file and save it..should solve
                                    > your problem.
                                    >
                                    > Wilson
                                    > --- irvine_stock <r_obermeyer@p...> wrote:
                                    >
                                    > >
                                    > > Rod,
                                    > > I ran Wilsons export to .bash_profile just as he
                                    > > described and it
                                    > > worked great. (Thanks Wilson) After that VI always
                                    > > worked.
                                    > > ALthough I hate it.
                                    > > I see that you are showing TERM=vt11. It has to be
                                    > > TERM=vt100 to
                                    > > work. If that is not it, then I don't know what it
                                    > > could be.
                                    > >
                                    > > Rich
                                    > > --- In LinkStation_General@yahoogroups.com,
                                    > > "rod_tucker"
                                    > > <rod_tucker@y...> wrote:
                                    > > >
                                    > > > Wilson,
                                    > > >
                                    > > > For some reason, this doesn't work for me. I
                                    > > confirmed that if I
                                    > > > log in as root and execute this command, a file
                                    > > > called .bash_profile does indeed appear in the
                                    > > home directory,
                                    > > and
                                    > > > it's contents are export TERM=vt11. (in fact I
                                    > > ran the command
                                    > > > twice, and export TERM=vt11 appears twice.)
                                    > > >
                                    > > > But if I log off and log in again, I still have
                                    > > problems with vi.
                                    > > I
                                    > > > can fix it by typing export TERM=vt100 every time
                                    > > I log in, but
                                    > > this
                                    > > > is a bit of a nuisance.
                                    > > >
                                    > > > I wonder if I need to do something to enable the
                                    > > file .bash_profile
                                    > > > or perhaps the home directory is not the right
                                    > > place for it.
                                    > > >
                                    > > > Any thoughts?
                                    > > >
                                    > > > Rod
                                    > > >
                                    > > > --- In LinkStation_General@yahoogroups.com,
                                    > > Wilson
                                    > > <sonsondei@y...>
                                    > > > wrote:
                                    > > > > Yes, that's what I do as root:
                                    > > > > echo "export TERM=vt100" >> ~/.bash_profile
                                    > > > >
                                    > > > > So whenever I login, it's with the proper term,
                                    > > even
                                    > > > > the LS doesn't recognize the xterm.
                                    > > > >
                                    > > > > W
                                    > > > > --- "C. Scott Ananian"
                                    > > > > <cananian@l...> wrote:
                                    > > > >
                                    > > > > > On Thu, 9 Dec 2004, irvine_stock wrote:
                                    > > > > >
                                    > > > > > > VI does not work in the telnet window unless
                                    > > its
                                    > > > > > vt100.
                                    > > > > >
                                    > > > > > Every time you log in, type
                                    > > > > > # export TERM=vt100
                                    > > > > > as the first thing you do.
                                    > > > > >
                                    > > > > > That's the simplest way to fix that up.
                                    > > > > >
                                    > > > > > > This is of coarse if you care. VI has been
                                    > > a
                                    > > > > > terrible editor since
                                    > > > > >
                                    > > > > > yes, i'd avoid using vi if you can help it.
                                    > > > > > something like this should
                                    > > > > > work:
                                    > > > > > $ cp /etc/passwd /www/passwd.old
                                    > > > > > $ sed -e 's:r.4feIpNeMISQ::' < /www/passwd.old
                                    > > >
                                    > > > > > /etc/passwd
                                    > > > > >
                                    > > > > > then telnet in as root (no passwd) and use
                                    > > > > > # passwd
                                    > > > > > to set your new root password.
                                    > > > > > [NOTE! I haven't actualy tested this! Use at
                                    > > your
                                    > > > > > own risk. If you've
                                    > > > > > already edited your passwd file, the string
                                    > > between
                                    > > > > > the colons in the
                                    > > > > > above command is likely not right for you.]
                                    > > > > >
                                    > > > > > No vi required.
                                    > > > > > I've attached the original LinkStation passwd
                                    > > file,
                                    > > > > > in case it helps those
                                    > > > > > of you who seem to have mucked it up.
                                    > > > > > --scott
                                    > > > > >
                                    > > > > > NSA Attache KUSODA IDEA ODOATH WSBURNT KMFLUSH
                                    > > > > > fissionable MI5 LA
                                    > > > > > Register to vote!
                                    > > > > > http://www.yourvotematters.org/VerifiedVoting
                                    > > > > > ( http://cscott.net/
                                    > > )>
                                    > > > > root:r.4feIpNeMISQ:0:0:root:/root:/bin/bash
                                    > > > > > bin:*:1:1:bin:/bin:
                                    > > > > > daemon:*:2:2:daemon:/usr/sbin:
                                    > > > > > sys:*:3:3:sys:/dev:
                                    > > > > > adm:*:4:4:adm:/var/adm:
                                    > > > > > sync:*:6:8:sync:/bin:/bin/sync
                                    > > > > > shutdown:*:7:9:shutdown:/sbin:/sbin/shutdown
                                    > > > > > halt:*:8:10:halt:/sbin:/sbin/halt
                                    > > > > > operator:*:12:0:operator:/root:
                                    > > > > > ftp:*:15:14:ftp:/var/ftp:
                                    > > > > > nobody:*:99:99:nobody:/home:/bin/sh
                                    > > > > >
                                    > > > >
                                    > > > >
                                    > > > >
                                    > > > >
                                    > > > > __________________________________
                                    > > > > Do you Yahoo!?
                                    > > > > All your favorites on one personal page – Try My
                                    > > Yahoo!
                                    > > > > http://my.yahoo.com
                                    > >
                                    > >
                                    > >
                                    > >
                                    >
                                    >
                                    >
                                    >
                                    >
                                    > __________________________________
                                    > Do you Yahoo!?
                                    > Yahoo! Mail - You care about security. So do we.
                                    > http://promotions.yahoo.com/new_mail
                                  • Wilson
                                    First, you need to make sure where you put the file to...it works if the file is under the user s home directory and bash is the default shell. Check your
                                    Message 17 of 22 , Dec 15, 2004
                                      First, you need to make sure where you put the file
                                      to...it works if the file is under the user's home
                                      directory and bash is the default shell.

                                      Check your /etc/passwd file, make sure you have /root
                                      as root home directory and /bin/bash for shell.

                                      Secondly, BASH will search for .bash_profile file
                                      under the user home directory for user's customized
                                      setting for the shell, so make sure your .bash_profile
                                      is in /root.

                                      For linux or many UNIX, environment variable uses
                                      capital letters..so it has to be TERM only, or PATH if
                                      you set up your path.

                                      to be save, you can login in as root, then do:

                                      echo 'export TERM=vt100' > ~/.bash_profile

                                      so it'll write/overwrite your .bash_profile in the
                                      home directory..and logout and login again..

                                      Run:
                                      set

                                      and you should see a line:
                                      TERM=vt100

                                      in there..

                                      Hope this help.

                                      Wilson
                                      --- rod_tucker <rod_tucker@...> wrote:

                                      >
                                      > -Wilson,
                                      >
                                      > The "vt11" on my post to this users group was a
                                      > ***typo***. Oops,
                                      > sorry! But I have been very careful to use "vt100"
                                      > in all of my
                                      > linkstation commands.
                                      >
                                      > But still it doesn't work. I have tried changing
                                      > the file name
                                      > to .bash-profile instead of .bash_profile, but that
                                      > didn't work.
                                      >
                                      > I have tried deleting the file and re-inserted it
                                      > using the echo
                                      > command, and I have have tried deleting it and
                                      > re-inserted it using
                                      > vi (after first manually typing: export TERM=vt11)
                                      > . But all to
                                      > no avail. It just won't work.
                                      >
                                      > Does .bash_profile need to be an executable file?
                                      > Using the ls -l
                                      > command, I see that .bash_profile is rated as
                                      > -rw-r--r--. I wonder
                                      > if this is the problem. Should it be -rwxr--r--? I
                                      > have also tried
                                      > using "term" instead of "TERM" in the command, but
                                      > that didn't work
                                      > either.
                                      >
                                      > I guess that I could forget about this and just type
                                      > every time I
                                      > log in. But I worry that what I am seeing is might
                                      > be a symptom of
                                      > a bigger problem.
                                      >
                                      > Rod
                                      >
                                      > In LinkStation_General@yahoogroups.com, Wilson
                                      > <sonsondei@y...>
                                      > wrote:
                                      > > Yes Rod, I don't know how did you come out with
                                      > > vt11... try to 'cat ~/.bash_profile' and see if
                                      > you
                                      > > actually have a typo in the file for vt11 instead
                                      > of
                                      > > vt100....just edit the file and save it..should
                                      > solve
                                      > > your problem.
                                      > >
                                      > > Wilson
                                      > > --- irvine_stock <r_obermeyer@p...> wrote:
                                      > >
                                      > > >
                                      > > > Rod,
                                      > > > I ran Wilsons export to .bash_profile just as he
                                      > > > described and it
                                      > > > worked great. (Thanks Wilson) After that VI
                                      > always
                                      > > > worked.
                                      > > > ALthough I hate it.
                                      > > > I see that you are showing TERM=vt11. It has to
                                      > be
                                      > > > TERM=vt100 to
                                      > > > work. If that is not it, then I don't know what
                                      > it
                                      > > > could be.
                                      > > >
                                      > > > Rich
                                      > > > --- In LinkStation_General@yahoogroups.com,
                                      > > > "rod_tucker"
                                      > > > <rod_tucker@y...> wrote:
                                      > > > >
                                      > > > > Wilson,
                                      > > > >
                                      > > > > For some reason, this doesn't work for me. I
                                      > > > confirmed that if I
                                      > > > > log in as root and execute this command, a
                                      > file
                                      > > > > called .bash_profile does indeed appear in
                                      > the
                                      > > > home directory,
                                      > > > and
                                      > > > > it's contents are export TERM=vt11. (in fact
                                      > I
                                      > > > ran the command
                                      > > > > twice, and export TERM=vt11 appears twice.)
                                      > > > >
                                      > > > > But if I log off and log in again, I still
                                      > have
                                      > > > problems with vi.
                                      > > > I
                                      > > > > can fix it by typing export TERM=vt100 every
                                      > time
                                      > > > I log in, but
                                      > > > this
                                      > > > > is a bit of a nuisance.
                                      > > > >
                                      > > > > I wonder if I need to do something to enable
                                      > the
                                      > > > file .bash_profile
                                      > > > > or perhaps the home directory is not the right
                                      > > > place for it.
                                      > > > >
                                      > > > > Any thoughts?
                                      > > > >
                                      > > > > Rod
                                      > > > >
                                      > > > > --- In LinkStation_General@yahoogroups.com,
                                      > > > Wilson
                                      > > > <sonsondei@y...>
                                      > > > > wrote:
                                      > > > > > Yes, that's what I do as root:
                                      > > > > > echo "export TERM=vt100" >> ~/.bash_profile
                                      > > > > >
                                      > > > > > So whenever I login, it's with the proper
                                      > term,
                                      > > > even
                                      > > > > > the LS doesn't recognize the xterm.
                                      > > > > >
                                      > > > > > W
                                      > > > > > --- "C. Scott Ananian"
                                      > > > > > <cananian@l...> wrote:
                                      > > > > >
                                      > > > > > > On Thu, 9 Dec 2004, irvine_stock wrote:
                                      > > > > > >
                                      > > > > > > > VI does not work in the telnet window
                                      > unless
                                      > > > its
                                      > > > > > > vt100.
                                      > > > > > >
                                      > > > > > > Every time you log in, type
                                      > > > > > > # export TERM=vt100
                                      > > > > > > as the first thing you do.
                                      > > > > > >
                                      > > > > > > That's the simplest way to fix that up.
                                      > > > > > >
                                      > > > > > > > This is of coarse if you care. VI has
                                      > been
                                      > > > a
                                      > > > > > > terrible editor since
                                      > > > > > >
                                      > > > > > > yes, i'd avoid using vi if you can help
                                      > it.
                                      > > > > > > something like this should
                                      > > > > > > work:
                                      > > > > > > $ cp /etc/passwd /www/passwd.old
                                      > > > > > > $ sed -e 's:r.4feIpNeMISQ::' <
                                      > /www/passwd.old
                                      > > > >
                                      > > > > > > /etc/passwd
                                      > > > > > >
                                      > > > > > > then telnet in as root (no passwd) and use
                                      > > > > > > # passwd
                                      > > > > > > to set your new root password.
                                      > > > > > > [NOTE! I haven't actualy tested this! Use
                                      > at
                                      > > > your
                                      > > > > > > own risk. If you've
                                      > > > > > > already edited your passwd file, the
                                      > string
                                      > > > between
                                      > > > > > > the colons in the
                                      > > > > > > above command is likely not right for
                                      > you.]
                                      > > > > > >
                                      > > > > > > No vi required.
                                      > > > > > > I've attached the original LinkStation
                                      > passwd
                                      > > > file,
                                      > > > > > > in case it helps those
                                      > > > > > > of you who seem to have mucked it up.
                                      > > > > > > --scott
                                      > > > > > >
                                      > > > > > > NSA Attache KUSODA IDEA ODOATH WSBURNT
                                      > KMFLUSH
                                      > > > > > > fissionable MI5 LA
                                      > > > > > > Register to vote!
                                      > > > > > >
                                      > http://www.yourvotematters.org/VerifiedVoting
                                      > > > > > > (
                                      > http://cscott.net/
                                      > > > )>
                                      > > > > > root:r.4feIpNeMISQ:0:0:root:/root:/bin/bash
                                      > > > > > > bin:*:1:1:bin:/bin:
                                      > > > > > > daemon:*:2:2:daemon:/usr/sbin:
                                      > > > > > > sys:*:3:3:sys:/dev:
                                      > > > > > > adm:*:4:4:adm:/var/adm:
                                      > > > > > > sync:*:6:8:sync:/bin:/bin/sync
                                      > > > > > >
                                      > shutdown:*:7:9:shutdown:/sbin:/sbin/shutdown
                                      > > > > > > halt:*:8:10:halt:/sbin:/sbin/halt
                                      > > > > > > operator:*:12:0:operator:/root:
                                      > > > > > > ftp:*:15:14:ftp:/var/ftp:
                                      > > > > > > nobody:*:99:99:nobody:/home:/bin/sh
                                      > > > > > >
                                      > > > > >
                                      > > > > >
                                      > > > > >
                                      >
                                      === message truncated ===




                                      __________________________________
                                      Do you Yahoo!?
                                      Yahoo! Mail - now with 250MB free storage. Learn more.
                                      http://info.mail.yahoo.com/mail_250
                                    • rod_tucker
                                      Wilson, Many thanks. For some reason the command: echo export TERM=vt100 ~/.bash_profile worked!! But the earlier one: echo export TERM=vt100
                                      Message 18 of 22 , Dec 15, 2004
                                        Wilson,

                                        Many thanks. For some reason the command:

                                        echo 'export TERM=vt100' > ~/.bash_profile

                                        worked!!

                                        But the earlier one:

                                        echo "export TERM=vt100" >> ~/.bash_profile

                                        did not work.

                                        I don't understand what the difference is between these two
                                        commands. Both of them put what seemed like *exactly* the same text
                                        into the file /root/.bash_profile. However, even though I don't
                                        understand, the net result is that I can now log in as root and vi
                                        works properly.

                                        Having done this, I tried to get vi working when I log in as a
                                        user. So I tried typing:

                                        echo 'export TERM=vt100' > /home/.bash_profile

                                        But this did not work. It came back with a > on the next line. So
                                        (logged in as root) I went to vi and created a file
                                        called /home/.bash_profile with the following single line:

                                        export TERM=vt100

                                        Bingo!

                                        Thanks for your help.

                                        Rod



                                        --- In LinkStation_General@yahoogroups.com, Wilson <sonsondei@y...>
                                        wrote:
                                        > First, you need to make sure where you put the file
                                        > to...it works if the file is under the user's home
                                        > directory and bash is the default shell.
                                        >
                                        > Check your /etc/passwd file, make sure you have /root
                                        > as root home directory and /bin/bash for shell.
                                        >
                                        > Secondly, BASH will search for .bash_profile file
                                        > under the user home directory for user's customized
                                        > setting for the shell, so make sure your .bash_profile
                                        > is in /root.
                                        >
                                        > For linux or many UNIX, environment variable uses
                                        > capital letters..so it has to be TERM only, or PATH if
                                        > you set up your path.
                                        >
                                        > to be save, you can login in as root, then do:
                                        >
                                        > echo 'export TERM=vt100' > ~/.bash_profile
                                        >
                                        > so it'll write/overwrite your .bash_profile in the
                                        > home directory..and logout and login again..
                                        >
                                        > Run:
                                        > set
                                        >
                                        > and you should see a line:
                                        > TERM=vt100
                                        >
                                        > in there..
                                        >
                                        > Hope this help.
                                        >
                                        > Wilson
                                        > --- rod_tucker <rod_tucker@y...> wrote:
                                        >
                                        > >
                                        > > -Wilson,
                                        > >
                                        > > The "vt11" on my post to this users group was a
                                        > > ***typo***. Oops,
                                        > > sorry! But I have been very careful to use "vt100"
                                        > > in all of my
                                        > > linkstation commands.
                                        > >
                                        > > But still it doesn't work. I have tried changing
                                        > > the file name
                                        > > to .bash-profile instead of .bash_profile, but that
                                        > > didn't work.
                                        > >
                                        > > I have tried deleting the file and re-inserted it
                                        > > using the echo
                                        > > command, and I have have tried deleting it and
                                        > > re-inserted it using
                                        > > vi (after first manually typing: export TERM=vt11)
                                        > > . But all to
                                        > > no avail. It just won't work.
                                        > >
                                        > > Does .bash_profile need to be an executable file?
                                        > > Using the ls -l
                                        > > command, I see that .bash_profile is rated as
                                        > > -rw-r--r--. I wonder
                                        > > if this is the problem. Should it be -rwxr--r--? I
                                        > > have also tried
                                        > > using "term" instead of "TERM" in the command, but
                                        > > that didn't work
                                        > > either.
                                        > >
                                        > > I guess that I could forget about this and just type
                                        > > every time I
                                        > > log in. But I worry that what I am seeing is might
                                        > > be a symptom of
                                        > > a bigger problem.
                                        > >
                                        > > Rod
                                        > >
                                        > > In LinkStation_General@yahoogroups.com, Wilson
                                        > > <sonsondei@y...>
                                        > > wrote:
                                        > > > Yes Rod, I don't know how did you come out with
                                        > > > vt11... try to 'cat ~/.bash_profile' and see if
                                        > > you
                                        > > > actually have a typo in the file for vt11 instead
                                        > > of
                                        > > > vt100....just edit the file and save it..should
                                        > > solve
                                        > > > your problem.
                                        > > >
                                        > > > Wilson
                                        > > > --- irvine_stock <r_obermeyer@p...> wrote:
                                        > > >
                                        > > > >
                                        > > > > Rod,
                                        > > > > I ran Wilsons export to .bash_profile just as he
                                        > > > > described and it
                                        > > > > worked great. (Thanks Wilson) After that VI
                                        > > always
                                        > > > > worked.
                                        > > > > ALthough I hate it.
                                        > > > > I see that you are showing TERM=vt11. It has to
                                        > > be
                                        > > > > TERM=vt100 to
                                        > > > > work. If that is not it, then I don't know what
                                        > > it
                                        > > > > could be.
                                        > > > >
                                        > > > > Rich
                                        > > > > --- In LinkStation_General@yahoogroups.com,
                                        > > > > "rod_tucker"
                                        > > > > <rod_tucker@y...> wrote:
                                        > > > > >
                                        > > > > > Wilson,
                                        > > > > >
                                        > > > > > For some reason, this doesn't work for me. I
                                        > > > > confirmed that if I
                                        > > > > > log in as root and execute this command, a
                                        > > file
                                        > > > > > called .bash_profile does indeed appear in
                                        > > the
                                        > > > > home directory,
                                        > > > > and
                                        > > > > > it's contents are export TERM=vt11. (in fact
                                        > > I
                                        > > > > ran the command
                                        > > > > > twice, and export TERM=vt11 appears twice.)
                                        > > > > >
                                        > > > > > But if I log off and log in again, I still
                                        > > have
                                        > > > > problems with vi.
                                        > > > > I
                                        > > > > > can fix it by typing export TERM=vt100 every
                                        > > time
                                        > > > > I log in, but
                                        > > > > this
                                        > > > > > is a bit of a nuisance.
                                        > > > > >
                                        > > > > > I wonder if I need to do something to enable
                                        > > the
                                        > > > > file .bash_profile
                                        > > > > > or perhaps the home directory is not the right
                                        > > > > place for it.
                                        > > > > >
                                        > > > > > Any thoughts?
                                        > > > > >
                                        > > > > > Rod
                                        > > > > >
                                        > > > > > --- In LinkStation_General@yahoogroups.com,
                                        > > > > Wilson
                                        > > > > <sonsondei@y...>
                                        > > > > > wrote:
                                        > > > > > > Yes, that's what I do as root:
                                        > > > > > > echo "export TERM=vt100" >> ~/.bash_profile
                                        > > > > > >
                                        > > > > > > So whenever I login, it's with the proper
                                        > > term,
                                        > > > > even
                                        > > > > > > the LS doesn't recognize the xterm.
                                        > > > > > >
                                        > > > > > > W
                                        > > > > > > --- "C. Scott Ananian"
                                        > > > > > > <cananian@l...> wrote:
                                        > > > > > >
                                        > > > > > > > On Thu, 9 Dec 2004, irvine_stock wrote:
                                        > > > > > > >
                                        > > > > > > > > VI does not work in the telnet window
                                        > > unless
                                        > > > > its
                                        > > > > > > > vt100.
                                        > > > > > > >
                                        > > > > > > > Every time you log in, type
                                        > > > > > > > # export TERM=vt100
                                        > > > > > > > as the first thing you do.
                                        > > > > > > >
                                        > > > > > > > That's the simplest way to fix that up.
                                        > > > > > > >
                                        > > > > > > > > This is of coarse if you care. VI has
                                        > > been
                                        > > > > a
                                        > > > > > > > terrible editor since
                                        > > > > > > >
                                        > > > > > > > yes, i'd avoid using vi if you can help
                                        > > it.
                                        > > > > > > > something like this should
                                        > > > > > > > work:
                                        > > > > > > > $ cp /etc/passwd /www/passwd.old
                                        > > > > > > > $ sed -e 's:r.4feIpNeMISQ::' <
                                        > > /www/passwd.old
                                        > > > > >
                                        > > > > > > > /etc/passwd
                                        > > > > > > >
                                        > > > > > > > then telnet in as root (no passwd) and use
                                        > > > > > > > # passwd
                                        > > > > > > > to set your new root password.
                                        > > > > > > > [NOTE! I haven't actualy tested this! Use
                                        > > at
                                        > > > > your
                                        > > > > > > > own risk. If you've
                                        > > > > > > > already edited your passwd file, the
                                        > > string
                                        > > > > between
                                        > > > > > > > the colons in the
                                        > > > > > > > above command is likely not right for
                                        > > you.]
                                        > > > > > > >
                                        > > > > > > > No vi required.
                                        > > > > > > > I've attached the original LinkStation
                                        > > passwd
                                        > > > > file,
                                        > > > > > > > in case it helps those
                                        > > > > > > > of you who seem to have mucked it up.
                                        > > > > > > > --scott
                                        > > > > > > >
                                        > > > > > > > NSA Attache KUSODA IDEA ODOATH WSBURNT
                                        > > KMFLUSH
                                        > > > > > > > fissionable MI5 LA
                                        > > > > > > > Register to vote!
                                        > > > > > > >
                                        > > http://www.yourvotematters.org/VerifiedVoting
                                        > > > > > > > (
                                        > > http://cscott.net/
                                        > > > > )>
                                        > > > > > > root:r.4feIpNeMISQ:0:0:root:/root:/bin/bash
                                        > > > > > > > bin:*:1:1:bin:/bin:
                                        > > > > > > > daemon:*:2:2:daemon:/usr/sbin:
                                        > > > > > > > sys:*:3:3:sys:/dev:
                                        > > > > > > > adm:*:4:4:adm:/var/adm:
                                        > > > > > > > sync:*:6:8:sync:/bin:/bin/sync
                                        > > > > > > >
                                        > > shutdown:*:7:9:shutdown:/sbin:/sbin/shutdown
                                        > > > > > > > halt:*:8:10:halt:/sbin:/sbin/halt
                                        > > > > > > > operator:*:12:0:operator:/root:
                                        > > > > > > > ftp:*:15:14:ftp:/var/ftp:
                                        > > > > > > > nobody:*:99:99:nobody:/home:/bin/sh
                                        > > > > > > >
                                        > > > > > >
                                        > > > > > >
                                        > > > > > >
                                        > >
                                        > === message truncated ===
                                        >
                                        >
                                        >
                                        >
                                        > __________________________________
                                        > Do you Yahoo!?
                                        > Yahoo! Mail - now with 250MB free storage. Learn more.
                                        > http://info.mail.yahoo.com/mail_250
                                      • Wilson
                                        This is the basic unix stuff.. a single will create the file if it s not existed or it ll overwrite it if it exists. a double will append your new
                                        Message 19 of 22 , Dec 16, 2004
                                          This is the basic unix stuff..

                                          a single > will create the file if it's not existed or
                                          it'll overwrite it if it exists.

                                          a double >> will append your new contents to the end
                                          of the file, so if you have a export line in the file
                                          already, and run it again with >>, it'll append a new
                                          export line after the one you already have.

                                          That's also why we encourage ppl in here having some
                                          basic unix skills...if so, you can get this thing
                                          works more easier instead of spending many times to
                                          find out what's wrong and trial..

                                          Wilson
                                          --- rod_tucker <rod_tucker@...> wrote:

                                          >
                                          > Wilson,
                                          >
                                          > Many thanks. For some reason the command:
                                          >
                                          > echo 'export TERM=vt100' > ~/.bash_profile
                                          >
                                          > worked!!
                                          >
                                          > But the earlier one:
                                          >
                                          > echo "export TERM=vt100" >> ~/.bash_profile
                                          >
                                          > did not work.
                                          >
                                          > I don't understand what the difference is between
                                          > these two
                                          > commands. Both of them put what seemed like
                                          > *exactly* the same text
                                          > into the file /root/.bash_profile. However, even
                                          > though I don't
                                          > understand, the net result is that I can now log in
                                          > as root and vi
                                          > works properly.
                                          >
                                          > Having done this, I tried to get vi working when I
                                          > log in as a
                                          > user. So I tried typing:
                                          >
                                          > echo 'export TERM=vt100' > /home/.bash_profile
                                          >
                                          > But this did not work. It came back with a > on the
                                          > next line. So
                                          > (logged in as root) I went to vi and created a file
                                          > called /home/.bash_profile with the following single
                                          > line:
                                          >
                                          > export TERM=vt100
                                          >
                                          > Bingo!
                                          >
                                          > Thanks for your help.
                                          >
                                          > Rod
                                          >
                                          >
                                          >
                                          > --- In LinkStation_General@yahoogroups.com, Wilson
                                          > <sonsondei@y...>
                                          > wrote:
                                          > > First, you need to make sure where you put the
                                          > file
                                          > > to...it works if the file is under the user's home
                                          > > directory and bash is the default shell.
                                          > >
                                          > > Check your /etc/passwd file, make sure you have
                                          > /root
                                          > > as root home directory and /bin/bash for shell.
                                          > >
                                          > > Secondly, BASH will search for .bash_profile file
                                          > > under the user home directory for user's
                                          > customized
                                          > > setting for the shell, so make sure your
                                          > .bash_profile
                                          > > is in /root.
                                          > >
                                          > > For linux or many UNIX, environment variable uses
                                          > > capital letters..so it has to be TERM only, or
                                          > PATH if
                                          > > you set up your path.
                                          > >
                                          > > to be save, you can login in as root, then do:
                                          > >
                                          > > echo 'export TERM=vt100' > ~/.bash_profile
                                          > >
                                          > > so it'll write/overwrite your .bash_profile in the
                                          > > home directory..and logout and login again..
                                          > >
                                          > > Run:
                                          > > set
                                          > >
                                          > > and you should see a line:
                                          > > TERM=vt100
                                          > >
                                          > > in there..
                                          > >
                                          > > Hope this help.
                                          > >
                                          > > Wilson
                                          > > --- rod_tucker <rod_tucker@y...> wrote:
                                          > >
                                          > > >
                                          > > > -Wilson,
                                          > > >
                                          > > > The "vt11" on my post to this users group was a
                                          > > > ***typo***. Oops,
                                          > > > sorry! But I have been very careful to use
                                          > "vt100"
                                          > > > in all of my
                                          > > > linkstation commands.
                                          > > >
                                          > > > But still it doesn't work. I have tried
                                          > changing
                                          > > > the file name
                                          > > > to .bash-profile instead of .bash_profile, but
                                          > that
                                          > > > didn't work.
                                          > > >
                                          > > > I have tried deleting the file and re-inserted
                                          > it
                                          > > > using the echo
                                          > > > command, and I have have tried deleting it and
                                          > > > re-inserted it using
                                          > > > vi (after first manually typing: export
                                          > TERM=vt11)
                                          > > > . But all to
                                          > > > no avail. It just won't work.
                                          > > >
                                          > > > Does .bash_profile need to be an executable
                                          > file?
                                          > > > Using the ls -l
                                          > > > command, I see that .bash_profile is rated as
                                          > > > -rw-r--r--. I wonder
                                          > > > if this is the problem. Should it be -rwxr--r--?
                                          > I
                                          > > > have also tried
                                          > > > using "term" instead of "TERM" in the command,
                                          > but
                                          > > > that didn't work
                                          > > > either.
                                          > > >
                                          > > > I guess that I could forget about this and just
                                          > type
                                          > > > every time I
                                          > > > log in. But I worry that what I am seeing is
                                          > might
                                          > > > be a symptom of
                                          > > > a bigger problem.
                                          > > >
                                          > > > Rod
                                          > > >
                                          > > > In LinkStation_General@yahoogroups.com, Wilson
                                          > > > <sonsondei@y...>
                                          > > > wrote:
                                          > > > > Yes Rod, I don't know how did you come out
                                          > with
                                          > > > > vt11... try to 'cat ~/.bash_profile' and see
                                          > if
                                          > > > you
                                          > > > > actually have a typo in the file for vt11
                                          > instead
                                          > > > of
                                          > > > > vt100....just edit the file and save
                                          > it..should
                                          > > > solve
                                          > > > > your problem.
                                          > > > >
                                          > > > > Wilson
                                          > > > > --- irvine_stock <r_obermeyer@p...> wrote:
                                          > > > >
                                          > > > > >
                                          > > > > > Rod,
                                          > > > > > I ran Wilsons export to .bash_profile just
                                          > as he
                                          > > > > > described and it
                                          > > > > > worked great. (Thanks Wilson) After that VI
                                          > > > always
                                          > > > > > worked.
                                          > > > > > ALthough I hate it.
                                          > > > > > I see that you are showing TERM=vt11. It
                                          > has to
                                          > > > be
                                          > > > > > TERM=vt100 to
                                          > > > > > work. If that is not it, then I don't know
                                          > what
                                          > > > it
                                          > > > > > could be.
                                          > > > > >
                                          > > > > > Rich
                                          > > > > > --- In LinkStation_General@yahoogroups.com,
                                          > > > > > "rod_tucker"
                                          > > > > > <rod_tucker@y...> wrote:
                                          > > > > > >
                                          > > > > > > Wilson,
                                          > > > > > >
                                          > > > > > > For some reason, this doesn't work for me.
                                          > I
                                          > > > > > confirmed that if I
                                          > > > > > > log in as root and execute this command, a
                                          > > > file
                                          > > > > > > called .bash_profile does indeed appear
                                          > in
                                          > > > the
                                          > > > > > home directory,
                                          > > > > > and
                                          > > > > > > it's contents are export TERM=vt11. (in
                                          > fact
                                          > > > I
                                          > > > > > ran the command
                                          > > > > > > twice, and export TERM=vt11 appears
                                          > twice.)
                                          >
                                          === message truncated ===




                                          __________________________________
                                          Do you Yahoo!?
                                          The all-new My Yahoo! - What will yours do?
                                          http://my.yahoo.com
                                        Your message has been successfully submitted and would be delivered to recipients shortly.