Loading ...
Sorry, an error occurred while loading the content.

HD-HG250 with Freelink trying to spindown

Expand Messages
  • stephenblender
    I ve been playing around and researching for a few days without much success (except of course learning my way around ;-) Neither hdparm nore noflushd have
    Message 1 of 7 , Feb 28 11:12 PM
    • 0 Attachment
      I've been playing around and researching for a few days without much
      success (except of course learning my way around ;-)

      Neither hdparm nore noflushd have allowed me to spindown my hard
      drive. Hdparm has no effect, noflushd has an "error on line 168
      cannot find device"

      Regarding noflushd: On the product website they advise mounting a
      filesystem 'devfs' which i have been unable to do succesfully using
      variations of "mount -t ext3 devfs /devfs"

      I have looked through the listed logs in Webadmin and none look to be
      writing especially often. I read that journalling filesystems such as
      ext3 can be the problem so tried switching to ext2 by changing
      /etc/fstab. No luck.

      Any help would be appreciated. Really i am just in the early stages
      of playing around with both linux and the linkstation. Freelink and
      Samba were my fist two projects, next is either apache or lighttpd
      (documention vs performance)
    • James Stewart
      ... Did you install noflushd from Debian so that it would be automatically set up for you? When I did: apt-get install noflushd it just worked. I then
      Message 2 of 7 , Mar 1, 2006
      • 0 Attachment
        --- In LinkStation_General@yahoogroups.com, "stephenblender"
        <stephen@...> wrote:
        >
        > Neither hdparm nore noflushd have allowed me to spindown my hard
        > drive. Hdparm has no effect, noflushd has an "error on line 168
        > cannot find device"
        >
        > Regarding noflushd: On the product website they advise mounting a
        > filesystem 'devfs' which i have been unable to do succesfully
        > using variations of "mount -t ext3 devfs /devfs"

        Did you install noflushd from Debian so that it would be
        automatically set up for you? When I did:

        apt-get install noflushd

        it just worked. I then modified its settings
        in /etc/default/noflush to my liking.

        Forget about devfs. The linkstation isn't using it and current
        Linux versions have phased it out in favor of "udev" anyway. As
        long as things are correct in fstab and you are feeding noflushd
        sane settings, it should work.

        > I read that journalling filesystems such as
        > ext3 can be the problem so tried switching to ext2 by changing
        > /etc/fstab.

        You should really put it back to ext3 before you really get into
        trouble. If you have an "improper shutdown" while it is in ext2
        mode, I'm not sure if the linkstation's current init scrips will
        know what to do to fix it and it might hang the bootup and require
        you to hack the file system by putting the drive in another Linux
        machine. Yes, there are issues with ext3, but that is what noflushd
        is suppose to take care of (hdparm alone does not). It works on my
        ext3.

        > Really i am just in the early stages of playing around with both
        > linux and the linkstation. Freelink and
        > Samba were my fist two projects, next is either apache or lighttpd
        > (documention vs performance)

        Here is my advice: Always install/upgrade/delete applications using
        Debian's package management tools when you are using Debian Linux
        (Freelink). Even when things go wrong there is usually a way to fix
        it using the package management tools (apt-get, dpkg, aptitude,
        synaptic, etc). This even includes many configuration tasks (using
        things like "dpkg-reconfigure <application-name>" whenever possible.
        It seems like everytime you try to fight Debian's package management
        system, you loose, but if you bring it over to your side to fight
        the problem, you win.

        Finally, other tools to see what is running:

        1) Do a "ps -A > report.txt", then post report.txt to us so we can
        see everything you are running and comment on it. (On viewing
        report.txt on a Windows machine: open it with Wordpad instead of
        Notepad to get the newlines translated correctly)

        2) Install "top" or "mtop" with apt-get. They give you real time
        stats of what is running and when. If something (non kernel
        related) starts up, you should see it "blip" on the list.

        3) There are probably even better things than #2 above, maybe
        someone else can comment.

        Welcome to Linux. It has a steep learning curve, but it is worth
        it.
      • stephen
        Thanks for your help James. First I think i am going to focus on noflushd. I did originally installed it using apt-get. Noflushd is still failing to run
        Message 3 of 7 , Mar 1, 2006
        • 0 Attachment
          Thanks for your help James.  First I think i am going to focus on noflushd.  I did originally installed it using apt-get.  Noflushd is still failing to run quoting this error:
          "BUG at state.c line 134: Unable to determine device dir at /dev/mtdblocka
          Segmentation fault
          I used dpkg-reconfigure (thanks for the tip as I origionally did not specify any drive and did not know how to go through this process again) and have set "etc/default/noflush" as follows:
          TIMEOUT="1"
          DISKS="/dev/hda1"
          #PARAMS="-r /dev/sdb -n 60,5 /dev/hda -t 15,default /dev/hdc"
          (I have ommited all other comments here).  My fstab is as follows:
          # /etc/fstab: static file system information.
          #
          # <file system> <mount point>   <type>  <options>               <dump>  <pass>
          /dev/hda1       /               ext3    defaults,noatime,errors=remount-ro      0 0
          proc            /proc           proc    defaults                        0 0
          none            /dev/pts        devpts  gid=5,mode=20            0 0
          /dev/hda2    swap        swap    defaults            0 0
          /dev/hda3    /mnt        ext3    defaults,noatime        0 0
          (Note restoration of ext3).  Does everything look ok so far?

          stephen


          James Stewart wrote:
          --- In LinkStation_General@yahoogroups.com, "stephenblender"
          <stephen@...> wrote:
          >
          > Neither hdparm nore noflushd have allowed me to spindown my hard
          > drive.   Hdparm has no effect, noflushd has an "error on line 168
          > cannot find device"

          > Regarding noflushd:  On the product website they advise mounting a
          > filesystem 'devfs' which i have been unable to do succesfully
          > using variations of "mount -t ext3 devfs /devfs"

          Did you install noflushd from Debian so that it would be
          automatically set up for you?  When I did:

          apt-get install noflushd

          it just worked.  I then modified its settings
          in /etc/default/noflush to my liking.

          Forget about devfs.  The linkstation isn't using it and current
          Linux versions have phased it out in favor of "udev" anyway.  As
          long as things are correct in fstab and you are feeding noflushd
          sane settings, it should work.

          > I read that journalling filesystems such as
          > ext3 can be the problem so tried switching to ext2 by changing
          > /etc/fstab.

          You should really put it back to ext3 before you really get into
          trouble.  If you have an "improper shutdown" while it is in ext2
          mode, I'm not sure if the linkstation's current init scrips will
          know what to do to fix it and it might hang the bootup and require
          you to hack the file system by putting the drive in another Linux
          machine.  Yes, there are issues with ext3, but that is what noflushd
          is suppose to take care of (hdparm alone does not).  It works on my
          ext3.

          > Really i am just in the early stages of playing around with both
          > linux and the linkstation.  Freelink and
          > Samba were my fist two projects, next is either apache or lighttpd
          > (documention vs performance)

          Here is my advice:  Always install/upgrade/delete applications using
          Debian's package management tools when you are using Debian Linux
          (Freelink).  Even when things go wrong there is usually a way to fix
          it using the package management tools (apt-get, dpkg, aptitude,
          synaptic, etc).  This even includes many configuration tasks (using
          things like "dpkg-reconfigure <application-name>" whenever possible. 
          It seems like everytime you try to fight Debian's package management
          system, you loose, but if you bring it over to your side to fight
          the problem, you win.

          Finally, other tools to see what is running:

          1) Do a "ps -A > report.txt", then post report.txt to us so we can
          see everything you are running and comment on it.  (On viewing
          report.txt on a Windows machine: open it with Wordpad instead of
          Notepad to get the newlines translated correctly)

          2) Install "top" or "mtop" with apt-get.  They give you real time
          stats of what is running and when.  If something (non kernel
          related) starts up, you should see it "blip" on the list.

          3) There are probably even better things than #2 above, maybe
          someone else can comment.

          Welcome to Linux.  It has a steep learning curve, but it is worth
          it.



        • James Stewart
          ... There is at least one problem: You specified hda1 which means you are trying to spin down only partition #1 of hda . No wonder the program is having
          Message 4 of 7 , Mar 1, 2006
          • 0 Attachment
            --- In LinkStation_General@yahoogroups.com, stephen <stephen@...> wrote:

            > and have set "etc/default/noflush" as follows:
            >
            > TIMEOUT="1"
            > DISKS="/dev/hda1"
            > #PARAMS="-r /dev/sdb -n 60,5 /dev/hda -t 15,default /dev/hdc"

            There is at least one problem: You specified "hda1" which means you
            are trying to spin down only partition #1 of "hda". No wonder the
            program is having fits! Try DISKS="/dev/hda" for the whole disk, or
            better yet just leave it as:

            DISKS=

            like mine is at it will spin down any disks it can.
          • stephen
            I tried both DISKS= and DISKS=/dev/hda without success. I have gone through the apt-get install/remove/clean process a few times. When apt-get installing
            Message 5 of 7 , Mar 1, 2006
            • 0 Attachment
              I tried both "DISKS=" and "DISKS=/dev/hda" without success.  I have gone through the apt-get install/remove/clean process a few times.  When apt-get installing it ends as follows:
              ...
              Unpacking noflushd (from .../noflushd_2.7.5-2_powerpc.deb) ...
              Setting up noflushd (2.7.5-2) ...
              Stopping No Flush Daemon: noflushd.
              Starting No Flush Daemon: BUG at state.c line 134: Unable to determine device dir at /dev/mtdblocka
              /etc/init.d/noflushd: line 163:   529 Segmentation fault    start-stop-daemon --start --quiet --pidfile /var/run/$NAME.pid --exec $DAEMON -- $PARAMS
              invoke-rc.d: initscript noflushd, action "start" failed.
              And that is the end of it.  "/etc/init.d/noflushd"  states that it:
              # /etc/init.d/noflushd: Control userland daemon to spin down idle disk
              #Test whether the kernal exposes devfs-style names in /proc/partitions.
              #We do this by probling for '/' in the device name...
              ....
              As a long shot i also tried 'DISKS="hda" ' but no difference.

              Any further ideas?


              James Stewart wrote:
              --- In LinkStation_General@yahoogroups.com, stephen <stephen@...> wrote:

              > and have set "etc/default/noflush" as follows:
              >
              >     TIMEOUT="1"
              >     DISKS="/dev/hda1"
              >     #PARAMS="-r /dev/sdb -n 60,5 /dev/hda -t 15,default /dev/hdc"

              There is at least one problem:  You specified "hda1" which means you
              are trying to spin down only partition #1 of "hda".  No wonder the
              program is having fits!  Try DISKS="/dev/hda" for the whole disk, or
              better yet just leave it as:

              DISKS=

              like mine is at it will spin down any disks it can.





            • stephenblender
              Still no luck spinning down my drive. As an experiment i reinstalled debian/freelink using the freelink installer freelink_powerpc-hdhglan-1.11 downloaded
              Message 6 of 7 , Mar 3, 2006
              • 0 Attachment
                Still no luck spinning down my drive. As an experiment i reinstalled
                debian/freelink using the freelink installer
                freelink_powerpc-hdhglan-1.11 downloaded from the linkstation wiki. I
                did an apt-get update and upgrade, installed shh and thats pretty much it.

                First i tried hdparm: installed and tried 'hdparm -S10' (5 secs) and
                the linkstation still fails to ever spindown. I tried 50secs as well.
                hdparm otherwise seems to work. I executed 'hdparm -tT /dev/hda' and
                it tested the speed of file transfers.

                Next i apt-get'd noflushd and configured '1' min and '/dev/hda' but it
                failed to start just as it has as described below.

                I am at a bit of a loss. Any ideas? If anyone has any ideas please
                let me know. My goal is to set up a VERY low traffic webserver so i
                would really like to be able to spindown the drive.

                Stephen


                --- In LinkStation_General@yahoogroups.com, stephen <stephen@...> wrote:
                >
                > I tried both "DISKS=" and "DISKS=/dev/hda" without success. I have
                gone
                > through the apt-get install/remove/clean process a few times. When
                > apt-get installing it ends as follows:
                >
                > ...
                > Unpacking noflushd (from .../noflushd_2.7.5-2_powerpc.deb) ...
                > Setting up noflushd (2.7.5-2) ...
                > Stopping No Flush Daemon: noflushd.
                > Starting No Flush Daemon: BUG at state.c line 134: Unable to
                > determine device dir at /dev/mtdblocka
                > /etc/init.d/noflushd: line 163: 529 Segmentation fault
                > start-stop-daemon --start --quiet --pidfile /var/run/$NAME.pid
                > --exec $DAEMON -- $PARAMS
                > invoke-rc.d: initscript noflushd, action "start" failed.
                >
                > And that is the end of it. "/etc/init.d/noflushd" states that it:
                >
                > # /etc/init.d/noflushd: Control userland daemon to spin down
                idle disk
                > #Test whether the kernal exposes devfs-style names in
                /proc/partitions.
                > #We do this by probling for '/' in the device name...
                > ....
                >
                > As a long shot i also tried 'DISKS="hda" ' but no difference.
                >
                > Any further ideas?
                >
                >
                > James Stewart wrote:
                > > --- In LinkStation_General@yahoogroups.com, stephen <stephen@> wrote:
                > >
                > > > and have set "etc/default/noflush" as follows:
                > > >
                > > > TIMEOUT="1"
                > > > DISKS="/dev/hda1"
                > > > #PARAMS="-r /dev/sdb -n 60,5 /dev/hda -t 15,default /dev/hdc"
                > >
                > > There is at least one problem: You specified "hda1" which means you
                > > are trying to spin down only partition #1 of "hda". No wonder the
                > > program is having fits! Try DISKS="/dev/hda" for the whole disk, or
                > > better yet just leave it as:
                > >
                > > DISKS=
                > >
                > > like mine is at it will spin down any disks it can.
                > >
                > >
                > >
                > >
                > >
                > >
                > >
                > > SPONSORED LINKS
                > > Buffalo linkstation
                > >
                <http://groups.yahoo.com/gads?t=ms&k=Buffalo+linkstation&w1=Buffalo+linkstation&w2=Communication+and+networking&c=2&s=59&.sig=r2CzGJvdC2av3mUUFW_Dfg>

                > > Communication and networking
                > >
                <http://groups.yahoo.com/gads?t=ms&k=Communication+and+networking&w1=Buffalo+linkstation&w2=Communication+and+networking&c=2&s=59&.sig=PnautBytSHe2Zj97cMHLqg>

                > >
                > >
                > >
                > >
                ------------------------------------------------------------------------
                > > YAHOO! GROUPS LINKS
                > >
                > > * Visit your group "LinkStation_General
                > > <http://groups.yahoo.com/group/LinkStation_General>" on the web.
                > >
                > > * To unsubscribe from this group, send an email to:
                > > LinkStation_General-unsubscribe@yahoogroups.com
                > >
                <mailto:LinkStation_General-unsubscribe@yahoogroups.com?subject=Unsubscribe>
                > >
                > > * Your use of Yahoo! Groups is subject to the Yahoo! Terms of
                > > Service <http://docs.yahoo.com/info/terms/>.
                > >
                > >
                > >
                ------------------------------------------------------------------------
                > >
                >
              • stephen
                I was wondering about the failure to determine device dir at /dev/mtdblocka so took a look at my /proc/partitions file whick looked a little odd to me.
                Message 7 of 7 , Mar 5, 2006
                • 0 Attachment
                  I was wondering about the failure to "determine device dir at /dev/mtdblocka" so took a look at my "/proc/partitions" file whick looked a little odd to me.  Does this seem normal:

                  major minor  #blocks  name     rio rmerge rsect ruse wio wmerge wsect wuse running use aveq

                    31     0       6144 mtdblocka 0 0 0 0 0 0 0 0 0 0 0
                    31     1        896 mtdblockb 0 0 0 0 0 0 0 0 0 0 0
                    31     2        128 mtdblockc 0 0 0 0 0 0 0 0 0 0 0
                    31     3       1024 mtdblockd 0 0 0 0 0 0 0 0 0 0 0
                    31     4       8192 mtdblocke 0 0 0 0 0 0 0 0 0 0 0
                     3     0  244198584 hda 15816 71942 176470 64320 1128 3195 8656 21290 -7 6213020 -43288140
                     3     1     385528 hda1 15655 71939 175188 63450 1127 3195 8648 21290 0 59050 84740
                     3     2     530145 hda2 1 0 8 10 0 0 0 0 0 10 10
                     3     3  243208036 hda3 159 0 1266 850 1 0 8 0 0 850 850
                     3     4      72291 hda4 0 0 0 0 0 0 0 0 0 0 0
                  I also tried to determine what IO might be preventing normal hdparm spindown.  I executed "find / -mmin -1" which i believe should list all files accessed in the last minute. (please correct me if i am wrong).  This produced a huge list made up mostly of files within the "/proc" directory.  Is this a clue or am i barking up the wrong tree.

                  stephen



                  stephenblender wrote:
                  Still no luck spinning down my drive.  As an experiment i reinstalled
                  debian/freelink using the freelink installer
                  freelink_powerpc-hdhglan-1.11 downloaded from the linkstation wiki.  I
                  did an apt-get update and upgrade, installed shh and thats pretty much it.

                  First i tried hdparm: installed and tried 'hdparm -S10' (5 secs) and
                  the linkstation still fails to ever spindown.  I tried 50secs as well.
                  hdparm otherwise seems to work.  I executed 'hdparm -tT /dev/hda' and
                  it tested the speed of file transfers.

                  Next i apt-get'd noflushd and configured '1' min and '/dev/hda' but it
                  failed to start just as it has as described below.

                  I am at a bit of a loss.  Any ideas?  If anyone has any ideas please
                  let me know.  My goal is to set up a VERY low traffic webserver so i
                  would really like to be able to spindown the drive.

                  Stephen


                  --- In LinkStation_General@yahoogroups.com, stephen <stephen@...> wrote:
                  >
                  > I tried both "DISKS=" and "DISKS=/dev/hda" without success.  I have
                  gone
                  > through the apt-get install/remove/clean process a few times.  When
                  > apt-get installing it ends as follows:
                  >
                  >     ...
                  >     Unpacking noflushd (from .../noflushd_2.7.5-2_powerpc.deb) ...
                  >     Setting up noflushd (2.7.5-2) ...
                  >     Stopping No Flush Daemon: noflushd.
                  >     Starting No Flush Daemon: BUG at state.c line 134: Unable to
                  >     determine device dir at /dev/mtdblocka
                  >     /etc/init.d/noflushd: line 163:   529 Segmentation fault  
                  >     start-stop-daemon --start --quiet --pidfile /var/run/$NAME.pid
                  >     --exec $DAEMON -- $PARAMS
                  >     invoke-rc.d: initscript noflushd, action "start" failed.
                  >
                  > And that is the end of it.  "/etc/init.d/noflushd"  states that it:
                  >
                  >     # /etc/init.d/noflushd: Control userland daemon to spin down
                  idle disk
                  >     #Test whether the kernal exposes devfs-style names in
                  /proc/partitions.
                  >     #We do this by probling for '/' in the device name...
                  >     ....
                  >
                  > As a long shot i also tried 'DISKS="hda" ' but no difference.
                  >
                  > Any further ideas?
                  >
                  >
                  > James Stewart wrote:
                  > > --- In LinkStation_General@yahoogroups.com, stephen <stephen@> wrote:
                  > >
                  > > > and have set "etc/default/noflush" as follows:
                  > > >
                  > > >     TIMEOUT="1"
                  > > >     DISKS="/dev/hda1"
                  > > >     #PARAMS="-r /dev/sdb -n 60,5 /dev/hda -t 15,default /dev/hdc"
                  > >
                  > > There is at least one problem:  You specified "hda1" which means you
                  > > are trying to spin down only partition #1 of "hda".  No wonder the
                  > > program is having fits!  Try DISKS="/dev/hda" for the whole disk, or
                  > > better yet just leave it as:
                  > >
                  > > DISKS=
                  > >
                  > > like mine is at it will spin down any disks it can.
                  > >
                  > >
                  > >
                  > >
                  > >
                  > >
                  > >
                  > > SPONSORED LINKS
                  > > Buffalo linkstation
                  > >
                  <http://groups.yahoo.com/gads?t=ms&k=Buffalo+linkstation&w1=Buffalo+linkstation&w2=Communication+and+networking&c=2&s=59&.sig=r2CzGJvdC2av3mUUFW_Dfg>

                  > >       Communication and networking
                  > >
                  <http://groups.yahoo.com/gads?t=ms&k=Communication+and+networking&w1=Buffalo+linkstation&w2=Communication+and+networking&c=2&s=59&.sig=PnautBytSHe2Zj97cMHLqg>

                  > >
                  > >
                  > >
                  > >
                  ------------------------------------------------------------------------
                  > > YAHOO! GROUPS LINKS
                  > >
                  > >     *  Visit your group "LinkStation_General
                  > >       <http://groups.yahoo.com/group/LinkStation_General>" on the web.
                  > >       
                  > >     *  To unsubscribe from this group, send an email to:
                  > >        LinkStation_General-unsubscribe@yahoogroups.com
                  > >     
                  <mailto:LinkStation_General-unsubscribe@yahoogroups.com?subject=Unsubscribe>
                  > >       
                  > >     *  Your use of Yahoo! Groups is subject to the Yahoo! Terms of
                  > >       Service <http://docs.yahoo.com/info/terms/>.
                  > >
                  > >
                  > >
                  ------------------------------------------------------------------------
                  > >
                  >




                Your message has been successfully submitted and would be delivered to recipients shortly.