Loading ...
Sorry, an error occurred while loading the content.

Telnet in gigabit LS doesn't work. Any other way?

Expand Messages
  • Fernando Cassia
    I have bought a LinkStation (gigabit version, 300gb). I don t want to replace the firmware, I m just interested in adding telnet to it and perhaps a decent
    Message 1 of 2 , Feb 24, 2006
    • 0 Attachment
      I have bought a LinkStation (gigabit version, 300gb).

      I don't want to replace the firmware, I'm just interested in adding telnet to it and perhaps a decent editor (joe, pico, come to mind) on top of the stock firmware -which after adding telnet, won't be very difficult-.
      .
      My Gigabit linkstation came with Firmware 1.42

      While there's a script over here http://www.sowbug.org/mt/archives/000180.html which supposedly patches in ssh / telnet to the LS firmware, I have run it, it generated an updated .dat file which is larger in size (so it contains the telnetd), and the firmware update proceeded fine. I rebooted the unit, after the firmware update... typed "TELNET {my LS IP}..." and.... CONNECTION REFUSED.

      I wonder if the guys at Buffalo have wised up and set some sort of firewall rule on the LS to DENY PORT 23 connections.... ???

      Any ideas?

      Anyone tried the script from the URL above? did it work? if so are you using a gigabit LS?

      Thanks
      FC

    • Larry Adams
      FC, You have to goto www.linkstationwiki.org and goto the downloads section. In there you will find a) the stock flash
      Message 2 of 2 , Feb 24, 2006
      • 0 Attachment

        FC,

         

        You have to goto www.linkstationwiki.org and goto the downloads section.  In there you will find a) the stock flash program to revert to 1.42 if you have problems and OpenLink 0.51b that unfortunately contains the Japanese flash utility.  Therefore, you will download the latest Freelink from the site and use it’s flash utility, just copy it in to the OpenLink directory and run it from there.  The combinations of these two set’s of files, will crack the Linkstation.  However, before you flash the Linkstation, please review the site carefully.  There are some warnings that you will find relative to the flashing process.

         

        Once you have successfully flashed the unit, you will be able to telnet to it.  Then you can download the developers tools and build whatever product you want on it.  The busybox version of vi on the current box is kind of hosed.  I was able to build busybox 1.1 and the problem went away BTB.

         

        Regards,

         

        TheWitness

         


        From: LinkStation_General@yahoogroups.com [mailto:LinkStation_General@yahoogroups.com] On Behalf Of Fernando Cassia
        Sent: Friday, February 24, 2006 6:50 AM
        To: LinkStation_General@yahoogroups.com
        Subject: [LinkStation_General] Telnet in gigabit LS doesn't work. Any other way?

         

        I have bought a LinkStation (gigabit version, 300gb).

        I don't want to replace the firmware, I'm just interested in adding telnet to it and perhaps a decent editor (joe, pico, come to mind) on top of the stock firmware -which after adding telnet, won't be very difficult-.
        .
        My Gigabit linkstation came with Firmware 1.42

        While there's a script over here http://www.sowbug.org/mt/archives/000180.html which supposedly patches in ssh / telnet to the LS firmware, I have run it, it generated an updated .dat file which is larger in size (so it contains the telnetd), and the firmware update proceeded fine. I rebooted the unit, after the firmware update... typed "TELNET {my LS IP}..." and.... CONNECTION REFUSED.

        I wonder if the guys at Buffalo have wised up and set some sort of firewall rule on the LS to DENY PORT 23 connections.... ???

        Any ideas?

        Anyone tried the script from the URL above? did it work? if so are you using a gigabit LS?

        Thanks
        FC


      Your message has been successfully submitted and would be delivered to recipients shortly.