Loading ...
Sorry, an error occurred while loading the content.

timezone problems with OpenLink (HD-HG250)

Expand Messages
  • ken_simler
    I recently used OpenLink to open my LinkStation (gigabit 250) so that I can run slimserver on it. Everything is in pretty good shape, but for some reason the
    Message 1 of 4 , Feb 11, 2006
    • 0 Attachment
      I recently used OpenLink to open my LinkStation (gigabit 250) so that
      I can run slimserver on it. Everything is in pretty good shape, but
      for some reason the LS thinks it's 5 hours east of where it really is.
      I'm in the US eastern time zone.

      /etc/timezone says:
      export TZ=CP437+5

      /etc/melco/info says:
      wg=foo
      string=LinkStation
      zone=
      wins=
      usbdisk=on
      bkfolder=off
      domain=off
      pdc=
      mtu=151
      timezone=+5
      locale=CP437

      Any solutions out there? Besides timing of setting the drive to sleep,
      it would be nice to get this fixed because I have my Squeezebox show
      the time and date when it's not playing.

      Thanks.
      -Ken
    • calvinlsc
      ... that ... is. ... sleep, ... Firstly check from the web config to see if you have set the timezone correctly there. Then, you can change the value by using
      Message 2 of 4 , Feb 11, 2006
      • 0 Attachment
        --- In LinkStation_General@yahoogroups.com, "ken_simler"
        <ken_simler@...> wrote:
        >
        > I recently used OpenLink to open my LinkStation (gigabit 250) so
        that
        > I can run slimserver on it. Everything is in pretty good shape, but
        > for some reason the LS thinks it's 5 hours east of where it really
        is.
        > I'm in the US eastern time zone.
        >
        > /etc/timezone says:
        > export TZ=CP437+5
        >
        > /etc/melco/info says:
        > wg=foo
        > string=LinkStation
        > zone=
        > wins=
        > usbdisk=on
        > bkfolder=off
        > domain=off
        > pdc=
        > mtu=151
        > timezone=+5
        > locale=CP437
        >
        > Any solutions out there? Besides timing of setting the drive to
        sleep,
        > it would be nice to get this fixed because I have my Squeezebox show
        > the time and date when it's not playing.
        >
        > Thanks.
        > -Ken
        >

        Firstly check from the web config to see if you have set the timezone
        correctly there.

        Then, you can change the value by using tzselect and tzconfig.
      • Tony Morehen
        You need to set up the /etc/localtime variable correctly. Check its current setting by entering ls -l /etc/localtime. Mine shows localtime -
        Message 3 of 4 , Feb 11, 2006
        • 0 Attachment
          You need to set up the /etc/localtime variable correctly. Check its
          current setting by entering ls -l /etc/localtime. Mine shows
          localtime -> /usr/share/zoneinfo/MST7MDT as I'm on Mountain time. Yours
          should be linked to EST5EDT. If its not, enter the following commands:
          rm /etc/localtime
          ln -s /usr/share/zoneinfo/EST5EDT /etc/localtime
          Once that is done use date to set the correct date and time or run
          /etc/init.d/ntpupdate (I assume that you have edited that script, adding
          the required list of NTP servers)

          Linux works off UTC or Greenwich mean time. Generally, the hardware
          clock is set to UTC and any functions that display time use the local
          time vaiable to adjust for the timezone. Note EST = UTC + 5.



          ken_simler wrote:
          > I recently used OpenLink to open my LinkStation (gigabit 250) so that
          > I can run slimserver on it. Everything is in pretty good shape, but
          > for some reason the LS thinks it's 5 hours east of where it really is.
          > I'm in the US eastern time zone.
          >
          > /etc/timezone says:
          > export TZ=CP437+5
          >
          > /etc/melco/info says:
          > wg=foo
          > string=LinkStation
          > zone=
          > wins=
          > usbdisk=on
          > bkfolder=off
          > domain=off
          > pdc=
          > mtu=151
          > timezone=+5
          > locale=CP437
          >
          > Any solutions out there? Besides timing of setting the drive to sleep,
          > it would be nice to get this fixed because I have my Squeezebox show
          > the time and date when it's not playing.
          >
          > Thanks.
          > -Ken
          >
          >
          >
          >
          >
          > SPONSORED LINKS
          > Buffalo linkstation
          > <http://groups.yahoo.com/gads?t=ms&k=Buffalo+linkstation&w1=Buffalo+linkstation&w2=Communication+and+networking&c=2&s=59&.sig=r2CzGJvdC2av3mUUFW_Dfg>
          > Communication and networking
          > <http://groups.yahoo.com/gads?t=ms&k=Communication+and+networking&w1=Buffalo+linkstation&w2=Communication+and+networking&c=2&s=59&.sig=PnautBytSHe2Zj97cMHLqg>
          >
          >
          >
          > ------------------------------------------------------------------------
          > YAHOO! GROUPS LINKS
          >
          > * Visit your group "LinkStation_General
          > <http://groups.yahoo.com/group/LinkStation_General>" on the web.
          >
          > * To unsubscribe from this group, send an email to:
          > LinkStation_General-unsubscribe@yahoogroups.com
          > <mailto:LinkStation_General-unsubscribe@yahoogroups.com?subject=Unsubscribe>
          >
          > * Your use of Yahoo! Groups is subject to the Yahoo! Terms of
          > Service <http://docs.yahoo.com/info/terms/>.
          >
          >
          > ------------------------------------------------------------------------
          >

          --
          Tony Morehen
          11414 118A Street
          Edmonton, AB, T5G3J2
          tmorehen@...
        • ken_simler
          Thanks Tony and calvinlsc, that did the trick. -Ken ... Yours ... adding ...
          Message 4 of 4 , Feb 11, 2006
          • 0 Attachment
            Thanks Tony and calvinlsc, that did the trick.
            -Ken

            --- In LinkStation_General@yahoogroups.com, Tony Morehen
            <tmorehen@...> wrote:
            >
            > You need to set up the /etc/localtime variable correctly. Check its
            > current setting by entering ls -l /etc/localtime. Mine shows
            > localtime -> /usr/share/zoneinfo/MST7MDT as I'm on Mountain time.
            Yours
            > should be linked to EST5EDT. If its not, enter the following commands:
            > rm /etc/localtime
            > ln -s /usr/share/zoneinfo/EST5EDT /etc/localtime
            > Once that is done use date to set the correct date and time or run
            > /etc/init.d/ntpupdate (I assume that you have edited that script,
            adding
            > the required list of NTP servers)
            >
            > Linux works off UTC or Greenwich mean time. Generally, the hardware
            > clock is set to UTC and any functions that display time use the local
            > time vaiable to adjust for the timezone. Note EST = UTC + 5.
            >
            >
            >
            > ken_simler wrote:
            > > I recently used OpenLink to open my LinkStation (gigabit 250) so that
            > > I can run slimserver on it. Everything is in pretty good shape, but
            > > for some reason the LS thinks it's 5 hours east of where it really is.
            > > I'm in the US eastern time zone.
            > >
            > > /etc/timezone says:
            > > export TZ=CP437+5
            > >
            > > /etc/melco/info says:
            > > wg=foo
            > > string=LinkStation
            > > zone=
            > > wins=
            > > usbdisk=on
            > > bkfolder=off
            > > domain=off
            > > pdc=
            > > mtu=151
            > > timezone=+5
            > > locale=CP437
            > >
            > > Any solutions out there? Besides timing of setting the drive to sleep,
            > > it would be nice to get this fixed because I have my Squeezebox show
            > > the time and date when it's not playing.
            > >
            > > Thanks.
            > > -Ken
            > >
            > >
            > >
            > >
            > >
            > > SPONSORED LINKS
            > > Buffalo linkstation
            > >
            <http://groups.yahoo.com/gads?t=ms&k=Buffalo+linkstation&w1=Buffalo+linkstation&w2=Communication+and+networking&c=2&s=59&.sig=r2CzGJvdC2av3mUUFW_Dfg>

            > > Communication and networking
            > >
            <http://groups.yahoo.com/gads?t=ms&k=Communication+and+networking&w1=Buffalo+linkstation&w2=Communication+and+networking&c=2&s=59&.sig=PnautBytSHe2Zj97cMHLqg>

            > >
            > >
            > >
            > >
            ------------------------------------------------------------------------
            > > YAHOO! GROUPS LINKS
            > >
            > > * Visit your group "LinkStation_General
            > > <http://groups.yahoo.com/group/LinkStation_General>" on the web.
            > >
            > > * To unsubscribe from this group, send an email to:
            > > LinkStation_General-unsubscribe@yahoogroups.com
            > >
            <mailto:LinkStation_General-unsubscribe@yahoogroups.com?subject=Unsubscribe>
            > >
            > > * Your use of Yahoo! Groups is subject to the Yahoo! Terms of
            > > Service <http://docs.yahoo.com/info/terms/>.
            > >
            > >
            > >
            ------------------------------------------------------------------------
            > >
            >
            > --
            > Tony Morehen
            > 11414 118A Street
            > Edmonton, AB, T5G3J2
            > tmorehen@...
            >
          Your message has been successfully submitted and would be delivered to recipients shortly.