Loading ...
Sorry, an error occurred while loading the content.
 

Re: XBMC Scripts Don't Work

Expand Messages
  • James F
    ... files section? ... think it might be ... hi the xbmc scripts like shutdown and reboot should work the q: in xbmc points to whereever its installed: eg on
    Message 1 of 5 , Feb 1, 2006
      --- In LinkStation_General@yahoogroups.com, "prezet2005"
      <powell.lee.imac@g...> wrote:
      >
      > Hi
      >
      > Has anyone managed to get the Kai / XBMC scripts working from the
      files section?
      > I've downloaded, put in my passwords and IP addresses but nothing -
      think it might be
      > something to do with the Q:\\scripts\\ but am not sure...
      >
      > Any advice appreciated.
      >
      hi

      the xbmc scripts like shutdown and reboot should work
      the q:\ in xbmc points to whereever its installed:
      eg on mine f:\mediaplayers\xbmc\
      therefore q:\scripts\ points to f:\mediaplayers\xbmc\scripts\

      i can see 2 possible problems:

      1:
      the problem may be in the python dir of xbmc. i run a cvs complile
      of xbmc and it works fine. if you use someone elses build, bother
      them.
      (see forums.xbox-scene.com under the xbmc pages for more details on
      other groups releases)

      as such the restartkaid script may also need python installed

      (quick fix: -
      get python23.zlib from
      http://cvs.sourceforge.net/viewcvs.py/xbmc/XBMC/python/
      ftp into your xbox, go to the xbmc\python dir and replace the one on
      the xbox with new one.)

      let us know if that works

      2.
      i am NOT using ssh on the linkstation, i have not delved into the
      the python libaries to see if it can be done,
      because an existing script could telnet into a linksys router i used
      that as a basis. the linkstation without ssh is secure enough for me
      and the ability to turn it off from xbmc was more important



      ps i hope kaid works for you, its great
    • prezet2005
      ... Hi I m currently running the latest T3CH build..., I also have telnet enabled and running on the LinkStation so that shouldn t be a problem. I will try to
      Message 2 of 5 , Feb 3, 2006
        --- In LinkStation_General@yahoogroups.com, "James F" <jim80b@...> wrote:
        >
        > --- In LinkStation_General@yahoogroups.com, "prezet2005"
        > <powell.lee.imac@g...> wrote:
        > >
        > > Hi
        > >
        > > Has anyone managed to get the Kai / XBMC scripts working from the
        > files section?
        > > I've downloaded, put in my passwords and IP addresses but nothing -
        > think it might be
        > > something to do with the Q:\\scripts\\ but am not sure...
        > >
        > > Any advice appreciated.
        > >
        > hi
        >
        > the xbmc scripts like shutdown and reboot should work
        > the q:\ in xbmc points to whereever its installed:
        > eg on mine f:\mediaplayers\xbmc\
        > therefore q:\scripts\ points to f:\mediaplayers\xbmc\scripts\
        >
        > i can see 2 possible problems:
        >
        > 1:
        > the problem may be in the python dir of xbmc. i run a cvs complile
        > of xbmc and it works fine. if you use someone elses build, bother
        > them.
        > (see forums.xbox-scene.com under the xbmc pages for more details on
        > other groups releases)
        >
        > as such the restartkaid script may also need python installed
        >
        > (quick fix: -
        > get python23.zlib from
        > http://cvs.sourceforge.net/viewcvs.py/xbmc/XBMC/python/
        > ftp into your xbox, go to the xbmc\python dir and replace the one on
        > the xbox with new one.)
        >
        > let us know if that works
        >
        > 2.
        > i am NOT using ssh on the linkstation, i have not delved into the
        > the python libaries to see if it can be done,
        > because an existing script could telnet into a linksys router i used
        > that as a basis. the linkstation without ssh is secure enough for me
        > and the ability to turn it off from xbmc was more important
        >
        >
        >
        > ps i hope kaid works for you, its great
        >


        Hi

        I'm currently running the latest T3CH build..., I also have telnet
        enabled and running on the LinkStation so that shouldn't be a problem.
        I will try to replace the python23.zlib file tonight and test, but
        from what I can see my current build has this version already.

        Fingers crossed it'll work.

        Which version linkstation are you running: PPC or Mips?

        Thanks
      • James F
        I have a mips LS i am running a cvs build of xbmc from the 6th can you try something.... use avalaunch to telnet into the LS. you need to specify the ip
        Message 3 of 5 , Feb 8, 2006
          I have a mips LS
          i am running a cvs build of xbmc from the 6th

          can you try something....
          use avalaunch to telnet into the LS. you need to specify the ip
          address in settings and reboot for the change to take effect
          if this works xbmc scripts should do also

          when telnet'd in type "shutdown -r now" and it should reboot
          the scripts use shutdown to reboot and turn of the LS


          > Hi
          >
          > I'm currently running the latest T3CH build..., I also have telnet
          > enabled and running on the LinkStation so that shouldn't be a
          problem.
          > I will try to replace the python23.zlib file tonight and test, but
          > from what I can see my current build has this version already.
          >
          > Fingers crossed it'll work.
          >
          > Which version linkstation are you running: PPC or Mips?
          >
          > Thanks
          >
        • prezet2005
          ... It seems I don t have the telnet library installed in the python directory.... Could you post it up please?
          Message 4 of 5 , Apr 6, 2006
            --- In LinkStation_General@yahoogroups.com, "James F" <jim80b@...> wrote:
            >
            > I have a mips LS
            > i am running a cvs build of xbmc from the 6th
            >
            > can you try something....
            > use avalaunch to telnet into the LS. you need to specify the ip
            > address in settings and reboot for the change to take effect
            > if this works xbmc scripts should do also
            >
            > when telnet'd in type "shutdown -r now" and it should reboot
            > the scripts use shutdown to reboot and turn of the LS
            >
            >
            > > Hi
            > >
            > > I'm currently running the latest T3CH build..., I also have telnet
            > > enabled and running on the LinkStation so that shouldn't be a
            > problem.
            > > I will try to replace the python23.zlib file tonight and test, but
            > > from what I can see my current build has this version already.
            > >
            > > Fingers crossed it'll work.
            > >
            > > Which version linkstation are you running: PPC or Mips?
            > >
            > > Thanks
            > >
            >
            It seems I don't have the telnet library installed in the python directory....
            Could you post it up please?
          Your message has been successfully submitted and would be delivered to recipients shortly.