Loading ...
Sorry, an error occurred while loading the content.

Tivo Media Server on Linkstation

Expand Messages
  • Tony Morehen
    I have sucessfully implemented a Tivo media server on my PPC Linkstation. This media server let s your Tivo play MP3 files and display pictures saved on your
    Message 1 of 9 , Jan 3, 2006
    • 0 Attachment
      I have sucessfully implemented a Tivo media server on my PPC Linkstation.  This media server let's your Tivo play MP3 files and display pictures saved on your Linkstation.

      What you need:
      1) ppctools or mipstools from LinkStationwiki
      2) LibJpeg from:  jpegsrc.v6b.tar.gz at http://www.ijg.org/files/
      • do the ususal ./configure; make; make install.
      • You must also make install-lib
      3) ImageMagick-6.2.5-5.tar.gz from http://www.imagemagick.org/script/download.php
      • again, do the ususal ./configure; make; make install.
      4) byRequest tivo HMO server at http://sourceforge.net/projects/byrequest/
      • edit the Makefile to set DESTDIR to the location where you want the media server installed.  I recommend /usr/local/bin
      • do make; make install
      • copy byRequest.conf to /etc; edit the image: and audio: lines to the locations where you store your files.  Note: your shares are subfolders of the /mnt folder.  I recommend commenting out the virtual: line as the virtual audio folders (for artist, album and title) run very very slow on the Linkstation.
      • start the server with
                  /usr/local/bin/byRequest /etc/byRequest.conf -preload
      • You should set up a script in init.d to start/stop the byRequest daemon and the appropriate symlinks in /rc.d/rc2.d (start) and rc0.d and rc6.d (both stop or kill) in order to start the daemon when the Linkstation restarts.
      -- 
      Tony Morehen
      11414 118A Street
      Edmonton, AB, T5G3J2
      tmorehen@...
    • James Stewart
      Hey thanks! I just got a TiVo and was looking for something like this. Your instructions worked perfectly, although I already had all the dependent stuff
      Message 2 of 9 , Jan 3, 2006
      • 0 Attachment
        Hey thanks!

        I just got a TiVo and was looking for something like this. Your
        instructions worked perfectly, although I already had all the
        dependent stuff already. I now have photo's and music streaming from
        my LS to my TiVo.
      • nshing_ny
        ... http://sourceforge.net/projects/byrequest/ ... Tony, I m a newbie with regard to hacking the Linkstation. My goal was to follow your instructions to setup
        Message 3 of 9 , Jan 7, 2006
        • 0 Attachment
          --- In LinkStation_General@yahoogroups.com, Tony Morehen
          <tmorehen@s...> wrote:
          >
          > I have sucessfully implemented a Tivo media server on my PPC
          > Linkstation. This media server let's your Tivo play MP3 files and
          > display pictures saved on your Linkstation.
          >
          > What you need:
          > 1) ppctools or mipstools from LinkStationwiki
          > 2) LibJpeg from: jpegsrc.v6b.tar.gz at http://www.ijg.org/files/
          >
          > * do the ususal ./configure; make; make install.
          > * You must also make install-lib
          >
          > 3) ImageMagick-6.2.5-5.tar.gz from
          > http://www.imagemagick.org/script/download.php
          >
          > * again, do the ususal ./configure; make; make install.
          >
          > 4) byRequest tivo HMO server at
          http://sourceforge.net/projects/byrequest/
          >
          > * edit the Makefile to set DESTDIR to the location where you want
          > the media server installed. I recommend /usr/local/bin
          > * do make; make install
          > * copy byRequest.conf to /etc; edit the image: and audio: lines to
          > the locations where you store your files. Note: your shares are
          > subfolders of the /mnt folder. I recommend commenting out the
          > virtual: line as the virtual audio folders (for artist, album and
          > title) run very very slow on the Linkstation.
          > * start the server with
          >
          > /usr/local/bin/byRequest /etc/byRequest.conf -preload
          >
          > * You should set up a script in init.d to start/stop the byRequest
          > daemon and the appropriate symlinks in /rc.d/rc2.d (start) and
          > rc0.d and rc6.d (both stop or kill) in order to start the daemon
          > when the Linkstation restarts.
          >
          > --
          > Tony Morehen
          > 11414 118A Street
          > Edmonton, AB, T5G3J2
          > tmorehen@s...
          >
          Tony,

          I'm a newbie with regard to hacking the Linkstation. My goal was to
          follow your instructions to setup a Tivo Media Server on my
          Linkstation. I reviewed the information on this forum and the
          information on the linkstationwiki site and found that I had a PPC
          Linkstation with firmware 1.44.

          I was able to follow the instructions to get root access to my
          Linkstation without any problems.

          I downloaded the ppc-tools-2.0 tools from linkstationwiki and followed
          the installation instructions. I next downloaded the
          jpegsrc.v6b.tar.gz package and then tried to perform the configure and
          failed with the following error message:

          gcc: /lib/libc.so.6: version `GLIBC_2.3' not found (required by gcc)

          It looks like the compiler installation failed. Any help would be
          greatly appreciated. If I can't get the compiler configured
          correctly, is it possbile to get the PPC binaries for the Tivo Media
          Server setup?

          Thanks,
          Norman
        • Tony Morehen
          I overlooked a step that I did independently severl weeks ago. You also need to update to the openlink firmware (ppc-openlink-0.52b) from linkstationwike.org.
          Message 4 of 9 , Jan 8, 2006
          • 0 Attachment
            I overlooked a step that I did independently severl weeks ago. You also
            need to update to the openlink firmware (ppc-openlink-0.52b) from
            linkstationwike.org. That installation adds the needed libraries like
            glibc2.3. The compiled binaries that I have will need the same libraries.

            nshing_ny wrote:

            > --- In LinkStation_General@yahoogroups.com, Tony Morehen
            > <tmorehen@s...> wrote:
            > >
            > > I have sucessfully implemented a Tivo media server on my PPC
            > > Linkstation. This media server let's your Tivo play MP3 files and
            > > display pictures saved on your Linkstation.
            > >
            > > What you need:
            > > 1) ppctools or mipstools from LinkStationwiki
            > > 2) LibJpeg from: jpegsrc.v6b.tar.gz at http://www.ijg.org/files/
            > >
            > > * do the ususal ./configure; make; make install.
            > > * You must also make install-lib
            > >
            > > 3) ImageMagick-6.2.5-5.tar.gz from
            > > http://www.imagemagick.org/script/download.php
            > >
            > > * again, do the ususal ./configure; make; make install.
            > >
            > > 4) byRequest tivo HMO server at
            > http://sourceforge.net/projects/byrequest/
            > >
            > > * edit the Makefile to set DESTDIR to the location where you want
            > > the media server installed. I recommend /usr/local/bin
            > > * do make; make install
            > > * copy byRequest.conf to /etc; edit the image: and audio: lines to
            > > the locations where you store your files. Note: your shares are
            > > subfolders of the /mnt folder. I recommend commenting out the
            > > virtual: line as the virtual audio folders (for artist, album and
            > > title) run very very slow on the Linkstation.
            > > * start the server with
            > >
            > > /usr/local/bin/byRequest /etc/byRequest.conf -preload
            > >
            > > * You should set up a script in init.d to start/stop the byRequest
            > > daemon and the appropriate symlinks in /rc.d/rc2.d (start) and
            > > rc0.d and rc6.d (both stop or kill) in order to start the daemon
            > > when the Linkstation restarts.
            > >
            > > --
            > > Tony Morehen
            > > 11414 118A Street
            > > Edmonton, AB, T5G3J2
            > > tmorehen@s...
            > >
            > Tony,
            >
            > I'm a newbie with regard to hacking the Linkstation. My goal was to
            > follow your instructions to setup a Tivo Media Server on my
            > Linkstation. I reviewed the information on this forum and the
            > information on the linkstationwiki site and found that I had a PPC
            > Linkstation with firmware 1.44.
            >
            > I was able to follow the instructions to get root access to my
            > Linkstation without any problems.
            >
            > I downloaded the ppc-tools-2.0 tools from linkstationwiki and followed
            > the installation instructions. I next downloaded the
            > jpegsrc.v6b.tar.gz package and then tried to perform the configure and
            > failed with the following error message:
            >
            > gcc: /lib/libc.so.6: version `GLIBC_2.3' not found (required by gcc)
            >
            > It looks like the compiler installation failed. Any help would be
            > greatly appreciated. If I can't get the compiler configured
            > correctly, is it possbile to get the PPC binaries for the Tivo Media
            > Server setup?
            >
            > Thanks,
            > Norman
            >
            >
            >
            >
            >
            >
            > SPONSORED LINKS
            > Buffalo linkstation
            > <http://groups.yahoo.com/gads?t=ms&k=Buffalo+linkstation&w1=Buffalo+linkstation&w2=Communication+and+networking&c=2&s=59&.sig=r2CzGJvdC2av3mUUFW_Dfg>
            > Communication and networking
            > <http://groups.yahoo.com/gads?t=ms&k=Communication+and+networking&w1=Buffalo+linkstation&w2=Communication+and+networking&c=2&s=59&.sig=PnautBytSHe2Zj97cMHLqg>
            >
            >
            >
            > ------------------------------------------------------------------------
            > YAHOO! GROUPS LINKS
            >
            > * Visit your group "LinkStation_General
            > <http://groups.yahoo.com/group/LinkStation_General>" on the web.
            >
            > * To unsubscribe from this group, send an email to:
            > LinkStation_General-unsubscribe@yahoogroups.com
            > <mailto:LinkStation_General-unsubscribe@yahoogroups.com?subject=Unsubscribe>
            >
            > * Your use of Yahoo! Groups is subject to the Yahoo! Terms of
            > Service <http://docs.yahoo.com/info/terms/>.
            >
            >
            > ------------------------------------------------------------------------
            >

            --
            Tony Morehen
            11414 118A Street
            Edmonton, AB, T5G3J2
            tmorehen@...
          • nshing_ny
            ... also ... like ... libraries. Tony, Thanks for the reply. I did the openlink firmware (pp-openlink- 0.52b) update and was able to compile the tools you
            Message 5 of 9 , Jan 9, 2006
            • 0 Attachment
              --- In LinkStation_General@yahoogroups.com, Tony Morehen
              <tmorehen@s...> wrote:
              >
              > I overlooked a step that I did independently severl weeks ago. You
              also
              > need to update to the openlink firmware (ppc-openlink-0.52b) from
              > linkstationwike.org. That installation adds the needed libraries
              like
              > glibc2.3. The compiled binaries that I have will need the same
              libraries.

              Tony,

              Thanks for the reply. I did the openlink firmware (pp-openlink-
              0.52b) update and was able to compile the tools you listed. I have
              byRequest working with by Tivo Series 2.

              Playback of mp3s are working find, but the display of pictures and
              thumbnails are very slow. Are you experiencing the same behavior?

              Thanks,
              Norman
            • Tony Morehen
              They are slow. It s a function of the slow (relatively) processor in the linkstation. Here s what happens: 1. The Tivo requests a list of all of the pictures
              Message 6 of 9 , Jan 9, 2006
              • 0 Attachment
                They are slow. It's a function of the slow (relatively) processor in
                the linkstation.

                Here's what happens:

                1. The Tivo requests a list of all of the pictures in the directory.
                2. For each picture file, the Tivo requests a jpeg of a specific,
                thumbnail size.
                3. The Linkstation converts the ful size picture size to the
                requested size and sends it off to the Tivo.
                4. The Tivo waits until it gets all of the thumbnails before
                displaying them.
                5. A similar picture size request and conversion goes on whenever the
                Tivo displays a picture ie when you select a picture or do a slide
                show.

                Picture size conversion is processor intensive and takes some time on
                the Linkstation just over a second for a thumbnail. In other words,
                there's not much we can do.

                MP3s on the other hand are sent over the network as is. The only role
                for the Linkstation is to act as a fileserver. In this case, network
                transfer speed is the limitation, not the Linkstation processor.

                nshing_ny wrote:

                > --- In LinkStation_General@yahoogroups.com, Tony Morehen
                > <tmorehen@s...> wrote:
                > >
                > > I overlooked a step that I did independently severl weeks ago. You
                > also
                > > need to update to the openlink firmware (ppc-openlink-0.52b) from
                > > linkstationwike.org. That installation adds the needed libraries
                > like
                > > glibc2.3. The compiled binaries that I have will need the same
                > libraries.
                >
                > Tony,
                >
                > Thanks for the reply. I did the openlink firmware (pp-openlink-
                > 0.52b) update and was able to compile the tools you listed. I have
                > byRequest working with by Tivo Series 2.
                >
                > Playback of mp3s are working find, but the display of pictures and
                > thumbnails are very slow. Are you experiencing the same behavior?
                >
                > Thanks,
                > Norman
                >
                >
                >
                >
                >
                >
                > SPONSORED LINKS
                > Buffalo linkstation
                > <http://groups.yahoo.com/gads?t=ms&k=Buffalo+linkstation&w1=Buffalo+linkstation&w2=Communication+and+networking&c=2&s=59&.sig=r2CzGJvdC2av3mUUFW_Dfg>
                > Communication and networking
                > <http://groups.yahoo.com/gads?t=ms&k=Communication+and+networking&w1=Buffalo+linkstation&w2=Communication+and+networking&c=2&s=59&.sig=PnautBytSHe2Zj97cMHLqg>
                >
                >
                >
                > ------------------------------------------------------------------------
                > YAHOO! GROUPS LINKS
                >
                > * Visit your group "LinkStation_General
                > <http://groups.yahoo.com/group/LinkStation_General>" on the web.
                >
                > * To unsubscribe from this group, send an email to:
                > LinkStation_General-unsubscribe@yahoogroups.com
                > <mailto:LinkStation_General-unsubscribe@yahoogroups.com?subject=Unsubscribe>
                >
                > * Your use of Yahoo! Groups is subject to the Yahoo! Terms of
                > Service <http://docs.yahoo.com/info/terms/>.
                >
                >
                > ------------------------------------------------------------------------
                >

                --
                Tony Morehen
                11414 118A Street
                Edmonton, AB, T5G3J2
                tmorehen@...
              • nshing_ny
                ... in ... directory. ... specific, ... whenever the ... slide ... on ... words, ... role ... network ... You ... from ... libraries ... have ...
                Message 7 of 9 , Jan 10, 2006
                • 0 Attachment
                  --- In LinkStation_General@yahoogroups.com, Tony Morehen
                  <tmorehen@s...> wrote:
                  >
                  > They are slow. It's a function of the slow (relatively) processor
                  in
                  > the linkstation.
                  >
                  > Here's what happens:
                  >
                  > 1. The Tivo requests a list of all of the pictures in the
                  directory.
                  > 2. For each picture file, the Tivo requests a jpeg of a
                  specific,
                  > thumbnail size.
                  > 3. The Linkstation converts the ful size picture size to the
                  > requested size and sends it off to the Tivo.
                  > 4. The Tivo waits until it gets all of the thumbnails before
                  > displaying them.
                  > 5. A similar picture size request and conversion goes on
                  whenever the
                  > Tivo displays a picture ie when you select a picture or do a
                  slide
                  > show.
                  >
                  > Picture size conversion is processor intensive and takes some time
                  on
                  > the Linkstation just over a second for a thumbnail. In other
                  words,
                  > there's not much we can do.
                  >
                  > MP3s on the other hand are sent over the network as is. The only
                  role
                  > for the Linkstation is to act as a fileserver. In this case,
                  network
                  > transfer speed is the limitation, not the Linkstation processor.
                  >
                  > nshing_ny wrote:
                  >
                  > > --- In LinkStation_General@yahoogroups.com, Tony Morehen
                  > > <tmorehen@s...> wrote:
                  > > >
                  > > > I overlooked a step that I did independently severl weeks ago.
                  You
                  > > also
                  > > > need to update to the openlink firmware (ppc-openlink-0.52b)
                  from
                  > > > linkstationwike.org. That installation adds the needed
                  libraries
                  > > like
                  > > > glibc2.3. The compiled binaries that I have will need the same
                  > > libraries.
                  > >
                  > > Tony,
                  > >
                  > > Thanks for the reply. I did the openlink firmware (pp-openlink-
                  > > 0.52b) update and was able to compile the tools you listed. I
                  have
                  > > byRequest working with by Tivo Series 2.
                  > >
                  > > Playback of mp3s are working find, but the display of pictures and
                  > > thumbnails are very slow. Are you experiencing the same behavior?
                  > >
                  > > Thanks,
                  > > Norman
                  > >
                  > >
                  > >
                  > >
                  > >
                  > >
                  > > SPONSORED LINKS
                  > > Buffalo linkstation
                  > > <http://groups.yahoo.com/gads?
                  t=ms&k=Buffalo+linkstation&w1=Buffalo+linkstation&w2=Communication+and
                  +networking&c=2&s=59&.sig=r2CzGJvdC2av3mUUFW_Dfg>
                  > > Communication and networking
                  > > <http://groups.yahoo.com/gads?
                  t=ms&k=Communication+and+networking&w1=Buffalo+linkstation&w2=Communic
                  ation+and+networking&c=2&s=59&.sig=PnautBytSHe2Zj97cMHLqg>
                  > >
                  > >
                  > >
                  > > ------------------------------------------------------------------
                  ------
                  > > YAHOO! GROUPS LINKS
                  > >
                  > > * Visit your group "LinkStation_General
                  > > <http://groups.yahoo.com/group/LinkStation_General>" on the
                  web.
                  > >
                  > > * To unsubscribe from this group, send an email to:
                  > > LinkStation_General-unsubscribe@yahoogroups.com
                  > > <mailto:LinkStation_General-unsubscribe@yahoogroups.com?
                  subject=Unsubscribe>
                  > >
                  > > * Your use of Yahoo! Groups is subject to the Yahoo! Terms of
                  > > Service <http://docs.yahoo.com/info/terms/>.
                  > >
                  > >
                  > > ------------------------------------------------------------------
                  ------
                  > >
                  >
                  > --
                  > Tony Morehen
                  > 11414 118A Street
                  > Edmonton, AB, T5G3J2
                  > tmorehen@s...
                  >
                  Tony,

                  Thanks for the information. I decided to disable the image handling
                  that byRequest does. Based upon the speed that jpeg's are delivered
                  to the Tivo, I felt that it wasn't worth the tying up Linkstation
                  resources.

                  In any case. I happy with the way that mp3's are being served to my
                  Tivo's.

                  Thanks again,
                  Norman
                • Tony Morehen
                  One other issue that has cropped up with the standard byRequest media server installation: My TiVo would lose track of the media server and I would get
                  Message 8 of 9 , Jan 10, 2006
                  • 0 Attachment
                    One other issue that has cropped up with the standard byRequest media
                    server installation:

                    My TiVo would lose track of the media server and I would get messages
                    such as no media server found at the Linkstation's network address. I
                    could get the server back by deleting the server and doing another
                    manual add server.

                    There is a better fix:
                    in the byRequest.conf file there is a line "#port:8080". Remove the "#"
                    (uncomment the line) and restart the byRequest server. Your server
                    should now be available to the TiVo on a permanent basis.

                    Why this works:
                    TiVo servers and clients broadcast "here I am messages" on port 2190
                    about once a minute. Clients use those messages to set up permanent
                    connections with the server. Those permanent connections should be on a
                    port other than 2190. Otherwise, the "here I am broadcast will break
                    the connection. This was what was happening with the default byRequest
                    installation. It was running both the "here I am" and permanent
                    connection on port 2190. When the "here I am" broke the permaent
                    connection, the TiVo seems to be unable to restore the permanent
                    connection unless you delete and re-add the server. Uncommenting the
                    port line as described above shifts the permanent connection to port
                    8080. Note if your system uses 8080 for something else, substitute
                    another port close to that number.

                    nshing_ny wrote:

                    > --- In LinkStation_General@yahoogroups.com, Tony Morehen
                    > <tmorehen@s...> wrote:
                    > >
                    > > They are slow. It's a function of the slow (relatively) processor
                    > in
                    > > the linkstation.
                    > >
                    > > Here's what happens:
                    > >
                    > > 1. The Tivo requests a list of all of the pictures in the
                    > directory.
                    > > 2. For each picture file, the Tivo requests a jpeg of a
                    > specific,
                    > > thumbnail size.
                    > > 3. The Linkstation converts the ful size picture size to the
                    > > requested size and sends it off to the Tivo.
                    > > 4. The Tivo waits until it gets all of the thumbnails before
                    > > displaying them.
                    > > 5. A similar picture size request and conversion goes on
                    > whenever the
                    > > Tivo displays a picture ie when you select a picture or do a
                    > slide
                    > > show.
                    > >
                    > > Picture size conversion is processor intensive and takes some time
                    > on
                    > > the Linkstation just over a second for a thumbnail. In other
                    > words,
                    > > there's not much we can do.
                    > >
                    > > MP3s on the other hand are sent over the network as is. The only
                    > role
                    > > for the Linkstation is to act as a fileserver. In this case,
                    > network
                    > > transfer speed is the limitation, not the Linkstation processor.
                    > >
                    > > nshing_ny wrote:
                    > >
                    > > > --- In LinkStation_General@yahoogroups.com, Tony Morehen
                    > > > <tmorehen@s...> wrote:
                    > > > >
                    > > > > I overlooked a step that I did independently severl weeks ago.
                    > You
                    > > > also
                    > > > > need to update to the openlink firmware (ppc-openlink-0.52b)
                    > from
                    > > > > linkstationwike.org. That installation adds the needed
                    > libraries
                    > > > like
                    > > > > glibc2.3. The compiled binaries that I have will need the same
                    > > > libraries.
                    > > >
                    > > > Tony,
                    > > >
                    > > > Thanks for the reply. I did the openlink firmware (pp-openlink-
                    > > > 0.52b) update and was able to compile the tools you listed. I
                    > have
                    > > > byRequest working with by Tivo Series 2.
                    > > >
                    > > > Playback of mp3s are working find, but the display of pictures and
                    > > > thumbnails are very slow. Are you experiencing the same behavior?
                    > > >
                    > > > Thanks,
                    > > > Norman
                    > > >
                    > > >
                    > > >
                    > > >
                    > > >
                    > > >
                    > > > SPONSORED LINKS
                    > > > Buffalo linkstation
                    > > > <http://groups.yahoo.com/gads?
                    > t=ms&k=Buffalo+linkstation&w1=Buffalo+linkstation&w2=Communication+and
                    > +networking&c=2&s=59&.sig=r2CzGJvdC2av3mUUFW_Dfg>
                    > > > Communication and networking
                    > > > <http://groups.yahoo.com/gads?
                    > t=ms&k=Communication+and+networking&w1=Buffalo+linkstation&w2=Communic
                    > ation+and+networking&c=2&s=59&.sig=PnautBytSHe2Zj97cMHLqg>
                    > > >
                    > > >
                    > > >
                    > > > ------------------------------------------------------------------
                    > ------
                    > > > YAHOO! GROUPS LINKS
                    > > >
                    > > > * Visit your group "LinkStation_General
                    > > > <http://groups.yahoo.com/group/LinkStation_General>" on the
                    > web.
                    > > >
                    > > > * To unsubscribe from this group, send an email to:
                    > > > LinkStation_General-unsubscribe@yahoogroups.com
                    > > > <mailto:LinkStation_General-unsubscribe@yahoogroups.com?
                    > subject=Unsubscribe>
                    > > >
                    > > > * Your use of Yahoo! Groups is subject to the Yahoo! Terms of
                    > > > Service <http://docs.yahoo.com/info/terms/>.
                    > > >
                    > > >
                    > > > ------------------------------------------------------------------
                    > ------
                    > > >
                    > >
                    > > --
                    > > Tony Morehen
                    > > 11414 118A Street
                    > > Edmonton, AB, T5G3J2
                    > > tmorehen@s...
                    > >
                    > Tony,
                    >
                    > Thanks for the information. I decided to disable the image handling
                    > that byRequest does. Based upon the speed that jpeg's are delivered
                    > to the Tivo, I felt that it wasn't worth the tying up Linkstation
                    > resources.
                    >
                    > In any case. I happy with the way that mp3's are being served to my
                    > Tivo's.
                    >
                    > Thanks again,
                    > Norman
                    >
                    >
                    >
                    >
                    >
                    >
                    > ------------------------------------------------------------------------
                    > YAHOO! GROUPS LINKS
                    >
                    > * Visit your group "LinkStation_General
                    > <http://groups.yahoo.com/group/LinkStation_General>" on the web.
                    >
                    > * To unsubscribe from this group, send an email to:
                    > LinkStation_General-unsubscribe@yahoogroups.com
                    > <mailto:LinkStation_General-unsubscribe@yahoogroups.com?subject=Unsubscribe>
                    >
                    > * Your use of Yahoo! Groups is subject to the Yahoo! Terms of
                    > Service <http://docs.yahoo.com/info/terms/>.
                    >
                    >
                    > ------------------------------------------------------------------------
                    >

                    --
                    Tony Morehen
                    11414 118A Street
                    Edmonton, AB, T5G3J2
                    tmorehen@...
                  Your message has been successfully submitted and would be delivered to recipients shortly.